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1 Welcome!

MemberTies is a membership tracking application designed to help you get your group organized and
keep it organized. Extensive features, many based on suggestions from users around the world, all
combine to give you the one of the most powerful, affordable, and comprehensive membership software
packages available.

This help topic is designed to help you get started using MemberTies as quickly as possible. 

Getting Started

To help you get started quickly, please choose one following options:

I'm a new user and I just installed for the first time 
I've just upgraded or reinstalled
I've just installed, but I've been given an existing database to use 
I'm an existing user and need to log in again 

 

This document was last updated on Friday, May 15, 2015.
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2 Standard Version Overview

MemberTies is designed to do much more than track basic contact information. It is a powerful database
system that will help you take control of all the information that is critical to the operation of your
organization. For example:

Membership Types - Most organizations are made up of many members, and each member is
assigned a particular status that designates the type of membership the person holds. 
MemberTies ships with a predefined set of statuses, but also allows you to add to them, or delete
them all and define your own. So regardless of whether your organization has statuses like Family
and Single or more generic terms like Prospect and Regular, MemberTies will let you set up
exactly what you need. In addition, the system will automatically migrate members from one
status to another (for example, from active to alumni) as their End Dates pass.

Dues Payments - Though not designed as a complete accounting package, you are able to track
dues payment information for your membership. With the standard version, you can enter any
number of dues payments for each membership record, including the amount and date paid, the
membership status purchased, a check/payment number, and additional comments. Once you
have set up your dues information, you can also use the Dues Calculator to figure the amount of
dues owed for a given status for a given month. 

If you are using MemberTies Professional, you have many additional dues features, including
automatic posting of interest charges or other scheduled fees, mass posting of dues amounts,
and the ability to create debit or credit dues "posting types" such as "payment", or "interest" or
more specific types, like "T-Shirt" or "Bar Sales." Several additional reports are available in the
professional version as well.

MemberTies Professional also provides a separate Donations tracking area for each member by
adding a Donations tab next to the Dues tab.  Posting types (as mentioned above) are identified
as specific to donation or dues entries, and are only available on the appropriate tabpage.  This
enables you to keep your donations entries separate from dues entries, making it easy to "zero
balance" the dues account while letting a member's donations total continue to grow.

Associated Members and Groups - If you need to remember that a link of some kind exists
between two different member records, you can track it on the Associated tab. Associated
members are might be golf partners, mentors, referring members, and spouses who are also
members.  Associated Groups might be committees, book clubs, or softball teams.

Friends and Family Members - These records are not "members" of the organization, but instead
are considered "part of" or subordinate to a main member record.  These would be children, non-
member spouses, friends who are guests occasionally, etc.  It is possible for Friend/Family
members to be checked-in to an activity, and they can have their own ID number if you do not
want them to share the number of the main member record..

Roles & Achievements - If your organization recognizes members for their achievements, tracks
offices or positions held, or just needs to know when someone was involved in a particular type of
activity, you can record it using membership or group Items.  Items are used as a generic way of
describing all of the things your members can be involved in. You can create distinct item
categories, such as Member Achievements or, Offices, and then assign items to those. For
example, in the Offices category, you might create items of President and Vice President. Then
you could assign the Offices/President item to the person who held that position, and add a
comment indicating the year they were in office. Items and Item Categories can be used very
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creatively!

Activities - Most organizations would not exist without activities. An activity might be a business
meeting, a movie review, a sporting event, a fund-raising event, a committee, or anything else that
involves member participation.  The software enables you to create any number of activities,
complete with start and end date and time, comments, description, and location. 

The professional version expands further on activities by enabling you to assign members as
attendees, and track associated activity income and expenses.

To Do Lists - Every organization has things that need to be done. Sometimes the To Do is related
to a specific  member, and other times it is more generic. Sometimes you (the user of 
MemberTies) needs a reminder just for yourself. The To Do List feature enables you to track To Do
items for any membership or group record, or for yourself. You can print your outstanding To Do
list, display future items, and of course, mark them as done as you complete them.

Groups - A group is simply a sub-division of your membership.  Members can belong to any
number of groups. A group could be a committee, another organization, a team, a list of sponsors,
or anything that multiple members have in common.  Members can be added to any number of
groups as you wish, and you can run reports based on group membership.  With the professional
version, you can even send email to everyone in a group! You can also change the name from
"Group" to something more appropriate if necessary.

Reporting - No membership system is complete without reports, so MemberTies provides a full
suite of predefined reports, including rosters, mailing labels, dues payments, statistics, birthday
lists, contact lists, individual member and group reports, and more. Many reports can be
customized to show only certain membership statuses, dates, assigned item, etc., or can be
restricted to limit membership records to those assigned to a specific group. After you get the
report the way you like it, you can save it under a different name for future reuse. Furthermore, if
the report you need isn't available, a custom report can be created for your organization that fits
your needs.

Importing Data - To help you transition from your old system, MemberTies enables you to import
existing membership and group information. Just export your existing data to a delimited text file,
and you're ready to map each of your existing fields to fields in MemberTies! All data to be
imported is displayed for you before it is sent to the database, so you will know exactly what is
being imported.

Protecting Your Data - All data is stored in a relational database, and full backup and restore
options are included within the program. MemberTies will automatically prompt you to backup the
database at the interval you specify, or leave you alone to do it manually.

MemberTies Professional

If your organization needs even more flexibility, consider upgrading your installation to the Professional
version. 

Getting Started

For instructions on the best way to get started using MemberTies, please see Initial Setup . This section
will walk you through the basic setup of default values, statuses, and other information. 

Help
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Several kinds of Help are available for your use, including what you're reading now.  See Help for more
information.
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3 Professional Version Overview

MemberTies Professional is the version reserved for more powerful features that may not be needed by
the average organization. These features typically involve increased control over certain functions of the
software, or features that may only apply to larger organizations.

The feature list restricted to MemberTies Professional will continue to grow, and of course, the
professional version will always include all the features of the standard version. For general information
about the standard version, see Standard Program Overview

Some key additional features in the professional version include:

User-Definable Views - In the standard version, there is one membership list, and one group list.
With the professional version, you can define as many different views of your data as you like for
either list! If you need a membership list that includes Name, Email Address, and various Custom
Fields, you can create a View using those fields. You can put the fields in the order you want
them, change the column heading text, the default sort order, and the column size. Then you can
change from one view to another with as little as two keystrokes.

Each view can serve as a user-defined export template. You can retrieve data into the list, apply
the View you want, and then choose Save As to save the data to a text file or other format.  The
data saved will be the same data you see on-screen.

User-Definable Mailing Labels - If the predefined labels available in the standard version aren't quite
what you want for your group's mailings, the professional version lets you set up your own labels. 
You can create either labels using membership or group data, choose the fields that will be on
each row of the label, size them, and even add prefix or suffix data to any field. These labels can
then be opened in the normal Reports window, from which you can specify report settings to limit
the records found, and print the labels. 

User-Definable Columnar Reports - Similar to the Mailing Labels above, you can also create your
own columnar reports! (By columnar report, we mean a report that has a single row of headings,
with columns of data.) With these user-definable reports, you can choose membership or group
data, pick the fields you want, arrange them in the order you like, change the heading text, select
the sort order, size the columns, and give the report a default title.  These reports can then be
opened on the normal Reports window, from which you can specify report settings to limit the
records found, and print the report. 

Customize Dues Posting Types - In the standard version, every entry in the Dues tab of a
membership record is considered a dues payment (a credit to the account balance). The idea was
simply to provide a means of knowing how much a given member had paid the organization over
the years.  With MemberTies Professional, you get to decide how to treat every entry. You can
set up any number of Posting Types, deciding whether they will affect the account as a debit or
credit, what the minimum and maximum amount allowed is, and more. Then, when posting dues
entries, you can choose the posting type and the entry will affect the account balance
appropriately. If you want to keep accounts current at a 0.00 balance, you can do so by posting a
dues charge (debit) of $50.00, and following it with a dues payment (credit) of $50.00, bringing
their balance to zero.  Using the Interest feature (see below) you tell the system to automatically
post interest to accounts with an outstanding balance.

Post Dues to Multiple Records at Once - Now you can post a dues entry to a large number of
membership records without having to open each record and add an identical entry! For example,
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you may have a dues posting type called "Dues Charge," and you need to post a $50.00 entry of
this type to all of your "Yearly" members once a year for annual dues. Using this feature, you can
open the Post Dues window from the Membership List, enter the information, and select to post
this entry to every membership record in the database that has a status of "Yearly".  You could
also just post the entry to whatever records have been selected on the Membership List.

Post Interest Charges Automatically - If your organization collects Interest charges on accounts
with an outstanding balance, this feature will take care of the tedious task of posting charges to
the appropriate accounts.  By entering an Interest Charge on a given Status, you can tell the
system to post charges on a daily, monthly, or yearly basis. You specify the annual percentage
rate, a minimum amount due, and the compounding period, and the software takes care posting
any applicable charges each time you log in.

Post Dues Charges of any kind Automatically - Taking the Interest Charges idea a step further,
you can also set up one or more schedule dues postings for any status. This enables you to
charge an automatic monthly fee on the 15th of each month, and/or a yearly fee on the 1st of
January, or even a one-time fee on a specific date.

Group Dues - Dues postings are available on Group records, and are supported for deposits, mass
posting, etc., just like membership dues.

Additional Dues Reports - With the expansion of Dues functionality, some new reports were
needed. Therefore, the Dues Account Statement, Dues Postings, and Dues Balance reports have
been added. The Account Statement is designed to be sent to your members, whereas the Dues
Postings and Dues Balance reports can be used to help reconcile your accounts, check what you
posted that day, etc.

Multiple Addresses - Each membership and group record can have an unlimited number of
addresses, with one address set as the Current (active) address. 

Predefined Address Types - Predefine a list of address types like "PO Box", "Home", "Work",
etc., to help ensure that records have consistent naming. Address Types can also be used as
report criteria to further control the records returned. For example, you could print all members
with PO Boxes, regardless of whether the PO Box address was the current active address.

Address Date Ranging - Specify optional date ranges within which each address is valid
throughout the year. The system will automatically make the appropriate address current each
time you start the system (great for summer/winter home members). 

Stored Comments - To make comments more consistent and easier, you can store a list of
comment texts that can be displayed and inserted on any comments field. If you seem to always
open a record and type "Called for information about us.", you can store that text once and then
quickly enter it whenever necessary.

Preloaded Member IDs - If your organization assigns member IDs from a pool of predefined values,
or you just want to predetermine the next ID used by the system when creating new records, this
feature will help. This enables you to load any number of member IDs into a list (either manually or
by importing from a text file), and even control whether the ID's are immediately available or not.

Associate Members or Income and Expenses to Activities - Expands the Activities functionality
by letting you associate membership records to the activity, including the role and status of the
member with regard to the activity, as well as related income and expense posting.
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Integrated Email Capability - Send email directly from MemberTies to an member or group record.
Easily send mail to all members of a group, all attendees of an activity, a specific member or
group, or any number of selected members or groups on the Membership or Group List. The
system will even send out a separate email to each person in the list, addressed only to that
person. No more long and unprofessional "TO" and "CC" lists, or hidden "BCC" lists are
necessary (though you can still do that if you wish).

Upgrading

For more information about MemberTies Professional, please visit http://www.myrro.com/memberties or 
contact support . Please note that a license issued for the standard version of MemberTies will not work
with MemberTies Professional, but an upgrade price is available for users changing versions.
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4 Server and Database Overview

This topic is designed to provide an informational overview of the entire database system that is
MemberTies. You don't absolutely have to understand everything to this level of detail in order to user the
system, but we wanted to provide the information in case you were interested.

It's easy to think of MemberTies as just a single piece of software -- that what you see on screen when
you're entering members is all there is -- but that isn't the whole picture.  The following diagram
illustrates the three major components of the system: the Server, the Databases, and the Application. 
The typical corresponding folder structure is also shown for reference.

Note: The above directory structure applies to a default installation on Windows Vista and newer. On
older operating systems such as Windows XP the ProgramData\MemberTies location was a much
longer folder structure: "Documents and Settings\All Users\Application Data\MemberTies" 

What it all Means

A simple way to understand the relationship between the database, the server, and MemberTies is to
think of it like a bank. Think of your database as the bank vault. Your data is like money in that vault. 
When you want to put money into the vault you have to request the services of an employee at the bank.
 That employee is the server -- moving money (data) back and forth between you (MemberTies) and the
vault (the database).

The Server
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It is a common misconception that any reference to a "server" is always a reference to something on the
Internet.  That can be true at times, but often a server is nothing more than another small program that
runs on your computer. With MemberTies, that is also the case; the server is the program that lets
MemberTies move data in and out of your database.  

The server program files reside in a "Server" folder, located in the folder where MemberTies is installed. 
The location is typically, c:/program files/MemberTies/server/.  Inside that folder are various other folders
containing the files required to start and run the server. You shouldn't ever have to touch anything in
these folders. In fact, doing so could actually prevent the server from starting at all, thereby preventing
access to any database. 

The server has several important jobs to do:

Track all databases.

Track all connections to the databases.

Manage the flow of data between MemberTies and the appropriate database, and maintain all the
tables in the database as they change with the data.

As you can see, the server can be very busy. Every time the application wants to view or update
information in the database, (for example, when you open a membership record), the server has to
receive the requests for data, open the appropriate table(s), get the data, and send it back to the
application so it can be formatted for display. When you run a query for 1,000 records, the server has
seen them all before they ever appear on the screen.

Note that you won't see a special window on-screen when the server is running. The server is a program
that runs invisibly in the background, content to simply manage the flow of data between the database
and the application.  You can tell it is "out there" if you open the Windows Task List (typically by
pressing CTRL+ALT+DEL) and look for a process called "mtmysqld.exe".  The server program takes up
very little memory, and will continue to run even after you shut down MemberTies. This is done so the
next time you start MemberTies it will be faster, because it won't have to bother starting the server again.
 When MemberTies isn't running, the server will be content to just sleep and do nothing. If you need to
check the status of the server, or shut it down manually for some reason, a special Server Utility is
installed and available for this purpose. 

The Database

The database is not a single file. instead, each database is comprised of a large number of files within a
single folder bearing the database name.  The database folders are located, appropriately enough, in a
"database" folder in a special folder in Windows where applications are allowed to make changes,
namely, ProgramData. This location is typically, c:/ProgramData/MemberTies/database/(database
name)/. There are lots of files inside that folder, representing the various tables within the database.

Important: These files should ONLY be managed by the server! Opening a file using a text editor or
word processor can corrupt the file, causing all of the data to be lost.  It is impossible to edit data by
modifying these files directly! If you run an antivirus program on the computer that hosts the server, it is
a very good idea to make sure it excludes checking on everything in the database folder. The files there
are non-executable text files anyway, so they are not virus threats.

MemberTies enables you to have any number of databases, each of which will have its own folder under
the Database folder. The system keeps track of the "friendly" database name, and the license in use for
it, and other details in a special file called mtdb.xml. This file is updated when you specify your license
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information or work with database profiles in the application.

The Server also maintains a single small database of its own.  This database is called "mysql" and it is
used by the server track permissions, connections, and other internal settings.  This means that you will
always have at least two databases: your own, and the server's "mysql" database.  In the example
above, there are two user defined databases ("ski_club" and "speech_club") in addition to the server's
database.

Also in the MemberTies folder are sub-folders called Temp and Logs.  The Temp folder is used as a
place to create and delete files that are only used for a short while as the server goes about its
business. These might be temporarily created image files, tracking files, documents in progress prior to
saving, etc.  The Logs folder contains all of the logs that are generated within MemberTies. These
include email logs, backup logs, etc.

The Application

The application is what you probably think of as MemberTies itself.  It's the collection of windows,
menus, buttons, reports, etc., that you use to view and manage all of your data. Essentially, the
application is what simplifies the process of working with a complicated database on a day to day basis.
Imagine if you had to type out complicated commands for every record you wanted to see, and then
more commands to change the data, and still more commands to see the results again.  It's much more
convenient type data in fields and click OK to save and redisplay!

When you start MemberTies, the first thing it does is make sure that the server has been started.  Then,
when you enter your username, password, and database choice on the Login window, the application
forwards those selections on to the server. The server looks at your selections and verifies that, 1) there
really is a user with the name you entered, 2) that the user by that name is allowed to login to the
database you specified, and 3) that the password you provided is correct. If anything isn't correct, the
server responds with an error, which the application then displays for you to see.
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5 Logging In

5.1 Firewall/Antivirus Notice

Initial Startup Issues

If you are using a firewall or antivirus software with a firewall component, you may receive a warning the
first time you start the system. The warning will probably indicate that a program called mtmysqld.exe is
attempting to connect to the internet or a network, and it will offer to block the program. 

Do not block this program! The program it is referring to is the MemberTies database server, and it is
part of the software installed on your computer. It is NOT on the internet like the message may imply.

If you block the program, the system will not be able to start or connect to any database.  You should
respond to the warning by telling it to allow this program to run, because you need the database server
to run.

The warning is received because the database server installed on your computer with uses the IP
address of your computer to identify itself.  No internet connection is being made, but since the firewall
or antivirus monitoring software notices the use of an IP address, it may display a warning.
Unfortunately, the default "recommended" action is often to block the program, which is the wrong
solution in this case.

If you have already blocked the program, the only solution is to open your firewall or antivirus settings,
find the list of blocked programs, and change it to be "allowed."

5.2 Overview

The Login window enables you to connect to the database and begin using the system.

Note: If you are running any sort of firewall or antivirus software on your computer, read this.

There are several different situations that can affect the way you log in:

Normal Login - If you're an existing user and are just restarting the program normally, read the
topic called Normal Login. This should always be the case after the first login.

New Users - If you're a new user and have just finished installing the software, read the topic
called New User Login

New Install, Need to Restore a Backup - If you've installed the software and have a backup file
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(usually called something like "bkup_date_DatabaseName.sql"), read the topic called New Install -
Restoring a Backup to learn how to get the database restored and active again.

New Install, Existing (Current) Database - If you've installed the software but have an existing
MemberTies database as a set of "myd", "myi", and "frm" files (i.e., a "copy" of what used to be
an active database), read the topic called New Install - Existing (Current) Database to learn how to
put the database on your computer.

New Install, Existing (Old) Database - If you've installed the software but have an existing
MemberTies database as a large ".db" file that you want to use, read the topic called New Install -
Existing (Old) Database to learn how to convert the database to the new format.

Upgrade/Reinstall - If you're an existing user, and you just installed a new upgrade, or just
reinstalled the software for some reason (maybe you're recovering from a crashed computer), read
the topic called New Upgrade or Reinstall.

5.3 New User Login

When you start MemberTies the first time after a new installation, the first thing the system has to do is
create a database for you to use (The "database" is where all of your information is going to be stored. 
All of the windows you see on your computer are just there to make it easy for you to make changes to
the underlying database.)  Since there is no database available, MemberTies will display a window
similar to the following:

Note: If you are running any sort of firewall or antivirus software on your computer, read this.
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Note that this window appears instead of the Login window because the system could not find any
existing databases on this computer. To tell the system what you want to do, choose one of the
following options:

1 If you want to connect to a remote database (on another computer) select, "Choose Existing
Database." 

2 If you have a backup file and need to restore it as a new database, select, "Restore Database
from a Backup File."

2 If you're just beginning with MemberTies and need to create a new database to use or import
data into, select "Create New Database."  

Once you've made your decision, click Next and follow the appropriate steps below.

Choosing an existing database:

1 When you choose this option, the system will open the Choose Database window. This window
provides two different ways to identify the database you want:

The Local Database option lets you pick one of the database already on this computer.

The Remote Database option lets you point to a database on another computer. If you're not
sure what these fields are for, see Setting Up a Multi-User System for complete details.

2 When you're finished, click OK, to move on to the Database Profile window.
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3 On the Database Profile window, provide a short name for the database in the Database Name
field. This name is going to appear in the Database dropdown list on the Login window, so keep
the name simple and short.  An abbreviated name of your organization is a good choice. 

4 If you have your license information available, you may enter it now. If not, leave the license
fields blank.

5 Click OK to save the new database profile and return to the Login window.

6 On the Login window, enter the user name and password of an existing user on the selected
database, then click Login.

Restoring a database from a backup:

1 When you choose this option, you are immediately taken to the Restore window so you can
choose a database backup file.

By default, the system will probably open the My Documents\MemberTies\Backup folder if it
exists, since that is the default location normally suggested to save backup files.  If your backup
file is somewhere else, you can navigate to that.
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2 Select the file, then click Start Restore and follow any instructions that appear.

3 After the restore completes, click Close and you will be taken to the Login window so you can
log in using a user name and password that is valid for the database that was just restored.

Creating a new database:

1 When you choose this option, you are immediately prompted to provide a name for your new
database. 

By default the new database is going to be called "MyDatabase," but you can change it to
whatever you want.  Remember that this name is going to appear in the Database dropdown on
the Login window, so keep the name simple and short.  An abbreviated name of your
organization is a good choice. After you choose a name, click OK.

2 MemberTies now creates the database for you, and then displays another message asking
whether you want to create a user in addition to the default administrator user. You should
normally choose Yes so you can create a user for yourself. See Users Overview for details
about user accounts.

3 When prompted to create an account for yourself, enter a user name (i.e., john or jsmith), and a
password.  

Important: Passwords are case-sensitive.  "PASSWORD", "PaSswOrRd" and "password" are
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all completely different words to the database.

When you have entered a user name and password, click OK.  The system will confirm that the
password is valid, and then will add your new user account to the database. Be sure to store
your user name and password somewhere safe!

4 When the database has been created, the system will offer to print some details about the new
database, such as the database name, and the user/password(s) you just created.  It is a good
idea to let the system print this report for future reference.

5 When the Login window appears, enter the user name and password you just created, then
click Login to connect to your new database.

Tips

As a new user, there are some other things you might want to set up. See Initial Setup in the help
section called "Getting Started" for details.

If you want to register the software, or if you have already registered and just need to use your
new license, see Registering or Using a New License for additional instructions.

 

5.4 New Upgrade or Reinstall

This topic applies to you if you have reinstalled the software, or have downloaded and installed an
upgrade to your current installation.

Note: If you are running any sort of firewall or antivirus software on your computer, read this.

Reinstalling the Software

If you have reinstalled MemberTies, you should be able to simply login to your database using whatever
user name and password you were using before.  If your previous installation was older than the version
you are installing, the system will probably upgrade the database when you login to make it compatible
with the current version.

5.5 New Install - Restoring a Backup

This procedure applies to people who have a single database backup file with a name like
"bkup_20080405_MyDatabaseName.sql". 

If you have a single file with a ".db" extension, you have an old-style database. See New Install -
From .db Database File
If you have a set of files including ".myd", ".myi", and ".frm", you have a database copy.  See New
Install - From Database Copy instead.
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If you have been given a database backup file with a name like "bkup_BackupDate_DatabaseName.sql"
you have been given a true database backup. This is the best way to transfer  the database from one
person to another. 

Since you are reading this, we'll assume that the initial installation of MemberTies has already been
accomplished.

Note: If you are running any sort of firewall or antivirus software on your computer, read this.

Restoring the Database Backup to a New Installation

1 Copy the Backup File (the bkup_date_name.sql file) to your computer. Just copy it to your
Desktop for simplicity.

2 Start the software and decide what to do next based upon the window that appears:

If the Welcome to MemberTies window appears

Choose "Restore Database from a Backup File". See instructions under New User Login for
further details.

If the Login Window Appears

Click the "Database" dropdown field and choose the option labeled, "(Restore Backup...)".
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Choose OK when prompted. 

On the Database Restore window, select the database backup file, then click Start
Restore.

After the restore completes, click Restart to reload the Login window, and the restored
database should be displayed for selection.

 

5.6 New Install - From Database Copy

This procedure applies if you have been given a set of files with extensions like ".myd", ".myi",
and ".frm".

If you have a single file with a ".db" extension, you have an old-style database. See New Install -
From .db Database File
If you have a single ".sql" file with a name like "bkup_Date_DBName.sql", you have a true
database backup. See New Install - Restoring a Backup instead.

A set of files like this is not the preferred way to transfer the database.  If you have access to the
computer that is running the database you're being given, you may want to follow the instructions for 
Moving the Software instead. It will make things a lot easier.  Otherwise, make certain you really have all
three types of files -- myi, myd, and frm.  If any type is missing, this procedure will not work.

Note: If you are running any sort of firewall or antivirus software on your computer, read this.

Reloading a Database Copy

1 First, you need to know where databases are going to be stored on your computer. This location
will be displayed on the Local Database Server utility:

Choose Start > Programs > MemberTies > Local Database Server.
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Look in the "Local Server Settings" area for the field labeled "Root Database Directory".
The path will normally be:

c:\documents and settings\all users\application data\MemberTies\Database (for windows
XP)

or

c:\ProgramData\MemberTies\Database (for Windows Vista)

Go to My Computer, and navigate to the location you found. (If you can't see the folder, you
may need to tell Windows to show hidden files and folders.  In Windows Explorer, choose
Tools > Folder Options, click View, and select the Show Hidden Files and Folders
checkbox, then click OK.)

2 Copy the database files into a sub-folder under the Database folder you found above.

The chances are that the files you were given are already in a folder of their own, so you can just
copy that folder into the Database folder.  Otherwise, you'll need to create a folder to hold the
database files.  Note: There will already be a folder under the Database folder called "mysql".
Leave that folder alone -- it is used by the server.  Create a new folder for your database files.

You should end up with your "myd", "myi", and "frm" files in a folder like:

c:\documents and settings\all users\application data\MemberTies\Database\MyClub\  (on
Windows XP)

or

c:\ProgramData\MemberTies\Database\MyClub\  (on Windows Vista)

NOTE: If you copy these files from a CD-ROM, they will probably be read-only.  After copying
them to the new folder under your database folder, you MUST select all these files and then
right-click and choose Properties. Make sure the Read Only checkbox is not selected.  Failure
to do this will prevent the server from being able to use the database, and result in, "unable to
write to xxxxx table" error messages.

3 Start MemberTies.

4 When the Login window appears, make sure your database is selected.

If your database is NOT listed, go back and verify that it really did contain all three types of
files, "myd", "frm", "myi".

5 Enter a username and password from the existing database, and click Login.

Things to try if you cannot log in:

Contact the previous user of the database and get their user name and password.

Try to log in using the default administrator account, and once you log in, create a new
user name and password for yourself by going to Tools >  Database Admin Tools>
Maintain Users.
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If you are completely locked out, contact support.

 

5.7 New Install - From ".db" Database File

This procedure applies if you have been given a single database file with a ".db" extension.

If you have a set of files including ".myd", ".myi", and ".frm", you have a database copy.  See New
Install - From Database Copy instead.
If you have a single ".sql" file with a name like "bkup_Date_DBName.sql", you have a true
database backup. See New Install - Restoring a Backup instead.

Databases with a ".db" file extension are from versions of MemberTies prior to 2006. 

As of January 1, 2009, the capability to upgrade these databases was removed from the software to
simplify the upgrade logic. We were simply trying to support too many versions of upgrades, and had to
draw a line somewhere. This impending change was communicated to all users who had email
addresses on file, several months beforehand.

It is still possible to upgrade an old database, but it must be done through our support team, and support
charges may apply.  Please contact us for details.

 

5.8 Normal Login

If you have logged in to MemberTies before, you should have a valid user name and password for at least
one database. 

Note: If you are running any sort of firewall or antivirus software on your computer, read this.

Logging In
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1 Enter your user name and password.

2 Select the appropriate Database.

3 Change the language if necessary.

4 Click Login.

Notes:

If you are trying to use a remote database profile and it isn't working (i.e., if the IP address has
changed, or something was typed incorrectly), you can modify it directly from the Login window.
Just select the database you want, then right-click and choose Modify Database Profile from the
popup menu.

If the maximum number of users allowed by your license are already logged in, the Active
Connections window will be displayed.

It is a common misconception to think that the number of asterisks (****) that appear in the
Password field represent the number of letters you type. They don't.  They are simply there to
mask the data, and will not necessarily correspond with the number of actual characters in the
password.

If you would like to skip the login window entirely (and you're sure nobody else will try to get into
your database) you can have the system log you in automatically. See the AutoLogin Database
Preference for more information.

If you are interested in helping to translate the software interface to your own language, please 
contact us. 

5.9 Languages

MemberTies is written and supported in English, so it is important that someone in your organization
can speak English if you ever need to contact us for support.

The following language variations are installed:

Default (English) - a mixture of US and UK English, with compound labels on some fields. For
example, "cheque" instead of "check" is used for describing a financial instrument, but "ZIP/
Postal Code"  is displayed as one label for addresses.
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US English - standard US translation

UK English - standard UK translation

We at Myrro International do not claim to be fluent in any language other than US English (and
sometimes even that is questionable -- we're programmers, after all), so if you notice something that
would be more properly written another way in a particular translation, please let us know and we'll
change it.

If you are interested in providing a new translation, please let us know.  In exchange for the translation,
and if you're willing to send us updates as we add new text strings for new versions, we'll give your
organization unlimited use of MemberTies free of charge.  We have a special utility designed to simplify
the process of making the translation files we need, and we can make it available to you.

Note: We do not plan to provide any translated versions of the Help system.  Keeping a help system
current in multiple languages would be very time-consuming.  It is assumed that someone in your
organization will be able to speak English to act as a liaison for us (for support needs) if necessary, and
to read the Help and provide assistance to your non-English speaking users.

5.10 Login Problems

If you experience problems logging in to MemberTies, it is normally caused by one of the following:

A firewall or antivirus program may be preventing the server from starting. If you are running any
sort of firewall or antivirus software on your computer, read this.

Too many connections: If the Active Connections window appears when you try to login, it means
the number of seats allowed by your license are already in use.  You won't be able to log in until
someone else disconnects.

Improper Case: You are not typing the password in the proper case, i.e., the Caps Lock key may
be on. This is the most common cause of login problems.

Illegal User: You are trying to use a user name or password that is not valid for the selected
database.

Invalid Database: The database selected in the Database dropdown does not exist, or is not a
MemberTies database. In this case, you should choose the "(Specify New…)" option and create a
new database profile.

Deleted User Name: Your user name has been removed. Contact your MemberTies administrator
in this case.

Access/Permission Problems: your Windows user name may not have privileges to write to the c:
\documents and settings\all users\application data\MemberTies folder (on Vista, this would be c:
\ProgramData\MemberTies\ ). This will prevent the system from starting or creating a database at
all.

Feel free to contact support if you continue to have problems.
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5.11 Command Line Arguments

If you would like to create a Windows shortcut to automatically fill in fields on the Login window (and
optionally start the login process as well) you can use command line switches. (Note that using these
switches will override any auto-login preference setting you may have set.)

Switch Meaning Example

-u [user] Identifies the user name to be entered on the Login window. -u myuser

-p [password] Identifies the password to be entered on the Login window. -p mypass

-d [database] Identifies the folder name of the database to be selected.
This is the value shown in parenthesis in the database
dropdown on the login window.

-d skiclub

-a Indicates that the system should "click the login button"
automatically. No information should follow the "-a".

-a

So a complete entry in a shortcut's Target property might look like:
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Note that the complete entry in the "Target" field is:

"C:\Program Files\MemberTies\mt.exe"  -u myuser -p mypass -d skiclub -a
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6 Getting Started

6.1 Initial Setup

To get the most out of MemberTies, it's important to get some basic things set up before you begin
entering records. The information below is designed to help you through this setup process.

Setting Up Defaults

There are several default values, lists, and settings that will help simplify the process of entering records
later. The following list covers the most import things to check:

Membership Statuses - are an extremely important area for customization. The system comes
pre-loaded with a selection of statuses that may or may not match the way your organization
works. Statuses are essentially classes of membership. Pre-loaded statuses include things like,
Regular, Couple, and Alumni., but you can create your own called "Family", "Newbie", or
whatever.

When you create statuses, you will also be able to set up dues information and other important
characteristics including the default status to be used for new records. Statuses drive a lot of
processing in MemberTies, so it is worth taking time to decide how you want to set them up.

Default State and Country - each time you create a new membership record, the state and
country are set automatically (though you can change them). The default state is (None), and the
default country is United States. You should change these values to match the majority of your
membership. 

Address Types - are used with the professional version, which allows for more than one address
per member record.  Address types might be "Main Address", "Summer Home", "School", etc. 

Phone Types - identify the type of phone number being stored. For example, in major cities, some
people have a "Metro" number that people can use to avoid long distance charges. Other
examples are "Cellular", "Pager", "Fax", or anything else that describes a phone number. The
default is "Normal," but you can create a default phone type for the Home, Work, and Other phone
number. The phone type is displayed on roster reports when the phone number defined as
something other than "Normal".   

References - the membership record has a field called "Reference," in which you can record the
method by which a person found out about your organization. The options you can choose are
called "References". The default is "Unknown". 

Categories and Items - are used together as a way to assign awards, titles, achievements, or
other miscellaneous "stuff" to membership and group records. A typical category might be
"Officer", and a typical item under that category might be "President". 

Custom Fields - are fields that you can name and use for anything you like. You can create any
number of custom fields, and they can be defined as numbers, text, dates, or currency. They can
display as a normal field, a calendar, a selection list, or a checkbox.  You can control what goes
in them, and how it displays. Custom fields are used for anything you need to track that doesn't
already have a field of its own. 

Locations - are used with any activities you create. Each activity has to take place somewhere,
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and MemberTies refers to these places as "Locations." By default, a location called
"Undetermined" is already available, but you can add more at any time.

Attendance Statuses - are used for every activity attendee to indicate whether they were present,
absent, declined, etc.  Each attendance status has a setting to indicate whether an attendee with
that status should be reported as an attendee.  You'll want to make sure statuses like "declined"
are not marked for reporting, or an activity attendance report will show attendees who weren't
really in attendance. 

Preferences

If you run a report, you'll see that the organization name displayed at the top is simply, "Your
Organization." Unless we were very lucky, that probably isn't the actual name of your organization.
Therefore, you need to tell MemberTies what name to use instead. The name setting is found in
Preferences -- a place you can tweak all sorts of program settings. See Organization Preferences for
complete details. 

Note: If you have a registered copy of MemberTies, you probably have a license applied to the database
you are using. In that case, the name is obtained from the license and cannot be changed. See 
Registering for more information if you need a license.

Some other preferences you might want to look at right away are the Report Preferences. These enable
you to set the kind of "tag line" you would like at the bottom of all of your reports, and other report
settings. (The tag line might be something like, "Please contact the Membership officer with changes to
this information.") 

The Administrator Password

Sooner or later you will want the administrator password. When you log in as the administrative user you
will have some special menu options under the Tools menu that let you do things like create new
databases, check, repair, and optimize tables, and create new users. By default, the administrator
account has a user name of "mtadmin" and a password of "password." It is strongly recommended that
you log in as the administrator at some point and change the password to something a little more
secure!

Security Groups

By default, every MemberTies user can do everything. If you will have multiple users, you may want to
control what they can and cannot do.  Security groups can be created to allow users within that group
the ability to do certain things.  Once you have setup the groups, you can simply assign users to them
as needed.

Additional Users

If multiple people will be using MemberTies, they should each have their own user name and password
so you can tell who has changed which records. See Working with Users for complete details.

Add Membership Records

Now you have set up defaults, built lists, and organized your statuses. You are now ready to add
membership records! As you do so, remember that you can press F1 on any window to display the Help
for that window.

If you run into problems, first check the Troubleshooting/Q&A section of this help file to see if your
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question has already been answered. If you don't see your question, check the Help index for related
topics. If all else fails, check the Frequently Asked Questions page on our website (http://www.myrro.
com/memberties) or contact support with your question.

Thank you for using MemberTies!

6.2 Getting Help

The software includes two different kinds of help:

Windows Help, which you are reading now, may be accessed by a Help button, by pressing F1, or by
choosing an option under the Help menu. This help is primarily meant to be procedural -- to explain
concepts or show how to do various tasks. It may also be searched, either via the predefined Index, or
using the full text search available on the Find tab of the main Help window.

MicroHelp, otherwise known as "that help text at the bottom of the screen", is available for anything
that can receive the focus of the cursor (i.e., fields, buttons, and other places the cursor goes when you
click or tab to it).  When a field or button receives the cursor focus, a short description may appear in
the status bar at the bottom of the screen.  Often it will just be the name of the field you're in, but
sometimes it includes something more descriptive.

If you cannot find the answer to your question in the Help files, you have two other options:

MemberTalk Online Forum - Accessed via the Internet at http://www.myrro.com/forum, users from all
over the world can post questions and suggestions, and answer questions from other users.  The forum
is searchable and contains a lot of good information.

Contact Support - Emails to support at support@myrro.com are answered quickly, often in less than
an hour.  We pride ourselves on our fast response time. See Contacting Support for additional
information.

6.3 Common Icons

The following are the most common icons and their general meanings.

Icon Name Meaning

Add Adds a new record

 Arrows Moves selections left & right

Calendar Displays the popup calendar

Copy Copies the selected record(s)

Credit Card Selects/Modifies stored credit card information

Delete Delete the selected record(s)
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Delete File Deletes the selected file(s)

Dial Phone Dials the selected telephone number using your PC's
modem

Dues Opens the dues entry window.

Dues Calculator Displays the system Dues Calculator

Email Opens the Send Email window

Export to File Exports data to a file.

Information Displays an information window.

Merge Merges two or more selected list items into one.

Open Opens the selected record for editing

Open/Browse for File Opens the Windows file system browser so you can
select a file.

Open Member Opens the selected membership record.

Open URL Opens a website URL in the default web browser

Photo Opens/displays a member photo file

Print Prints the selected record(s)

Save Saves changes

Search Searches for a record

Sent Mail List Displays the list of sent email for the current record.

Stored 
Comment

Displays the list of stored comments for selection

Toggle Size Changes a display from scaled to original size and back.

6.4 Toolbar Buttons

The following are the normal toolbar buttons that are displayed. Some buttons are only available to the
professional version, as noted below.  The buttons below are in alphabetical order, not necessarily the
order in which the appear on the main toolbar.
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Button Name Meaning Menu Access

Activity List Opens the activity list. File - Workspace - Activity List

Group List Opens the group list. (Note that
the word "Groups" is controlled
by an organization preference.)

File - Workspace - Group List

Email 

(Pro Version Only)

Enables you to send email. The
addresses listed on the email
window vary, depending on what
window you were on when the
button was clicked.

Actions - Send Email

Front Desk

(Pro Version Only)

Enables you to use activity front
desk window to check members
in and out of activities.

File - Workspace - Activity Front
Desk

Help Options Opens online help, or displays
information about the system.

Help - All Help Topics or,
Help - About MemberTies

Membership List Opens the membership list. File - Workspace - Membership List

Preferences Opens the preferences window,
enabling you to set various
options related to different areas
in the system.

Tools - Preferences

Reports Opens the reports window. File - Workspace - Reports

Snapshots

(Pro Version Only)

Opens the snapshots window. File - Workspace - Snapshots

User Reports

(Pro Version Only)

Opens the user defined reports
window

From the Reports window --
Actions - User Reports

Views

(Pro Version Only)

Opens the user defined views
window

From the Group List or Membership
List --
Actions - Views
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6.5 Calendar

A popup calendar is available to help you pick dates wherever you see the calendar icon. The calendar
and/or calendar field supports a number of keyboard shortcuts.

Key Action         

T Go to Today's Date

D (or plus "+" key) Add One Day

CTRL+D (or minus "-" key) Subtract One Day

H Show Hebrew date for the 
(see below)

M (or Page Up) Add One Month

CTRL+M (or Page Down) Subtract One Month

Y Add One Year

CTRL+Y Subtract One Year

The Gregorian to Hebrew Date Conversion is accessible by pressing the "H" key.  The date is converted
to numeric and text formats and may be quickly copied by clicking the Copy button next to the desired
date format. This is intended for users who need to get the corresponding date for use in a comment or
other text field.  It does not cause the current date field to be replaced by the converted date.
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6.6 Selecting Rows in Lists

Many lists allow you to select more than one row, so you can perform some action on them all.  For
example, you may be able to delete all selected records, or load them all into the Email window, or save
them to a file.

MemberTies supports the standard Windows row selection actions using a combination of the keyboard
and the mouse, as described below.

To Select... Use... In Detail...

One or more rows CTRL + Click Hold down the CTRL key and click each row you want.
Each row you click while holding down the CTRL key
will be added to the set of selected (highlighted) rows.

All rows between one and
another

SHIFT + Click Click the first row, then hold down the SHIFT key and
click the last row. Every row between the first and last
will be selected.

All rows in a list (select all) CTRL+A Hold down the CTRL key and press the "A" key.

Note that the CTRL and SHIFT keys can be combined to select different sets of rows. i.e., you can hold
the CTRL key to select several rows, then add the SHIFT key to it and click further down the list.

To Unselect Single Rows

If you have a bunch of rows selected and just want to unselect a row within the set, hold the CTRL key
down and click the row you don't want.  If it is already selected (highlighted), it will be unselected.

6.7 Tip of the Day

The Tip of the Day window will appear on startup unless you uncheck the Show Tips on Startup
checkbox on the window. The tips are designed to point out lesser-known features of the software and
other ways to do things.
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To Reactivate the Tip of the Day

If you have disabled the Tip of the Day and want to display it again:

1 Open the Help menu and choose Tip of the Day. 

2 When the window appears, select the Show Tips on Startup checkbox.

3 Click OK.

The next time you start MemberTies, the Tip of the Day will be displayed.

6.8 Using a New License

First of all, THANK YOU for registering! Your support is greatly appreciated.

Your new license will generally be sent to you in an email, which should include instructions on how to
apply the license. Since MemberTies is available for download at any time, most users will already have
seen the "reminder" Registration Notice window that is displayed each time you login.  If you follow the
instructions in the email and copy the specified license text to the clipboard, it will automatically be
entered in the license fields when the window appears.

The text to copy form the email will normally be in a special area of text, like this:

--Start Here---------------------------------

My Organization Name

x011p54d023a17zs09u90ak47s78

-----------------------------------End Here--

You should copy everything, including the dashed line above and below the text to use the "Paste
License" option. But if you would prefer to copy just the licensee, and then right-click and paste it into
the Licensee field, then copy the license number and right-click and paste it into the Number field, that
is fine too.
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If you choose not to enter information at this time, just click "Not Yet" to bypass the window and
continue to log in. You can choose "Registering" under the Help menu and click the "I Have a License"
button to display this window again if needed.  You can also enter the license information on any
existing Database Profile in Preferences.

Note: There is a difference between a license for MemberTies, and a license for MemberTies
Professional -- they are not interchangeable. You can upgrade an existing standard license to the
professional version by paying the difference in cost.

Updating the License on Multiple Databases

If you have multiple databases, you should open each database profile in Database Preferences and add
the information there. See Working with Database Profiles for details.

Updating the License for Multiple Users

The license information is stored within the database itself, so as soon as one person loads a new
license, it will apply to all other users.

Upgrading a License

A license is typically valid for all upgrades, large or small, for a full year.  When the license expires, the
only thing that changes is your ability to download and install new releases. Nothing will change with
respect to using your database(s), logging in, adding records, etc.  You still have an existing license, but
the maintenance period has expired.

Note: If the "License Update Prompt" preference is turned on, a message will be displayed 30 days prior
to the expiration date.

You can quickly determine when your current license expires by choosing Help > About MemberTies. 
The date of expiration ("Free Updates Until"), as well as the maximum number of users is displayed on
the License Information tab.
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7 Importing Data

7.1 Converting an Old Database

Databases with a ".db" file extension are from versions of MemberTies prior to 2006. 

As of January 1, 2009, the capability to upgrade these databases was removed from the software to
simplify the upgrade logic. We were simply trying to support too many versions of upgrades, and had to
draw a line somewhere. This impending change was communicated to all users who had email
addresses on file, several months beforehand.

It is still possible to upgrade an old database, but it must be done through our support team, and support
charges may apply.  Please contact us for details.

7.2 Importing Data

Several types of data can be imported into the database from a delimited ASCII text file. "Delimited"
means that each 'chunk' or field of data is separated from the previous chunk by a character of some
kind. The best formats are called "tab-delimited" and "comma-delimited." You can usually look at the
data to tell how it has been saved. "ASCII" means the file should be plain ASCII text (if you see funny
black or white squares in the text -- remove them).

Tab-delimited data is better, because you may have legitimate commas within the text of a field, and
these commas could confuse the import engine into thinking a new field has been started.

For example, tab-delimited data might look like this:

John      Smith      Anytown      PA       75074       United States

But comma-delimited data would look like this:

John,Smith,Anytown,PA,75074,United States

The first rule to remember about importing data is that if the data you are importing is not consistent,
you will probably have trouble getting a clean import. The better the data coming in, the less cleanup
you'll have to do afterward. Sometimes it is a good idea to open your entire data file in something like
Microsoft Excel, so you can view all the rows and columns of data at once.  Scan through it and look for
inconsistencies, stray characters, missing data, etc.  Clean it up as best you can, then save the data to
a tab-delimited text file again.

It is also important to remember that the system assumes the record being imported is the way you
want it to be.  The only data that is automatically added if not found is for fields that are required in the
system. A good example is the Start Date. There is a preference to default the start date to the current
date or some specific date, but it does not apply to imports because the Start Date is not required.

Importing from an Excel File

Before you can import data from an Excel file, you must first convert it to a plain text file.  This is done
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from within Excel itself, as follows:

1 Open the file in Excel. (This is a good time to scan your data for inconsistencies, blank rows,
etc., and fix any problems you find.)

2 Choose File - Save As.

3 Depending on your version of Excel, there should be an option at the bottom of the Save As
window to set the File Type. Choose "Text (Tab Delimited)" as shown below:

4 Now the data is in a format that can be imported.

Blank Rows

Make sure your import file doesn't have any blank lines in it.  The import will stop when it finds the blank
row, thinking it has reached the last record.

Updates vs New Records (Membership Data Only)

When you import data, the system will make a decision as to whether the data is new, or an update to
an existing record.  This is done by looking for the Member ID field in your import map file.  If you are
importing a Member ID, the system will check the database for a matching Member ID on an existing
record.  If found, data will be used to update the existing record rather than create a new record.

If the data for a field being imported is blank, the system ignores it and does not change the membership
record being updated. However, if you really want to import blank data to clear existing data in a field,
import the text =CLEAR  (that's an equal sign followed by the word 'clear' with no spaces).  The system

will respond by clearing any existing data in the target field.

Note: It is a good idea to verify the available State/Province, Country, Phone Type, and Status codes
before attempting an import if your data needs to match these values. Each of these code lists are
available under the Tools > Dropdown Lists menu.  This is important, because if you import a status
called, "Family" and do not have a status in the system by that name, the default status will be used --
possibly generating incorrect data.

Importing Data

1 Choose Tools > Database Tools > Import Data. 

A "Choose File" window will open automatically so you can choose the File that contains the
data to be imported.  Browse to the appropriate text file, select it, and click Open. (If you receive
an error that the file can't be opened, or is already in use, make sure you don't still have it open
in Excel, or some other program that was used to create the file.)
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2 When the Import window returns, the file will be displayed in the File field. If you selected the
wrong file, click the Browse icon to change it.

3 Choose the delimiter used in the text file from the dropdown.

4 Specify the type of data you are importing. The data type you specify will determine the fields
available for import and also which, if any, fields are required to be part of your import file.

Membership Data - enables you to import new, or update an existing, membership
record, including fields on the General, Status, and Custom tabs of the membership record.

Associated Member Data - enables you to import member-to-member relationships,
including the Association Type, date, and comment. The following fields are required in the
import file:

Member ID - Must be an ID that matches an existing membership record. 

Associated Member ID - Must be an ID that matches an another membership record.

Note that the other importable fields with the word "Associated" apply to the Associated
Member ID. The ones without the word "Associated" apply to the primary Member ID
record. 

Friends & Family Data - enables you to import friend/family records to existing
membership records. The following fields are required in the import file:
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Member ID - Must be an ID that matches an existing membership record.

First Name - The first name of the person being added

Last Name - The last name of the person being added

Assigned Item Data - enables you to import assigned item data. The following fields are
required in the import file:

Member ID - Must be an ID that matches an existing membership record. 

Assigned Category Name - Must be the name of an existing Group item category.

Assigned Item Name - Must be the name of an existing item under the specified
category.

Additional Address Data - (Pro Version only) enables you to import additional (non-
current) addresses to existing membership records. The following fields are required in the
import file:

Member ID - Must be an ID that matches an existing membership record.

Address Type - The address type to use for the new address record.  Be sure the
address type you import actually exists.

Country - The country on the address. This can be a country name or code, i.e., "United
States" or "USA" that exists in the list of current country codes.

Dues Data - (Pro Version only) enables you to import dues entries to existing membership
records. The following fields are required in the import file:

Member ID - Must be an ID that matches an existing membership record.

Date Posted - The date for the dues entry

Amount Posted - This will be set to 0.00 if not provided

Posting Type - Must be a posting type in the format,  "Dues Charge (D)", i.e., the
posting type name, followed by a D or C (debit or credit) in parenthesis, just like it
appears on the list of Donations on a membership record.

Donation Data - (Pro Version only) enables you to import donation entries to existing
membership records. The following fields are required in the import file:

Member ID - Must be an ID that matches an existing membership record.

Date Posted - The date for the dues entry

Amount Posted - This will be set to 0.00 if not provided

Posting Type - Must be a posting type in the format,  "Donation (C)", i.e., the posting
type name, followed by a D or C (debit or credit) in parenthesis, just like it appears on
the list of Donations on a membership record.
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Group Data - enables you to import a new Group record, including any field on the General
and Custom tabs of the group record.

Associated Group Data - enables you to import new member-to-group relationships. The
following fields are required in the import file:

Member ID - Must be an ID that matches an existing membership record. 

Group Name - Must be a name that matches an existing group record.

Assigned Item Data - enables you to import new assigned item data. The following fields
are required in the import file:

Group Name - Must be a name that matches an existing group record.

Assigned Category Name - Must be the name of an existing Group item category.

Assigned Item Name - Must be the name of an existing item under the specified
category.

Activity Data - enables you to import a new activity. The following fields are required in the
import file:

Activity Name - The name for the activity

Activity Location - The name of an existing activity location.

Attendance Data - (Pro Version only) enables you to import attendance (and associated
postings) for an existing activity. The following fields are required in the import file:

Activity Name - Must be the name of an existing Activity.

Member ID - Must be an ID that matches an existing membership record.

If posting data is imported as well, the following additional fields are required:

Posting Type - Must be a posting type in the format,  "Activity Income (C)", i.e., the
posting type name, followed by a D or C (debit or credit) in parenthesis, just like it
appears on the list of postings on an activity record.

Note: If the import results in an activity now having more attendees than the specified
activity capacity, a notice will be displayed in the results area. The system will always
import all records regardless of capacity.

5 Click "Next" 

The first 50 lines of data will be read from your file held for display as sample data in the
"Sample Import Fields" section.  You can page through this data one record at a time using the
left/right arrows below the list. Depending on whether your data has a header row or not (i.e., the
first row contains the field names), you will either see headers or your first line of data.

Note: If you see a blank line and have to click the right-arrow a couple of times to get to the
data, you need to fix your import file.  Blank lines in an import file can cause the import to stop
prematurely, so you should remove them.
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6 The Map Fields tab enables you to specify a target field for each piece of data you are
importing. The rows in the "Sample Import Fields" section exactly match the rows in the
"Mapped Target Fields" section. For each row in the Sample list do one of the following in the
Target list:

Ignore it - If you don't want to import data for this field for some reason, either leave the
target blank, or choose "[Ignore Field]"

Map to a Specific Field - If the field contains data that belongs in a specific field, such as
"last name", you can simply select the specific target field (i.e., "Last Name")

Split Data to Two Fields - A split is needed when your field contains combined data like,
"Smith, John". In this case, you don't want to move the contents to either the Last Name
field or the First Name field; you want to divide it between them. In this case, you would
select "[Split First-Last Name]" and then specify which part of the split comes first. There
are several splits defined for you (when importing standard membership and group data). If
you have a combination that is not available, you will have to manually edit your data.

Note: If you are importing data to custom fields, you must set up your custom fields first so
they are defined for the proper kind of data, and the names appear in the target field list. Also
remember that only custom fields marked as usable for imports will be available.

Custom fields defined as a Checkbox will only recognize an import value of Y or N, where Y =
selected, and N = unselected.
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Creating a correct map can be time-consuming. You can save your work at any time by
choosing "Save Map." Once saved, you can reload it at any time. (This can really help if your
first import map doesn't work and you need to adjust it.)

7 Once you have mapped all of your fields, specify the first row of "real" data in the "Begin with
Record" field. This tells the import engine where to start reading data. For example, if your
import file begins with a row of column headings (which is very common), you would want to
start the import with row 2, not 1.

Note: Some things are required by the database, and have to be imported in order to have a valid
record to save.  For example, every record has a Country, every phone number has a Phone
Type, etc.  If your import file does not include this data, the default set on your database will be
used.  All of the default values can be verified via Tools > Dropdown Lists, and the specific type
of field.

8 When you're ready to import, click "Next."

The system begin the process of moving all of your data to the database.

Note: If the import detects a problem, you may be presented with a dialog box for an on-the-
spot correction. The most common cause of this is setting a Split for a field that doesn't always
have a space in it. For example, if you split the last name and first name, but have a field of data
that reads "SMITHJOHN", the engine won't known where to divide the word. Follow the
instructions in any dialogs that appear.

Important: The import process can be very resource-intensive, and the system will ignore any
attempts to click on windows, etc.  If you try to click around while the import is running, you
may see the window title change to "Not Responding".  That simply means MemberTies is
ignoring you because it is busy right now.  If you're importing a hundred thousand records, you
may want to go do something else while it is working. Do not shut off the computer or kill the
program in some other way.

9 When the import is finished, the Results tab will show the results of the process, and any errors
that occurred.



MemberTies59

©1998-2014 Myrro International

If you see errors listed, you'll have to examine each one to decide if any action is necessary.
Common errors that may be reported include:

A member ID was not found when importing a secondary address, so the data couldn't be
imported.

A matching value was not found for some field. i.e., a state of TT was imported by mistake
instead of TX, so the system was unable to look up a state called "TT".  The system will
use the default state/province value in this case.

Invalid data, such as mapping a phone number to a birth date field, or something similar.

The error messages should be fairly self explanatory, and will include the row in record in your
import file where the problem occurred so you can find the original data. The location of the error
file is included in the error log.

10 When you're finished, click Close and then go verify the data within the system.  If the import
went wrong, you can delete all the imported data, modify your map or data, and try again.



Part

VIII
Activity Records
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8 Activity Records

8.1 Overview

An activity is anything your organization "does."  Typical activities include Meetings, Parties, Fund
Raisers, Walks, Tournaments, etc.  Activities can have specific Start and End Dates (including start and
end times), or they can just "exist" without any associated date. 

Using MemberTies Professional, you can also associate members with activities, and track associated
postings. Each associated member can have a unique role  (i.e., "Chairperson", "Speaker", etc.), and
must have an attendance status (i.e., "Confirmed", "Declined", etc.). Any posting items will
automatically be summed and displayed as an overall balance. You can add multiple members to an
activity directly from the Membership List. See Adding Members to an Activity for details.

You work with activities via the Activity List. To get to the Activity List, choose File > Workspace >
Activity List, or click the Activity List toolbar button.

8.2 Reporting on Absent Membres

Obtaining a list of members who did not attend an activity is a little tricky.  If you run an activity report
that includes attendance, it can only show members who did attend, not members who did not.

The solution is to run a membership report (like the Contact list, Roster, Directory, or any user-defined
report based on membership data) and use a special criteria called "Absent from Activity".

This criteria set, used on the Contact List report in this case, will find any members aged 50+ who did
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not attend (were absent from) the "Boring Activity":

Don't try to use the Absent from Activity criteria on an Activity report, or no data will be found. Since an
activity report can only show attending members, restricting it to members who aren't there will eliminate
all attendees.

8.3 Using the Activity List

8.3.1 Overview

The Activity List lets you access all of the activity records in the database. It enables you to define,
store, and load search criteria, as well as access the records themselves. You can also set up a
specific search to run each time the list opens.

The Activity List is made up of two tabs, Search and Results.

The Search Tab
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The Search Tab is used for entering criteria to restrict the records that will be found and displayed on the
Results tab.  In the sample above, only activities with a description containing the word "fundraising" will
be found.

If no criteria is specified, all records will be displayed. If you have a large number of records (more than
1000), using some criteria to limit the number of records found will improve the search speed.

The Results Tab

The Results tab displays the record(s) that matched the criteria entered on the Search tab. 

The Results tab is used for accessing individual records.
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8.3.2 Search Tab

You can use the Search tab on the Activity List to search for records based on your own criteria, and
then display the records found on the Results tab. Refer to the Overview for a quick description of the
types of searches.

Searching for Records

1 Choose File > Workspace > Activity List.

2 When the Membership List appears, choose the Search tab.

3 Determine whether you want to run a basic or advanced search:

Entering Basic Search Criteria 

Entering Advanced Search Criteria

4 When you have finished entering criteria, click Search to tell the database to find the records
that fit the criteria you created.  The matching records will be displayed on the Results tab.

Tip

When you use Advanced search criteria you can save the search for future reuse. See Entering
Advanced Search Criteria for more information about this kind of searching.

8.3.3 Results Tab

The Results tab displays the record(s) that matched the criteria entered on the Search tab, whether
basic or advanced.

If you're not familiar with selecting records in lists, please see this topic on how to select records from
lists in Windows.

Finding a Record in the List

When the Results list is displayed, you can quickly find an activity by simply typing the activity name.
As you begin to type, a field labelled, "Activity Name Search" will appear above the list and will contain
the letters you type. Type enough of the name to identify the record, then press Enter. The current list
will be searched for that name and if found, the record will be highlighted for you.
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Note that the list will be searched in the order that it is currently displayed, from top to bottom. 

Also, use the Page Up/Page Down and Arrow keys to move through the list, or use CTRL+Home and
CTRL+End to scroll to the beginning or end of the list, respectively.

Changing the Sort

Click the column heading of any column to sort the list by that column. This example from the
membership list illustrates clicking the column heading to sort by email address:

 

The first click will sort the column in ascending order, the second click will sort the column in
descending order. 

Widening a Column

If you need to read especially long entries, just position your mouse pointer between the column
headings until the cursor changes to a double-headed arrow, then drag the column to the size you want.
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Dividing the View

Divide the list into two sections by using the split-scroll bar so you can see two different parts of the list
at once. 

Refreshing the Data

Depending on the setting of the "Refresh Lists Automatically" preference, the list may or may not
redisplay to show changes each time you add or modify a record. If the preference to automatically
refresh has been turned off, you can press F5 or choose Actions > Refresh Display to re-retrieve data
from the database. Note that the number of records matching the search criteria is always displayed on
the Results tab. 

Working with Records

Press Enter to open the currently highlighted record for editing.

Press the plus ( + ) key to add a new record. 

Duplicate a selected record by highlighting the row and choosing File > Copy Activity

Display attendance entries for an activity by choosing Actions > Display Current Attendance

Additional options are available either from the Actions menu, or from the popup menu accessed
by right-clicking a row in the list.
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8.3.4 Displaying Current Attendance

You can quickly display the current attendance status of any activity directly from the Activity List.

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, select the activity you wish to display.

3 Choose Actions > Display Current Attendance.

The Checked In tab shows everyone without an End Date. 

Note: If you want to check out one or more attendees immediately, you may select them on the
"Checked In" list, then choose "Check Out" from the right-click menu. All selected entries will
be checked out as of the current date and time.

The Checked Out tab shows everyone with both a Start and End Date.

4 When you are finished, click Close.

8.4 Working with Views

8.4.1 Overview

A "View" is simply a layout of either the Activity, Membership, or Group List consisting of one or more
columns of data representing the fields you want to see.



Activity Records 68

©1998-2014 Myrro International

Note: The Views topics appear under help chapters for each type of list. The process for using views is
the same regardless of the list the view is for.

You work with views via the Maintain Views window. To open this window for the list you're on, click the
Views toolbar button.

MemberTies ships with a single view of both lists, designed to display the most common information
about a record. The default views do not include all available fields, because displaying more fields
means retrieving more data from the database for each record, and retrieving data takes time.  Of
course, you know your computer better than we do, so if it's happy retrieving more fields and more data,
we're happy too.

With MemberTies Professional, you can create your own views to use with the Activity, Membership,
and Group List. This powerful feature puts the decision making totally in your hands, allowing you to
choose whatever fields you want. You have the ability to place them in any order, set both a primary and
secondary sort order (i.e., by City, then by Last Name), and even change the text displayed for the
column headings.

The Views you define will work just like the standard lists. Clicking a column heading will still sort the
whole list, menu options will remain the same, and you can still open and add records normally. Even if
you create a view that only shows the City (which would make it very hard to distinguish one record from
another), if you select one of the rows in the list and open it, MemberTies will still know what record it is
and will open it normally.  

Tip: You can rename a view from the Maintain Views window. Just right-click the view you want to
change and choose Rename from the popup menu.

  

8.4.2 Working with Views

You can create views for the Group List and the Membership List by opening the Maintain Views
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window. 

Adding a View

 1 Open the List to which the View will apply.

For an Activity List view, choose File > Workspace > Activity List

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
This window displays all views that are currently available for the list you are on. In other words,
if you open the window from the Group List, you won't see any membership or activity views.

 3 When the Maintain Views window appears, click Add. This will open the Add View window for a
new view.

 4 The details of using the Add View window are fairly extensive, so it is described on a separate
topic. See Maintaining Views for complete information about adding, editing, or previewing a
View.

 5 If you want the view to be applied when you close this window and return to the original List, be
sure the "Apply Selected View on Close" checkbox is selected before you close the window.

Tip: You can only rename an existing view via the Maintain Views window. To do so, select the view in
the list, then right-click the view and choose Rename from the popup menu.

Changing a View

 1 Open the List that includes the desired View.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
 

 3 When the Maintain Views window appears, select the view you want to change, then click Open
.  This will open the Edit View window.

 4 Make your changes, then click OK.

Deleting a View

 1 Open the List that includes the desired View.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
 

 3 When the Maintain Views window appears, select the view you want to delete, then click Delete
.

 4 Confirm the deletion.

Note: If the deleted view was currently in use, it will remain active until the List on which it
appears is closed and reopened. At that time, the system will use the new default view if one is
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available, or will revert to the system-defined view if there is no default.

8.4.3 Maintaining Views

This window is divided into two tabs. The Define Fields tab must be completed and changes applied
before the Preview tab is available. If you have opened an existing View, the Preview tab is available
immediately, but if you make any changes on the Define Fields tab, the Preview tab will be disabled
again until the new changes are saved.

Note: This procedure assumes that you have already opened or started a new View; if not, see Working
with Views for details. 

The Define Fields Tab

 1 If you are creating a new View, enter a name for it in the "View" field. 

 2 To make this View appear immediately whenever the list is opened, select the Default
checkbox.

 3 Select fields for the view. Use the left and right arrow buttons to move fields back and forth
between the Available Fields list and the Selected Fields list. All fields that are visible in the
Selected Fields list will be shown on the completed View.
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 Note: The top-to-bottom order of fields in the Selected Fields list represents the left-to-right
order the columns will take on the View. In other words, the first (top) field in the Selected Fields
list will appear as the left-most column on the View.

Things to Consider when choosing fields:

When choosing fields, it is very important to consider the primary data type of the view you are
creating.  Even though you can choose almost any activity, group, or membership field, they
can change the behavior of the view based on the primary data type.  For example, if the primary
data type is Membership Data, adding activity fields will convert it into an "activity attendance"
style of view, where only members who have attended an activity will display. Likewise, adding
dues posting fields to a membership view will turn it into a dues postings view, and only
members who have dues postings will be considered.

Primary Data
Type

Type of Field
Added

Restricts the View to:

Membership Membership No Restriction

Activity Members who have attended at least one activity.

Posting (Dues) Members who have at least one dues posting.

Posting
(Donations)

Members who have at least one donation posting.

Group Members who are assigned to at least one group.

Activity Activity No Restriction

Membership Activities with at least one attendee

Posting
(activity)

Activities with at least one posting (attendee or non-attendee)
unless a membership field is also used, in which case the
postings must be tied to an attendee.

Custom Field Activities with at least one attendee (custom fields represent
membership custom fields when used on an activity report).

Group Group No Restriction

Membership Groups with at least one assigned member.

 4 If you want to adjust attributes for a field in the Selected Fields list, select the field you want to
change and click Open to open the Field Properties window. See Changing Field Properties for
complete details. Make the desired changes, then click OK to save the new properties.

 5 Adjust fields up and down in the Selected Fields list to put them in the correct left-to-right order.
The top of the list is the left-most column, and the bottom of the list is the right-most column.
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 6 When you are ready to display the View, click Apply to save changes, then click the Preview
tab.

The Preview Tab

The Preview tab enables you to see what the View will look like, to make changes to the widths of
columns, and even adjust the column order again.

 1 The Record Limit field below the list can be used to prevent the preview window from returning an
unnecessarily large number of records for viewing. This setting has no effect on the way the
View will work on the list -- it only applies to the Preview. 

 2 Click the Adjust Column Widths button to shift the preview into editing mode. In this mode you
can:

Drag the border between column headings to resize the column.

Drag an entire column by its heading to change its position.

Tip: To adjust the width of the right-most column, drag the whole column to the left one column
position by clicking and holding the column heading. That will enable you to "grab" the right-
hand edge with the mouse, adjust the width, then drag it back to its former position on the right.

 3 When you're finished, click the Return to Preview button.
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Once you have the view the way you like it, close the window and return to the Maintain Views list. From
there, you can select the new or modified view and apply it to the current list.

 

8.4.4 Changing Field Properties

The Field Properties window is available for any field on a user-defined report, label, or view.  The
properties vary by type of report/view, as described below.

The following fields are available:

Name: The name may be changed for your own reference, even if it doesn't appear on the report
(such as for a mailing label).

Hide Data - Select this option to hide the entire field. This is helpful if you only want to use the field
as a primary or secondary sort, but don't want to actually see it. For example, suppose you use the
combined First Name/Last Name smart field on the report, but want to sort on the last name only.
Since the combined field shows the first name first you can't sort on the last name portion; instead,
add the last name field and mark it as the primary sort, and then make it hidden to solve the
problem.

Hide Heading: If you want to see the field, but want the heading left blank, select this option. This
field is not available to mailing labels or other report that don't have column headings.

Sort: Choose a Primary and an optional Secondary sort. It is important to at least choose a field for
the Primary Sort. If no sort is chosen, the records will be returned in the order they are found in the
database, which may not be the way you want to see them.

Bold: Select this option to display bold text.

Italic: Select this option to display italic text.

Underline: Select this option to display underlined text.
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Font: Choose a specific font face and height for this field, or select "Use Default" to take the default
font settings  from the Define Fields tab.

Font Color: Defines the color used for the field data.

Back Color: Defines the color used for the field background. This option is not available to Views.

Case: Choose whether data should be forced to appear in uppercase, lowercase, or "any" case (i.e.,
as entered in the database).

Alignment: Choose the alignment setting for data in the field. 

Calculate: For numeric data fields, you can choose to produce a total or average of the column in
the summary area of the report. This option only applies to standard columnar reports, not to labels
or directories.

PreText: Text entered here will be displayed to the left of the data for this field (you can leave
leading or trailing spaces in this field). Tip: If you want to force a blank line to appear above a
particular line (for a Roster style report), enter "~r~n" (without the quotes) in the pretext field. This
code means "carriage return/line feed" and will cause a blank line to be produced before the data of
the field. (This field is not available to Views.)

PostText: Text entered here will be displayed to the right of the data for this field (you can leave
leading or trailing spaces in this field). This field is not available to Views.

PreText and PostText are designed to be used however you choose. One possibility is to use
PreText in place of the column heading. In other words, if the column's "Hide Heading" checkbox is
checked, no heading will appear. Instead, you could use PreText to show the same "heading" in
front of each field to display. For example, a telephone entry on one line might show, "Tel: 123-456-
7890" by using a pretext value of. "Tel:".

8.4.5 Exporting Data with a View

The easiest way to export data from MemberTies is to use Views. You can create a view that contains
exactly the fields you want to export and then use Save As to save the data to a file. The file created will
contain the same data that is displayed on-screen.

To Export Data from a View

 1 Open the Membership or Group List and apply the View of your choice. For instructions on
creating or applying Views, see Working with Views.

 2 Search for the data that you want to export. For example, to export members living in "Anytown,
USA", enter the appropriate search criteria and retrieve those records.

 3 Select the Results tab, then choose File > Save As > [file type] to save the data to a file.

Note: The best format to export data to is Text. Text files are universal, and can be read by
almost any program. The text file export was written by Myrro International for use in
MemberTies, and it will try to use the names of fields as you see them on-screen, rather than
the database names. i.e., you will normally see "Last Name", not "lname".
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You can save data in other formats, but the results may vary widely. In addition, formats other
than "Text" will use the database column names, not the field names you see on-screen. This is
because these are not formats controlled by us, and we can only "dump" data directly to them
without any manipulation.

 

8.5 Maintaining Activity Records

8.5.1 Working with Activities

New activity records can be added to the database whenever the Activity List is active.

Adding an Activity

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, choose File > Add Activity.  You can also click the Add toolbar
button. This will open the Details window for a new activity.

3 The following fields are available:

Name - This dropdown contains the names of all activities that already exist. This is designed
to help keep spelling and naming consistent for recurring activities. You can select an existing
name, or enter something new.

Location - This dropdown contains all active locations that are defined in your database. See
Maintaining Locations for information about creating new locations.

Type - This dropdown contains a all activity types that are defined in your database. Activity
types can be used as another way of categorizing your activities for quick reference. See 
Maintaining Activity Types for information about creating new types.

Description - This is a freeform data entry field that can be used to describe anything you wish
about the activity.

Start Date/Time - These fields indicate the date and time the activity officially starts. They are
both optional, though if you enter a time, you must also enter a corresponding date.

End Date/Time - These fields indicate the date and time the activity officially ends. They are
both optional, though if you enter a time you must also enter a corresponding date.

Dates Apply to New Attendance Entries as Follows - (MemberTies Professional only) This
controls how the Start and End Date/Time values are used to control attendance entries.  The
options are:

No effect on attendance records

Enforce dates as start/end boundaries - requires that the start/end date/time of attendance
records fall within the dates of the activity itself.

Copy start date/time - causes the start date/time to be automatically entered on new
attendance records.
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Copy end date/time - causes the end date/time to be automatically entered on new
attendance records.

Copy both start and end date/time -  causes the both the start and end date/time to be
automatically entered on new attendance records.

Capacity - This indicates the maximum number of attendees allowed for the activity. A value of
zero ( 0 ) indicates that there is no limit. If set to a non-zero value, then once the capacity is
reached, no more attendees or guests can be added unless the Overbook option is turned on
(see below).  The percentage full is displayed next to the capacity if applicable.

Overbook - Select this option if you want to have an activity capacity, but allow it to be
exceeded. For example, you may have a target of 50 attendees, but if you exceed it, that's all
the better.  If you enter 50 as the capacity, the percentage full will be displayed, but you won't
be limited to 50.

If you are using MemberTies Professional, a set of tabs are available on the lower half of the
window for entering associated membership records and income/expenses.

Exempt from Attendance Max - Select this option if attendance of this activity should not
toward the maximum allowed for a membership status.  See Status Codes for more information
about limiting total activity attendance for a membership status.

Advanced options - If you are using  MemberTies Professional, you can click the Advanced
button to access additional options. See Advanced Options for details.

The following sections are available once the activity has been saved:

Associated Members - associates one or more membership records to the activity. See
Associating Members to an Activity for more information.

Income & Expenses - assigns income and expense postings to the activity and relates
them to an attendee if desired. See Tracking Activity Income and Expenses for more
information.

Related Files - associates one or more files on your PC to the activity record. See Relating
Files to Activities for more information.

4 Complete all appropriate information, then click OK.

Tips

If the time format is not appropriate to your country, you can switch between 12 and 24 hour
display. See Miscellaneous Preferences for more information.

Your changes to the activity may not appear in the Activity List until it is Refreshed.

Changing an Activity

1 Choose File > Workspace > Activity List.
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2 Select the activity you want to change, then choose File > Open Activity, or click the Open
toolbar button. This will open the Details window for the record.

3 Make your changes, then click OK.

Copying an Activity

1 Choose File > Workspace > Activity List.

2 Select the activity you want to copy, then choose File > Copy Activity, or click the Copy toolbar
button.

3 If you're using MemberTies Professional you will be prompted to copy Attendance and/or Income
and Expense entries. Select the types of additional data to be copied to the new activity, then
click OK.

4 The new activity will appear in the Activity List with the word "(Copy)" appended to the activity
name.

Deleting an Activity

If you're using MemberTies Professional, deleting an activity will also remove all associated Income and
Expenses, as well as all associations between members and that activity. However, deleting the activity
has no affect on the membership records themselves.

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, select the record(s) you want to delete, then choose File >
Delete Activity, or click the Delete toolbar button.

3 Confirm the deletion.

8.5.2 Advanced Options

With MemberTies Professional, you can setup some advanced options on the Activity Details window
that will apply to the Front Desk check-in / check-out process.  To access advanced options, click the
"Advanced" button on the activity window.

Setting Advanced Options

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, either click the Add or Open toolbar button to either create or
open an activity. See Working with Activities if you haven't created an activity yet.

3 Once the Details window for the record opens, click the Advanced button.
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The Advanced Options window is divided into two tabpages:

Automatic Reports - enables you to specify one or more reports that will automatically print for
the attendee upon check-in and/or check-out. 

You can select from any user-defined membership or activity report, but keep in mind that the
report will run as if you had entered the attendee as criteria. It will only print one record.  This
option is designed for printing a name card at check-in, for example. 

Choose the desired report, and then select when it should print.  The "Active" option enables you
to turn off a report without losing your settings.
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Automatic Postings - enables you to default specific charges based on the membership status of
the member being checked in.

Anything entered on this window will be entered on the posting record created when a member of
the applicable status is checked-in.  If you want to be able to override the values, select the
"Optional" checkbox.  If "Optional" is not selected, the fields on the Front Desk window will be
disabled. The "Active" option enables you to turn off a report without losing your settings.

Note that a special "status" for "Undefined" is also available.  If this is used, it will be applied
whenever an attendee has a status that doesn't have a specific amount associated with it. 

In the above example, there are specific amounts associated with several statuses.  If a member
having a different status attends, the system will use the "(Default)" amount shown.

Attendance Limits - enables you to specify how many times a member with a given status can
attend this specific activity.  Any status that is not listed is assumed to be unlimited.  A limit of
zero effectively denies members with that status access to the activity. 
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Note: An attendance limit can also be defined on the Status itself (see Status Codes ). Any
limit defined at the status itself takes priority over a per-activity status defined here.  So if the
"Regular" status itself is set to a maximum of 5, a member with this status will never be able to
attend more than 5 total activities and will never reach the limit of 10 defined here.

8.5.3 Recording Activity Attendees

With MemberTies Professional, you can keep track of all members who attend an activity, the role they
played, and their attendance status, and whether the brought any guests. This makes it easy to track
things like "who was the host", "who declined to attend", "who tended the bar", etc.  The combination of
member name, role, and status lets you easily track the people involved.

The count of attendees and guests is displayed on the tab and is be updated each time you add or
delete attendees.

Note: If you are creating a new activity record, the activity must be saved first (click Apply) before you
can access this tab.

Note: This help topic explains how to add attendees from the Activity record itself.  You may also add
multiple members to an activity directly from the Membership List. See Adding Members to an Activity
for details.

Adding an Attendee

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, either click the Add or Open toolbar button to either create or
open an activity. See Working with Activities if you haven't created an activity yet.

3 Once the Details window for the record opens, choose the Attendance tab.

4 Click Add. Since attendees must already exist in the database, a Search window appears.

5 Use the search window to find the desired attendees. Each time you search for members, the
results of the search will be added to the results list on the search window.  To keep from
clearing the results with every search, select the "Append" checkbox located beneath the
Search button.
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6 Choose one or more members in the Results list, then click Select to assign them to the
activity. Each record will be assigned the default Role (if a default exists) and default Status
automatically (note that you can supply this information using the "Additional Information" tab on
the search window if you wish, though it will be applied to all selected members). 

7 After the new members appear on the Attendance list, you can open and edit them individually
or as a group to assign role, status, etc. See below for details.

Changing Attendee Details

1 Choose File > Workspace > Activity List.

2 Select the activity you want to change, then choose File > Open Activity, or click the Open
toolbar button. This will open the Details window for the record.

3 Choose the Attendance tab.

The attendance tab includes several counts for quick reference. In this example, "5 (6,4,1)" is
shorthand for "5 valid attendees (6 members are listed, 4 of which are in attendance based on
their attendance status, 1 guest). 

4 Select one or more records to modify, then click Open.  Note that by choosing multiple records,
all changes will be applied to all selected records.

5 The following fields are available:

Role - This dropdown contains all Activity Roles currently defined in the database. See
Maintaining Activity Roles for information.

Status - This dropdown contains all Attendance Statuses currently defined in the database.
See Maintaining Attendance Statuses for more information. The attendance status is required.

Start Date - This date represents the date and time the attendance starts

End Date -  This date represents the date and time the attendance ends

Sponsor - An optional sponsoring member for the attendee.  Use the Choose Sponsor and
Remove Sponsor icons next to the field to change the selection.

Comments - This is a freeform text field for additional details.

Guest List - Shows a record for each guest recorded for the attendee. There are two ways to
add a guest: 
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If all you care about is the count of guests, click the Quick Guest button and enter the
number of guests.  A placeholder guest record will be created automatically for each guest.
A guest added in this manner will display "No Name Available" for the Guest Name.

If you want to enter the name or address of the guest, click the Add icon below the guest
list, and add a detailed guest record.

Income & Expenses - Shows a record for each income or expense entry associated with the
attendee. 

Any posting added here will automatically be tied to the current attendee (as opposed to adding
postings at the activity level, when you have the option of assigning it to an attendee).

Deleting an Attendee

When an attendee is deleted, any guest record or income/expense record tied to that attendee is also
deleted.

1 Choose File > Workspace > Activity List.

2 Select the activity you want to change, then choose File > Open Activity, or click the Open
toolbar button. This will open the Details window for the record.

3 Choose the Attendees tab.

4 Select one or more records, then click Delete.

5 Confirm the deletion.

8.5.4 Recording Activity Income and Expenses

With MemberTies Professional, you can post debits and credits to activities just like you can post dues
or donation debits and credits on membership records.   Each entry can be associated with the activity
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itself, or specifically associated with an attendee.

Activity postings are also available when creating a Deposit.

Note: If you are creating a new activity record, the activity must be saved first (click Apply) before you
can access this tab.

Adding Income and Expenses

1 Choose File > Workspace > Activity List.

2 Click the Add or Open toolbar button to either create or open an activity. See Working with
Activities if you haven't created an activity yet.

3 Choose the Income & Expenses tab.

4 Click Add

5 The following fields are available:

Date Posted - The date on which the entry is being recorded.

Date Recognized - The date on which you want the amount to apply to your organization.
Since most activities tend to start and end in a short time period, the date recognized will
normally be the same as the date posted. But if you need to prepare for an activity during the
latter part of one year but actually account for it the following year, you can use the date
recognized to identify these entries.  That way, a report run for the first quarter of next year will
show an entry that was actually posted the year before.

Posting Type - the posting type to be applied to this entry. The debit/credit action of the type is
displayed in the dropdown, and any minimum or maximum amount requirement is displayed to
the right of the field. See Maintaining Posting Types for more information. 

The posting type will be defaulted to the default Activity posting type specified in the Posting
Types list, if available. If no default has been set, the type will be blank.

Amount - The amount to be recorded. Only positive numbers may be used. The posting type
determines whether the amount is applied as a debit or credit to the account. 

There are several ways to enter the amount. In addition to typing in an amount, you may have
other options depending upon the way you set up your Posting Types. If you associated
minimum or maximum amounts for the posting type, you can quickly enter those amounts by
clicking the appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  

Receipt Number/Book -These fields are enabled whenever the selected posting type is one
that has been defined to generate a receipt number. The fields are disabled for all other posting
types.  The Receipt Number is a sequential number generated by the system. The Receipt
Book is the value set as the Dues Receipt Book Nbr in preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 
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Assign Now - Click this option if you want to force the system to generate the next receipt
number immediately. Note that once a receipt number has been generated, it is "used"
permanently, even if you choose not to save the entry.  The only way to reset it is via the Dues
Receipt Book Nbr preference.  If you want to "regenerate" a new number for an entry that
already has a receipt number, you must clear the field first, then click Assign Now to generate a
new number. If you do not want the Assign Now option to be available at all, it can be turned off
via the Allow Assign Now preference.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  

Printed Receipt - This option controls when a receipt should be printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Income/Expense list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Activity Print Receipt = Selected"
to print all marked receipts at once.  

Associated To - Members currently associated to the activity are available in the dropdown list.
If this entry should be tied to a specific attendee, choose that person here. (Note that if you
assign income or expenses while editing an attendee directly, it is automatically associated to
that attendee.)

6 When you are finished, click OK.

Changing an Income or Expense Entry

1 Choose File > Workspace > Activity List.

2 Select an activity, then click Open. This will open the Details window for the record.

3 Choose the Income & Expenses tab.

4 Select the entry you want to change, then click Open.

5 Make your changes, then click OK.

Deleting an Income or Expense Entry

1 Choose File > Workspace > Activity List.

2 Select an activity, then click Open. This will open the Details window for the record.

3 Choose the Income & Expenses tab.

4 Select one or more records, then click Delete.

5 Confirm the deletion.
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8.5.5 Relating Files to Activities

With MemberTies Professional, you can link one or more files on your PC to an activity. This is
convenient for things like activity ledgers, notes, maps, or any other file stored on your PC. 

Note: Any file stored on your computer can be associated with the activity record.  The file is either
stored as a link to the physical file, or stored in the database, depending on the File & Photo Storage 
database preference.  If you are storing files and photos in the database, be sure to keep file sizes as
small as possible to avoid dramatically increasing the database size.

Note: If you are creating a new activity record, the activity must be saved first (click Apply) before you
can access this tab.

Relating a File

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, either click the Add or Open toolbar button to either create or
open an activity. See Working with Activities if you haven't created an activity yet.

3 Choose the Related Files tab.

4 Click Add

5 The New Related File window will open, and a browsing dialog will open at the same time to
enable you to find the file you want to relate to the activity.  Choose the desired file and click
Open; the path to the file will appear on the New Related File window.

6 The following fields are available:

Select the File to Relate - This field cannot be edited directly. Click the browse icon to reopen
the browsing window if you need to choose a different file.

Brief Description - This is a freeform text field for additional details about the file.  Something
more readable like, "Activity Budget" will make the entry in the list of files more meaningful.

7 When you are finished, click OK.

8 When the Related Files tab is active again, you can select any listed file and click "Open File"
to tell your computer to open the file using the appropriate program.

Changing Related File Details

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, select an activity, then click Open. This will open the Details
window for the record.

3 Choose the Related Files tab.

4 Select the entry you want to change, then click Open.

5 Make your changes, then click OK.
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Delete a Related File

1 Choose File > Workspace > Activity List.

2 When the Activity List appears, select an activity, then click Open. This will open the Details
window for the record.

3 Choose the Related Files tab.

4 When deleting a related file entry, you have two options:

To delete only the relationship, leaving the physical file on your computer, click the delete
icon

To delete the relationship and the physical (or stored) file, removing the file itself forever,
click the delete file icon.

Note: If files are stored in the database, deleting the relationship always deletes the stored file
as well. Otherwise, the orphaned file would sit in the database forever.

5 Confirm the deletion.

8.5.6 Tracking Deposits

Using MemberTies Professional, any number of postings can be grouped together as a "Deposit"
identified by a deposit number and date.  

Adding a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, click Add.

3 The Deposit Detail window displays all postings currently assigned to this deposit as well as the
deposit header information:
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Date - The date of the deposit.  This may represent the date you create the deposit, or the date
it goes to the bank.

Number - The system generates a deposit number automatically, but you can change it if you
wish.  The system will always add 1 to the highest recorded deposit number when generating a
new deposit.

4 Click Add to search for more postings.

5 On the Add Postings to Deposit window use the search criteria fields to limit the postings
returned by the search:

From Date - The oldest date a dues/donations posting or activity income/expense entry can
have. This defaults to the  date of the most recent deposit.

To Date - The most recent date a dues/donations posting or activity income/expense entry can
have.

Include - The type of items to be searched (i.e., dues, donations, etc.)

Posting Type - Indicate the type of postings to search. Most deposits will only contain Credit
postings (activity income is treated as a credit), but you can search Debit postings as well.
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6 Click Search.

7 Select one or more postings to add to the deposit, then click OK to return to the Deposit Detail
window.

8 Click OK to save the deposit.

Changing a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, select the deposit you want to modify, then click Open.

3 On the Deposit Detail window, use the Add and Delete icons to either add more postings, or
remove existing postings.

4 When you are finished, click OK

Deleting a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, select the deposit you want to delete, then click Delete.

3 Confirm the deletion.

Printing a Deposit

Use the Reports window to print the Deposit Detail report.

 

8.6 Using the Activity Front Desk

8.6.1 Using the Activity Front Desk

With MemberTies Professional, you can use a special "Front Desk" window to quickly search for
members and check them into and out of activities.  The Front Desk window is designed to simplify the
use of bar-coded membership ID cards. (The assumption is that the ID cards contain a bar code with the
member ID encoded, and that you have entered the appropriate member ID value into the corresponding
membership record within MemberTies). However, there is no requirement to have an ID card to use the
Front Desk window. You can manually enter a value in any of the search fields.

The Front Desk window is composed of three sections:

Member Search Criteria
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The search criteria area works just like other MemberTies search windows. You can enter one or more
criteria values, and when you click the Search button, the system will try to find the matching record.  If
you have the member ID on a bar-coded membership card, you can leave the cursor in the Member ID
field, and when the card is scanned, the system should automatically display the member if the ID
matches a record in the system.  The bar code needs to contain the exact matching member ID, and
the scanner you use needs to terminate the scan with a "carriage return" or "enter key". This simulates
you pressing the Enter key on your keyboard, which triggers the Search button.

Options in this Section:

Set Favorite - Enables you to choose the search criteria field the cursor should return to when
you press the Escape key or complete a successful Check In.  If you're using a scanner to
display membership records, you can essentially scan the card, see the member, click "Check
In" (or just press the space bar, as the Check In button should be active at that point) and the
cursor will immediately return to the favorite field with the screen resent for the next person.  If for
some reason the cursor needs to return to the favorite field sooner, you can press the ESC key to
force it.  To set the favorite field, put the mouse cursor in the desired field, and click the button.

The Add icon - Enables you to add a new membership record immediately. When you save the
new member, it will automatically be selected and displayed in the Member Synopsis area.

The Member ID field - is used for finding a matching Member ID but it will also search for a
matching Friends/Family record with the corresponding ID.

If you click Search and more than one record matches the criteria, a list of possible matches will
appear. (See the Multiple Records window description below.)

The "Custom 01" and "Custom 02" fields are examples of custom fields that can be displayed if
you use the Custom Field maintenance window to mark a field as usable for Front Desk searches.
 See Maintaining Custom Fields for more information.  

Multiple Matching Records

If more than one record matches the search criteria, a list of matching records will be displayed so you
can choose the desired record to use, or just check one or more in immediately:
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Options on this window:

Use - Displays the selected record in the Member Synopsis area (see below) of the main Front
Desk window, ready to be checked-in.  This happens automatically when your search only yields
a single matching record.

Check-In - Enables you to check-in one or more records automatically, without ever displaying
them on the main window. Note that if you select a record that is already checked in, the resulting
behavior depends on your Front Desk preference settings. The system may ignore it, prompt you,
or allow it to be checked in a second time.

Check-Out - Enables you to check-out one or more records, similar to the Check-In option above.
This options works like the unattended mode check-out, in that it finds all open (not-checked-out)
attendance entries for the member on the current activity and closes them.

Hide Photo - Select this option to remove the photo display and expand the list in its place.

Note: if you do not want to see the Company Name in this list, turn off the Show Company in Results 
preference.

Member Synopsis
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The  Member Synopsis provides basic membership information at a glance. 

In this section:

If the End Date on the membership record has passed, the date will be displayed in red text as an
informational warning to you.

A popup warning that the End Date is in the past will appear if the End Date Warning preference is
turned on.

The system will prevent the check-in if someone with an expired End Date is selected if the End
Date Validation preference is turned on.

The member's name is a clickable link to open the full member record. (If the selected attendee is
actually a family member, clicking the name will open the main member record, and you can go to
the Family tab from there.)

The Comments icon enables you to change the comments field on the membership record without
opening the full record.

The "Hide Photo" checkbox can be selected if you don't typically use photos or don't want to
display them.

A Dues icon can be displayed by enabling the Allow Dues preference. This allows the creation of
dues entries directly from the Front Desk. This can be helpful if the person using the Front Desk
doesn't have access to the membership record.

The information displayed in the Member Synopsis can be limited by the Limit Synopsis Data
preference.

 The photo is a clickable link to the photo window, enabling you to change a photo, or view the
member's friends/family photos, as shown below:
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Activity Check In/Out

The Activity Check In/Out section controls the process of actually assigning a member to an activity.
When the member checks IN, the start date and time are set. When the member checks OUT, the end
date and time are set. The attendance entries for the currently selected person, for the current activity,
are displayed in the list on the right.  In addition, the number of times the person has attended an event
with the same type is shown above the list.
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Note: The information icon displayed next to the Activity field can be used to quickly display a synopsis
of the activity, and the current number of attendees checked in or out.

The following fields are available:

Activity - This dropdown contains the names of all activities that are "active". An activity is listed if
the current date falls within the activity start and end date, or if the activity has no end date, or no
dates at all.

The following fields enable you to setup entries that will automatically be "stamped" on each
member attendance entry.

Date/Time - The selected date and time. This is normally used when you need to enter something
other than the current date and time. If you would prefer to enter the current date and time, select
the Use Current Date and Time checkbox instead.

Role - This dropdown contains all available activity roles.

Status - This dropdown contains all available attendance status codes. The attendance status is a
required field.

Comments - This is a freeform text field for additional details about the attendance entry.

Sponsor - An optional sponsoring member for the attendee. i.e., if a person is attending with the
support or "sponsorship" of an existing member, this enables you to record the link between
attendee and member.

Posting Type- Choose the posting type appropriate to the entry. If everyone coming to the activity
must pay $15.00 to get in, for example, setting this field to "Activity Income" and the Amount field to
$15.00 will streamline the recording of incoming fees by automatically entering that amount for each
attendee.

Amount - The amount of the income or expense entry.

Cheque - The cheque number or other identifier of the entry.

Comments - This is a freeform text field for additional details about the income/expense entry.

Notes: 

If automatic postings have been defined for the activity, these fields may be filled in
automatically and disabled. For details, see Advanced Options for the activity.

If you want to be warned when checking-in a person who is already checked-in to the
activity, turn on the Multiple Check-In Warning preference.

Checking In an Attendee

The ability to check-in via the Front Desk is controlled by several preferences. 

1 Setup the appropriate data in the Activity Check-In Details section.

2 Search for the member using the Criteria section.
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3 Click "Check-In." If the member has already been checked in to the current activity, you will be
prompted to confirm an additional entry.

Checking Out an Attendee

1 Search for the member using the Criteria section.

2 The "Current Attendance Entries" list will display all entries for the selected member.

Note: The Hide Closed Entries checkbox will filter out all entries that already have a Check Out
date/time. 

Select the current attendance entry you want to close, then click "Check Out".  The end date
and time will be set to the current date/time.

Changing an Attendance Entry

Any entry shown in the Current Attendance section can be opened for editing. Just select the record and
click Open.

Unattended Check In

Once the Activity Check In/Check Out section has been set up with the appropriate values, you can
click "Unattended Mode" to open a special full screen window that is designed to accept incoming card
scans.  When the window opens you are given the opportunity to create a password to secure it.  This is
helpful if you want to prevent one of your guests from simply closing the window and accessing your
entire database.  If you do not want a password, you can leave it blank.

See Using Unattended Check In Mode for details.

8.6.2 Using Unattended Mode

If you have membership cards created with a barcoded Member ID, and those IDs have been entered on
the corresponding membership records in MemberTies, you are ready to let people check in or out of an
activity without intervention by you.  This means you could setup a card reader at the entrance to an
activity, and as people scan their cards, MemberTies will automatically find the appropriate membership
record and create an activity attendance entry for them (in Check In mode) or check them out of the
activity (in Check Out mode). A third option, "Smart Mode", lets the system determine whether to check
them in or out.

Unattended mode is an extension of the Activity Front Desk window. Once the Activity Check In/Check
Out section has been set up with the appropriate values, you can click "Unattended Mode" to open a
special full screen window that is designed to accept incoming card scans.  

Starting Unattended Check In

1 Choose File > Workspace > Activity Front Desk.

2 Setup the appropriate data in the Activity Check In/Check Out section. See Using the Activity
Front Desk for details.
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3 Click "Unattended Mode".

4 When the Create Password window appears, enter a password if you want to secure the
unattended mode window so someone can't easily close it and access the rest of your
database. If you do not want to use a password, click OK without entering anything. If you click
Cancel, you'll be returned to the Front Desk window.

Note: If you don't ever want a password, turn off the Use Unattended Password preference.

5 When the Unattended window opens, it will say, "Waiting -- Ready for Scan..."  (unless changed
via Setup options, see below). When a card is scanned, the stored Member ID will appear in the
box in the middle of the window.

6 Click Setup to open the Unattended Mode Options window. This window includes the following
settings:

Operating Mode - Determines how the system will react to scans. In "Check In" mode, the
system will create a new attendance record for the scanned member record; in "Check
Out" mode, the system will close ALL open entries for the current activity; in "Smart
Mode", the system will first check to see whether the member is currently checked in or
not.  If not, the member is checked in, and if so, the member is checked out.  The title of
the window will also vary based on the Mode setting.

Stop on Error or Not Found - Select this option if you want the window to stop responding
to scans when an error occurs or an ID cannot be found in the database.  If this is not
selected, a message will be displayed briefly that no match was found, and then the
system will accept the next scan.

Not Found Log - Select this option if you want the system to maintain a log of every "not
found" scan. This enables you to then click the Open icon next to this checkbox or run the
Activity Check-In Not Found report to find ID issues. Note that you can delete log entries
via the window accessed by choosing the Open icon.

Terminator Key - Most bar code readers can be set to send a specific key press after each
scan, typically an Enter key or a TAB key.  Identify the type of key the system should treat
as the end of the scan.  If you are not sure, leave it set to the Enter key.

Welcome Text - Sets the large welcome message displayed in the top portion of the
window. The default text is, "Welcome!".  This message will hold up to three lines of text,
the width of the window. To enter a line break in the message, use "<CR>",

 i.e., "This is line 1<CR>This is line 2<CR>This is line 3"

This text is limited to 250 characters.

Waiting for Scan Message - Sets the text displayed while the system is waiting for the
next card to be scanned. The default text is, "Waiting for Scan..." This text is limited to 50
characters.

Allow Activity Selection - Select this option to display a "button" that shows the currently
selected activity.  Users can click this button to open another window to quickly change
the activity prior to scanning their card. (For example, if members are coming in to work on
one of several projects, this option will allow them to choose the project in question before
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scanning their card.)

Activity Selection Message - Sets the text displayed above the activity selection button.
For example, "Choose Activity..." This text is limited to 50 characters. This setting has no
effect if the Allow Activity Selection option is not selected.

When you have verified the setup options, click OK to save.

7 Scan a card to be sure the system can recognize the input.  

If nothing appears on the screen, be sure everything is connected correctly and that the
scanner is properly set up.  

If the member ID appears, but nothing happens, be sure the scanner is set up to terminate
the scan with an Enter or Tab keystroke, and that the Setup options on the window
correspond to that setting.

If a "Not Found" message appears, try searching for the member manually using the ID
that is displayed. 

Stopping Unattended Mode

1 Click "Close". 

2 If you entered a password when the window was opened, you will be prompted for it again.
Otherwise you will be returned to the Front Desk window.
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9 Database Maintenance

9.1 Server and Database Overview

This topic is designed to provide an informational overview of the entire database system that is
MemberTies. You don't absolutely have to understand everything to this level of detail in order to user the
system, but we wanted to provide the information in case you were interested.

It's easy to think of MemberTies as just a single piece of software -- that what you see on screen when
you're entering members is all there is -- but that isn't the whole picture.  The following diagram
illustrates the three major components of the system: the Server, the Databases, and the Application. 
The typical corresponding folder structure is also shown for reference.

Note: The above directory structure applies to a default installation on Windows Vista and newer. On
older operating systems such as Windows XP the ProgramData\MemberTies location was a much
longer folder structure: "Documents and Settings\All Users\Application Data\MemberTies" 

What it all Means

A simple way to understand the relationship between the database, the server, and MemberTies is to
think of it like a bank. Think of your database as the bank vault. Your data is like money in that vault. 
When you want to put money into the vault you have to request the services of an employee at the bank.
 That employee is the server -- moving money (data) back and forth between you (MemberTies) and the
vault (the database).
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The Server

It is a common misconception that any reference to a "server" is always a reference to something on the
Internet.  That can be true at times, but often a server is nothing more than another small program that
runs on your computer. With MemberTies, that is also the case; the server is the program that lets
MemberTies move data in and out of your database.  

The server program files reside in a "Server" folder, located in the folder where MemberTies is installed. 
The location is typically, c:/program files/MemberTies/server/.  Inside that folder are various other folders
containing the files required to start and run the server. You shouldn't ever have to touch anything in
these folders. In fact, doing so could actually prevent the server from starting at all, thereby preventing
access to any database. 

The server has several important jobs to do:

Track all databases.

Track all connections to the databases.

Manage the flow of data between MemberTies and the appropriate database, and maintain all the
tables in the database as they change with the data.

As you can see, the server can be very busy. Every time the application wants to view or update
information in the database, (for example, when you open a membership record), the server has to
receive the requests for data, open the appropriate table(s), get the data, and send it back to the
application so it can be formatted for display. When you run a query for 1,000 records, the server has
seen them all before they ever appear on the screen.

Note that you won't see a special window on-screen when the server is running. The server is a program
that runs invisibly in the background, content to simply manage the flow of data between the database
and the application.  You can tell it is "out there" if you open the Windows Task List (typically by
pressing CTRL+ALT+DEL) and look for a process called "mtmysqld.exe".  The server program takes up
very little memory, and will continue to run even after you shut down MemberTies. This is done so the
next time you start MemberTies it will be faster, because it won't have to bother starting the server again.
 When MemberTies isn't running, the server will be content to just sleep and do nothing. If you need to
check the status of the server, or shut it down manually for some reason, a special Server Utility is
installed and available for this purpose. 

The Database

The database is not a single file. instead, each database is comprised of a large number of files within a
single folder bearing the database name.  The database folders are located, appropriately enough, in a
"database" folder in a special folder in Windows where applications are allowed to make changes,
namely, ProgramData. This location is typically, c:/ProgramData/MemberTies/database/(database
name)/. There are lots of files inside that folder, representing the various tables within the database.

Important: These files should ONLY be managed by the server! Opening a file using a text editor or
word processor can corrupt the file, causing all of the data to be lost.  It is impossible to edit data by
modifying these files directly! If you run an antivirus program on the computer that hosts the server, it is
a very good idea to make sure it excludes checking on everything in the database folder. The files there
are non-executable text files anyway, so they are not virus threats.

MemberTies enables you to have any number of databases, each of which will have its own folder under
the Database folder. The system keeps track of the "friendly" database name, and the license in use for
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it, and other details in a special file called mtdb.xml. This file is updated when you specify your license
information or work with database profiles in the application.

The Server also maintains a single small database of its own.  This database is called "mysql" and it is
used by the server track permissions, connections, and other internal settings.  This means that you will
always have at least two databases: your own, and the server's "mysql" database.  In the example
above, there are two user defined databases ("ski_club" and "speech_club") in addition to the server's
database.

Also in the MemberTies folder are sub-folders called Temp and Logs.  The Temp folder is used as a
place to create and delete files that are only used for a short while as the server goes about its
business. These might be temporarily created image files, tracking files, documents in progress prior to
saving, etc.  The Logs folder contains all of the logs that are generated within MemberTies. These
include email logs, backup logs, etc.

The Application

The application is what you probably think of as MemberTies itself.  It's the collection of windows,
menus, buttons, reports, etc., that you use to view and manage all of your data. Essentially, the
application is what simplifies the process of working with a complicated database on a day to day basis.
Imagine if you had to type out complicated commands for every record you wanted to see, and then
more commands to change the data, and still more commands to see the results again.  It's much more
convenient type data in fields and click OK to save and redisplay!

When you start MemberTies, the first thing it does is make sure that the server has been started.  Then,
when you enter your username, password, and database choice on the Login window, the application
forwards those selections on to the server. The server looks at your selections and verifies that, 1) there
really is a user with the name you entered, 2) that the user by that name is allowed to login to the
database you specified, and 3) that the password you provided is correct. If anything isn't correct, the
server responds with an error, which the application then displays for you to see.

9.2 Creating a New Database

When MemberTies is initially installed there are no databases available, which is why you were
prompted to create a new database when you first started the program.  If you would like to create
another database you can do so at any time.

Note: Only the administrator user (mtadmin) can create new databases.

Creating a New Database

1 Login to MemberTies as the user "mtadmin". 

2 Choose Tools > Database Admin Tools > Create New Database.
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3 Enter a name for the database, then click OK.

If you receive a warning message that the database already exists, STOP. You are about to
wipe out an existing database. Only proceed if you really want to destroy all data in the
database. See Resetting a Database for more details.

Note: You can uses spaces in the name if you wish, i.e., "Ski Club", but the actual name of the
database folder will replace the spaces with underscore characters. So if the name you choose
is "Ski Club", the folder name for the database will be "ski_club".  Do not use any special
characters in the name, such as punctuation or quotation marks. i.e., "John's Database" would
be illegal.

4 You will receive a message about the mtadmin user account:

This message is just letting you know that the master user, "mtadmin" will automatically be
able to connect to your new database.  The password for this account is "password" by default,
but you can change it. 

5 The Create User window will open. Enter the new name and password information, then click
OK.
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6 When the database has been created, the system will show you a report containing details
about the new database, such as the database name, and the user/password you just created. 
It is a good idea to let the system print this report for future reference.  It is very frustrating to
return to the Login window, only to realize you've forgotten the password you just created!

7 When the process is finished, a message indicating the success or failure of the database
creation process will be displayed.

9.3 Deleting a Database

A database cannot be deleted from within MemberTies. It can only be deleted by using the Server Utility.

9.4 Moving a Database

If you have two copies of MemberTies running and you want to copy the database from one installation
to another, you should simply create a backup of the database, take that file to the second computer,
create a new database, log in, and restore the backup to it.

This will allow you to create an exact copy of the database.  

Note that if you have photos and other files tied to various records, you will need to copy the appropriate
folders to the identical locations on the new computer. (Unless you use the File and Photo Storage
preference to store these within the database, in which case this is not an issue.)

See Backing Up the Database and Restoring a Backup for details.

9.5 Database Hosting

If you would like your database to be available to multiple users in multiple locations, but do not want to
expose your home computer to the Internet for it to function as a database server, you may want to
consider database hosting.

Myrro International offers monthly database hosting on dedicated database servers.  These servers are
used solely for our customers' databases. They do not host other websites, email, games, or anything
commonly found on internet servers. They are not used by any other company or individual. 
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Here are some things to consider:

The database servers are not shared with anyone or used for anything but hosting databases for
our customers. That means no email, no games, no chat, no telecom, no cable services, nothing.
There are no children loading games or unknown programs on the computer. Nobody receives an
email with a potentially dangerous attachment on these computers. 

The servers are really servers (as opposed to a home computer that typically has fast download
speeds, but slow upload speeds, and lots of other processes running and demanding attention
from the CPU).

The servers are in a secure data center, accessible only to authorized personnel. Keycard
protocols, biometric scanning protocols and round-the-clock interior and exterior surveillance
monitor access to the data center.

The data center partners with multiple network providers to provide redundancy and 100% uptime.
If something does happen and access to your database is temporarily interrupted, we will extend
your hosting period accordingly to make up for it.

Every fiber carrier enters the data center at a separate point to protect against complete service
failures caused by an unlikely network cut.

Should a total utility power outage ever occur, the data center's power systems are designed to
run uninterrupted, with every server receiving conditioned UPS (Uninterruptible Power Supply)
power.

The UPS power subsystem is N+1 redundant, with instantaneous failover if the primary UPS fails.

If an extended utility power outage occurs, the routinely tested, on-site diesel generators can run
indefinitely.

The data center's HVAC (Heating Ventilation Air Conditioning) system is N+1 redundant. This
ensures that a duplicate system immediately comes online should there be an HVAC system
failure.

Security

Each customer is issued a complex username and password that is required to connect to the database
server. That username/password combination enables you to access only your specific database. No
other customer will even know what other databases exist, because their username/password
combination will be blind to all but their own.

The server username and password values are stored once on your database connection profile, so you
don't have to enter them again. Once connected you will be able to create users and passwords inside
MemberTies normally, using any security groups and rules you wish.

Database Backup

For an additional fee, we will add your database to a weekly backup process to give you additional
peace of mind.  We still strongly recommend doing an additional backup to your own computer for added
redundancy, but having an additional automatic backup can save you if you forget to make your own
backup occasionally.

Database Restore
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To restore a database, you must contact support. For security reasons, we cannot allow anyone to load
or restore a database onto the server.  You can either send use the desired backup file, or we can
restore the backup stored on our servers. Allow 24 hours for a database restore.

Maintenance

Backups (if requested for your database) run at approximately 1:00 am CST (Central Standard Time,
GMT -600). When backups run, your database tables may lock momentarily while the database is
processed (if you're subscribing to our backup service).  If we need to do other server maintenance that
requires a restart of the server, we will send out an email ahead of time.

Contact support with any questions about database hosting, or visit our website at http://www.myrro.
com/memberties to order.

9.6 Using a Remote Database

To use a database that is not on your machine, you will need a database profile that points to a "remote"
database via IP Address.

In this scenario, the computer that actually has the database on it is known as the "Server Host", and
you will be connecting to that computer via the remote database connection profile.  The "server Host"
can be another computer in your office or home, or it can be a database server here at Myrro
International.

This kind of setup is covered in Setting Up a Multi User System.

9.7 Setting Up a Multi-User System

MemberTies can be setup to run on a any TCP/IP network, enabling multiple users to connect to the
database at the same time, up to the number of users allowed by your license.  In this scenario, the
server will be running on one host computer, and users will connect to the database on that computer,
rather than to a local database on their own computer. The key is that each computer needs to have
TCP/IP enabled (see your network administrator if you aren't sure), and the server computer needs to
have port 3310 enabled (if using a firewall, for example), because the server will "listen" on that port by
default.

Note: The computer hosting the server can also be used as a normal workstation. It does not have to be
dedicated solely as a "server."

Note: It is best to setup the server to run as a Windows service when running multiple users. This
ensures the database server is always started on the server machine. See Running the Server as a
Windows Service for instructions.

The first thing to do is decide which computer that will be hosting the server. We'll refer to this computer
as the "Server Host" throughout this procedure. The Server Host is where the database other people
connect to will actually reside.  You will need to know the IP Address of this computer.  If you don't
know the address, try the following:

Finding the Server IP Address

1 Click the Start Button and choose Run.



MemberTies105

©1998-2014 Myrro International

2 Type "cmd" and click OK.

3 When the command prompt window appears, type "IPCONFIG" and press ENTER. You should
see output similar to the following:

In this example, the Server Host's IP address is: 192.168.0.2

Don't worry about the Subnet Mask or Default Gateway entries.

4 Write down this address, you will need it later.

Set Up the Server Host Computer

The Server Host is the only computer you need to create a database on, because the other users will be
connecting to this one.  If, in the future, you want to create a local database on one of the other
computers, you can still do that, but for this procedure it doesn't apply.

1 Install MemberTies.

2 Start MemberTies and follow the appropriate procedures to either create a database or connect
to an existing database.

3 Exit MemberTies

4 Start the Server Utility (choose Start > Programs > MemberTies > Local Database Server)

5 Use the server window to change the Server IP Address from "localhost" to the IP address of
this computer.

Take note of the Server Port (3310). If you are using a firewall, be sure this port is open for TCP
traffic within your network. Refer to your firewall documentation if you don't know how to do this.

6 Click Save.
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7 Shutdown and restart the server.

The server is now listening for connections, and is bound to the IP address of the Server Host
computer.

8 If necessary, start MemberTies as the administrator and add users.

Set Up Other Users' Computers

1 Install MemberTies normally.

2 Start MemberTies but STOP on the Login window.  If the "No Database Found" window appears
instead of the Login window, click Search and then skip to step 4 below.

3 On the Login window, choose "Specify New" from the database dropdown.

4 On the New Database Profile window, enter a Profile Name to represent the database on the
server. For simplicity, you might want to use the same name that you used on the Server Host
computer, but you do not have to.

5 Click Choose Existing Database.

6 On the Choose Database window, select the option called, "Remote Database (on another
computer)" The remote database fields will be displayed.

7 Complete the following fields:

IP Address - If this computer is part of your local network, enter the IP address of the Server
Host computer obtained above.

If this computer is OUTSIDE your local network (possibly connecting via the Internet), you will
need to use the IP address that is exposed to the outside world (because from outside your
network, the IP address of the server host is not visible or accessible).  For most home users
with broadband internet access, this address will be the IP address of the broadband modem. If
you don't know the "outside" IP address, it will probably be displayed in your Firewall software or
your router. In addition, if you have a router you will probably need to tell it to pass port 3310
requests on to the IP address of the Server Host computer. Refer to your router/firewall
documentation if you do not know how to do this.

If you are not running a firewall of some kind, you should never expose your database to the
Internet. In fact, you shouldn't be using the Internet at all without a firewall, because you're
exposing all of your personal information to thousands of internet worms, scans, and other sorts
of attacks.  Even if you think nothing on your computer is of any value, consider that you're also
offering your computer up to be taken over by an attacker and used as a slave machine to
attack other computers on the Internet.  Get a firewall.

Port - Enter the Server Port number noted earlier. This is normally 3310.

Folder Name - should contain the name of the actual database folder on the server. This is not
a full path and it is not necessarily the same as the display name shown in the Database
dropdown on the Login window.  If you go to the Server Host computer and click the Database
dropdown on the Login window, there will be two names displayed for the database: Database
Name and Folder Name.  The Folder Name shown is the simple database folder name to use on
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this window.

8 Click OK to return to the New Database Profile window.  The Database Folder field should now
show something like, "192.168.0.2:3310/mydatabase". 

9 Click OK to return to the Login window.

Now you have a profile that will connect to a database on the Server Host, rather than starting a
local server for a local database.  Remember that the server must be running for any
connections to work.

10 Try to login. If you cannot connect, verify the following:

Be sure the server has been started on the Server Host. You may need to contact your
database administrator to verify this.

Be sure the database profile is pointing to the correct database folder name on the server
host (remember, this is not a complete path, just a folder name)

See if you can "ping" the server host computer's IP address.  Choose Start > Run, type
CMD, and press Enter. At the command prompt type (for example): "ping 192.168.0.2" If
the ping doesn't work, you have network problems that need to be solved.

Examine the diagram below to see if you've misconfigured anything.

Note: If the Server Host is open to the Internet, the database can be accessed from anywhere in the
world. You need to be careful if you do this, and be sure that any users you create have secure
passwords. (There are programs on the internet that will scan for an open port 3306 and look for a
MySQL database. This is the reason MemberTies defaults to port  3310 instead.) 

Example of Internal (local) and External (remote) Connections

This graphic example depicts 10 connections, 5 coming from outside the local network (the computers
at the top) and 5 coming from inside the local network (the computers at the bottom).  

External Network Connections  - shown at the top of the illustration, have to pass through the
firewall to get to the server host computer. Therefore, they use a profile that points to the IP
address of the modem, because that is the "doorway" into the internal network where the server
host resides.  The firewall protecting the internal network has also been configured to keep port
3310 open, and direct requests inward to the server host computer's IP address.  (Note that the
host computer may have it's own firewall, such as the one installed with Windows XP. You may
need to enable port 3310 on that firewall as well.)

Internal Network Connections - shown at the bottom of the illustration,  can see the server host
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computer directly. Therefore they have profiles defined that point to the server host IP address
instead of the modem address.

Increasing Security

There are some things you should do to increase the security of your database:

Limit user accounts - be sure that you only have the user accounts that you actually need. If
someone leaves your organization, remove or at least deactivate their account so that nobody can
login using their credentials. 

Change the mtadmin password. The default password for this account is just "password", and
since it's documented in the Help, anyone can know what it is.  Be sure to change it to something
more secure.

Secure the computer where the database physically resides. Don't use it for children's games,
internet surfing, or other things that can introduce viruses or worms that could be seeking out
database information.  Also remember that anyone with physical access to a computer can
eventually bypass any security.

Consider hosting the database with Myrro International and connecting to it remotely. That way a
major computer crash or theft on your end won't take your database with it.
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Common Problems

The following problems are most commonly encountered by users trying to setup a remote connection:

The computer running the server has received a new IP address, so now the remote computers
can't see it because they have database profiles set up and pointed to the old IP address. Update
the remote profiles on the remote computers (see example below to update the profile from the
login window), OR change the IP address on the server computer back to what it was before.

A full path was entered instead of just the database folder name for the profile.  This is by far the
most common issue!  The database folder entry should be something like, "mydatabase", NOT c:/
long-path-to-some-folder/mydatabase/

Note that you can modify a profile directly from the Login window to correct a typo or other error.
Just select the database you want, then right-click and choose Modify Database Profile from the
popup menu. Make your changes and save, the then try to login again.

The server utility has the Server IP Address set to "localhost" instead of the actual public IP of the
server machine. Correct the IP address on the server utility on the server computer.

The port (default is 3310) is not open. Consult your firewall documentation to determine how to
open the port.

Windows is blocking the mtmysqld.exe program. Consult your firewall documentation to
determine how to allow the program.

The database server computer is running, but the server software has not been started.  The server
software can be started either by logging into  MemberTies once (you can exit afterward), or by
starting the Server Utility and starting the server manually.  You can also setup the server to run
as a Windows service so it starts automatically when Windows starts.

The database folder has been "shared" using Windows File Sharing. The database server does
not work this way, and using a shared database from multiple workstations will almost certainly
cause database corruption.  There should only be one database server running, and it should be
accessed via an IP address and port number.
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9.8 Running the Server as a Windows Service

Normally, when you start MemberTies, it starts the database server if it isn't already running. Thereafter,
the server continues to run until it is manually stopped, or the computer is shut down. A better way to
run the server is as a Windows Service, which means when Windows starts up (whether you log in or
not) the service starts and starts the database server.  When Windows shuts down, the service
gracefully stops the database server as well.  It's clean and efficient and is the recommended way to run
the server.

Note: This is especially helpful for multi-user systems, because when the server computer starts the
database server starts automatically. There is no need to start MemberTies or use the server utility to
start the server manually.

Creating the Service

Before continuing, be sure everyone is out of MemberTies!

1 Start the Server Utility (see Using the Server Utility if you don't know where this is)

2 Enter the Windows Service Name (i.e., "MemberTiesServer") and click "Install"

3 If you are prompted that the server will be stopped, click OK. The server will be stopped and
then the process will continue.

4 You will receive a warning that the service will be installed as a system-level Windows  process.
All this means is that you're telling MemberTies to install something that Windows may not
think it has the rights to do, because MemberTies runs as a normal user. Because of this, if you
are running Windows Vista or newer, you may receive an authorization request to perform this
action. It is important that you tell Windows to allow the process to continue so service can be
installed.

After the install completes, the message log above will be similar to the following:

5 The service is now installed and will start the next time Windows starts.  If you don't want to
restart your computer right now, click "Start" to start the service immediately. 
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If you are running Windows Vista or newer, you may receive an authorization request to perform
this action. This won't happen during Windows startup, because the service will be handling it by
itself then.

Removing the Service

The service can be removed at any time if you want to rename it, or want to go back to manual control of
the database server.

1 Start the Server Utility (see Using the Server Utility if you don't know where this is)

2 Click the "Delete" icon. The system will attempt to stop the service and the database server,
and then will remove the service.  If you are running Windows Vista or newer, you may receive
an authorization request to perform this action.

3 MemberTies will display the results of the service removal as reported by Windows. If the
message indicates the removal was successful, you could clear the Windows Service Name
field and click Save.

9.9 Housekeeping

9.9.1 Maintaining Tables

As a database matures and records are added and deleted, they eventually need a little bit of
maintenance.  When you log in as the administrator user you can run various table maintenance
functions to keep your database running smoothly.

Note: A database preference controls how often the system will prompt you to maintain tables.
Depending on usage, frequency of deletes, etc., maintenance should be performed every 30-90 days.



Database Maintenance 112

©1998-2014 Myrro International

The following maintenance actions are available:

Analyze Table - Verifies indexes and keys for optimal internal operation for queries. It may be
worthwhile running this action if large amounts of new data has been imported into the database.

Check Table - Checks the table or tables for errors.  This function might produce many rows of
information for each checked table. The last row will have a Msg Type value of "status" and the
Msg Text normally should be "OK". If you don't get "OK," or "Table is already up to date" you
should normally run a repair of the table. A message reading, "Table is already up to date" means
that there was no need to check the table.

Repair Table - Repairs a possibly corrupted table. Normally you should never have to run this
command. However, if disaster strikes, the repair is very likely to get back all your data. Like the
Check Table function, Repair Table may produce many rows of information for each checked
table. The last row is the most important, and should be "OK".

Optimize Table - Should be used if you have deleted a large number of records.  Ordinarily,
running an optimization once a month will keep tables compacted and well optimized.  The most
common use of the Optimize function is to reclaim allocated but unused space in a table (such as
when a large block of records has been deleted.)  This is a little like degragmenting a computers
hard disk. You can see how much space a table has by running "Show Table Info" and checking
the value in the Data Free column.

Show Table Info - Displays various statistics for a table, including the amount of allocated but
unused space.  This information may be asked for by Support to help analyze an issue.  The
following information is displayed:

- Table Name: the name of the table being acted upon
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- Rows: the number of rows in the table
- Avg Row Length: the average number of bytes per row in the table
- Data Length: the total number of bytes of the table data file
- Index Length: the total number of bytes of the index data file
- Max Data Length: the maximum length of the data file
- Data Free: the number of bytes of allocated, but unused space in the table 
- Create Time: the date/time the table was created
- Update Time: the date/time the table was last modified
- Check Time: the date/time of the last Check Table operation
- Engine: the storage engine used for the table
- Comment: the description of the table's use (or some information why the server couldn't
access the table information if the table's information could not be displayed)

Maintenance Frequency

It is a good idea to get in the habit of running the table maintenance operations on a monthly to quarterly
basis, depending upon how much activity you have on your database (i.e., a database with 10
concurrent users may require more frequent maintenance for optimal performance).  Think of table
maintenance as basic housekeeping for a healthy database.  Like changing the oil in your automobile, it
keeps the database engine running well.

At a minimum, run Check Tables and look at the results.  If any errors or warning are reported, run the
Repair Tables option and then run Check Tables again.  When finished, run Analyze and/or Optimize
Tables to refresh indexes and compact and organize your data.

Running Maintenance Functions

From within MemberTies...

1 Login as the user "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Tables.

3 Continue to Step 4 below.

From the Server Utility...

1 Start the server utility and click Maintain Tables.

2 Choose the desired database, and enter the mtadmin username and password.

3 Continue to Step 4 below.

Then...

4 Select one or more tables to affect in the Tables area. (If you're not sure, just right-click the list
and choose Select All)

5 Choose the action to perform from the dropdown, then click "Start".

Normal Housekeeping can be accomplished by selecting all tables, and then successively
running Check, Repair, and Optimize.

6 Information about the operation will be displayed in the Details section.
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7 When the operation is finished, you can write the contents of the "Details" section to a log file if
you wish. To do this, click "Write Log", enter a filename in the "Save Message Log As" dialog,
and click Save.

8 If you want to perform another operation, repeat the previous steps, otherwise, click Close.

Note: If for some reason you cannot start MemberTies to run table maintenance, the same functions can
be run from the Server Utility.

 

9.9.2 Testing Data Integrity

The Data Integrity checker is designed to help point out what may be errors in records. Note that it only
looks for things that might be errors -- it is up to you to decide whether an actual problem has been
found.

For example, if you enter a membership record with the same first and last name as an existing record,
you will receive a message stating that a duplicate record is potentially being created; but, you are
allowed to ignore this message and create the record.  Many times this is necessary simply because
two people may have the same name. If the Data Integrity checker finds that duplicate record, you would
know that it is not a problem.

Running Data Integrity Tests

1 Choose Tools > Database Tools > Run Data Tests.

2 On the Data Integrity window, select either Membership or Group data to test. The list of
Available Tests will change based on the type of data being tested.

Note: The relationships test for Membership records actually includes four tests. The following
types of relationship requirements are checked: 

Records that must be related to at least one other membership record

Records that must be related to at least one other group record

Records that must be related to both a group and a membership record

Records that must be related to at least one group or membership record

3 Select the tests that should run.

4 Click Test Now. Each record found to match one of the selected tests will appear in the Test
Results list at the bottom of the window. The Test column will show the number of the test that
a given record failed.

Note: If no records meet the criteria for a given test, an entry will appear in the list stating "No
Data Found"

5 You can choose to Open or Delete any records that appear in the Test Results list by clicking
the appropriate icon. If a record is deleted, it is permanently removed from the database just like
deleting it from the membership or group list window.
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9.9.3 Using the Event Log

MemberTies Professional includes an "event logging" feature that will maintain a log of various "high
level" membership, group, and activity record changes.  By "high level" we mean that the system will not
track the change to each and every field.  There are two reasons for this: 1) the resulting log would be
massive, and 2) the log would not be very readable, because it would have to track the actual values the
database knows about, i.e., "statecd changed to 17" isn't very user friendly.

Instead, the event log will note that a record was opened, updated, created, deleted, or closed, and will
also track things like email sent (address and subject line), check-ins, backups, restores, and various
other changes in the system.  It does not track changes made to dropdown lists under the Tools menu,
since most organizations lock this down via security if they're concerned about it.

If database size is a concern, it is recommended that you export the log to a file on a regular basis, and
then clear the log table.  The appropriate schedule must be determined based on the activity in your
database.

Note: Several Security Group settings apply to the event log, allowing you to control who can view the
log, enable/disable it, and manage the data.

Log Columns

The following data is tracked in the log:

Date - The date and time the log entry is made.
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Area - The area of the system that generated the log.

User - The user who caused the action that generated the log entry.

Log Entry - The event that occurred.

Managing the Event Log

The following options are available on the event log window:

Enable Log - Select this option to turn logging on, or clear it to stop logging.

Sort - Controls how the list is sorted. If you have multiple users, you may want to occasionally
change to the sort by User, then Area, then Date. Normally, the default sort by user and date is
the most usable.

Refresh - Causes the list to refresh with the current log data.

Delete File - Click this icon to delete the entire log from the database.

Delete - Click this icon to delete the currently selected log entries.

Export to File - Click this icon to write the currently selected log entries to a text file you specify.

9.9.4 Clearing all Print Receipt Settings

If you want to clear the Print Receipt field on all dues/donation records in the database at once, you can
do so using Database Tools menu "Clear Print Receipt Settings" command.  

Clearing all Flags

1 Choose Tools > Database Tools > Clear Print Receipt Settings.

2 Confirm the change.

3 The number of entries cleared will be displayed.

9.9.5 Clearing all Membership Flag Settings

If you want to clear the Flag field on all membership records in the database at once, you can do so
using Database Tools menu "Clear Flag Settings" command.  

Clearing all Flags

1 Choose Tools > Database Tools > Clear Flag Settings.

2 Confirm the change.

3 The number of flags cleared will be displayed.
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10 Database Backup/Restore

10.1 Backing Up the Database

You should keep a backup copy of the database at all times. This copy should either be on a separate
local drive, or on a removable media such as a CD-ROM. A "backup" folder under your My Documents
folder is created by default when MemberTies is installed. You can backup the database here if you
wish.

Note that your security settings control whether you are allowed to backup the database.

Backing up the Database

1 Choose Tools > Database Tools > Backup Database.

The last used database backup folder will be entered for you in the "Backup to" field.  

The "File Name" field is automatically set to a suggested backup file name. The format of the
name is:

bkup_[date]_[database name].sql

2 If you want to backup the database to a different file/folder, click the Browse icon and navigate to
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the desired folder. If you choose to enter a folder name by hand and the folder does not exist, it
will be created automatically.

3 The "Backup File can only be restored as" setting controls how the backup file itself is created.
If this option is selected, additional code is placed in the backup file so that when it is restored it
will recreate a database by the same name, regardless of the database you are in when you run
the restore process.  If this option is not selected, a database can be restored into any
database, overwriting all existing data. The default is unselected, because most people want to
be able to restore data into any database name.

3 When you are satisfied with the settings, click Start Backup.  A series of messages will be
displayed in the "Messages" section, indicating the steps taken. These messages are all
written to the log file indicated as soon as the backup completes.

Automatic Database Backup Prompting

If a non-zero Backup Prompt value has been entered in Database Preferences, the system will check
the date of the most recent backup each time you exit the program. This date will be compared with the
current date to determine whether to prompt you to run a new backup.

If you choose Yes when prompted to run a backup, the Backup Database window will appear as if you
had selected the Backup Database option manually. The system will not run a backup in the
"background" without you knowing about it.

10.2 Restoring a Backup

A database backup copy can be used to restore the database to the state it was in when the backup
was performed. Any data that was entered into the database after the backup was created will be lost.
Note that you must be logged in as the  administrator to restore a backup. (The restore menu option will
not appear otherwise.)

Note that you are not allowed to restore the database if you are connected remotely. This is to protect
the database from being easily overwritten by a remote user. 

Important: If you need to restore a backup copy from a previous (Professional 2.x or Standard 5.x)
version of MemberTies, you cannot do it via this restore functionality. These version databases must be
converted to the new database format, and the restore process cannot do that.  To convert an old
database, you must create a new database profile for it, and let the system convert it.  See Maintaining
Database Profiles for details.

Restoring a Database Backup

1 On the Login window, open the Database list and choose "Restore". (If this is a new installation
and you get the Welcome window instead, you can choose the Restore option there as well.)

2 The Restore window will open and immediately prompt you to choose the database backup file
to restore.  The "Choose File" window will default to the last-used backup location. Choose the
file to restore, then click Open.

Note: If your backup is a folder full of dozens of files with extensions "MYD" and "FRM", and not
a single file as described above, you need to tell the system to use the old window for choosing
the file(s) to restore.  To do this, hold down the CTRL (control) key when you click the Restore
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Database menu option. i.e., choose Tools > Database Tools > {hold down CTRL} > Restore
Backup.

3 After you choose what should be restored, the information is entered for you on the Restore
window. 
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4 Click "Start Restore" and confirm the restore prompt. If you are restoring directly from the
Welcome or Login window, the system may prompt you for the name to use for the database.
This is the name that will appear in the Database list on the Login window when you're finished.
It can be any name you like, but something short is best.

Note: The restore will either replace all data in the active database, or restore the database to
its original name. The behavior depends upon whether the "Backup File Can Only Be Restored
As" option was selected when the backup was created.

5 When the restore finishes, you may be prompted to restart MemberTies to complete the restore
process.  Remember that only user names and passwords that existed in the restored database
will be valid when you login again.

10.3 Resetting a Database

If you want to clear all data from a database and start over (for example, because you're still testing
MemberTies and want to start clean), the easiest way is to create a new database using the same name
as your existing database. The system will prompt you, then overwrite you database with a new one.

Resetting a Database

1 On the Login window, check the Folder Name of the database shown in the Database dropdown.
That is the actual name of your database. The entry will look something like this:

In this example, the database name is the same as the folder name, but they could be different.

2 Choose "Specify New" from the database dropdown on the Login window.
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3 Enter the database name determined in Step 1 (in this example, we would replace "My
Database" with "Demo").

4 Click "Create New Database."

5 When prompted to overwrite the existing database, choose Yes.

6 After the database has been created and you return to the Login window, choose the database
and login (remember, any old users and passwords will be gone, so you'll have to use the
default "mtadmin" user and "password" password). The database should only contain the
original sample record.
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11 Database Profiles/Licenses

11.1 Applying a License

First of all, THANK YOU for registering! Your support is greatly appreciated.

Your new license will generally be sent to you in an email, which should include instructions on how to
apply the license. Since MemberTies is available for download at any time, most users will already have
seen the "reminder" Registration Notice window that is displayed each time you login.  If you follow the
instructions in the email and copy the specified license text to the clipboard, it will automatically be
entered in the license fields when the window appears.

The text to copy form the email will normally be in a special area of text, like this:

--Start Here---------------------------------

My Organization Name

x011p54d023a17zs09u90ak47s78

-----------------------------------End Here--

You should copy everything, including the dashed line above and below the text to use the "Paste
License" option. But if you would prefer to copy just the licensee, and then right-click and paste it into
the Licensee field, then copy the license number and right-click and paste it into the Number field, that
is fine too.

If you choose not to enter information at this time, just click "Not Yet" to bypass the window and
continue to log in. You can choose "Registering" under the Help menu and click the "I Have a License"
button to display this window again if needed.  You can also enter the license information on any
existing Database Profile in Preferences.

Note: There is a difference between a license for MemberTies, and a license for MemberTies
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Professional -- they are not interchangeable. You can upgrade an existing standard license to the
professional version by paying the difference in cost.

Updating the License on Multiple Databases

If you have multiple databases, you should open each database profile in Database Preferences and add
the information there. See Working with Database Profiles for details.

Updating the License for Multiple Users

The license information is stored within the database itself, so as soon as one person loads a new
license, it will apply to all other users.

Upgrading a License

A license is typically valid for all upgrades, large or small, for a full year.  When the license expires, the
only thing that changes is your ability to download and install new releases. Nothing will change with
respect to using your database(s), logging in, adding records, etc.  You still have an existing license, but
the maintenance period has expired.

Note: If the "License Update Prompt" preference is turned on, a message will be displayed 30 days prior
to the expiration date.

You can quickly determine when your current license expires by choosing Help > About MemberTies. 
The date of expiration ("Free Updates Until"), as well as the maximum number of users is displayed on
the License Information tab.
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11.2 Importing/Exporting Database Profiles

If you have multiple installations, the task of getting the identical database connection profile on each
machine can be time-consuming and error-prone. The best way to setup additional installations is to
take an exported ".profile" file to that machine and use it to automatically create a copy of the known
working profile.

Fortunately, once you have a profile created it is easy to export it to a file for just this purpose.  This is
most helpful with remote connection profiles, since they include an IP address, port number, and
possibly a complex server username and password.

Note: The exported profile file is encrypted for security, but it can still be imported by anyone. Be sure to
keep it safe so you don't compromise your database security!

Exporting a Database Profile

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Database section by double-clicking it, or by clicking the [+] symbol.

3 Choose Profiles.

4 Right-click on the profile you want to export, and choose "Export to File" from the popup menu.

5 When the "Save Exported Data As" dialog appears, choose the location for the saved file (the
Desktop is a good choice) and provide a name. The file will be saved as "YourName.profile".  Do
not alter the file in any way or it may not be possible to import it!
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Importing a Database Profile - From Preferences

1 A profile can be imported from within Preferences, by choosing the Import from File menu option
(see graphic above).

Importing a Database Profile - From Login Window

1 Open the Database list and choose "Specify New"

2 On the New Database Profile window, click Import

3 Choose the .profile file, and click Open.

4 The file will be imported and you will be returned to the Login window with the new profile
available in the Database list.

Importing a Database Profile - From Welcome to MemberTies Window

1 Select "Choose Existing Database" and click Next

2 When the Choose Database window appears,  choose "Import Database Profile" then click OK

3 Choose the .profile file, and click Open.

4 The file will be imported and you will be taken to the Login window with the new profile available
in the Database list.

11.3 Maintaining Database Profiles

Database profiles tell MemberTies where to find a particular database, what to call it (the name that
appears in the Database dropdown on the Login window), and what license should be used with it, if
any. 

Note: All profiles that are stored on your computer are available for editing. However, the license
information can only be modified if you are connected to the database the license is assigned to.  If you
log into one database and then open the profile for another, license information will not be available
because the system cannot find the information from the other database.

Profiles can also be exported/imported for easy distribution. See Importing/Exporting Database Profiles
for details.

Adding a Database Profile

1 Open the New Database Profile window. This can happen in several ways:

From the Login Window, choose (Specify New…) from the database dropdown list.

From within MemberTies, choose Tools > Preferences, expand the Database section,
choose Profiles, and click New.
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2 A new Database Profile has two major sections: 

Database Name - This is the brief "user friendly" name of the database which will appear in the
Database dropdown on the Login window.  If your database is for your Skiing Club, a logical
profile name would be, "Ski Club". The profile name is simply a convenience. If your database
folder name is actually "mt_skiclub_aspen_division", a simple name like "Ski Club" is much
nicer to see in the Database list.

Database Folder - This section lets you specify the name or location of the database folder,
which is where all the files that make up the database are stored.  Chose one of the following
options:

Choose Existing Database - to identify an existing local or remote database

Create New Database - to create a new database. See Creating a New Database for
details.

3 If you click "Choose Existing Database", the Choose Database window will open:

To specify a local database, select "Local Database (on this computer)", and then choose a
database from the dropdown list of available databases.  This list contains all database on your
computer to which the server has access.
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To specify a remote database, select "Remote Database (on another computer)", and then
complete the fields to identify the database. If you're not sure what these fields are for, please
see, Setting Up a Multi-User System database for details.

4 After choosing or creating a database, you will return to the New Database Profile window, and
the database folder will be displayed. 

If you are connecting to a database hosted by Myrro International, you will have received special
Server Login credentials.  In this case click the Advanced button and enter the login information
on the Advanced Profile Settings window.

Note: Do NOT use these fields if you are running a local database server (i.e., a normal
MemberTies installation with a database on your computer) or you will not be able to connect.
These settings are only for remote database profiles to servers requiring special connection
parameters (such as our hosted database server).  These fields are not used for the normal user
name and password information you put on the Login window when  MemberTies  starts.
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The "Show" button will display the password in plain text so you can see what you're typing. 

After entering advanced options, click OK to return to the Database Profile window.

5 When you are finished, click OK. The database information will be verified, and if applicable the
license name and number will be validated. If everything is correct, the new profile will be added
to the list of databases MemberTies knows about.

Note: If you are adding a new profile from the Login window, clicking OK will return you to the
login window and the database dropdown list will be updated with the new entry.

Changing a Database Profile

A database profile can be modified from within MemberTies, or from the Login window.

From the Login window:

1 Select the database you want in the Database list.

2 Right-click the Database field, and choose "Modify Database Profile" from the popup menu.

or from within MemberTies:

1 Choose Tools > Preferences, expand the Database section, and choose Profiles.

2 Select the database profile you want to change, then click Open.

On the Maintain Database Profile window...
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The following fields are available:

Database Name - This is the name that displays in the Database list on the Login window.  Any
short, simple name is good.

Database Folder - This is the actual location of the database. This field is filled-in for you when you
choose an existing database or create a new one.

License Info for this Database - 

(These fields are only displayed if you are editing the active database profile from within
MemberTies. )

If you do not have a license, leave these fields blank and the database will function in
"shareware mode," allowing a limited number of records but otherwise fully functional. 

You can also leave the license fields blank if you have just upgraded from an older version of
MemberTies and your license is no longer valid.  You may not be allowed to enter new records
until you upgrade your license, but your existing data will not be harmed or lost, and you'll be
able to open records and see everything normally.
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Licensee - If you have an existing license, enter the licensee name exactly as it appears on
your license.

Number - If you have a license number, enter it exactly as it appears on your license.

Easy License Entry: If you have an email containing the license information, it contains specific
instructions about how to copy the license text from the email message so that it can be easily
pasted into these fields all at once using the "Paste License" option. 

Advanced

If you are connecting to a database hosted by Myrro International, you will have received special
Server Login credentials.  In this case click the Advanced button and enter the login information
on the Advanced Profile Settings window.

Note: Do NOT use these fields if you are running a local database server (i.e., a normal
MemberTies installation with a database on your computer) or you will not be able to connect.
These settings are only for remote database profiles to servers requiring special connection
parameters (such as our hosted database server).  These fields are not used for the normal user
name and password information you put on the Login window when  MemberTies  starts.

The "Show" button will display the password in plain text so you can see what you're typing.
For security reasons, if you accessed this window from the login window rather than from within
MemberTies, any existing password will be cleared first before the field is changed to plain text.
Otherwise, anyone could go to the login window, edit your profile, and see your password.

After entering advanced options, click OK to return to the Database Profile window.

Deleting a Database Profile

Deleting a database profile has NO EFFECT on the actual database or its current or backup directory. It
simply removes details in the database profile.  To physically delete the database follow the instructions
under Deleting a Database.  If you do not delete the physical database itself, a new empty profile will be
created for it the next time you log in, because MemberTies will see that a database exists.

1 Choose Tools > Preferences, expand the Database section, and choose Profiles.
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2 Select the database profile you want to delete, then click Delete.
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12 Local Database Server Utility

12.1 Server and Database Overview

This topic is designed to provide an informational overview of the entire database system that is
MemberTies. You don't absolutely have to understand everything to this level of detail in order to user the
system, but we wanted to provide the information in case you were interested.

It's easy to think of MemberTies as just a single piece of software -- that what you see on screen when
you're entering members is all there is -- but that isn't the whole picture.  The following diagram
illustrates the three major components of the system: the Server, the Databases, and the Application. 
The typical corresponding folder structure is also shown for reference.

Note: The above directory structure applies to a default installation on Windows Vista and newer. On
older operating systems such as Windows XP the ProgramData\MemberTies location was a much
longer folder structure: "Documents and Settings\All Users\Application Data\MemberTies" 

What it all Means

A simple way to understand the relationship between the database, the server, and MemberTies is to
think of it like a bank. Think of your database as the bank vault. Your data is like money in that vault. 
When you want to put money into the vault you have to request the services of an employee at the bank.
 That employee is the server -- moving money (data) back and forth between you (MemberTies) and the
vault (the database).
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The Server

It is a common misconception that any reference to a "server" is always a reference to something on the
Internet.  That can be true at times, but often a server is nothing more than another small program that
runs on your computer. With MemberTies, that is also the case; the server is the program that lets
MemberTies move data in and out of your database.  

The server program files reside in a "Server" folder, located in the folder where MemberTies is installed. 
The location is typically, c:/program files/MemberTies/server/.  Inside that folder are various other folders
containing the files required to start and run the server. You shouldn't ever have to touch anything in
these folders. In fact, doing so could actually prevent the server from starting at all, thereby preventing
access to any database. 

The server has several important jobs to do:

Track all databases.

Track all connections to the databases.

Manage the flow of data between MemberTies and the appropriate database, and maintain all the
tables in the database as they change with the data.

As you can see, the server can be very busy. Every time the application wants to view or update
information in the database, (for example, when you open a membership record), the server has to
receive the requests for data, open the appropriate table(s), get the data, and send it back to the
application so it can be formatted for display. When you run a query for 1,000 records, the server has
seen them all before they ever appear on the screen.

Note that you won't see a special window on-screen when the server is running. The server is a program
that runs invisibly in the background, content to simply manage the flow of data between the database
and the application.  You can tell it is "out there" if you open the Windows Task List (typically by
pressing CTRL+ALT+DEL) and look for a process called "mtmysqld.exe".  The server program takes up
very little memory, and will continue to run even after you shut down MemberTies. This is done so the
next time you start MemberTies it will be faster, because it won't have to bother starting the server again.
 When MemberTies isn't running, the server will be content to just sleep and do nothing. If you need to
check the status of the server, or shut it down manually for some reason, a special Server Utility is
installed and available for this purpose. 

The Database

The database is not a single file. instead, each database is comprised of a large number of files within a
single folder bearing the database name.  The database folders are located, appropriately enough, in a
"database" folder in a special folder in Windows where applications are allowed to make changes,
namely, ProgramData. This location is typically, c:/ProgramData/MemberTies/database/(database
name)/. There are lots of files inside that folder, representing the various tables within the database.

Important: These files should ONLY be managed by the server! Opening a file using a text editor or
word processor can corrupt the file, causing all of the data to be lost.  It is impossible to edit data by
modifying these files directly! If you run an antivirus program on the computer that hosts the server, it is
a very good idea to make sure it excludes checking on everything in the database folder. The files there
are non-executable text files anyway, so they are not virus threats.

MemberTies enables you to have any number of databases, each of which will have its own folder under
the Database folder. The system keeps track of the "friendly" database name, and the license in use for
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it, and other details in a special file called mtdb.xml. This file is updated when you specify your license
information or work with database profiles in the application.

The Server also maintains a single small database of its own.  This database is called "mysql" and it is
used by the server track permissions, connections, and other internal settings.  This means that you will
always have at least two databases: your own, and the server's "mysql" database.  In the example
above, there are two user defined databases ("ski_club" and "speech_club") in addition to the server's
database.

Also in the MemberTies folder are sub-folders called Temp and Logs.  The Temp folder is used as a
place to create and delete files that are only used for a short while as the server goes about its
business. These might be temporarily created image files, tracking files, documents in progress prior to
saving, etc.  The Logs folder contains all of the logs that are generated within MemberTies. These
include email logs, backup logs, etc.

The Application

The application is what you probably think of as MemberTies itself.  It's the collection of windows,
menus, buttons, reports, etc., that you use to view and manage all of your data. Essentially, the
application is what simplifies the process of working with a complicated database on a day to day basis.
Imagine if you had to type out complicated commands for every record you wanted to see, and then
more commands to change the data, and still more commands to see the results again.  It's much more
convenient type data in fields and click OK to save and redisplay!

When you start MemberTies, the first thing it does is make sure that the server has been started.  Then,
when you enter your username, password, and database choice on the Login window, the application
forwards those selections on to the server. The server looks at your selections and verifies that, 1) there
really is a user with the name you entered, 2) that the user by that name is allowed to login to the
database you specified, and 3) that the password you provided is correct. If anything isn't correct, the
server responds with an error, which the application then displays for you to see.

12.2 Using the Server Utility

The server utility is a small program that enables you to do certain things with the database server
without having to start MemberTies at all.  It enables you to restart the server if necessary, delete a
database, package a database for easy transport, and perform various other maintenance functions.

The server utility has a separate executable file located in the MemberTies program directory called
"mtsrv.exe". (There should also be an icon for it in the Start Menu along with the MemberTies icon.) 

Note: The server utility window is a way to look at the server that is running in the background. It is not
the server itself.  You can open and close the utility without affecting whether the server is running or not.
 The only way to manually shutdown the server is to click "Stop Server". Closing the window will have no
effect.

When you launch the utility, it will immediately display the current status of the server.
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The server utility includes several sections containing various options. 

Server Status 

The options in this section control the starting/stopping of the server itself:

Start - Reads configuration files and starts/restarts the server. If a Windows service has been
installed to control the service, this will start/restart the service.

Stop - Stops (shuts down) the running server and aborts all existing connections.  You should be
certain nobody is logged in before doing this. If a Windows service has been installed to control the
service, this will stop the service.

Refresh - Redisplays the server status with the current uptime values.

Tools

The options in this section allow you to perform various tasks:

Start MemberTies - Starts the main program.  This button is here for convenience only. It has the
same effect as starting the software using the normal desktop or Start menu icon.

Maintain Tables - Opens the table maintenance window. You will be prompted for a login username
and password, and will have to choose a database to maintain when selecting this option. Once
logged in, see Maintaining Tables for more information.

Remove Database - Enables you to delete a database. You will be prompted for a login username
and password, and will have to choose a database to delete when selecting this option. See 
Deleting a Database for more information.

Sys Info File - Generates a text file that can be sent upon request to MemberTies to help
troubleshoot a problem.  The text file is saved to a location you specify, and contains information
from various MemberTies configuration files.

Local Server Settings

The options in this section control the way the server starts and runs. Ordinarily you should never need
to change any settings here.  If you choose to make changes, be very careful and take note of what the
current settings are.  An incorrect setting will prevent the server from starting and MemberTies will be
unable to access any databases.
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Never include a trailing backslash ( \ ) on any directory entry!

Root Database Directory - The parent directory containing all of your database sub-directories.
This defaults to  "c:\programdata\MemberTies\database".

Root Server Directory - The parent directory containing the server files. This defaults to "c:
\program files\MemberTies\server".

Temp Files Directory - The directory where the server should write temporary files.  You must have
read/write permissions to this directory or the server will not be able to start. This defaults to "c:
\programdata\MemberTies\temp".

Server IP Address - The address to which the server is bound. This defaults to "localhost."

Server Engine - The name of the MySQL server engine in use. This defaults to mtmysqld.exe.

Server Port - The port on which the server is listening for connections. This defaults to 3310.

Windows Service Name - (optional, but recommended) The name of the service that controls the
server. There is no default for this because it is optional. See Running the Server as a Windows
Service for details.

 

12.3 Starting the Server Automatically

If you would like to put a shortcut into your Start > Programs > Startup folder so that Windows starts the
server for you when you start your computer, a command line switch is available for this purpose.

Creating a Shortcut

1 Create a shortcut to the mtsrv.exe file. Go to My Computer, and navigate to the c:\program files\
MemberTies\ folder.  Right-click the "mtsrv.exe" file, and choose "Create Shortcut." Windows
will normally create the new shortcut automatically, calling it something like, "Shortcut to mtsrv.
exe"

2 Right-click the newly created shortcut and choose, "Rename" and change the name to
"MTServer Autostart".
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3 Right-click the shortcut again and choose, "Properties."  The window should display something
like this:

4 Change the Target entry, by adding a "/s" after the existing line as shown:

Be sure to put this outside the quotation marks, if they exist, and be sure to use a forward slash
as shown, not a backslash.

5 Click OK to save the new shortcut.

Using the Shortcut

Now you are ready to use the new shortcut.  The way to use it varies with different versions of windows,
but the general steps are:

1 Right-click the new shortcut and choose "Copy".

2 Right-click the Start Button and choose "Explore".

3 Navigate to Programs, then the Startup folder.

4 Right-click the Startup folder and choose "Paste".

The new shortcut should now run each time you start your computer.  

If you see the Server Utility window opening when you start your computer, it means that the shortcut
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doesn't include the "/s" switch correctly.  Without that flag, the window won't know to do its job silently
and it will open and wait for you to act. Be sure to type a forward-shash (/) not a backslash (\).

12.4 Running the Server as a Windows Service

Normally, when you start MemberTies, it starts the database server if it isn't already running. Thereafter,
the server continues to run until it is manually stopped, or the computer is shut down. A better way to
run the server is as a Windows Service, which means when Windows starts up (whether you log in or
not) the service starts and starts the database server.  When Windows shuts down, the service
gracefully stops the database server as well.  It's clean and efficient and is the recommended way to run
the server.

Note: This is especially helpful for multi-user systems, because when the server computer starts the
database server starts automatically. There is no need to start MemberTies or use the server utility to
start the server manually.

Creating the Service

Before continuing, be sure everyone is out of MemberTies!

1 Start the Server Utility (see Using the Server Utility if you don't know where this is)

2 Enter the Windows Service Name (i.e., "MemberTiesServer") and click "Install"

3 If you are prompted that the server will be stopped, click OK. The server will be stopped and
then the process will continue.

4 You will receive a warning that the service will be installed as a system-level Windows  process.
All this means is that you're telling MemberTies to install something that Windows may not
think it has the rights to do, because MemberTies runs as a normal user. Because of this, if you
are running Windows Vista or newer, you may receive an authorization request to perform this
action. It is important that you tell Windows to allow the process to continue so service can be
installed.

After the install completes, the message log above will be similar to the following:
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5 The service is now installed and will start the next time Windows starts.  If you don't want to
restart your computer right now, click "Start" to start the service immediately. 

If you are running Windows Vista or newer, you may receive an authorization request to perform
this action. This won't happen during Windows startup, because the service will be handling it by
itself then.

Removing the Service

The service can be removed at any time if you want to rename it, or want to go back to manual control of
the database server.

1 Start the Server Utility (see Using the Server Utility if you don't know where this is)

2 Click the "Delete" icon. The system will attempt to stop the service and the database server,
and then will remove the service.  If you are running Windows Vista or newer, you may receive
an authorization request to perform this action.

3 MemberTies will display the results of the service removal as reported by Windows. If the
message indicates the removal was successful, you could clear the Windows Service Name
field and click Save.

12.5 Maintaining Tables

As a database matures and records are added and deleted, they eventually need a little bit of
maintenance.  When you log in as the administrator user you can run various table maintenance
functions to keep your database running smoothly.

Note: A database preference controls how often the system will prompt you to maintain tables.
Depending on usage, frequency of deletes, etc., maintenance should be performed every 30-90 days.
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The following maintenance actions are available:

Analyze Table - Verifies indexes and keys for optimal internal operation for queries. It may be
worthwhile running this action if large amounts of new data has been imported into the database.

Check Table - Checks the table or tables for errors.  This function might produce many rows of
information for each checked table. The last row will have a Msg Type value of "status" and the
Msg Text normally should be "OK". If you don't get "OK," or "Table is already up to date" you
should normally run a repair of the table. A message reading, "Table is already up to date" means
that there was no need to check the table.

Repair Table - Repairs a possibly corrupted table. Normally you should never have to run this
command. However, if disaster strikes, the repair is very likely to get back all your data. Like the
Check Table function, Repair Table may produce many rows of information for each checked
table. The last row is the most important, and should be "OK".

Optimize Table - Should be used if you have deleted a large number of records.  Ordinarily,
running an optimization once a month will keep tables compacted and well optimized.  The most
common use of the Optimize function is to reclaim allocated but unused space in a table (such as
when a large block of records has been deleted.)  This is a little like degragmenting a computers
hard disk. You can see how much space a table has by running "Show Table Info" and checking
the value in the Data Free column.

Show Table Info - Displays various statistics for a table, including the amount of allocated but
unused space.  This information may be asked for by Support to help analyze an issue.  The
following information is displayed:

- Table Name: the name of the table being acted upon
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- Rows: the number of rows in the table
- Avg Row Length: the average number of bytes per row in the table
- Data Length: the total number of bytes of the table data file
- Index Length: the total number of bytes of the index data file
- Max Data Length: the maximum length of the data file
- Data Free: the number of bytes of allocated, but unused space in the table 
- Create Time: the date/time the table was created
- Update Time: the date/time the table was last modified
- Check Time: the date/time of the last Check Table operation
- Engine: the storage engine used for the table
- Comment: the description of the table's use (or some information why the server couldn't
access the table information if the table's information could not be displayed)

Maintenance Frequency

It is a good idea to get in the habit of running the table maintenance operations on a monthly to quarterly
basis, depending upon how much activity you have on your database (i.e., a database with 10
concurrent users may require more frequent maintenance for optimal performance).  Think of table
maintenance as basic housekeeping for a healthy database.  Like changing the oil in your automobile, it
keeps the database engine running well.

At a minimum, run Check Tables and look at the results.  If any errors or warning are reported, run the
Repair Tables option and then run Check Tables again.  When finished, run Analyze and/or Optimize
Tables to refresh indexes and compact and organize your data.

Running Maintenance Functions

From within MemberTies...

1 Login as the user "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Tables.

3 Continue to Step 4 below.

From the Server Utility...

1 Start the server utility and click Maintain Tables.

2 Choose the desired database, and enter the mtadmin username and password.

3 Continue to Step 4 below.

Then...

4 Select one or more tables to affect in the Tables area. (If you're not sure, just right-click the list
and choose Select All)

5 Choose the action to perform from the dropdown, then click "Start".

Normal Housekeeping can be accomplished by selecting all tables, and then successively
running Check, Repair, and Optimize.

6 Information about the operation will be displayed in the Details section.
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7 When the operation is finished, you can write the contents of the "Details" section to a log file if
you wish. To do this, click "Write Log", enter a filename in the "Save Message Log As" dialog,
and click Save.

8 If you want to perform another operation, repeat the previous steps, otherwise, click Close.

Note: If for some reason you cannot start MemberTies to run table maintenance, the same functions can
be run from the Server Utility.

 

12.6 Deleting a Database

The Server Utility enables you to complete destroy a database. You will be prompted for a login
username and password, and will have to choose a database to remove when selecting this option. You
will be prompted several times to confirm the deletion.

This is the best way to remove a test database or any database you no longer use.

Deleting a Database

1 Start the Server Utility (see Using the Server Utility if you don't know where this is)

2 Click "Remove Database". 

3 Choose the desired database, and enter the password for the mtadmin user.

4 Click OK, and confirm the removal when prompted.  If everything looks ok, the system will
display a final warning.



Local Database Server Utility 146

©1998-2014 Myrro International

5 Type "YES" in the box to confirm the removal, then click OK.
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13 Deposits

13.1 Tracking Deposits

Using MemberTies Professional, any number of postings can be grouped together as a "Deposit"
identified by a deposit number and date.  

Adding a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, click Add.

3 The Deposit Detail window displays all postings currently assigned to this deposit as well as the
deposit header information:

Date - The date of the deposit.  This may represent the date you create the deposit, or the date
it goes to the bank.

Number - The system generates a deposit number automatically, but you can change it if you
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wish.  The system will always add 1 to the highest recorded deposit number when generating a
new deposit.

4 Click Add to search for more postings.

5 On the Add Postings to Deposit window use the search criteria fields to limit the postings
returned by the search:

From Date - The oldest date a dues/donations posting or activity income/expense entry can
have. This defaults to the  date of the most recent deposit.

To Date - The most recent date a dues/donations posting or activity income/expense entry can
have.

Include - The type of items to be searched (i.e., dues, donations, etc.)

Posting Type - Indicate the type of postings to search. Most deposits will only contain Credit
postings (activity income is treated as a credit), but you can search Debit postings as well.

6 Click Search.

7 Select one or more postings to add to the deposit, then click OK to return to the Deposit Detail
window.

8 Click OK to save the deposit.

Changing a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, select the deposit you want to modify, then click Open.

3 On the Deposit Detail window, use the Add and Delete icons to either add more postings, or
remove existing postings.

4 When you are finished, click OK

Deleting a Deposit

1 Choose Tools > Deposits.

2 On the Maintain Deposits window, select the deposit you want to delete, then click Delete.

3 Confirm the deletion.

Printing a Deposit

Use the Reports window to print the Deposit Detail report.
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14 Dues, Donations, etc. (Postings)

14.1 Postings Overview

Postings are handled differently depending on whether you are using the standard or professional version
of the software.

The standard version of MemberTies simply tracks a running total of dues paid. It doesn't include
donations, or postings via activities or groups. You can think of every entry as being a credit (positive
adjustment) to the member's account.  For more accurate tracking of payments and charges,
MemberTies Professional enables you to enter both debits and credits.  The system of debits and
credits enables you to maintain a zero balance when a member's account is paid in full (i.e., $50 dues
charge balanced by a $50 dues payment).

For example, if a member had paid two payments of $50 each, the difference between the standard
method and the professional method would look something like this:

Standard 
Dues Payments

Professional 
Dues Charges and Payments

Dues Payment 1: $50.00
Dues Payment 2: $50.00

Dues Charge 1: ($50.00)
Dues Payment 1: $50.00

Dues Charge 2: ($50.00)
Dues Payment 2: $50.00

Balance: $100.00 Balance: $0.00

As you can see, both versions tracked two incoming payments, but the professional version also tracked
the charges. When a person was charged, their account became negative, and when the paid, the
account returned to zero. (Note: If you want charges to be positive, and payments to be negative, you
can change a preference to control it.)

Whose dues are due?

When it comes to Dues, everyone needs to know which members currently owe money. The answer to
that question frequently comes down to the way you are tracking dues.  

With the standard version, there is no way to tell simply by looking at a running balance; instead, you
have to maintain the End Date on the member record.  MemberTies assumes that the End Date
represents the date through which a person is "paid in full," and when the End Date is reached the
member pays for another period and gets a new End Date set for some point in the future. So, to find
out who owes money, you can simply search for everyone with an End Date in the past (because if
their dues were paid, they would have a new End Date in the future).

With the professional version, you can look at the End Date as described above, but you can also look
for anyone with a negative dues balance (if you're letting debits be negative). That's because a negative
balance would mean they have been charged more than they've paid.  Likewise, anyone who has paid
too much will have a credit (positive) balance.

Sending out Statements
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To send out a statement requesting payment, you can run the Dues Account Statement report.  By
default it will list all postings for a given member, and finish with the balance. If you run the report with
criteria like:

Dues Balance < 0 (i.e., dues balance less than zero)

The report will only show members who have a negative balance.  The statement can include a tear-off
remittance advice that your member can return to you with payment.

Date Posted vs Date Recognized

All postings enable you to track both the date the entry was posted, and the date you want to
"recognize" the posting.  (This is also sometimes called the "effective date".)  For example, if your dues
are all due on January 1st, you may want to "recognize" dues payments received in December as of
January 1. So you would enter a December payment with a December posting date, but a January 1st
recognized date.

That enables you to run a report using criteria like, "Date Recognized = January 1" to get everyone who
has paid their January dues, regardless of when the payment arrived.

"Any" Postings Criteria

When using postings as search criteria for reports, you'll notice that there are seemingly duplicate fields
like Date Posted, Amount, etc., listed under Dues, Donations, Groups, and Activities, as well as under
"Any" as shown below:

If you choose the Amount criteria from "Postings (Dues)", you can only find record with Dues postings



MemberTies153

©1998-2014 Myrro International

that match.  However, if you choose the Amount criteria from the Postings (Any) section, the amount
can match a Dues entry, as well as a Donation, Activity, or Group posting.

14.2 Dues Tab (Members)

The Dues tab is used to record postings to a member's "dues" account. The current account balance is
displayed at the bottom of the list, as well as a subtotal if the list is filtered by Posting Type (posting
types, shown in the example below, only apply to MemberTies Professional). 

Note: If you are creating a new record, the member must be saved first (click Apply) before you can
access this tab unless you turn on the "Auto Save New Members" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via Membership
Preferences.

Filtering the Display

If you are using MemberTies Professional, you can create a system of dues "posting types" to better
categorize the type of payment or charge being posted (such as Dues Charge, Dues Payment, Refund,
T-Shirt Sale, Food Order, etc.). If you are using corresponding debits and credits to balance the
member's account, the number of entries can become fairly lengthy; therefore, the Dues tab includes a
dropdown at the top labelled, "Show by Posting Type," which enables you to filter the display by a
specific type. (The dropdown is not displayed in the standard version, which does not use posting
types.)

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
type or choose "(All)".
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Adding (posting) Dues

1 On the Dues tab, click Add.

2 The following fields are available:

Posted - The date on which the dues entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone pays for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this dues entry, even though it was actually posted the year
before.

Posting Type - (MemberTies Professional only) the posting type to be applied to this entry. The
debit/credit action of the type is displayed in the dropdown, and any minimum or maximum
amount requirement is displayed to the right of the field. See Maintaining Posting Types for
more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the Dues
tab if the display is being restricted to a particular posting type, or b) the default posting type
specified in the Posting Types list, if available. If neither of these apply, no default value will be
entered.

Status - The membership status being purchased. You do not have to enter the status of the
actual membership record (you might be entering a historical dues payment for a previous
status, such as "prospect", even though the member is actually a full member now). There is no
connection between the status entered here and the status of the main record, though you can
have the system synchronize them (see below). 

Update Record - (MemberTies Professional only) Select this option if you want to synchronize
the status of the record with the status being purchased. If they already match, this will have no
effect. Note that this option does not create a "link" between the statuses. If you subsequently
change the status on the main record, it will not have any effect on the dues entry that updated
it.

Amount - The amount to be recorded. Only positive numbers may be used. In the professional
version, the posting type determines whether the amount is applied as a debit or credit to the
account. 

If you have entered yearly dues values for your statuses, you can click the calculator button to
the right of the Amount field to use the Dues Calculator to quickly determine the prorated (or
normal) amount to charge. See Using the Dues Calculator for more information.

In MemberTies Professional there are several ways to enter the amount. In addition to typing in
an amount, you may have other options depending upon the way you set up your Posting Types
and Status codes. If you associated minimum or maximum amounts for the posting type, or a
yearly dues amount for the status code, you can quickly enter any of those amounts by clicking
the appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the member, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Member Credit Card Data for
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more information.

Receipt Number/Book - (MemberTies Professional only) These fields are enabled whenever the
selected posting type is one that has been defined to generate a receipt number. The fields are
disabled for all other posting types.  The Receipt Number is a sequential number generated by
the system. The Receipt Book is the value set as the Dues Receipt Book Nbr in preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - (MemberTies Professional only) Click this option if you want to force the system
to generate the next receipt number immediately. Note that once a receipt number has been
generated, it is "used" permanently, even if you choose not to save the entry.  The only way to
reset it is via the Dues Receipt Book Nbr preference.  If you want to "regenerate" a new number
for an entry that already has a receipt number, you must clear the field first, then click Assign
Now to generate a new number.  If you do not want the Assign Now option to be available at all,
it can be turned off via the Allow Assign Now preference.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report  (MemberTies Professional only) if you wish.

Print Receipt - (MemberTies Professional only) This option controls when a receipt should be
printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Dues tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Dues Print Receipt = Selected" to
print all marked receipts at once.  

Update the Start Date To - If the member should receive a new Start Date because of this
entry, select this option and enter the new date. The system will update the date on the member
record automatically.

Update the End Date To - If the member should receive a new End Date because of this entry,
select this option and enter the new date. The system will update the date on the member
record automatically.

The Suggest New End Date dues preference (MemberTies Professional only) can be set to
make the system automatically select this option and enter a suggested date in the "Update
End Date To" date field. This preference lets you specify the number of months the End Date
should advance when posting debits or credits. If you set this preference and then use the
appropriate debit or credit posting type, the system will automatically fill in the date (though you
can override it by clearing the checkbox).

4 When you're finished, click OK to save.
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5 If you have filtered the display by Posting Type (MemberTies Professional only) and you add a
dues entry that uses a posting type that has been filtered out, the new entry will not appear until
the filter is changed to one that will include it.

Changing a Dues Entry

1 On the Dues tab, click the entry you want to change, then click Open.

2 When the Edit Dues window opens, make your changes, then click OK. The current balance will
recalculate automatically if necessary.

Deleting a Dues Entry

1 On the Dues tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple
Records.

Printing Receipts as a Group

(MemberTies Professional only)  As described above for the, "Printed Receipt" field, you have the option
of marking many entries for future receipt printing. Any entry that has been marked for printing will
include a checkmark in the "Rcpt" field on the list. (Note that this checkmark does not prevent you from
selecting an entry on the list and printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

Additional Dues Capabilities

If you are using MemberTies Professional, there are some other dues-related options:

You can post dues directly from the Membership List to any number of selected records, or
records with a specific status. See Posting to Multiple Records for more information

The system can automatically post dues on new records, the start date, the end date, or on
specific dates, all based on the member's status. See Maintaining Status Codes for more
information.

The system can automatically post interest charges to past-dues accounts based on the
member's status. See Maintaining Status Codes for more information.

You can maintain a separate list of Donations that do not affect the dues account at all. See the 
Donations Tab for details.
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You can create a Deposit containing any number of Dues, Donation, and Activity Income entries.
See Tracking Deposits for details.

You can clear ALL Print Receipt checkmarks for the entire system by choosing Tools > Database
Tools > Clear Print Receipt Settings.

14.3 Dues Tab (Groups)

The Dues tab is used to record postings to the group's "dues" account. The current account balance is
displayed at the bottom of the list, as well as a subtotal if the list is filtered by Posting Type. 

Note: If you are creating a new group record, the group must be saved first (click Apply) before you can
access this tab unless you turn on the "Auto Save New Groups" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via via Preferences.

Filtering the Display

You can create a system of dues "posting types" to better categorize the type of payment or charge
being posted (such as Dues Charge, Dues Payment, Refund, T-Shirt Sale, Food Order, etc.). If you are
using corresponding debits and credits to balance the account, the number of entries can become fairly
lengthy; therefore, the Dues tab includes a dropdown at the top labeled, "Show by Posting Type," which
enables you to filter the display by a specific type. 

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
type or choose "(All)".

Adding (posting) Dues

1 On the Dues tab, click Add.

2 The following fields are available:
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Posted - The date on which the dues entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone pays for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this dues entry, even though it was actually posted the year
before.

Posting Type - the posting type to be applied to this entry. The debit/credit action of the type is
displayed in the dropdown, and any minimum or maximum amount requirement is displayed to
the right of the field. See Maintaining Posting Types for more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the Dues
tab if the display is being restricted to a particular posting type, or b) the default posting type
specified in the Posting Types list, if available. If neither of these apply, no default value will be
entered.

Amount - The amount to be recorded. Only positive numbers may be used. The posting type
determines whether the amount is applied as a debit or credit to the account. 

There are several ways to enter the amount. In addition to typing in an amount, you may have
other options depending upon the way you set up your Posting Types. If you associated
minimum or maximum amounts for the posting type, you can quickly enter any of those
amounts by clicking the appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the Group, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Credit Card Data for more
information.

Receipt Number/Book - These fields are enabled whenever the selected posting type is one
that has been defined to generate a receipt number. The fields are disabled for all other posting
types.  The Receipt Number is a sequential number generated by the system. The Receipt
Book is the value set as the Dues Receipt Book Nbr in preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - Click this option if you want to force the system to generate the next receipt
number immediately. Note that once a receipt number has been generated, it is "used"
permanently, even if you choose not to save the entry.  The only way to reset it is via the Dues
Receipt Book Nbr preference.  If you want to "regenerate" a new number for an entry that
already has a receipt number, you must clear the field first, then click Assign Now to generate a
new number.  If you do not want the Assign Now option to be available at all, it can be turned off
via the Allow Assign Now preference.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report if you wish.

Print Receipt - This option controls when a receipt should be printed for the entry:  
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No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Dues tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Dues Print Receipt = Selected" to
print all marked receipts at once.  

4 When you're finished, click OK to save.

5 If you have filtered the display by Posting Type and you add a dues entry that uses a posting
type that has been filtered out, the new entry will not appear until the filter is changed to one
that will include it.

Changing a Dues Entry

1 On the Dues tab, click the entry you want to change, then click Open.

2 When the Edit Dues window opens, make your changes, then click OK. The current balance will
recalculate automatically if necessary.

Deleting a Dues Entry

1 On the Dues tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple
Records.

Printing Receipts as a Group

As described above for the, "Printed Receipt" field, you have the option of marking many entries for
future receipt printing. Any entry that has been marked for printing will include a checkmark in the "Rcpt"
field on the list. (Note that this checkmark does not prevent you from selecting an entry on the list and
printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

Additional Dues Capabilities

There are some other dues-related options:
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You can post dues directly from the Group List to any number of selected records, or records with
a specific status. See Posting to Multiple Records for more information

You can create a Deposit containing any number of Group Dues or Member Dues, Donation, and
Activity Income entries. See Tracking Deposits for details.

You can clear ALL Print Receipt checkmarks for the entire system by choosing Tools > Database
Tools > Clear Print Receipt Settings.

14.4 Donations Tab (Members)

The Donations tab is used to record donations or gifts the member has made to the organization that
should not be reflected in the Dues account.  This tab works essentially the same, but separate from,
the Dues tab. The current account balance is displayed at the bottom of the list, as well as a subtotal if
the list is filtered by Posting Type. 

Note: If you are creating a new member record, the member must be saved first (click Apply) before you
can access this tab unless you turn on the "Auto Save New Members" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via Membership
Preferences.

Filtering the Display

You can create a system of donation "posting types" to better categorize the type of donation received if
you don't want to use the standard "donation" entry. Using the dropdown at the labelled, "Show by
Posting Type," enables you to filter the display by a specific type. 

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
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type or choose "(All)".

Adding (posting) Donations

1 On the Donations tab, click Add.

2 The following fields are available:

Posted - The date on which the donation entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone donates for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this entry, even though it was actually posted the year before.

Posting Type - The posting type to be applied to this entry. The debit/credit action of the type
is displayed in the dropdown, and any minimum or maximum amount requirement is displayed
to the right of the field. See Maintaining Posting Types for more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the
Donations tab if the display is being restricted to a particular posting type, or b) the default
posting type specified in the Posting Types list for donation entries, if available. If neither of
these apply, no default value will be entered.

Amount - The amount to be recorded. Only positive numbers may be used. The posting type
determines whether the amount is applied as a debit or credit to the account. 

There are several ways to enter the amount. In addition to typing in an amount, you may have
other options depending upon the way you set up your Posting Types. If you associated
minimum or maximum amounts for the posting type you can quickly enter those by clicking the
appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the member, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Member Credit Card Data for
more information.

Receipt Number/Book - (MemberTies Professional only) These fields are enabled whenever the
selected posting type is one that has been defined to generate a receipt number. The fields are
disabled for all other posting types.  The Receipt Number is a sequential number generated by
the system. The Receipt Book is the value set as the Donations Receipt Book Nbr in 
preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - (MemberTies Professional only) Click this option if you want to force the system
to generate the next receipt number immediately. Note that once a receipt number has been
generated, it is "used" permanently, even if you choose not to save the entry.  The only way to
reset it is via the Donations Receipt Book Nbr preference.  If you want to "regenerate" a new
number for an entry that already has a receipt number, you must clear the field first, then click
Assign Now to generate a new number. If you do not want the Assign Now option to be available
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at all, it can be turned off via the Allow Assign Now preference.

Print Receipt - (MemberTies Professional only) This option controls when a receipt should be
printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Donations tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Donations Print Receipt =
Selected" to print all marked receipts at once.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report  (MemberTies Professional only) if you wish

3 When you're finished, click OK to save.

4 If you have filtered the display by Posting Type (MemberTies Professional only) and you add an
entry that uses a posting type that has been filtered out, the new entry will not appear until the
filter is changed to one that will include it.

Changing a Donation Entry

1 On the Donations tab, click the entry you want to change, then click Open.

2 When the Edit Donation window opens, make your changes, then click OK. The current balance
will recalculate automatically if necessary.

Deleting a Donation Entry

1 On the Donation tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple
Records.

Printing Receipts as a Group

(MemberTies Professional only)  As described above for the, "Printed Receipt" field, you have the option
of marking many entries for future receipt printing. Any entry that has been marked for printing will
include a checkmark in the "Rcpt" field on the list. (Note that this checkmark does not prevent you from
selecting an entry on the list and printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
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the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

14.5 Posting to Multiple Records

With MemberTies Professional, you can post a specific dues entry to multiple records at once. You can
choose to post to all records currently selected on the Membership or Group List, or to specific records,
or to all records of a particular membership status, regardless of whether they are visible on the
Membership List. 

This feature can also be used to "zero-balance" an account, i.e., to post whatever amount is required to
bring an account to a balance of zero. This is helpful if you have upgraded from the standard version
(which just maintains a running positive balance) and would like to bring each account current to a zero
balance.

Whether you want to post a specific amount, or zero-balance accounts, you will use the Post Dues
window. This window is accessible whenever the Membership List or Group List is open.

If you accidentally post dues entries to a group of records and want to remove the postings, see Deleting
Postings from Multiple Records.

Posting Dues

1 Choose File > Workspace > Membership List or Group List.

2 If you plan to post to a set of selected records, highlight each record to which you want the dues
entry to be posted. You can use the standard Windows key combinations to select multiple
records, i.e., hold down the CTRL key to select various records, or hold the CTRL + SHIFT keys
down to select groups of records.  You can also simply search for the records that meet a
specific criteria, and then select all of them.

3 Choose Actions > Post Dues.

4 When the Post Dues window opens, the following fields are available:

Type - This setting determines the basic operation of the window:

Manual Entry - Enables you to post a specific amount, using the posting type you choose.

Zero-Balance - Tells the system to post whatever amount is required to bring the selected
dues account(s) to zero, using the appropriate debit or credit posting types you choose.

Date Posted - The date on which the entry was created. Normally the current date.

Date Recognized - The date on which you want the amount to apply to your organization

Posting Type - The posting type to be used for each entry. If you selected Zero-Balance as the
Entry Type, there will be two posting type fields visible. The Credit  type will be used for any
account that requires a credit entry to balance it, and the Debit type will be used for any
account that requires a debit entry to balance it.
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Note that if you select a posting type that generates a receipt number, this will be done
automatically as postings are written to the database.

Status - (available  posting from the Membership List) The "Use Status on the Membership
Record" checkbox is selected by default, meaning each entry will use the member's current
status.  To use a different status, clear this checkbox and choose the desired status to be set. 

Amount - The amount to be posted can be entered manually, or selected from various other
options. 

Manual Amount - lets you enter any amount you choose (note that all amounts are entered
as positive numbers -- it is the posting type that determines whether it is applied as a debit
or credit)

Minimum for Posting Type - automatically uses the minimum allowed for the selected
posting type

Maximum for Posting Type - automatically uses the maximum allowed for the selected
posting type

Yearly Dues for Selected Status -  (available  posting from the Membership List)
automatically uses the yearly dues amount set for the selected status (this option is not
available if you have selected the "Use Status on the Membership Record" option, because
the status can vary with each record.

Yearly Dues for Record Status -  (available  posting from the Membership List) This option
is only available when the "Use Status on the Membership Record" option has been
selected. This will cause the system to automatically enter the appropriate yearly dues
amount on each posted record, based on the record's current status.

Note: If you selected Zero-Balance as the Entry Type, the amount fields are not visible because
the system will calculate the amount for each account.

Method - Enter the payment method.

Cheque - Enter the number of the physical cheque, or another payment identifier.

Set New Dates -  (available  posting from the Membership List) If you want to change the
current Start and/or End Date on the membership record(s) posted to, set the appropriate date
(s).

Comments - Enter any comments that should be used for the entry, i.e., "Yearly Dues"

Mark for Printing - You can choose to print receipts from this window, or just mark records for
printing later.  If you want to print receipts from this window, leave this option unselected.

5 Use the Records to Post section of the window to specify which records will be updated:

All Selected Records - will post to every record current selected (highlighted) on the List

All Records with a Status of [your selection] -  (available  posting from the Membership
List) will post to all members currently set to the selected status, regardless of whether
they are currently selected or even displayed on the Membership List. 
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Specific Record - will post the the member/group selected in the field. 

6 When you're ready to post entries, click Post.  The posting will be saved to the database, and
the name and amount will appear in the Completed Postings list.

Printing Receipts

To print one or more receipts, select the record or records to be printed from the Completed
Postings list, then click Print.  If you want to preview the receipts before they are printed, turn on the
Preview option (note that this will preview EVERY receipt, so if you just want to test it, you may only
want to select one or two receipts at a time.

 

14.6 Posting Dues Automatically

With MemberTies Professional, you can setup auto-posting rules on any membership status so that the
system will automatically post a specific dues entry at specific times of the year.

For example, you can have the system automatically post the your annual dues charge on the day a
member's End Date arrives. Or if you want to be more specific, you can have the automatic posting
occur on a particular day, month, and/or year.

See Maintaining Status Codes for details.

14.7 Deleting Postings from Multiple Records

With MemberTies Professional a special deletion window is available to remove dues and/or donations
from multiple records based on specific criteria.  This enables you to "undo" an errant posting without
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opening and modifying hundreds of records individually.

Deleting Postings

1 Choose File > Workspace > Membership List or Group List.

2 Choose Actions > Delete Postings.

3 When the Delete Postings window opens, enter the appropriate criteria to match the unwanted
entries. The following criteria fields are available (each field is optional, but you must select at
least one criteria):

Date Posted - The date to be matched.

Posting Type - The posting type.

Record Status - The status of the membership record itself (this field only applies when deleting
member Dues/Donation/Activity postings).

Posting Status - The status on the individual  posting.

Amount - The amount posted.

Limit to Currently Selected Records - Select this option to limit the search to only those
records currently selected on the List.

In the "Apply To" section, choose whether the system should search for Activity, Dues,
Donations, or Group postings. Note that this window is used for both member and group
postings, so it is possible to choose an impossible combination. i.e., if you choose to apply to
Group postings, but require a specific (member) Record Status, the system won't find anything
to delete.

4 When you have entered enough criteria to limit the search to the postings you want to remove,
click Delete.  A message will be displayed with the results of the operation.
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14.8 Maintaining Posting Types

With MemberTies Professional, Posting Types enable you to categorize dues or donation postings,
restrict the amount that can be posted under the type, control whether the amount posted will affect the
member's account as a debit (reducing the account balance) or credit (increasing the account balance),
and indicate whether the system should generate a receipt number.  

Several posting types are provided, including:

Interest - To be used for automatic interest postings. This is a debit to the account balance.

Dues Payment - To be used for monies received. This is a credit to the account balance.

Dues Charge -To be used for monies owed. This is a debit to the account balance.

Balance Adj. - Both a credit and a debit type by this name are provided, to be used for adjusting
entries.

Donation - To be used for donations received. This is the default donations posting type.

Activity Income - To be used for income associated with an activity or attendee.

Activity Expense - To be used for expenses associated with an activity or attendee.

Adding a new Posting Type 

1 Choose Tools > Dropdown Lists > Posting Types. 

2 When the Maintain Posting Types list opens, click Add. 

3 On the New Posting Type window, the following fields are available:
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Posting Type - The name of the posting type. This name will appear, along with the a debit or
credit indicator, in Posting Type dropdowns.

Action - Choose Debit if amounts posted under this posting type should decrease the account
balance, or choose Credit if amounts posted should increase the account balance.

Available To - Indicates the type of record with which the posting type may be used.

Minimum - The minimum amount that can be posted under this type. The default is 0.00.

Maximum - The maximum amount that can be posted under this type. The default is 0.00,
indicating no maximum.

Receipt - Indicates whether a unique receipt number should be generated for the posting (for
display on the printed receipt). The current receipt and receipt book numbers can be set via 
Financial Preferences.

Generate Now - Click this option to cause the system to scan all existing postings of the
current type. Any posting found without a receipt/book number will be updated. (This option is
only visible when modifying an existing posting type, since a new posting type obviously has no
existing entries.)

Default - If a Posting Type is marked as the default, it will be automatically selected when
adding entries of the type specified in the Available To field. You can specify two default; one for
Dues, and one for Donations.

Active - Indicates whether the posting type is available for new postings.  Once marked inactive,
the posting type will still display on records that were using it already, but will no be available for
new records. Inactive posting types are always available for reports and queries.

4 When you are finished, click OK.

Changing an existing Posting Type 

1 Choose Tools > Dropdown Lists > Posting Types.

2 When the Maintain Posting Type list opens, select the one you want to change.

3 Click Open.

4 Make your changes, then click OK. Your changes will be automatically reflected on any records
that were already using the posting type.

Note: You cannot change the action assigned to a posting type once entries have been posted
using it.

Deleting a Posting Type

1 Choose Tools > Dropdown Lists > Posting Types.

2 When the Maintain Posting Type list opens, select the record(s) you want to delete.

3 Click Delete.

4 Confirm the deletion.
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Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

14.9 Maintaining Credit Card Data

You can store information about any number of credit/debit cards for each member or group record.
Each time a  record is opened, the system will check the expiration date on any cards stored for that
record, and will clear the Valid checkbox if the card is expired.

Access to this window is controlled by the "Open Credit Card Data" Security Setting.

Important: Credit card information should be considered sensitive data. Myrro International cannot be
held responsible for any use or misuse of credit card data stored or printed using this software. Security
Group settings are available to restrict access to credit card data and reports.

Maintaining Credit Cards

1 There are two ways to access the list of stored credit cards:

From any list of postings (Dues/Donations/Activities), click the credit card icon in the lower
left corner

When entering or editing a posting, click the credit card  icon displayed next to the Cheque
field.
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2 The Maintain Card list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Card - Select the name of the card. Values in this list are controlled by the Credit Card Names
system list. See Maintaining Credit Card Names for information about adding or editing available
names.

Type - Select whether this is a credit or debit card.

Card Number - Enter the card number. When a card is selected for use with a dues payment,
the last four digits of the number will be displayed in the Cheque field (i.e., if the card number is
1111-2222-3333-4444, the Cheque field will show "4444")

Expiration - Enter the month and year the card expires (the format is MM/YY). Note that if the
expiration date has already passed, the Valid checkbox will be cleared automatically when you
save the data.

Verification Value - Also known as the "CVC2" or "CVV2," this is the 3 or 4 digit security
code typically printed in reverse italics on the back of the card above the signature area (or the
front above the account number on some cards). This code can be used as part of the
authentication process to reduce fraud by helping to ensure that the card is physically present
when the number is provided.

Name on Card - Enter the name of the card holder as it appears on the card.

Issuing Bank - This field may be used for additional information about the bank that issued the
card.

Bank Phone - Enter the telephone number for the issuing bank. Many credit cards have a
contact or verification telephone number on the back of the card. 

Comments - Enter general comments about this card.

Valid - Indicates whether the card is valid. The system cannot know whether the card number is
actually valid, so it will only check the expiration date value. You may also want to uncheck this
value if the card is declined, etc. Note: Any card marked as invalid will be displayed in the card
list with a line through the card name.

4 When you are finished, click OK to return to the list.

 

14.10 Using the Dues Calculator

Remembering the appropriate member dues payments for everyone can be difficult, especially when
people may decide to join the organization at odd times of the year. The Dues Calculator will determine
the correct dues amount for you for any status joining at any month of the year, based on dues amounts
you have defined for the status.

Note: The Dues Calculator is designed for simple monthly proration, and assumes the yearly dues
amount has been entered for the appropriate status code. Your organization's dues system may be too
complex for the Dues Calculator to handle. See Maintaining Status Codes for information about setting
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the yearly dues amounts.

Using the Dues Calculator

1 The calculator can be accessed in two ways:

When adding or editing a Dues payment via the Dues tab of a membership record.

By choosing Tools > Dues Calculator.

2 The calculator is divided into two sections, Criteria and Results. The Criteria section enables
you to choose the options that determine what will be calculated. The following fields are
available:

Status - Choose the being purchased; only status codes with a Yearly Dues amount defined are
available (if there is no yearly dues amount, there is nothing to use for calculations). Choosing
the status tells the system which amount to use for the calculator. Once the status is selected,
the yearly dues amount will be displayed in the Yearly Dues field, and any custom proration
amount will be displayed in the "Prorating" area.

Use Application Fee - If an application fee has been setup in Financial Preferences, it is
displayed next to the checkbox. Select this option to include the application fee in the total.

The following options enable you to control how the yearly dues amount is prorated. The setting
is defaulted to the setting on the status code (i.e., if the status is setup to prorate by day, then
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the Prorate by Day option will be selected automatically):

Type - Select the type of prorating to apply

Prorate by Month / Effective Month - Select these options to prorate the yearly dues by
month. The Effective Month setting determines the month prior to which dues will be waived.
 Dues will be prorated from the beginning of the year, which is the "Year Begin Date" set in 
preferences.

Prorate by Day / Effective Date - Select these options to prorate the yearly dues by day.
The Effective Date setting determines the date prior to which dues will be waived. Dues will
be prorated from the beginning of the year, which is the "Year Begin Date" set in 
preferences.

When you have select all desired options, click Calculate. The appropriate payment appears in
the Results section.

3 If you would like to copy the total amount to the clipboard, click Copy.

4 If you opened the calculator from the Post Dues window, a "Use" button will be available. Click
"Use" to paste the dues total into the amount field of the current dues entry.
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15 Email

15.1 Sending Email

With MemberTies Professional you can send email to members, groups, and attendees of activities
using your Internet account.  When you open the email window, it will automatically populate itself with
email addresses based on where you were when you opened the window, as described below.

When email is sent, there are various ways to address the message(s). You can choose to put email
addresses in the "To", "CC", or "BCC" fields of the message (i.e., the old-fashioned way), or you can
have MemberTies generate separate, individually addressed messages, one for each person on your
address list (i.e., the more modern way).  The second, more modern method is normally preferred,
because it looks more professional and prevents others from seeing the email addresses of your other
members.

Warning: SPAM email (also known as unsolicited commercial email) is a growing problem on the
Internet today.   If we determine that you are using MemberTies Professional to send SPAM, we will
terminate your license and report you to the appropriate authorities. Using MemberTies Professional to
send unsolicited email (SPAM), or to transmit illegal content is expressly forbidden.

Note: You must have your own Internet connection in order to send email.

Sending Email

1 All email activity is performed on the Send Email window. There are several different ways to
open this window, depending on what you want to do. If you want to send email to:

The contact email addresses for one or more groups - select the desired group(s) on
the Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Only". The
contact email address for each selected group will appear in the Addresses tab.

The associated members of one or more groups - select the desired group(s) on the
Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Members".
The contact email address for all membership records associated with each selected group
will appear in the Addresses tab.

One or more membership records - select the desired member(s) on the Membership
List,  then click the Email toolbar button or choose Actions > Send Email.  The email
address for all selected records will appear in the Addresses tab.

The attendees of one or more activities - select the desired activity(s) on the Activity
List, then click the Email toolbar button or choose Actions > Send Email.  The email
address for all attendance records associated with each selected activity will appear in the
Addresses tab.

There are also various places in the system where an email address is displayed as a data-
entry field. When an Email icon appears next to a field, you can click the icon to open the Send
Email window with the current address displayed.  In addition, the Email toolbar button is
always available even when no list is open. This enables you to open the Send Email window
and enter your own addresses, i.e., without bring in any existing email addresses.
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2 Once the Send Email window opens, there are several tabs available that affect or control the
sending of the message:

Message Tab - This tab is used to define the email message text, add attachments, and select
the email Profile that will be used to send the message.

Pasting In Message Text

While it is possible to cut/paste an email message from another source, such as a word
processing document, another email client, etc., you should be sure to send a test message to
see how it converts.  There are hundreds of character sets, fonts, and formatting tools out there,
and their output may not convert neatly to HTML email.  For things like bulleted and numbered
lists, put the mouse cursor on a bulleted line and see if the Bullet toolbar button activates.  If it
doesn't, then it isn't "really" a bullet and may not substitute neatly.  Reformat the pasted text as
necessary.

Message Options

Options on this tab that apply to creating the email message:

To save the email message for later reuse (including all text and attachment links) click the
Save button located to the right of the Subject line. (Messages are stored in the database,
so they are available to all users.)

To load a previously saved email message, click the Load button located to the right of the
Subject line. (See Loading Email Messages for details about the Load Message window.)

To Insert database fields in the email message so that MemberTies will use the appropriate
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data for the current member, click  the Fields button to display the list of fields. Note that
database fields can only be used if you are using the Multiple Messages addressing
method (see Addresses Tab below). This restriction exists because if you are using the
Single Message method to send one message with everyone listed in the To/CC/BCC
fields, MemberTies will not know which recipient's record to use for the data.

See Using Database Fields for more information.

To add an attachment, click the Open File icon located to the right of the Attachment List.

To remove an attachment, select the unwanted attachment in the Attachment list, then
click click the Delete icon located to the right of the Attachment List.

To send an HTML formatted email, you must set the Format option to, "Send as HTML." 
This will cause the email engine to reformat the convert the message to HTML before
sending.  The formatting toolbar will also only display when this option is set to send as
HTML. Please also see the note above about pasting in text!

Additional options are available by right-clicking the message itself:

Insert Image - enables you to choose an image to be embedded into the message.
Note that some older email clients (software that reads email) will filter out embedded
images.

Insert Table - enables you to create a table

Insert Link - enables you to enter a URL or Email hyperlink:

Address - The actual URL or email address

Link Text - Typically identical to the Address, but can be different, such as "Click
Here". Note that any recipient who displays the email as text instead of HTML will
not be able to determine what the address would have been, as they will only see
the Link Text. 

Format Bullets and Numbering - opens the standard bullets and numbering dialog

Format Font - opens the standard font dialog
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Options on this tab that apply to sending the email message:

To select an existing Email Profile, which determines what the return email address will be,
as well as the server through which the email will be sent, use the Email Profile dropdown. 

To open the list of Email Profiles so you can create a new profile or manage existing
profiles, click the Open icon located to the right of the Email Profile dropdown. See
Working with Email Profiles for more information.

To change the priority with which the email will be sent (this may or may not be respected
by all email servers), use the Email Priority dropdown.

To cause MemberTies to open a read-only email preview window for each message before
it is sent, select the Preview checkbox (this option is only available when using the Multiple
Messages addressing method (see Addresses Tab below).

Addresses Tab - This tab is used to identify the email addresses to which the email message
will be sent.

The most important setting on this tab is the Addressing Method. There are two methods
available:

Multiple Messages - Selecting this option causes MemberTies to format a separate
message for each person in the address list.  Only one address is used per email. When
this option is selected, the list of database fields on the Message tab is available. This is
normally the preferred option.  This is the preferred option, because each person gets a
uniquely addressed email, and never sees the addresses of any other recipient. 

Single Message - Selecting this option enables you to choose which field (TO/CC/BCC) to
use for each address. The "TO" field is normally used for the primary recipient(s) of the
message; the "CC" field is normally used for people of secondary importance (i.e., people
being "copied" on the message); the "BCC" field is used for people who need to see the
message but whose addresses should be invisible to all other recipients (i.e., people being
"blind copied" on the message).  Note that this method is often faster when sending an
attachment, because only the attachment only has to be processed one time, rather than
once per recipient.

Note that you can use the "BCC All" button that displays when you choose this option to
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automatically move the entire list of addresses to the BCC field.

After the Addressing Method is selected there are several icons below the Recipients list that
control additional options:

To prevent the member name from being displayed with the email address (i.e., to show
"jsmith@myisp.com" instead of "John Smith <jsmith@myisp.com>", clear the "Show
Name with Address" checkbox.

To search for one or more membership records and automatically add their email address
(es) to the list, click the Search icon.

To manually add a new recipient to the list, click the Add icon. You will be prompted for the
name and email address.

To change a recipient, select it and click the Open icon.

To delete one or more recipients, select the ones you want to remove and click the Delete
icon.

To save the recipient list for future reuse (including the designations for the TO/CC/BCC
fields if appropriate), click the Save icon. Enter a file name when prompted.

To reload a saved recipient list, click the Open File icon. Note that reloading a save list
causes all addresses to be appended to the existing list. This enables you to open several
saved lists to create a combined list.

If the Recipients list contains duplicate addresses, you can clear them automatically by
choosing Remove Duplicates from the right-click menu.

Settings Tab - This tab is used to control miscellaneous mail sending options.

Enable Log - To generate a log of all communication with the email server (useful for tracking
down problems), select the Enable Log checkbox. The current log file may be viewed by clicking
the Open File icon to the right of the Enable Log checkbox. Note: Your password may appear in
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the log in plain text.

Include Timestamp in Log File Name - Select this option to cause the log file name to
include the current timestamp, for example, "mtemail071405183025.log" for a log generated July
14, 2015 at 18:30:25.

Validate Address List(s) before Sending - Select this option to have the system check each
email address for technical accuracy, i.e., the format of the address will be verified to conform to
the requirements of a valid email address. This does not insure that the address itself is valid or
that the mail will be delivered, only that the address is formatted correctly.  If this option is used,
the check will occur just before beginning the sending process. If any problems are found, the
offending address(es) will be highlighted in red italic text for easy identification, and you will be
given the opportunity to stop the process to correct them.

Transmission Control - If your ISP limits the number of messages you can send per minute,
per hour, or per connection, typically to try to prevent mass unsolicited email distribution, you
can enter the appropriate settings here to comply. 

Select the "Restrict the number of messages sent" checkbox, then enter the maximum number
of messages that can be sent in a minute, hour or in a given connection (email session). If you
select "per minute" or "per hour" the system will send up to the max messages allowed that
period, and then pause until the end of the minute/hour before starting the next batch. If you
select "per connection", the connection with the server will be broken and restarted for each
batch.

Note: If you are sending in Single Message mode with a number of addresses in the TO, CC, or
BCC fields, "one" message can contain an unlimited number of recipients, unless limited by the
"Max Recipients" setting (see below).

Max Recipients - This option only applies when sending in "Single Message" mode. If your ISP
limits the number of recipients that can be in a single email message, set the value here. If you
enter 10 for example, the system will process the message several times, adding recipients
from the To list, then the CC list, then the BCC list, until the maximum number is reached. Then
the message will be sent, and it will start a new message and select new people from each list
in turn, repeating the process until all addresses in the TO, CC, and BCC lists have been
accounted for.

Control Address - If you would like the system to send a final email to a specific address (as a
check to verify that all messages were processed) enter that address here.  The email will be
addressed to a person called, "Control Address" at the address you specify.  Note that if you
are using the "Single Message" addressing option, this address will be added to the BCC list.

Save Messages to Sent Mail - Select this option to save a copy of the mail message to the
Sent Mail list. Note that it is important to understand that a message will be saved to the Sent
Mail list regardless of whether it is successfully delivered. All the system knows is that the
message was sent to the specified mail server for delivery. It does not know whether the server
ever delivered it, whether it bounced back, or whether or not it was read.

Request Read Receipt - Select this option to send a request that the receiving email program
notifies you when the message is opened/viewed. Note that this is NOT fool-proof, and does
NOT guarantee in any way that a message has or has not been received.  Many people turn off
read-receipts because automatically returning receipts is guaranteed to increase the amount of
junk email you receive (because that automatic reply tells the spammer that your address is a
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real or "live" one, and therefore a good candidate for even more junk mail). But if the recipient
has their email software configured to allow receipts, this option will request one.

3 The final tab is the Sent Mail Tab. This tab displays copies of email messages that were sent
while the "Save Messages to Sent Mail" setting was selected. See Viewing Sent Mail for
complete information about this tab.

You can filter the list to only messages containing specific text. Enter the text to be found in the
Find Text field, and choose the field (or all) to be searched. Click Search to filter the list, or
Reset to clear the filter and show all messages again.

 

15.2 Loading Email Messages

Email messages are stored in the database, and can be quickly reloaded to create a new message.

Loading a Message

1 On the Message tab of the email window, click the Browse icon to open the Load Message
window.
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2 The Load Message window displays all previously stored messages in the "Available Messages"
list.  The following options are available on this window:

Delete Message - permanently deletes the selected stored message

Load HTML File - enables you to load a complete HTML file that you may have created using
an external HTML editing tool. Note that no link will persist between the original file and the
email message, so if the external file is modified, it will need to be reloaded.

Load Selected Message - Select this option to load the selected message into the Email
window when you click OK.  This checkbox is provided so that you can open this window and
load or delete messages without actually affecting the email message you may already be
working with.

3 When you are finished, click OK.

15.3 Using Database Fields

Inserting database fields into a message means that the appropriate data for the member will be
substituted for the field name. In other words, you could select the First Name field from the field list as
a salutation, creating something like:
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When the email is generated, the system will substitute "John" for "<<First Name>>" when generating
the email address for John.

Adding Fields to a Message

1 With the email message tab displayed, click the Fields button to display the field list.

2 Place the cursor where the field should go, and then click the field name in the list. The field
name will appear in the message.

Note: Custom fields will only appear in this list if they have been defined as available to be used
in Email.

3 If you are done with the Fields window, you can dismiss it using the Hide button. This will not
have any effect on the fields that have been used in the message, it just gets the Fields window
out of the way.

Preventing Blank Lines

There are situations where telling the system to "delete the line" when the only thing on it is blank,
is helpful. We cannot force the software to do this automatically though, because there are times
when it wouldn't be appropriate. So this section explains how to "tell the system" what you want to
do.  For example, consider an address block like this:

<<Name (First/Last Name)>>
<<Address Line 1>>
<<Address Line 2>>
<<City/State/ZIP Code>>
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If a record is missing data for Address Line 2, the output will show a blank line, like this:

John Smith
100 Main Street

Dallas, TX 75025

In order to prevent this, create the address block and add a leading "@" symbol ahead of any field
that should get special treatment when blank, like this:

<<Name (First/Last Name)>>
@<<Address Line 1>>
@<<Address Line 2>>
@<<City/State/ZIP Code>>

The "@" symbol is never printed, but it causes the system to effectively hit the backspace key when
the field is empty. So if the field is the first thing on the line, the "backspace" causes it to delete the
line break and jump "back" up to the previous line.  The resulting output looks like this:

John Smith
100 Main Street
Dallas, TX 75025

This trick can also be used when fields are lined up on the same line.  For example:

Hello @<<First Name>>!

Becomes:

Hello John!

or if there is no first name,

Hello!

15.4 Working with Email Profiles

An email profile defines the way MemberTies Professional connects to your internet service provider's
(ISP) email server to send email.  A profile contains some basic addressing information, and optional
authorization information that you may or may not need to use, depending on the policies of your ISP.

For help troubleshooting email issues, see Troubleshooting Email.

For some sample profile settings, see Email Profile Examples

Adding an Email Profile

1 Click the Open icon next to the Email Profile dropdown on the Message tab of the Send Email
window. See Sending Email for more information about accessing the Send Email window if
necessary.

2 When the Maintain Email Profiles window opens, click the Add icon to start a new profile.
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3 The Email Profile window includes several sections, controlling the basic to/from information,
SSL (encrypted transmission), SMTP (the server that sends the message) and POP3 (the
server that receives your mail).

This the following fields are available:

Address Information

Porfile Name - The name of the profile as it should appear in the Profiles dropdown on the
Send Email window.

Default - Select this option if you want this profile to be selected automatically when you open
the Send Email window.

Your Name - The name that should appear as the sender of the email. This is typically your
first and last name, but it could also be something like, "Support" or "Sales Dept."

From Address - The email address that will display as the sender's address. This is typically
your normal email address.

Reply-To Address - The email address to which any reply to your email should be sent. This is
typically the same as the From Address, but not necessarily.

Comments - This is a freeform text field for additional details about this profile.

Available to All Users - Select this option if you want all users (in a multi-user environment) to
be able to use and/or modify this profile.  
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SMTP Settings Section

Use SSL Security - Select this option if your SMTP mail server expects you to use SSL
encryption. If they don't explicitly say so, assume no SSL is involved. However, if they tell
you that the SMTP port is 465, that is a common SSL port, so you'll want to turn on SSL.
Selecting this option automatically changes the SMTP port to the standard SSL port, and
enables the following two SSL options:

Protocol - The SSL encryption protocol to use. This will normally be left at "Default".  

Use StartTLS - Select this option if your SMTP mail server supports SSL over standard
SMTP (port 25) instead of the special SSL port.  

SMTP Server - The domain name or IP address of the server through which your ISP allows
you to send mail.  This might be something like "mail.myisp.com" or "myisp.com" or
something entirely different. Contact your ISP if you do not have this information.

SMTP Port - The port on which the SMTP server "listens" for incoming mail. This is
typically port 25 for standard transmission, or 465 for SSL encrypted transmissions.

The SMTP Authentication section is required if your ISP authenticates people who send
mail through their servers. Almost all ISPs do this in some form.

Username - The username for the SMTP account.

Password - The password for the SMTP account.

Auth Method - The specific authentication method used by the server. Set this to LOGIN if
you aren't sure, or just try various methods and check the Email Log for any errors.  The
methods available are:

(None) - Only use this if you are not using any SMTP Authentication

No Authentication - Essentially accepts your username and password as an identifier
only.

PLAIN - Supported by many SMTP servers, however, the password is not encrypted
during the transfer.

LOGIN - The most common authentication method. Supported by almost all SMTP
servers, however, the password is not encrypted during the transfer.

CRAM-MD5 - Sends the password in encrypted form to protect it from cracking.

NTLM - A form of (Secure Password Authentication - SPA). Used in many Microsoft
products such as IIS SMTP.

MSN - Another form of (Secure Password Authentication - SPA), alias of NTLM, used
with Microsoft Network services.

Test Button - The "Test" button can be used to test whether an SMTP connection can be made
using the current settings. If this test fails, it will not be possible to use these settings to send
email.
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POP3 Authentication Section

The POP3 Authentication section is required if your ISP requires you to check mail prior to
sending mail. This sort of authentication is commonly referred to as "POP-then-SMTP" or "POP-
before-SMTP"; it essentially makes sure you have rights to use the server before you send mail
through it. Note: The username/password used on an email profile is not the same as your
MemberTies username and password.

Use SSL Security - Select this option if your POP3 mail server expects you to use SSL
encryption. If they don't explicitly say so, assume no SSL is involved. However, if they tell you
that the POP3 port is 995, that is a common SSL port, so you'll want to turn on SSL. Selecting
this option automatically changes the POP3 port to the standard SSL port, and enables the
following two SSL options:

Protocol - The SSL encryption protocol to use. This will normally be left at "Default".  

Use StartTLS - Select this option if your POP3 mail server supports SSL over standard
POP3 (port 110) instead of the special SSL port.  

POP3 Server - The server that you are authorized to use for receiving email. This will be
something like "mail.myisp.com" or possibly "pop.myisp.com", or an IP address like,
"10.123.456.1". 

Port - The port used by the POP3 Server for incoming requests. The default is 110, or 995 for
SSL encrypted transmissions.

Username - The username for the POP3 account.

Password - The password for the POP3 account.

Auth Method - The specific authentication method used by the server. Set this to LOGIN if you
aren't sure, or just try various methods and check the Email Log for any errors.  The methods
available are:

(None) - Only use this if you are not using any POP3 Authentication

LOGIN - The most common authentication method. Supported by almost all POP3
servers.

APOP - Uses the APOP command, a secure MD5-based authentication type, supported
by most POP3 servers.

NTLM - A form of (Secure Password Authentication - SPA). Used in many Microsoft
products such as IIS SMTP.

MSN - Another form of (Secure Password Authentication - SPA), alias of NTLM, used
with Microsoft Network services.

Test Button - The "Test" button can be used to test whether an POP3 connection can be made
using the current settings. If this test fails, it will not be possible to use these settings to send
email.
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Signature Button - Opens the Maintain Signature window so you can set a plain text and/or
HTML signature. The system will use the appropriate signature based on the way you create the
email message. Note that you can also create a global email signature via preferences.  If the
global signature exists, it will display below any profile-specific email signature.

Changing an Email Profile

1 Click the Open icon next to the Email Profile dropdown on the Message tab of the Send Email
window. See Sending Email for more information about accessing the Send Email window if
necessary.

2 When the Maintain Email Profiles window opens, all existing profiles will be displayed in the list.
Select the profile you want to change, then click the Open icon.

3 Make your changes, then click OK.

Deleting an Email Profile

1 Click the Open icon next to the Email Profile dropdown on the Message tab of the Send Email
window. See Sending Email for more information about accessing the Send Email window if
necessary.

2 When the Maintain Email Profiles window opens, all existing profiles will be displayed in the list.
Select the profile you want to delete, then click the Delete icon.

3 Confirm the deletion.

 
 

15.5 Email Profile Examples

Here are some profile settings for some common email services:

Hotmail (aka Windows Live)

Note: If your address is @live.com or some other flavor of Hotmail/Windows Live, substitute the
appropriate email address in the example.

From Email - you@hotmail.com

SMTP Settings POP3 Authentication settings

Use SSL Security - selected
Protocol - default
StartTLS - selected
SMTP Server - smtp.live.com
Port - 25
User Name - you@hotmail.com
Password - your hotmail password
Auth Method - LOGIN

Use SSL Security - selected
Protocol - default
StartTLS - NOT selected
SMTP Server - pop3.live.com
Port - 995
User Name - you@hotmail.com
Password - your hotmail password
Auth Method - LOGIN
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Gmail

From Email - you@gmail.com

SMTP Settings POP3 Authentication settings

Use SSL Security - selected
Protocol - default
StartTLS - NOT selected
SMTP Server - smtp.gmail.com
Port - 465
User Name - your gmail username
Password - your gmail password
Auth Method - LOGIN

Use SSL Security - selected
Protocol - default
StartTLS - NOT selected
SMTP Server - pop.gmail.com
Port - 995
User Name - your gmail username
Password - your gmail password
Auth Method - LOGIN

15.6 Removing Email Addresses

If you send an email and receive a "bounce" back indicating the address is not valid, you can use the
"Remove Email Address" window to automatically search for the member and/or group record(s)
containing the invalid address, move the address to the Comments field, and even preceded the new
comment with text like, "Removed invalid address."

Users must have the Edit Members and Edit Groups security to use this window.

To Remove an Invalid Address

1 Choose Actions > Remove Email Address.

2 On the Remove Email Address window, the following fields are available:

Specific Address - enables you to specific a single invalid email address. You can paste an
address using the standard keyboard shortcut CTRL+V, or via the right click popup menu.

File - enables you to specify a text file containing a list (one address per line) of email
addresses to be removed. This should be a standard text file, with no blank lines at the top or
within the list.
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Move to Comments - Select this option to add a comment to the record from which the email
address is removed.  The comment will begin with the date, and will include any additional text
specified, followed by the email address.

Additional Comment Text - Additional text to add to the comment.  For example, if this field
contains "Removed invalid address", the comment stored on the new record will be similar to:
"{date}: Removed invalid address: john.smith@myemail.com"

3 Click Remove. All membership and group records will be searched and updated.  The total
number of updates made will be displayed in the lower left corner of the window.

4 You can repeat steps 2 and 3 for another other addresses or files you may need to process.

5 When you are finished, click Cancel.

 
 

15.7 Viewing Sent Mail

With MemberTies Professional a copy of each email you send can be saved in a Sent Mail list. The
message, the address list, and the attachment list is saved just as it was defined on the Send Email
window.

The Sent Mail list enables you to reload a message for resending, or to reload only certain addresses,
attachments, or the subject and body of the message. 

Viewing Sent Mail

1 Sent Mail is a tabpage on the Send Email window.  This window can be accessed in a variety of
ways, as described under Sending Email. The easiest way to simply view Sent Mail is to just
click the Email toolbar button.

This is the sent mail for a single member, which is displayed by clicking the the Sent Mail icon
on the member record.
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2 On the Email window, go to the Sent Mail tab.

Deleting Messages

To permanently remove one or more messages from the Sent Mail list, select the messages you want to
remove, then click Delete.

Opening a Message

You can display all the details of any message in the Sent Mail list. Just select the message you want
to open, then click the Open icon.

Reloading a Message

Though the message is view-only, you can restore the message, address(es), and attachment(s) to the
active message.   If you would like to reload the entire message, click the "Reload this Message" button
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at the bottom of the window. This will load all attachments, addresses, and the subject and body text
into the message tabpage on the Send Email window.

If you would rather only reload certain things, you must use the right-click mouse menu as follows:

To reload the subject and message text, right-click the Message area, then use the right-click
menu to copy the subject and message text to the current message.

To reload one or more addresses, select the addresses you want, then use the right-click menu
to copy them to the current message. 

Note: Since the Addresses tab could be setup for Single or Multiple messages, it may not be
possible to copy the addresses to location they had on the original message. If the Addresses
tab is set up for Single and the message was sent as Multiple, or visa versa, all copied
addresses may be placed in the Available Addresses list, from which they can be assigned as
appropriate.

To reload one or more attachments, select the attachments you want, then use the right-click
menu to copy them to the current message.

Note: You can also use the right-click menu on the Sent Mail itself list to perform similar
actions.

Searching for Messages

To search for sent messages containing specific text, email addresses, or names, use the search fields
located below the sent mail list.  When you click Search, the system filters the sent mail list down to
just the messages matching your search criteria.  Click "Reset" to make the list show all messages
again.

Opening a Record

You can right-click any name in the address list and open the associated membership or group record. 
Note that this only works if the email address was added from a list within MemberTies. If you added the
address manually to the Address List when sending the original email, the system doesn't know what
record it should be associated with and it won't be able to open it.

Opening an Attachment

You can right-click any attachment in the Attachment List and open the associated file (if it still exists in
the specified location).

 

15.8 Troubleshooting Email Delivery

The vast majority of email issues can be traced back to an incorrect email profile.  When you send
email, the profile you use tells MemberTies what server to use, how to log in, how to authenticate, and
how to send.  If anything is wrong, your mail server, not MemberTies, will reject the message.

When an error occurs, the system may or may not know whether it got anything back from your mail
server.  Sometimes it will prompt you to open a log file after sending mail, and when you accept, the log
file will be empty.  This is because the message(s) returned by the server was blank or "null".
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Basic Checks

Here is a list of the most common mistakes we see:

Did not click the Test button on the Email Profile window to test the SMTP or POP3 settings.  If
the test fails, it will be impossible to send email.

Set a user name/password for SMTP and/or POP3, but left authentication at "No Authentication".
That essentially tells MemberTies to send the login information, but that the server should ignore
it. Sometimes this is the correct setting, but rarely.

Used the MemberTies user name and password instead of the user name and password provided
by your Internet Service Provider for your mail server.

Set the "From" and/or "Reply To" values on the email profile to normal names, rather than email
addresses.  i.e., used "John Smith" instead of jsmith@myemail.com

Enabled SSL Security when the mail server doesn't use it.

Most ISPs will have a website with a support area that provides the information you need to create a
valid email profile.  They will provide the SMTP and POP3 server names, the ports to use, whether to use
SSL and StartTLS, etc.

'The best way to troubleshoot other email errors is to turn on the Send Mail Log, which will record every
communication to and from the mail server.  You should only use this for troubleshooting, because the
logged data may include your username and password, and potentially other details that shouldn't be left
laying about.

Enabling/Using the Log

1 On the Settings tab of the Email window, select the Enable Log checkbox.  A message will be
displayed indicating where the log file will be stored.  The log file will normally be called
"mtemail_log.txt".

2 Send a test email message.

3 After sending completes, return to the Settings tab, and click the icon next to the Enable Log
checkbox. This will open a dialog so you can select the mtemail_log.txt file to view.

Note: If your computer does not know how to open .log files, nothing will happen.  In that case,
click the icon again, and when the Choose File dialog opens, right-click the file and choose
Open With, and then pick Notepad or your favorite text editor.

4 Review the log.  Typically you will see an entry that tells you what is wrong. For example, when
the user name/password provided on the profile wasn't right, this message appeared in our
testing (your server may respond differently)

11:29:59 [Connecting to server mail.myrro.com at port 110]
11:29:59 [Using regular POP3 authentication]
11:29:59 [Sending UserName]
11:29:59 [Sending Password]
11:30:04 [Error: Negative or void server response]
11:30:04 [Server responded: -ERR Login failed.\r\n]
11:30:04 [Possible error reason: incorrect UserName and/or Password]
11:30:04 [Error: Connection failure]

mailto:jsmith@myemail.com
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This message sequence makes it clear that the user name/password combination we provided
to log in to the mail server was incorrect.

If none of the above helps, send an email to support@myrro.com with a copy of the email log and a
screen shot of your email profile, and we'll try to help.

15.9 Troubleshooting Email Display

If your email arrives and contains bizarre characters that don't look like what you sent, it normally means
that something in the message could not be converted into HTML (formatted). If a message is typed
directly in the email window from scratch, it should all display correctly; but, if the message has been
copy/pasted from another source, like a word processing document, PDF file, or even another email
program, things can go wrong.  Incompatible formatting, unknown fonts, and character set and code
page issues can cause lots of problems that we cannot control.  

The best thing to do when using copy/pasted email text is to send a test message to yourself first. 
Don't test the output by sending a message to 5,000 members!  Go to the Addresses tab and delete any
addresses there, add one entry for yourself, and send the message.

In some cases, you can tell whether or not a message is going to convert neatly by putting the cursor in
the message and looking at the formatting toolbar above the message.  If the cursor is in a line that is
bulleted and the Bullet toolbar button doesn't activate, then the text probably isn't recognized as a bullet
and it should be reformatted.

Remember -- when you're unsure, send a test message first!



Part

XVI
Group Records



MemberTies195

©1998-2014 Myrro International

16 Group Records

16.1 Overview

A group record represents something that can have membership. This might be another organization, or
it might be a committee or any other subdivision of your own organization.  Since you can relate
membership records to group records, groups can be a useful means of arranging members for various
purposes.

Note: The actual word "Group" is controlled by an Organization Preference. If you would prefer the word
"Club" or "Committee" or whatever, you may change it using this preference setting. Throughout this
help system, we use the generic term "Group".

You work with groups via the Group List. To get to the Group List, choose File > Workspace > Group
List, or click the  Group List toolbar button.

Note: You can add multiple members to a group directly from the Membership List. See Adding
Members to a Group for details.

16.2 Using the Group List

16.2.1 Overview

The Group List lets you access all of the group records in the database. 

Note: Unless you set it up differently (see below) the list automatically tries to find all available records
when the window opens.  When you open the list on a new database there probably won't be any
records available to show, so a message will be displayed indicating that no records were found
matching the search criteria. 

The Group List window is divided into two tabs, "Search" and "Results".  The search tab enables you to
run both basic and advanced searches. 

The Search Tab (Basic Search)
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A basic search lets you enter specific information in predefined search fields, such as "City Name". For
a record to be found by the Basic Search, its data must match every criteria field you use. You can think
of the search engine as thinking, "field A has to equal value 1, AND field C has to equal value 2, AND
etc.

The Search Tab (Advanced Search)

The advanced search gives you much greater flexibility in your searches. By enabling you to choose
which fields to search by, the operator to use to compare the value you specify (i.e., = ABC, or > 5), and
a logical And/Or option, you can create nearly unlimited searches.  The example above will find any
group located in Beverly Hills where the contact person has a name like (beginning with) "smith". 
Advanced searches will be covered in more detail later.

Note: Regardless of whether you use Basic or Advanced searches, if no criteria is specified, all records
will be returned. If you have thousands of group records, using some criteria to limit the number of
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records found will improve the search speed. (The number of records that constitutes a "large" amount
will vary based on the power of the computer you're using. An old PC may struggle with a few hundred
records, whereas a new PC may be perfectly happy retrieving tens of thousands.)

The Results Tab

The Results tab displays the record(s) that matched the criteria entered on the Search tab, whether
basic or advanced.  In the above sample, two groups were found using our criteria. 

This tab is used for accessing individual records, and for performing certain tasks that can affect multiple
records, such as changing the Include in Mailings setting.

16.2.2 Search Tab

You can use the Search tab on the Group List to search for group records based on your own criteria,
and then display the records found on the Results tab. Refer to the Overview for a quick description of
the types of searches.

Searching for Records

1 Choose File > Workspace > Group List.

2 When the Group List appears, choose the Search tab.

3 Determine whether you want to run a basic or advanced search:

Entering Basic Search Criteria 

Entering Advanced Search Criteria

4 When you have finished entering criteria, click Search to tell the database to find the records
that fit the criteria you created.  The matching records will be displayed on the Results tab.

Tips

Multiple Addresses: With MemberTies Professional you can assign a record more than one
address. When you do this, you will also want to use the "Addresses" field on the Search tab to
specify which address to use for the results. If you choose "All Addresses" you might see the
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record more than once in the list -- once for each of its addresses.

When you use Advanced search criteria you can save the search for future reuse. See Entering
Advanced Search Criteria for more information about this kind of searching.

 

16.2.3 Results Tab

The Results tab displays the record(s) that matched the criteria entered on the Search tab, whether
basic or advanced.

If you're not familiar with selecting records in lists, please see this topic on how to select records from
lists in Windows.

Finding a Record in the List

When the Results list is displayed, you can quickly find a Group name by simply typing the name. As
you begin to type, a field labelled, "Group Name Search" will appear above the list and will contain the
letters you type. Type enough of the name to identify the record, then press Enter. The current list will
be searched for a name beginning with the text you type and if found, the record will be selected for you.

Also, use the Page Up/Page Down and Arrow keys to scroll up and down through the list, or use CTRL
+Home and CTRL+End to scroll to the beginning or end of the list, respectively.

Changing the Sort

Click the column heading of any column to sort the list by that column. For example, to sort the entire
list by phone number, click the Contact Phone column heading:
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The first click will sort the column in ascending order, the second click will sort the column in
descending order. 

Widening a Column

If you need to read especially long entries, just position your mouse pointer between the column
headings until the cursor changes to a double-headed arrow, then drag the column to the size you want.

Dividing the View

Divide the list into two sections by using the split-scroll bar so you can see two different parts of the list
at once. 
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Choosing a Preview Display

With MemberTies Professional you can choose up to two "previews" of the selected group record. A
preview is a synopsis of a certain portion of the overall group data, displayed at the bottom of the results
list.  Each time you click on a group record in the list, the appropriate preview information displays.  This
enables you to make certain types of information immediately available without having to actually open
the record.

See Working with Previews for more information.

Choosing a View

With MemberTies Professional you can define your own version(s) of the List, choosing the fields you
want to display. This is especially helpful with regard to Custom fields that are not automatically
displayed on the standard List.

See Working with Views for more information.

Refreshing the Display

Depending on the setting of the "Refresh Lists Automatically" preference, the list may or may not
redisplay to show changes each time you add or modify a record. If the preference to automatically
refresh has been turned off, you can press F5 or choose Actions > Refresh Display to re-retrieve data
from the database. Note that the number of records matching the search criteria is always displayed on
the Results tab. 

Working with Records

Press Enter to open the currently highlighted record for editing.

Press the plus ( + ) key to add a new record. 

Quickly display or copy contact information for a selected record by highlighting the row and
choosing Actions > Display Contact Info.

Copy a selected record by highlighting the row and choosing File > Copy Group.

Toggle the Include in Mailings checkbox by selecting any number of records and choosing
Actions > Include in Mailings or Actions > Exclude from Mailings

Build an Email List by selecting any number of records and choosing Actions > Build Email List
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Select any single record that contains a Website entry, and then choose Actions > Open Website
to open your default web browser and go to the site.

Additional options are available either from the Actions menu, or from the popup menu accessed
by right-clicking a row in the list.

 

16.2.4 Building an Email List

You can build an email list from a selection of records. The list can be saved as a text file, or copied
directly to the clipboard so you can paste it into an email program. Only unique email addresses are
included in the list. If more than one record has the same address, the address will only appear in the
list once.

When the email list is created, only records containing an entry in the Email field will be used. If you
select records that do not contain an email address, the list will be empty.

Building an Email List

1 Search for the appropriate records on the membership or group list. (This procedure applies to
both the membership and group lists.)

2 On the Results tab, select one or more records to use for the email list.

3 Choose Actions > Build Email List.

4 When the Build Email List window opens, select the following:

Separator - The type of separator, or delimiter, to place between names in the list. The list will
be generated as one long line (unless you choose a carriage-return separator), with each email
address separated from the previous one by the separator you choose. The type of separator to
choose will depend upon what you want to do with the list and/or what your email software
requires.  

Output - Choose the way you want to handle the finished list. You can copy the list
immediately to the clipboard, so you can open your email program and paste the whole list into
an address field, or you can save the list to a text file for future use. 

For example, if your email program expects a semicolon between each address, you would use
the semicolon separator, and then you could choose an output to the clipboard so that you
could immediately paste the results into the "To:" field of your email program.
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5 Click OK to build the list.

If you selected to save the list as a file, MemberTies will try to open a text editor to display the file
(typically Notepad). If a text editor cannot be found, a message will tell you where the file is located so
you can open it in another program.

 

16.2.5 Sending Email

With MemberTies Professional you can send email to members, groups, and attendees of activities
using your Internet account.  When you open the email window, it will automatically populate itself with
email addresses based on where you were when you opened the window, as described below.

When email is sent, there are various ways to address the message(s). You can choose to put email
addresses in the "To", "CC", or "BCC" fields of the message (i.e., the old-fashioned way), or you can
have MemberTies generate separate, individually addressed messages, one for each person on your
address list (i.e., the more modern way).  The second, more modern method is normally preferred,
because it looks more professional and prevents others from seeing the email addresses of your other
members.

Warning: SPAM email (also known as unsolicited commercial email) is a growing problem on the
Internet today.   If we determine that you are using MemberTies Professional to send SPAM, we will
terminate your license and report you to the appropriate authorities. Using MemberTies Professional to
send unsolicited email (SPAM), or to transmit illegal content is expressly forbidden.

Note: You must have your own Internet connection in order to send email.

Sending Email

1 All email activity is performed on the Send Email window. There are several different ways to
open this window, depending on what you want to do. If you want to send email to:

The contact email addresses for one or more groups - select the desired group(s) on
the Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Only". The
contact email address for each selected group will appear in the Addresses tab.

The associated members of one or more groups - select the desired group(s) on the
Group List, then click the Email toolbar button or choose Actions > Send Email.  When
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prompted to send to either the group or the groups members, choose "Group Members".
The contact email address for all membership records associated with each selected group
will appear in the Addresses tab.

One or more membership records - select the desired member(s) on the Membership
List,  then click the Email toolbar button or choose Actions > Send Email.  The email
address for all selected records will appear in the Addresses tab.

The attendees of one or more activities - select the desired activity(s) on the Activity
List, then click the Email toolbar button or choose Actions > Send Email.  The email
address for all attendance records associated with each selected activity will appear in the
Addresses tab.

There are also various places in the system where an email address is displayed as a data-
entry field. When an Email icon appears next to a field, you can click the icon to open the Send
Email window with the current address displayed.  In addition, the Email toolbar button is
always available even when no list is open. This enables you to open the Send Email window
and enter your own addresses, i.e., without bring in any existing email addresses.

2 Once the Send Email window opens, there are several tabs available that affect or control the
sending of the message:

Message Tab - This tab is used to define the email message text, add attachments, and select
the email Profile that will be used to send the message.

Pasting In Message Text

While it is possible to cut/paste an email message from another source, such as a word
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processing document, another email client, etc., you should be sure to send a test message to
see how it converts.  There are hundreds of character sets, fonts, and formatting tools out there,
and their output may not convert neatly to HTML email.  For things like bulleted and numbered
lists, put the mouse cursor on a bulleted line and see if the Bullet toolbar button activates.  If it
doesn't, then it isn't "really" a bullet and may not substitute neatly.  Reformat the pasted text as
necessary.

Message Options

Options on this tab that apply to creating the email message:

To save the email message for later reuse (including all text and attachment links) click the
Save button located to the right of the Subject line. (Messages are stored in the database,
so they are available to all users.)

To load a previously saved email message, click the Load button located to the right of the
Subject line. (See Loading Email Messages for details about the Load Message window.)

To Insert database fields in the email message so that MemberTies will use the appropriate
data for the current member, click  the Fields button to display the list of fields. Note that
database fields can only be used if you are using the Multiple Messages addressing
method (see Addresses Tab below). This restriction exists because if you are using the
Single Message method to send one message with everyone listed in the To/CC/BCC
fields, MemberTies will not know which recipient's record to use for the data.

See Using Database Fields for more information.

To add an attachment, click the Open File icon located to the right of the Attachment List.

To remove an attachment, select the unwanted attachment in the Attachment list, then
click click the Delete icon located to the right of the Attachment List.

To send an HTML formatted email, you must set the Format option to, "Send as HTML." 
This will cause the email engine to reformat the convert the message to HTML before
sending.  The formatting toolbar will also only display when this option is set to send as
HTML. Please also see the note above about pasting in text!

Additional options are available by right-clicking the message itself:

Insert Image - enables you to choose an image to be embedded into the message.
Note that some older email clients (software that reads email) will filter out embedded
images.

Insert Table - enables you to create a table

Insert Link - enables you to enter a URL or Email hyperlink:
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Address - The actual URL or email address

Link Text - Typically identical to the Address, but can be different, such as "Click
Here". Note that any recipient who displays the email as text instead of HTML will
not be able to determine what the address would have been, as they will only see
the Link Text. 

Format Bullets and Numbering - opens the standard bullets and numbering dialog

Format Font - opens the standard font dialog

Options on this tab that apply to sending the email message:

To select an existing Email Profile, which determines what the return email address will be,
as well as the server through which the email will be sent, use the Email Profile dropdown. 

To open the list of Email Profiles so you can create a new profile or manage existing
profiles, click the Open icon located to the right of the Email Profile dropdown. See
Working with Email Profiles for more information.

To change the priority with which the email will be sent (this may or may not be respected
by all email servers), use the Email Priority dropdown.

To cause MemberTies to open a read-only email preview window for each message before
it is sent, select the Preview checkbox (this option is only available when using the Multiple
Messages addressing method (see Addresses Tab below).

Addresses Tab - This tab is used to identify the email addresses to which the email message
will be sent.



Group Records 206

©1998-2014 Myrro International

The most important setting on this tab is the Addressing Method. There are two methods
available:

Multiple Messages - Selecting this option causes MemberTies to format a separate
message for each person in the address list.  Only one address is used per email. When
this option is selected, the list of database fields on the Message tab is available. This is
normally the preferred option.  This is the preferred option, because each person gets a
uniquely addressed email, and never sees the addresses of any other recipient. 

Single Message - Selecting this option enables you to choose which field (TO/CC/BCC) to
use for each address. The "TO" field is normally used for the primary recipient(s) of the
message; the "CC" field is normally used for people of secondary importance (i.e., people
being "copied" on the message); the "BCC" field is used for people who need to see the
message but whose addresses should be invisible to all other recipients (i.e., people being
"blind copied" on the message).  Note that this method is often faster when sending an
attachment, because only the attachment only has to be processed one time, rather than
once per recipient.

Note that you can use the "BCC All" button that displays when you choose this option to
automatically move the entire list of addresses to the BCC field.

After the Addressing Method is selected there are several icons below the Recipients list that
control additional options:

To prevent the member name from being displayed with the email address (i.e., to show
"jsmith@myisp.com" instead of "John Smith <jsmith@myisp.com>", clear the "Show
Name with Address" checkbox.

To search for one or more membership records and automatically add their email address
(es) to the list, click the Search icon.

To manually add a new recipient to the list, click the Add icon. You will be prompted for the
name and email address.

To change a recipient, select it and click the Open icon.

To delete one or more recipients, select the ones you want to remove and click the Delete
icon.
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To save the recipient list for future reuse (including the designations for the TO/CC/BCC
fields if appropriate), click the Save icon. Enter a file name when prompted.

To reload a saved recipient list, click the Open File icon. Note that reloading a save list
causes all addresses to be appended to the existing list. This enables you to open several
saved lists to create a combined list.

If the Recipients list contains duplicate addresses, you can clear them automatically by
choosing Remove Duplicates from the right-click menu.

Settings Tab - This tab is used to control miscellaneous mail sending options.

Enable Log - To generate a log of all communication with the email server (useful for tracking
down problems), select the Enable Log checkbox. The current log file may be viewed by clicking
the Open File icon to the right of the Enable Log checkbox. Note: Your password may appear in
the log in plain text.

Include Timestamp in Log File Name - Select this option to cause the log file name to
include the current timestamp, for example, "mtemail071405183025.log" for a log generated July
14, 2015 at 18:30:25.

Validate Address List(s) before Sending - Select this option to have the system check each
email address for technical accuracy, i.e., the format of the address will be verified to conform to
the requirements of a valid email address. This does not insure that the address itself is valid or
that the mail will be delivered, only that the address is formatted correctly.  If this option is used,
the check will occur just before beginning the sending process. If any problems are found, the
offending address(es) will be highlighted in red italic text for easy identification, and you will be
given the opportunity to stop the process to correct them.

Transmission Control - If your ISP limits the number of messages you can send per minute,
per hour, or per connection, typically to try to prevent mass unsolicited email distribution, you
can enter the appropriate settings here to comply. 

Select the "Restrict the number of messages sent" checkbox, then enter the maximum number
of messages that can be sent in a minute, hour or in a given connection (email session). If you
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select "per minute" or "per hour" the system will send up to the max messages allowed that
period, and then pause until the end of the minute/hour before starting the next batch. If you
select "per connection", the connection with the server will be broken and restarted for each
batch.

Note: If you are sending in Single Message mode with a number of addresses in the TO, CC, or
BCC fields, "one" message can contain an unlimited number of recipients, unless limited by the
"Max Recipients" setting (see below).

Max Recipients - This option only applies when sending in "Single Message" mode. If your ISP
limits the number of recipients that can be in a single email message, set the value here. If you
enter 10 for example, the system will process the message several times, adding recipients
from the To list, then the CC list, then the BCC list, until the maximum number is reached. Then
the message will be sent, and it will start a new message and select new people from each list
in turn, repeating the process until all addresses in the TO, CC, and BCC lists have been
accounted for.

Control Address - If you would like the system to send a final email to a specific address (as a
check to verify that all messages were processed) enter that address here.  The email will be
addressed to a person called, "Control Address" at the address you specify.  Note that if you
are using the "Single Message" addressing option, this address will be added to the BCC list.

Save Messages to Sent Mail - Select this option to save a copy of the mail message to the
Sent Mail list. Note that it is important to understand that a message will be saved to the Sent
Mail list regardless of whether it is successfully delivered. All the system knows is that the
message was sent to the specified mail server for delivery. It does not know whether the server
ever delivered it, whether it bounced back, or whether or not it was read.

Request Read Receipt - Select this option to send a request that the receiving email program
notifies you when the message is opened/viewed. Note that this is NOT fool-proof, and does
NOT guarantee in any way that a message has or has not been received.  Many people turn off
read-receipts because automatically returning receipts is guaranteed to increase the amount of
junk email you receive (because that automatic reply tells the spammer that your address is a
real or "live" one, and therefore a good candidate for even more junk mail). But if the recipient
has their email software configured to allow receipts, this option will request one.

3 The final tab is the Sent Mail Tab. This tab displays copies of email messages that were sent
while the "Save Messages to Sent Mail" setting was selected. See Viewing Sent Mail for
complete information about this tab.

You can filter the list to only messages containing specific text. Enter the text to be found in the
Find Text field, and choose the field (or all) to be searched. Click Search to filter the list, or
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Reset to clear the filter and show all messages again.

 

16.2.6 Working With Previews

With MemberTies Professional, you can define one, two, or three data previews each for the membership
list, group list, and activity list. A preview is a quick synopsis of additional information about the currently
selected list record.  Different lists have different preview data available. This example shows two of the
available previews for the Group List.

Setting or Changing Previews

1 Open the desired list (this procedure applies equally to the membership, group, and activity
lists).

2 Choose Actions > Preview

3 When the Setup Preview Display window opens, select the "Enable Preview Display" option.
This will enable the list of available preview choices.

4 You may choose a Left, Center, and Right preview. The previews correspond to the left, center,
and right thirds of the preview display area on the list.  

Note: Depending on the resolution of your computer monitor, three previews may not fit.

5 When you have made your selections, click OK.

Disabling Previews

1 Open the desired list.

2 Choose Actions > Preview.

3 When the Setup Preview Display window opens, select the "Disable Preview Display" option.  

4 Click OK. The list window will redisplay, hiding the preview area.
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16.2.7 Viewing Contact Information

You can quickly display contact information for a given membership or group record.

Viewing Contact Information

1 Open the List containing the appropriate record:

For a Membership record, choose File > Workspace > Membership List.

For a Group record, choose File > Workspace > Group List.

2 Select the record you want to display.

3 Choose Actions > Display Contact Info.

The window is divided into three tabs:

Address -- Shows the current address.

Phone List -- Shows all phone numbers

Email/Web -- Shows the email address and website

All tabs have a "Copy" button enabling you to copy only the data on that tab. An additional
"Copy All" button is provided to copy all data from all tabs at once.
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16.3 Working with Views

16.3.1 Overview

A "View" is simply a layout of either the Activity, Membership, or Group List consisting of one or more
columns of data representing the fields you want to see.

Note: The Views topics appear under help chapters for each type of list. The process for using views is
the same regardless of the list the view is for.

You work with views via the Maintain Views window. To open this window for the list you're on, click the
Views toolbar button.

MemberTies ships with a single view of both lists, designed to display the most common information
about a record. The default views do not include all available fields, because displaying more fields
means retrieving more data from the database for each record, and retrieving data takes time.  Of
course, you know your computer better than we do, so if it's happy retrieving more fields and more data,
we're happy too.

With MemberTies Professional, you can create your own views to use with the Activity, Membership,
and Group List. This powerful feature puts the decision making totally in your hands, allowing you to
choose whatever fields you want. You have the ability to place them in any order, set both a primary and
secondary sort order (i.e., by City, then by Last Name), and even change the text displayed for the
column headings.

The Views you define will work just like the standard lists. Clicking a column heading will still sort the
whole list, menu options will remain the same, and you can still open and add records normally. Even if
you create a view that only shows the City (which would make it very hard to distinguish one record from
another), if you select one of the rows in the list and open it, MemberTies will still know what record it is
and will open it normally.  
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Tip: You can rename a view from the Maintain Views window. Just right-click the view you want to
change and choose Rename from the popup menu.

  

16.3.2 Working with Views

You can create views for the Group List and the Membership List by opening the Maintain Views
window. 

Adding a View

 1 Open the List to which the View will apply.

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
This window displays all views that are currently available for the list you are on. In other words,
if you open the window from the Group List, you won't see any membership views.

 3 When the Maintain Views window appears, click Add. This will open the Add View window for a
new view.

 4 The details of using the Add View window are fairly extensive, so it is described on a separate
topic. See Maintaining Views for complete information about adding, editing, or previewing a
View.

 5 If you want the view to be applied when you close this window and return to the Membership or
Group List, be sure the "Apply Selected View on Close" checkbox is selected before you close
the window.

Changing a View

 1 Open the List to which the View will apply.

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
This window displays all views that are currently available for the list you are on. In other words,
if you open the window from the Group List, you will see Group List views, not membership list
views.

 3 When the Maintain Views window appears, select the view you want to change, then click Open
.  This will open the Edit View window.

 4 Make your changes, then click OK.

Deleting a View

 1 Open the List to which the View will apply.
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For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, to open the Maintain Views window.  This window displays all views
that are currently available for the list you are on. In other words, if you open the window from
the Group List, you won't see any membership views.

 3 When the Maintain Views window appears, select the view you want to delete, then click Delete
.

 4 Confirm the deletion.

Note: If the deleted view was currently in use, it will remain active until the Membership/Group
List is closed and reopened. At that time, the system will use the new default view if one is
available, or will revert to the system-defined view if there is no default.

16.3.3 Maintaining Views

This window is divided into two tabs. The Define Fields tab must be completed and changes applied
before the Preview tab is available. If you have opened an existing View, the Preview tab is available
immediately, but if you make any changes on the Define Fields tab, the Preview tab will be disabled
again until the new changes are saved.

Note: This procedure assumes that you have already opened or started a new View; if not, see Working
with Views for details. 

The Define Fields Tab
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 1 If you are creating a new View, enter a name in the "View" field. 

 2 To make this View appear immediately whenever the list is opened, select the Default View
checkbox.

 3 Select fields for the view. Use the left and right arrow buttons to move fields back and forth
between the Available Fields list and the Selected Fields list. All fields that are visible in the
Selected Fields list will be shown on the completed View.

 Note: The top-to-bottom order of fields in the Selected Fields list represents the left-to-right
order the columns will take on the View. In other words, the first (top) field in the Selected Fields
list will appear as the left-most column on the View.

Things to Consider when choosing fields:

When choosing fields, it is very important to consider the primary data type of the view you are
creating.  Even though you can choose almost any activity, group, or membership field, they
can change the behavior of the view based on the primary data type.  For example, if the primary
data type is Membership Data, adding activity fields will convert it into an "activity attendance"
style of view, where only members who have attended an activity will display. Likewise, adding
dues posting fields to a membership view will turn it into a dues postings view, and only
members who have dues postings will be considered.
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Primary Data
Type

Type of Field
Added

Restricts the View to:

Membership Membership No Restriction

Activity Members who have attended at least one activity.

Posting (Dues) Members who have at least one dues posting.

Posting
(Donations)

Members who have at least one donation posting.

Group Members who are assigned to at least one group.

Activity Activity No Restriction

Membership Activities with at least one attendee

Posting
(activity)

Activities with at least one posting (attendee or non-attendee)
unless a membership field is also used, in which case the
postings must be tied to an attendee.

Custom Field Activities with at least one attendee (custom fields represent
membership custom fields when used on an activity report).

Group Group No Restriction

Membership Groups with at least one assigned member.

 4 If you want to adjust attributes for a field in the Selected Fields list, select the field you want to
change and click Open to open the Field Properties window. See Changing Field Properties for
complete details. Make the desired changes, then click OK to save the new properties.

 5 Adjust fields up and down in the Selected Fields list to put them in the correct left-to-right order.
The top of the list is the left-most column, and the bottom of the list is the right-most column.

 6 When you are ready to display the View, click Apply to save changes, then click the Preview
tab.

The Preview Tab

The Preview tab enables you to see what the View will look like, to make changes to the widths of
columns, and even adjust the column order again.
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 1 The Record Limit field below the list can be used to prevent the preview window from returning
an unnecessarily large number of records for viewing. This setting has no effect on the way the
View will work on the list -- it only applies to the Preview. 

 2 Click the Adjust Column Widths button to shift the preview into editing mode. In this mode you
can:

Drag the border between column headings to resize the column.

Drag an entire column by its heading to change its position.

Tip: To adjust the width of the right-most column, drag the whole column to the left one column
position by clicking and holding the column heading. That will enable you to "grab" the right-
hand edge with the mouse, adjust the width, then drag it back to its former position on the right.

 3 When you're finished, click the Return to Preview button.

Once you have the view the way you like it, close the window and return to the Maintain Views list. From
there, you can select the new or modified view and apply it to the current list.

 

16.3.4 Exporting Data with a View

The easiest way to export data from MemberTies is to use Views. You can create a view that contains
exactly the fields you want to export and then use Save As to save the data to a file. The file created will
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contain the same data that is displayed on-screen.

To Export Data from a View

 1 Open the Membership or Group List and apply the View of your choice. For instructions on
creating or applying Views, see Working with Views.

 2 Search for the data that you want to export. For example, to export members living in "Anytown,
USA", enter the appropriate search criteria and  display those records.

 3 Select the Results tab, then choose File > Save As > [file type] to save the data to a file.

Note: The best format to export data to is Text. Text files are universal, and can be read by
almost any program. The text file export was written by Myrro International for use in
MemberTies, and it will try to use the names of fields as you see them on-screen, rather than
the database names. i.e., you will normally see "Last Name", not "lname".

You can save data in other formats, but the results may vary widely. In addition, formats other
than "Text" will use the database column names, not the field names you see on-screen. This is
because these are not formats controlled by us, and we can only "dump" data directly to them
without any manipulation.

 

16.4 Maintaining Group Records

16.4.1 Working with Groups

New group records can be added to the database whenever the Group List is active. 

Adding a Group

1 Choose File > Workspace > Group List.

2 When the Group List appears, choose File > Add Group.  You can also click the Add toolbar
button. This will open the Details window for a new record.

3 The Details window consists of several tabs, each of which are designed to track a certain type
of information. Choose any tab below for more details about it's usage.

General Tab - Contains basic address and phone number information, as well as references
to the group's website and email address, if applicable.

Status Tab - Contains additional miscellaneous information about the group.

Note: If your computer monitor has a high enough resolution (1024 x 768 or higher) this tab
is hidden and its information is included on the General Tab.

Items Tab - Contains a record of Items that have been assigned to this group.

Members Tab - Contains a record of all membership records that have been assigned to
this group.

To Do Tab - Contains a list of To Do items that have been assigned to this group.
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Custom Tab - Contains custom fields that can be used for whatever data you desire.

4 Complete all appropriate information, then click OK.

Tip

Your changes may not appear in the Group List until it is Refreshed.

Select the Add Another checkbox before you save the record if you plan to add several records.

Changing a Group

1 Choose File > Workspace > Group List.

2 Select the group you want to change, then choose File > Open Group, or click the Open toolbar
button. This will open the Details window for the record.

3 Make your changes, then click OK.

Deleting a Group

1 Choose File > Workspace > Group List.

2 When the Group List appears, select the record(s) you want to delete, then choose File >
Delete Group, or click the Delete toolbar button.

3 Confirm the deletion.

 

16.4.2 The "Auto-Relate" Group

Each group in your database can be related to one or more membership records, thereby tracking the
"members" of that particular group.  This becomes an efficient way of tracking not only groups, but
committees, councils, and any other connected group of people.

Each time a new membership record is created, a relationship is built between it and any Auto-Relate
groups. If you expect each member you create to be a member of a particular group or groups, you can
set up those group(s) as "auto relate" groups. This is particularly helpful if you have a group record that
represents your organization. 

Setting a Group to Auto-Relate

1 Choose File > Workspace > Group List.

2 Select the group you want make auto-related to new membership records.

3 Choose File > Open Group.  You can also click the Open toolbar button. This will open the
Details window for the group.

4 On the General tab, select the Auto-Relate checkbox.
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5 Click OK.

6 This group and any other auto-relate groups will be automatically related to all new membership
records.

Tip

To relate existing members to an existing group, use the Membership List to select all of the
members that need a relationship. Then choose Actions > Relate Group, and search for the
appropriate group or groups. Then click the "Select" button to create the relationships.

 

16.4.3 The "Report Default" Group

One group record in your database can be specified as the Report Default. The group with this setting
will be the default group displayed in dropdowns when you use the group as criteria. Note that if you do
not relate any membership records to specific groups, you should not set a default group. Leaving the
default unspecified will cause reports to default to (All Groups), which just means that membership
reports won't worry about group relationships when selecting members.

Setting the Default Group

1 Choose File > Workspace > Group List.

2 Select the group you want to use as the default.

3 Choose File > Open Group.  You can also click the Open toolbar button. This will open the
Details window for the group.

4 On the Status tab, select the Report Default checkbox.
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5 Click OK.

6 If another group is currently set as the report default, you will be prompted to confirm the
change.

 

16.4.4 Using Multiple Addresses

With MemberTies Professional, you can assign more than one address to membership and group
records. Each address can be given a unique name such as "Summer Home," "Winter Home", "Billing,"
"Mailing,", etc. Each address appears as a separate address tab so you can switch between addresses.
 

In the following example, the record includes two addresses, one called "Main Address", and another
called "Summer Home."

Multiple addresses and the date ranges assigned to them can greatly simplify the task of keeping track
of which address to use when members have both summer and winter homes.  The primary rule involved
with multiple addresses is that one (and only one) address must be "Current" at all times.
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Adding a New Address

1 Right-click the address tab, and choose the New option from the popup menu. (This is also
where the option to delete an address is found.)

 

2 A new tab will be created with a name of "<New Address>".

The text on the tab will match the Address Type on the address. You may either type a new
address type, or select an existing predefined address type from the dropdown in the Address
Type field. After you enter or choose a type and move to another field, the tab will be updated to
reflect the change.

3 Since this is a new address, the "Current" checkbox is not checked. The system assumes the
first address will remain the current, active address.  If you want this address to be current
instead, select the checkbox. See below for more information about the current address.

4 Complete the address fields appropriately.  The record now has multiple addresses, and you
can switch between them by clicking the tab for the desired address.

Renaming an Address

1 Use the Address Type dropdown to choose the new Address Type. The tab will be updated once
the change is applied.
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Deleting an Address

1 Right-click the tab for the address you want to remove.

2 Choose the Delete option from the popup menu.

3 Confirm the deletion. The system will change to a different existing address if the record has
one. (Note that at least one address must exist, so the system won't let you delete the last
address.).

The Current Address

When generating reports, the current address will always be used by default. However, many reports
enable you to build your own criteria, in which case you can choose to select all addresses, or only non-
current addresses. In addition, you may be able to further qualify the selection by requiring a specific
Address Type.  In general though, the Current Address should represent the address to which mailings
should be sent.

For example, you could create report criteria that always uses the Current address, OR any address
called "Additional Mail", which might represent people who have requested two copies of a newsletter,
one to their home, and one to another (the Additional Mail) address.

Setting the Current Address

The current address can either be set manually by choosing the "Current" checkbox, or automatically by
the system based on date ranges. 

Manual: Select the "Current" checkbox on the appropriate address on the record.  In order to use
the Current checkbox, there cannot be any date ranges assigned to any address associated to
the record.

Automatic: For each address on the record, create a date range within which the address is
current (i.e., a person's summer address might be valid from June 1st to September 1st).  Each
time the application is started, all ranged addresses are checked and the appropriate address is
made current.  A record cannot be saved until all 365 days of the year are covered by an address
range (February 28 and 29 are considered the same) without any overlapping. This ensures that
on any given day, a single address will be current.

Note: Do not create date ranges unnecessarily. If a record only has a single address, don't create a
range that covers the entire year. Doing so will cause the record to be checked by the system every
time the application starts to see if it is current or not. Since it will always be current, this is a waste of
system processing time.

Address Types

Each address should have a unique type. To ensure consistent naming, you can predefine a list of
Address Types and set one of them as the Default. The system will assign the default address type to
the first address created on any record. See Maintaining Address Types for more information. 

Multiple Addresses and Searching for Records

When searching for records, you can use the Addresses dropdown on the Search tab to restrict the
search to only the Current address, Non-Current addresses, or all addresses. If a record has more than
one address and you choose "All Addresses", the record will appear in the Results list once for each
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address that is found.

16.5 Group Record Tab Pages

16.5.1 General Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

This tab is used for basic group contact information, such as the contact name, address, email, and
website.

Note: If your computer monitor is set to a resolution lower than 1024 x 768, the the right-most fields from
the General tab are moved to a separate Status page.

The following fields on this tab require some additional explanation:

Address Type - In the standard version of MemberTies, the Address Type is automatically
populated with the default address type from preferences.  Normally this is left as the default entry,
"Main Address" (the default address type is set via the Address Type Preference).  If you use
MemberTies Professional you can create more than one address per record, and the address type
field is displayed as a dropdown list. In addition, predefined address types are defined under Tools >
Dropdown Lists > Address. 

Address Line Names - If you always plan to use Address Line 1 for a specific purpose, such as
"Mail Stop" or something similar, you can change the name displayed for the line.  In addition, if you
have complicated addresses that require four open lines instead of three, you can tell the system to
provide a fourth line.  See the Address Lines/Names Miscellaneous Preferences for more
information.

City - This dropdown contains the cities that are defined in the City list. These are pre-loaded, but
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can be edited at any time. In addition, if you enter a city that is not already in the list, the system
will prompt you to add it automatically. This feature is only available to dropdowns that typically
receive a lot of new values (i.e., it isn't available on Country lists, since these don't change very
often). See Maintaining City Names for additional information about maintaining this list.

County -  This dropdown contains the counties that are defined in the County list. These are pre-
loaded, but can be edited at any time. In addition, if you enter a county that is not already in the list,
the system will prompt you to add it automatically. This feature is only available to dropdowns that
typically receive a lot of new values (i.e., it isn't available on Country lists, since these don't change
very often). See Maintaining County Names for additional information about maintaining this list.

State/Province - This dropdown contains the states/provinces that are defined in the State/Province
Codes list. These are preloaded, but can be edited at any time. See Maintaining State/Province
Codes for more information. Note that the state/province defined as the "default" will appear
automatically on new records.

Country - Similar to the State/Province field, this dropdown contains countries that are defined in
the Country Codes list. See Maintaining Country Codes for more information. Note that the Country
defined as the "default" will appear automatically on new records.

Date Ranges - (MemberTies Professional Only) Ranges are primarily designed for membership
records, but if a group has addresses that are valid only at certain times of the year, you can have
the system automatically keep the proper address current by creating one or more date ranges
within which each address is valid. See Using Multiple Addresses for more information.

Phone - All telephone number fields have a small Dial Phone icon displayed next to them. If your
computer has a modem installed, clicking this icon will tell Windows to use your modem to dial the
associated phone number. This will typically cause the Windows Phone Dialer utility to open and
dial the number.

Email - (MemberTies Professional Only) The Email icon next to the email field will launch the Send
Email window with the group's email address already listed in the addresses list. The Sent Mail icon
will display the list of email sent with the current group as one of the recipients.

Website - (MemberTies Professional Only) The Open URL icon next to the website field will launch
your default web browser and open the group's website.

16.5.2 Status Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

This tab is used for miscellaneous group settings, such as whether it is the default group for reports,
whether members are automatically related to it, general comments, etc. This page is only displayed if
your monitor is set to a resolution less than 1024 x 768.
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Note: If your computer monitor supports a higher resolution, the General and Status tab pages will be
combined into one "General" page.

The following fields on this tab require some additional explanation:

Established - This field can be used to track the date a group was established, founded, etc.  There
is no system processing tied to this date.

Include in Mailings - The behavior of this field is controlled by the "Use Include Criteria" report
preference. If the preference is on, then group mailing label reports will only include this group if this
checkbox is selected.  If the preference is off, this checkbox has no effect unless you manually use
the "Include in Mailings" field as part of your report criteria.

This checkbox can also be cleared automatically by the system if the status is automatically
changed to an Inactive status. To enable this feature, see the Clear Mailing Flag setting in 
Membership Preferences. .

This setting can also be changed automatically based on the status you select. See Maintaining
Status Codes for more information.

Report Default - One group in your database can be specified as the Report Default. The group with
this setting will be the default group used on reports when the group name is part of the criteria.
Note that if you do not relate any membership records to specific groups, you should not set a
default group. Leaving the default unspecified will cause reports to default to (All Groups), which in
this case would be your entire database.

Auto-Relate - Each time a new membership record is created, a relationship is built between it and
any Auto Relate groups.  If you would like to tie your members to your organization's Group record,
you can create a group record and select this checkbox. Then, each time you create a new
membership record it will automatically be tied to your group. Any number of groups can be set as
Auto-Relate groups.

16.5.3 Dues Tab

The Dues tab is used to record postings to the group's "dues" account. The current account balance is
displayed at the bottom of the list, as well as a subtotal if the list is filtered by Posting Type. 

Note: If you are creating a new group record, the group must be saved first (click Apply) before you can
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access this tab unless you turn on the "Auto Save New Groups" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via via Preferences.

Filtering the Display

You can create a system of dues "posting types" to better categorize the type of payment or charge
being posted (such as Dues Charge, Dues Payment, Refund, T-Shirt Sale, Food Order, etc.). If you are
using corresponding debits and credits to balance the account, the number of entries can become fairly
lengthy; therefore, the Dues tab includes a dropdown at the top labeled, "Show by Posting Type," which
enables you to filter the display by a specific type. 

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
type or choose "(All)".

Adding (posting) Dues

1 On the Dues tab, click Add.

2 The following fields are available:

Posted - The date on which the dues entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone pays for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this dues entry, even though it was actually posted the year
before.

Posting Type - the posting type to be applied to this entry. The debit/credit action of the type is
displayed in the dropdown, and any minimum or maximum amount requirement is displayed to
the right of the field. See Maintaining Posting Types for more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the Dues
tab if the display is being restricted to a particular posting type, or b) the default posting type
specified in the Posting Types list, if available. If neither of these apply, no default value will be
entered.
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Amount - The amount to be recorded. Only positive numbers may be used. The posting type
determines whether the amount is applied as a debit or credit to the account. 

There are several ways to enter the amount. In addition to typing in an amount, you may have
other options depending upon the way you set up your Posting Types. If you associated
minimum or maximum amounts for the posting type, you can quickly enter any of those
amounts by clicking the appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the Group, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Credit Card Data for more
information.

Receipt Number/Book - These fields are enabled whenever the selected posting type is one
that has been defined to generate a receipt number. The fields are disabled for all other posting
types.  The Receipt Number is a sequential number generated by the system. The Receipt
Book is the value set as the Dues Receipt Book Nbr in preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - Click this option if you want to force the system to generate the next receipt
number immediately. Note that once a receipt number has been generated, it is "used"
permanently, even if you choose not to save the entry.  The only way to reset it is via the Dues
Receipt Book Nbr preference.  If you want to "regenerate" a new number for an entry that
already has a receipt number, you must clear the field first, then click Assign Now to generate a
new number.  If you do not want the Assign Now option to be available at all, it can be turned off
via the Allow Assign Now preference.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report if you wish.

Print Receipt - This option controls when a receipt should be printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Dues tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Dues Print Receipt = Selected" to
print all marked receipts at once.  

4 When you're finished, click OK to save.

5 If you have filtered the display by Posting Type and you add a dues entry that uses a posting
type that has been filtered out, the new entry will not appear until the filter is changed to one
that will include it.
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Changing a Dues Entry

1 On the Dues tab, click the entry you want to change, then click Open.

2 When the Edit Dues window opens, make your changes, then click OK. The current balance will
recalculate automatically if necessary.

Deleting a Dues Entry

1 On the Dues tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple
Records.

Printing Receipts as a Group

As described above for the, "Printed Receipt" field, you have the option of marking many entries for
future receipt printing. Any entry that has been marked for printing will include a checkmark in the "Rcpt"
field on the list. (Note that this checkmark does not prevent you from selecting an entry on the list and
printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

Additional Dues Capabilities

There are some other dues-related options:

You can post dues directly from the Group List to any number of selected records, or records with
a specific status. See Posting to Multiple Records for more information

You can create a Deposit containing any number of Group Dues or Member Dues, Donation, and
Activity Income entries. See Tracking Deposits for details.

You can clear ALL Print Receipt checkmarks for the entire system by choosing Tools > Database
Tools > Clear Print Receipt Settings.

16.5.4 Items Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

This tab displays all Items that have been assigned to the group. Items, or "categories and items" as
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they are commonly referred, are a very powerful and flexible feature. 

Items are used for situations where you need to store more than one value for a give kind of data (this is
sometimes referred to as a one-to-many relationship). In other words, a group (the "one") may hold
multiple titles, win multiple awards, etc. (the "many"). Custom fields don't work very well for this,
because each field only holds one piece of data. Items, on the other hand, work perfectly because you
can create any number of items, linked to any number of categories, and assign them any number of
times to a given record. In the sample above, this group has received the award for Largest Group twice,
and they are recorded as identical items under the same category, "Group Successes." 

Filtering the Display

By default, all items assigned to the group are displayed. If the group has a large number of Items
assigned to it from various categories, you can filter the list to a specific category using the Show By
Category dropdown.

Note: If you add or change an Item and give it a different category than the one currently being used to
filter the display on the tab, the item will not appear in the list until you select the appropriate category or
choose "(All)". In other words, if the category is filtered to "Group Successes" and you add a new item
under the category "General", it will not appear in the list until you change the list to "General" or "(All)".

Adding an Item

1 On the Items tab, click Add.

2 When the Add Item window opens, the following fields are available:

Category - The category you select determines which items will appear. 

Item - The item to assign.

Date - The date to associate with this item. 
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Comments - General comments. Since items may be used multiple times, the combination of
date and comment help distinguish one from another.

If no items (or categories) are available in the dropdowns, you will need to create them first. See
Maintaining Items for more information.

3 When you are finished, click OK.

Changing an Item

1 On the Items tab, select the item you want to change, then click Open.

2 When the Maintain Item window opens, make your changes, then click OK.  

Deleting an Item

Deleted items are removed from the current group only. If you want an item to no longer be available to
any group records in the future, you must delete the Item from the system dropdown list. See 
Maintaining Items for more information.

1 Select one or more items to delete.

2 Click Delete. 

3 Confirm the deletion.

16.5.5 Members Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

This tab displays all membership records that have been assigned to the group, as well as an option
group-specific start and end date. You can open any listed membership record for viewing by selecting it
and clicking the Open Member icon.

Note: This help topic explains how to add members from the Group record itself.  You may also add
multiple members to a group directly from the Membership List. See Adding Members to a Group for
details.
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Assigning Membership Records

1 On the Members tab, click Search.

2 When the search window opens, enter criteria that will help you find the member(s) you want to
assign, then click "Search".  You can search for as many records as you need (select the
Append checkbox to continue adding to the results list). 

3 When all records to be related are shown in the results list, select the desired records and then
click "Select". All highlighted records will be assigned to the group.

Setting the Start and End Date

1 On the Members tab, right-click the record for which you want to set dates.

2 Choose Edit Dates

3 On the Edit Dates window, set the desired Start and/or End Date, and click OK.

Removing an Assigned Member

Removing a membership entry from this tab merely breaks the relationship between that membership
record and the group. The actual membership record is unaffected.

1 Select one or more membership records to delete.

2 Click Delete. 

3 Confirm the deletion.

16.5.6 ToDo Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

A To Do entry is simply a reminder of something the group needs "to do." The To Do tab displays all
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entries for the group.

Note: If you want to be notified of open To Do items when MemberTies starts, the  Login Preference to
display open To Do's on startup must be turned on

Adding a To Do Item

1 On the To Do tab, click Add.

2 When the New To Do window opens, complete the following fields:

Description - A brief description of the required action

Due Date - The date the To Do is to be completed

Prompt - The number of days ahead of the Due Date you want to be reminded of the Item.

Complete - Select this option if this item has already been completed (perhaps you're entering
it for historical purposes).

3 Click OK.

Changing or Completing a To Do Item

1 On the To Do tab, select the entry you want to change.

2 Click Open. This will open the To Do window for the selected record.

To complete the item, mark the Complete checkbox

To reopen the item, clear the Complete checkbox

3 Make your changes, then click OK.

Deleting a To Do Item

1 On the To Do tab, select the entry or entries you want to delete.

2 Click Delete.

3 Confirm the deletion.
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16.5.7 Custom Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Custom tab displays custom field data. Custom fields can be used for nearly any sort of data you
wish, and they can be customized to become dropdown lists, editable lists, check boxes, and ordinary
text fields.  

You can create as many custom fields as you wish, and you can choose where and how they will be
used and displayed.  This example shows a simple text field, two dropdown lists (one for text, one for
decimal values), a simple number field, and a checkbox.

See Maintaining Custom Fields for information about changing the definition of a field.

Note: If you use custom fields a lot, you may wish to change the Tab Order preference to make this tab
appear next to the General tab.  You can also (using the Professional version) display any custom field
on the main Group List by creating a view of your own.



Part

XVII
Lists (Dropdown Lists)
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17 Lists (Dropdown Lists)

17.1 Overview

Almost every dropdown list in MemberTies can be customized to meet the needs of your organization.
The most common list that needs changes is the Membership Status, which almost always needs
additional entries to match the terms used by your organization.

While you can add a new entry to most lists by selecting the "<New>" option in the list, it is sometimes
helpful to maintain the entire list at once.  The lists are available via Tools > Dropdown Lists.

Since there are a large number of dropdowns, some are grouped together to make the menu more
usable.  All dropdowns related to Activities are in their own sub-menu, as are all dropdowns related to
Addresses.  All other dropdowns are listed alphabetically.

Note: Some dropdowns, such as Occupation Names, are special.  Occupation names are not pre-
defined in the system -- the list grows as you use new names.  As such, the list will only contain values
you have already used. You cannot add new ones, but you can correct the spelling of existing entries. 
Other dropdowns, such as "Categories & Items" are inter-related, and are maintained together.

17.2 Merging/Combining Values

Some dropdown lists allow you to combine two or more values into one.

A common reason for doing this is to correct bad or similar spellings of the same word. For example,
suppose you have a number of members assigned to the city, "My Town", and several others assigned
to, "My Towne."  If you open the City list and change "My Towne" to "My Town" by renaming the
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incorrect version, you'll find that the list  now shows two seemingly identical entries.  However, to the
database they are completely different. Here's why:

The database identifies these records by an internal ID number. So previously, you had:

My Town - ID: 34
My Towne - ID: 41

After you renamed it, you were left with:

My Town - ID: 34
My Town - ID: 41

You never knew about these internal IDs, and don't have a reason to care about them. But as far as the
database knows, it still has an "ID 34" and an "ID 41" record, they just both happen to display as "My
Town." It only cares about the IDs.

That means if you use the city as report criteria, and choose "My Town", you may or may not get all the
records you'd expect. That's because choosing the first entry really means, "find everyone with a city of
'34'", and choosing the other one means, "find everyone with a city of '41'".

The way to correct this is to tell the database to merge the values into one so you're left with only one
"My Town" entry.  Merging tells the system to find every record where the city is EITHER 34 or 41, and
change them to point to a single value.

To Merge Records

If the list you open allows merging, the Merge button will be displayed. 

1 Select two or more records to merge. 

Note: The record to merge "to" must already exist, so create it first if necessary. In other words,
if in this example we wanted to combined these values to a new value called,  "Charity Event"
we'd have to create that first because it isn't in the list already.  In this case, we're going to
combine everything into a value that is already in the list.
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2 Click the Merge button.

3 On the Merge Names window, choose the version of the name you want to keep, and if you
would like the other versions removed, be sure the "Remove old..." checkbox is ticked. In this
example, we're going to let the system discard the other names.

4 Click Merge and confirm the change. All appropriate records will be modified to point to the
name you choose to keep. 
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5 Click OK to close the window. (Note, choosing Cancel will not cancel the merge, because the
database has already been modified and records have been converted.)

17.3 Activity Roles

Activity Roles enable you to describe the role played by a given attendee with regard to an activity.
Typical roles may be, "Host", "Greeter", "Facilitator", "Bartender", "Usher", etc.  They typically represent
things people "do" at an activity.

A role is not required for every attendee, therefore you are allowed to delete a role that is in use.  If you
choose to delete the record even after being prompted that it is in use, the role value will be cleared on
any records that were using it (i.e., those records will no longer have any role assigned).

Maintaining Activity Roles

1 Choose Tools > Dropdown Lists > Activity > Activity Roles.

2 The Maintain Activity Roles list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the role.

Default - Select this option if you want this role to be the default for new attendance records.
Setting a default is optional.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.
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17.4 Activity Types

Activity Types enable you to quickly identify certain kinds of activities, by using types like "Fundraiser",
"Party", "Luncheon", etc.

An activity type is not required for every activity, therefore you are allowed to delete a type that is in use.
 If you choose to delete the record even after being prompted that it is in use, the value will be cleared on
any records that were using it.

Maintaining Activity Types

1 Choose Tools > Dropdown Lists > Activity > Activity Types.

2 The Maintain Activity Types list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the activity type.

Default - Select this option if you want this activity type to be the default for new activity
records. Setting a default is optional.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.5 Address Types

To help facilitate more consistent address type names, you can predefine a set of address types. These
will then be available whenever you add a new address, or change the type of an existing address.

Maintaining Address Types

1 Choose Tools > Dropdown Lists > Address > Address Types.

2 The Maintain Address Type list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate action. If you choose to add or change a type, the following fields are
available: 

Address Type - The address type, i.e., Main Address, Summer Home, College, etc.

Default - Select this option if you want this type to be used automatically for the first address of
a membership or group record. Note that a default address type is required. To delete the default
value, create or mark a different type as the default, then delete the old default.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.
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17.6 Association Types

Association types enable you to further identify the type of association that exists between two
membership records.  You are allowed to specify the type as seen from both sides, i.e., "Joe is Jane's
Husband", "Jane is Joe's Wife", therefore it is good to create opposite entries.

Maintaining Association Types

1 Choose Tools > Dropdown Lists > Association Types.

2 The Maintain Association Type list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the association type.

Default - This option has no effect at this time.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

17.7 Attendance Statuses

Attendance Statuses enable you identify whether members associated to an activity attended, declined,
canceled, etc. For example, you might set the default attendance status to be "Invited" so that new
attendees will automatically be given that status. Then, after the activity takes place, you can use the
sign-in sheet from the activity to change the appropriate members to "Attended" and the no-shows to
"Absent."

The status also controls whether an attendee with that status will appear on activity reports. 

Note: Attendance Statuses are in no way related to membership statuses.

Maintaining Attendance Statuses

1 Choose Tools > Dropdown Lists > Activity > Attendance Statuses.

2 The Maintain Attendance Status list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Status - The name of the status.

Report as Attendee - Select this option if an attendee with this attendance status should be
considered reportable.  If an attendee has a status that  is not reportable, they will not appear on
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any report that includes attendee data. This enables you to list a non-attendee with a Declined
or Absent status for your records, without that person appearing on an attendance report.

Default - Select this option if you want this entry to be the default for new attendance records.
One attendance status must be set as the default, because the status is required on all
attendance records.

17.8 Categories & Items

Categories and their associated Items are designed for tracking the "one to many" relationships between
your members and "whatever."  In other words, most fields only allow a single value, i.e., you can only
enter one status, one occupation, one entry in a given custom field; but a member can be assigned any
number of Items.  

This provides a flexible way of tracking things members (or groups) may have more than one of, such as
achievements, awards, officer positions, duties, pledges, etc.  They can be used very creatively to track
all sorts of information. 

Perhaps your organization presents various awards to its members. You could create a category called
"Award" and items associated to it like, "Member of the Month", "Queen", "1st Place", "Top Bidder",
"Most Valuable Player", "Record Sales", etc. Then when member "John" wins the "Top Bidder" award,
you can open his record, go to the Items tab, and add an entry for the "Top Bidder" item.  If he also wins
the "Record Sales" award a few months later, you can simply add another item under the category of
"Award" for "Record Sales".  Any item can be added to any member/group any number of times.

Categories and Items are related to each other, so they are setup at once.  The maintenance window
displays all categories, and the associated items for each.



Lists (Dropdown Lists) 242

©1998-2014 Myrro International

Maintaining Categories

1 Choose Tools > Dropdown Lists > Categories & Items.

2 The Maintain Categories and Items window is divided into two halves. On the left are all
Categories; on the right are all Items associated to the currently selected category. 

In the Category section, icons are available to  Add, Open, or Delete any entry.

3 If you choose to Add or Change an entry, the following fields are available:

Category Name - The name of the category

Available To - The type of records with which this category can be used. 

When changing an existing category, you cannot change the Availability if doing so would
invalidate items that are associated to the category and assigned to membership or group
records. For example, if the category was initially available to All Records, you cannot change
the availability to be only Membership Records after it has been used on a group record,
because the Item would become invalid. In other words, you can always increase the availability,
but you can't decrease it once items for the category have been used on records.

Sort Order - The ranking of this category within other categories. The sort order is used on the
Assigned Items report. If no sort order is specified, the order is assumed to be 0 (zero). All
categories with a sort of zero will sort alphabetically within themselves. 

4 If you choose to Delete an entry, that has associated Items, all of the associated Items will be
deleted as well, and the items will likewise be deleted from all membership or group records to
which they were assigned (see below). 

Note: When setting Sort Orders, it is a good idea to use increments of 10, so you have room to add
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another entry within the list. For example, if you have three entries, sort them as 10, 20, 30, instead of
1,2,3. That way, a new entry can be inserted between the first and second by giving it a sort order of 15.

Maintaining Items

1 If you are not already on the Maintain Categories and Items window, choose Tools > Dropdown
Lists > Categories & Items.

2 The Maintain Categories and Items window is divided into two halves. On the left are all
Categories; on the right are all Items associated to the currently selected category. 

Select a Category first, then in the Associated Items section, icons are available to Add, Open,
or Delete any entry.

3 If you choose to Add or Change an entry, the following fields are available:

Item Name - the name of the Item

Sort Order - the ranking of this item within other items on the selected category. The sort order
is used on the Assigned Items report. For example, if you use a category called Officers, you
can use this option to ensure that the "President" item always prints above the "Vice President"
item.

Note: When setting Sort Orders, it is a good idea to use increments of 10, so you have room to
add another entry within the list. For example, if you have three entries, sort them as 10, 20, 30,
instead of 1,2,3. That way, a new entry can be inserted between the first and second by giving it
a sort order of 15.

Active - If you do not want the Item to be usable yet, clear the Active checkbox. An inactive
item will not appear in the selection list when adding new items to a membership or group
record. However, the item will still appear on any records that were assigned the item when it
was still active. 

Comments - General comments about how the item is intended to be used. These comments
only appear on this window and are for your own information. You might want to enter the date it
was created, or your initials.

4 If you choose to Delete an entry, that Item will be deleted from all membership or group records
to which it is currently assigned (because the Item won't exist anymore). If you want an Item to
remain on existing records, but not be available to other records, you should clear its Active
checkbox instead of deleting it.

Configuring Additional Fields/Labels

With MemberTies Professional, when an item is assigned to a member or group record, a number of
additional common fields can be made available.  These include another date field, two text fields, and
two numeric fields. Each of these fields can have a name you define.

1 If you are not already on the Maintain Categories and Items window, choose Tools > Dropdown
Lists > Categories & Items.

2 Click the "Field Labels" button to open the Maintain Item Field Labels window.
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3 The Maintain Item Field Labels window enables you to set the field label for each of the six
special fields that are available when assigning items. By default, only the first date field is
displayed, but you can select the "Show" option for each field you want to use, and give it a
name.  

In the above example, the first date field was changed to "Awarded", and the two numeric fields
to, "Points" and "Placement".

4 When you are finished, click OK to save your changes.

Here is what the New Item window looks like when assigning an item to a member record, using
the newly named fields.
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17.9 Cities

Cities are available to all address records. 

Note: If you attempt to delete a city that is used on one or more address records, you will be prompted
to confirm the change. If you proceed with the deletion, all records that used to use that value will show
a blank city.

Maintaining Cities

1 Choose Tools > Dropdown Lists > Address > Cities.

2 The Maintain Cities list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Name - The name of the city.

Default - Select this option if you want this entry to be the default for new address records. No
default is required.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.10 Club Types

Each group record can be assigned a specific "type."  The group type can be especially helpful to
categorize similar groups.

For example, a common use of group records is for committees. A group record is a convenient way to
group members together in a way that can be easily used on search windows. So if groups have been
renamed to "Committees", you might setup group types for "Fundraising", "Social Planning", etc. Then
you can easily find all of  the members on the committee by simply using that group name and type as
search criteria.

Maintaining Group Types

1 Choose Tools > Dropdown Lists > Group Types.

2 The Maintain Group Type list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the group type.

Default - Select this option if you want this status to be the default for new group records.
Setting a default is optional.
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Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.11 Counties

Counties are available to all address records. 

Note: If you attempt to delete a county that is used on one or more address records, you will be
prompted to confirm the change. If you proceed with the deletion, all records that used to use that value
will show a blank county.

Maintaining Cities

1 Choose Tools > Dropdown Lists > Address > Counties.

2 The Maintain Counties list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Name - The name of the county.

Default - Select this option if you want this entry to be the default for new address records. No
default is required.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

17.12 Countries

Country codes are used on all address records.  We tried to include all known countries by default, but
there may be occasions where you need to change an existing entry, or add a new one. This feature
was very helpful in the year 1492, for example.

Note: Since a country is the minimum requirement for any address (we have great faith in the postal
service) you cannot delete a country if it is used on an address record.

Maintaining Countries

1 Choose Tools > Dropdown Lists > Address > Countries.

2 The Maintain Countries list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Name - The name of the country.
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Code - The two letter abbreviation of the country.

Default - Select this option if you want this country to be the default for new address records.
One country must be set as the default, because the country is the only required part of an
address record.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.13 Credit Card Names

Credit (or Debit) card names are available for selection when creating or editing credit card data stored
for a membership record.

Maintaining Card Names

1 Choose Tools > Dropdown Lists > Credit Card Names.

2 The Maintain Credit Card Names list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the card.

Default - Select this option if you want this entry to be the default selection when adding new
cards. Setting a default is optional.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.14 Custom Fields

Any number of custom fields can be defined for membership records or group records. Custom fields can
be used to store virtually any kind of data you wish. You can specify the label that will appear for the
field, the type of data to be stored, how it will be displayed, and how the field can be used.
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Data Type Choices

The data type determines the kind of information that the field will store:

Text - This is the default data type. A text field can hold up to 40 characters of alphanumeric data.
Text data types can be displayed as a standard field, a list, or a checkbox.

Date - A date field stores a full date, including month, day, and year, in the same format as other
date fields in the system (it uses the Short Date format defined for your computer in Control
Panel, Regional Settings). Date data types can only be displayed as a standard field for a single
value, though a popup calendar icon will be displayed with the field for easy data entry. Date fields
cannot be lists.

Number - A number field stores up to a 9 digit number, with no decimal places. Number data
types can be displayed as a standard field, or a list.

Decimal - A decimal field stores up to a 7 digit number, followed by 2 decimal digits (i.e.,
1234567.89). Decimal data types can be displayed as a standard field, or a list, and can also be
specified as "Currency", which will cause the field to display using the Currency format defined for
your computer in Control Panel, Regional Settings.

Note: (MemberTies Professional Only) When a field is used on a user report or view, you are allowed to
set your own label for the field. In other words, a field might display as "Favorite Team" on the Custom
tab of a membership record, but display as "Team" on your user-defined view to save space. You're
allowed to do this because information about fields for views and user reports is stored apart from normal
field information. This means that changing a custom field label will not affect the label as it appears on
user reports and views -- you will have to manually edit the report or view and make the same change if
you want it to match.

Maintaining Custom Fields
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You can change a field type at any time, but certain changes can (possibly adversely) affect existing
data. In other words, if you have a field that stores "Red", "White" and "Blue" and you change it to a
number, all of those values will vanish because they are not numbers.  But if the field used to stored
"Red", "100", and "Blue", then all of the "100" entries would survive the change to a number, but the Red
and Blue entries would vanish.

1 Choose Tools > Dropdown Lists > Custom Fields.

2 The Maintain Custom Fields list enables you to Add, Open, or Delete any entry.  You can also
filter the list to only show fields available to Membership records, for example.

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

4 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Field Label - indicates the name that will appear for the label on the screen. 

Data Type - indicates the type of data the field can store. The following table shows the options
available to each data type:

Data Type Length Currenc
y?

List
?

Checkb
ox?

Date N/A No No No

Decimal 1-7 + 2 decimal digits Yes Yes No

Number 1-9 No Yes No

Text 1-40 No Yes Yes

If you change the data type of an existing field, the system will attempt to convert all existing
data to the new type. Any incompatible data will be lost.  It is a good idea to backup your
database prior to making data type changes, just in case it doesn't work as expected.

Converting to Dates:

The most complicated change is from Text to Date.  If you make this change, the system can
successfully change the following "text" formats into real dates: mm/dd/yyyy, m/dd/yyyy, mm/
d/yyyy, m/d/yyyy, mm/dd/yy, m/dd/yy, m/d/yy, yyyy/mm/dd, yyyy/m/dd, yyyy/mm/d, yyyy/m/
d, dd/mm/yyyy, dd/m/yyyy, d/mm/yyyy, d/m/yyyy, dd/mm/yy, dd/m/yy, d/m/yy, yyyy/dd/mm,
yyyy/dd/m, yyyy/d/mm, yyyy/d/m. (Formats with a leading 2-digit year are impossible to
convert, because there is no way to know what a value like "07/09/08" represents.)  In addition
to the "/" separator, the system will also look for dates using a hyphen (01-01-1998) and period
(01.01.1998).

Converting to Checkboxes:

A checkbox custom field is stored internally as a Y or N value.  When changing a normal text
field to a checkbox, the system tries to use common options for yes and now, so values of
"Yes", "On", and "1" will convert to "Y". Similarly, "No", "Off", and "0" will convert to "N". 
Anything that doesn't match will convert to the default setting for the field.

Field Style - indicates the way a field will be displayed:
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Standard - A standard field that you can type data into. Use this type when the entry
doesn't have to be controlled at all.

List - A dropdown list filled with the values you specify. A selection must be made from the
values in the list, or the field must be left blank. Use this type when you want to require a
specific entry to ensure consistent data. One list item can be selected as the default value
to be used automatically on new records.

List (Editable) - Identical to the List type, except the user can type an entry that is not one
of the choices in the list. Typing a new entry doesn't change the available list values. (Think
of it as an override entry.) Use this format when you want the list to provide basic choices,
but need to allow for unforeseen entries. One list item can be selected as the default value
to be used automatically on new records.

Checkbox - Behind the scenes, this is a standard field that stores "Y" or "N", but it is
displayed as a checkbox for easy entry.  You can specify whether it should start selected
or cleared.

Available To - indicates the type of record that will use the field.  Once this is set, it cannot be
changed.

Sort Order - indicates the order on the screen (top to bottom) in which the field will appear for
data-entry.

Required - indicates that the field must always have a value.  If this option is selected, a
Default Value must also be provided. 

Default Value - the value that will be used automatically on new records, or on imported
records when no value is provided.  Required fields must always have a default value set,
otherwise it is optional. Note: If the field is defined as a List, the default value is set for one of
the list values.

This field May Be - select the options to indicate how the field can be used. The field will
automatically appear on the data entry tabpage on a member/group record (as appropriate). 
These options control how the field can be used elsewhere in the system. 

Note that the option to display the field on activity front desk searches only applies to the
Professional version, and then only to membership data fields. A maximum of two fields can
be selected for this purpose.

5 If you choose to Delete an entry, you will permanently erase that field's data on all records that
use it.

6 When you are finished, click OK.

Maintaining List Values

If you specified a Field Style of List or List (Editable), you can assign values to the field. The assigned
values will appear in the dropdown as choices for the field.

1 If you are not already on the Maintain Custom Fields window, choose Tools > Dropdown Lists >
Custom Fields. 

2 Open the field you wish to modify.
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3 The "List Values" section enables you to Add, Open, or Delete any entry.  

4 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - the name to display in the list.

Default - Select this option if you want this entry to be the default selection on new records.
Setting a default is optional unless the field is marked as Required, in which case a default must
be specified before the main custom field record can be saved.

 

17.15 Locations

Locations are used with Activities to specify where the activity taking place. Since Locations are more
than just place names, they are maintained separately for easy reuse.

Note: You cannot delete a location if it is used on a record; however, you can make it Inactive, which will
prevent it from displaying in the selection dropdown when creating new activities. (If an existing activity is
using the location and the location is made inactive, it will still show on the existing activity, but if the
location is subsequently changed, the inactive location will not be available for reselection.)

Maintaining Locations

1 Choose Tools > Dropdown Lists > Activity > Locations.

2 The Maintain Locations list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Name - The name of the location, i.e., "Palace Hotel", "Bob's House", "City Park", etc.

Code - An optional abbreviation for the code. 

Type - The kind of location, such as "restaurant", "home", etc. See Maintaining Location Types
for more information.

Active - Indicates whether the location is active and available for new activities. You can use
this option to remove a location that is in use on existing activities, since it cannot be deleted.

Description - A description of the location. This could be used for the address or other basic
details.

Comments - General comments about the location, i.e., "Unavailable on major holidays", or
"Hours: M-F 8:00 -12:00"

4 When you are finished, click OK.
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17.16 Location Types

Location Types enable you to categorize locations according to their type of business, usage, or any
other appropriate designation. Typical location types are, "restaurant", "home", "park", "apartment", etc.,
but they could also be things like, "Free", "Rsv. Reqd", "Private", "Public", etc.

Maintaining Location Types

1 Choose Tools > Dropdown Lists > Activity > Location Types.

2 The Maintain Location Types list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the location type.

Default - Select this option if you want this entry to be the default selection when adding new
locations. Setting a default is optional.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

17.17 Occupation Names

Occupation Names are used on membership records to record a person's type of employment. Typical
entries might be, "Doctor", "Lawyer", "Con Artist", etc.

Maintaining Occupation Names

1 Choose Tools > Dropdown Lists > Occupation Names.

2 The Maintain Occupation Names list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The occupation name

Default - Select this option if you want this entry to be the default selection when adding new
members. Setting a default is optional.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.
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17.18 Payment Methods

Payment methods enable you to identify payments by cash, cheque, Visa, etc.

Maintaining Payment Methods

1 Choose Tools > Dropdown Lists > Payment Methods.

2 The Maintain Payment Method list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate action. If you choose to add or change a method, the following fields are
available: 

Name - The name of the method, such as "cash" or "American Express"

Code - A short form of the name, used by default on posting reports and some lists. For
example, "AMX" for "American Express.  "

Default - Select this option if you want this method to be used automatically for new postings..

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.19 Phone Types

Phone Types are used on the details window for membership records to further identify phone numbers
to be pagers, fax numbers, mobile phones, etc.  You can add or delete phone types at any time. As
soon as the new type is added, it is available for all phone numbers on membership records.
Additionally, the phone type specified as the Default for a given type will automatically be entered on
new records. A default should exist for Home, Work, and Other phone types.

Note: You should leave the phone type called Normal alone.  This should be used for any phone number
that is a "normal" phone. Certain system defined reports that include the phone type will omit the value if
it is set to Normal.

Maintaining Phone Types

1 Choose Tools > Dropdown Lists > Phone Types.
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2 The Maintain Phone Types list enables you to Add, Open, or Delete any entry. 

3 Specify the appropriate option(s). If you are adding or changing an entry, the following fields are
available:

Description - The name of the phone type.

Default For - Specify the types of phone numbers, if any, for which this phone type should be
the default.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

17.20 Posting Types

With MemberTies Professional, Posting Types enable you to categorize dues or donation postings,
restrict the amount that can be posted under the type, control whether the amount posted will affect the
member's account as a debit (reducing the account balance) or credit (increasing the account balance),
and indicate whether the system should generate a receipt number.  
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Several posting types are provided, including:

Interest - To be used for automatic interest postings. This is a debit to the account balance.

Dues Payment - To be used for monies received. This is a credit to the account balance.

Dues Charge -To be used for monies owed. This is a debit to the account balance.

Balance Adj. - Both a credit and a debit type by this name are provided, to be used for adjusting
entries.

Donation - To be used for donations received. This is the default donations posting type.

Activity Income - To be used for income associated with an activity or attendee.

Activity Expense - To be used for expenses associated with an activity or attendee.

Adding a new Posting Type 

1 Choose Tools > Dropdown Lists > Posting Types. 

2 When the Maintain Posting Types list opens, click Add. 

3 On the New Posting Type window, the following fields are available:

Posting Type - The name of the posting type. This name will appear, along with the a debit or
credit indicator, in Posting Type dropdowns.

Action - Choose Debit if amounts posted under this posting type should decrease the account
balance, or choose Credit if amounts posted should increase the account balance.

Available To - Indicates the type of record with which the posting type may be used.
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Minimum - The minimum amount that can be posted under this type. The default is 0.00.

Maximum - The maximum amount that can be posted under this type. The default is 0.00,
indicating no maximum.

Receipt - Indicates whether a unique receipt number should be generated for the posting (for
display on the printed receipt). The current receipt and receipt book numbers can be set via 
Financial Preferences.

Generate Now - Click this option to cause the system to scan all existing postings of the
current type. Any posting found without a receipt/book number will be updated. (This option is
only visible when modifying an existing posting type, since a new posting type obviously has no
existing entries.)

Default - If a Posting Type is marked as the default, it will be automatically selected when
adding entries of the type specified in the Available To field. You can specify two default; one for
Dues, and one for Donations.

Active - Indicates whether the posting type is available for new postings.  Once marked inactive,
the posting type will still display on records that were using it already, but will no be available for
new records. Inactive posting types are always available for reports and queries.

4 When you are finished, click OK.

Changing an existing Posting Type 

1 Choose Tools > Dropdown Lists > Posting Types.

2 When the Maintain Posting Type list opens, select the one you want to change.

3 Click Open.

4 Make your changes, then click OK. Your changes will be automatically reflected on any records
that were already using the posting type.

Note: You cannot change the action assigned to a posting type once entries have been posted
using it.

Deleting a Posting Type

1 Choose Tools > Dropdown Lists > Posting Types.

2 When the Maintain Posting Type list opens, select the record(s) you want to delete.

3 Click Delete.

4 Confirm the deletion.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.
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17.21 Private Field Labels

An additional tab on membership records is available if you are using MemberTies Professional. This tab
is for highly private information that can only be viewed on that tabpage. The information is not available
on any report, and cannot be used as criteria.

Maintaining Private Field Names

1 Choose Tools > Dropdown Lists > Private Field Labels.

2 The Maintain Credit Card Names list enables you to Open any entry to change the name. 

3 If you choose to change an entry, the following fields are available:

Label - The name to display for the field. If you clear the name and save it as blank, the field will
revert to the default name of "Private Field XX"

 

17.22 References

References are used on membership records to record the way in which someone came to know about
your organization. Typical entries might be, "friend", "newspaper", "event", etc. 

Maintaining References

1 Choose Tools > Dropdown Lists > References.

2 The Maintain Reference Names list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Value - The name of the reference.

Default - Select this option if you want this role to be the default for new membership records. A
default must be specified.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

17.23 States/Provinces

States/Provinces are available to on all address records. For areas where the value is not applicable, the
system includes a value of "(None)" that can be set as the default.

Note: If you attempt to delete a state that is used on one or more address records, you will be prompted
to confirm the change. If you proceed with the deletion, all records that used to use that value will show
a state of (None).
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Maintaining States/Provinces

1 Choose Tools > Dropdown Lists > Address > States/Provinces.

2 The Maintain States/Provinces list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Name - The name of the state or province.

Code - The two or three letter abbreviation (i.e., NY = New York, QLD = Queensland).

Default - Select this option if you want this entry to be the default for new address records. One
entry must be set as the default, even if you choose the "(None)" option.

Combining Values

Entries on this list can be combined into one. See Merging/Combining Values for details.

 

17.24 Status Codes

Status Codes (often referred to as "membership types" or simply "statuses") control one of the most
basic aspects of membership records. The status of a member can trigger a lot of different functionality,
especially if you are using MemberTies Professional. 

Status codes can:

Control the automated processing of membership records that have expired (i.e., the End Date
has passed), determining whether they should be converted to a different (usually inactive) status,
deleted, or left alone. 
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Control the yearly dues payment amount for each status, whether that amount is prorated, and
how. This information is used on the Dues Calculator.

Control whether a relationship is required for the status. For example, a "Family" status might be
expected to always involve more than one membership record, so the status can be defined to
require that another membership record be tied to any record with that status.

Control which status is the default used on new records.

Control any Interest charges to be automatically applied to "past due" memberships with a
negative dues balance. (MemberTies Professional only)

Control any automatic "scheduled" dues postings, for example, to automatically post a dues
charge to members with this status on the 15th of each month, the 1st of January, etc.
(MemberTies Professional only)

Control the default setting of the "Include in Mailings" and "Include on Reports" checkboxes.

Control the number of activities a member can attend. (MemberTies Professional only)

Overview of Creating Statuses 

The system comes preloaded with several statuses, but you can remove any or all of them, or just
rename and redefine them. You may enter several hundred statuses in addition to the default DELETE
status that is required by the system. It is a good idea to draw out the flow of statuses in your
organization before setting them up. 

For example:

PROSPECT changes to DROPPED 30 days after the End Date
DROPPED changes to (DELETE) 90 days after the End Date
REGULAR changes to ALUMNI 90 days after the End Date
ALUMNI never expires and never changes

The above example indicates that once a Prospect status record expires (reaches the End Date), there
is a 30 day grace period before it changes to an inactive Dropped status. The idea being that if you
haven't heard from then within 30 days you want them removed from the active roster. If another 90 days
passes without contact, the record should be deleted because they apparently aren't interested.

Regular members, in the above example, might be people who are truly members that you don't want to
forget about. Those records shift to an inactive Alumni status if they don't renew after 90 days, and they
remain as Alumni indefinitely.

Note: Any membership record that is set to the "(Delete)" status (manually or automatically via "Next
Status") will be automatically deleted when you exit the program, unless the "Auto Delete (Delete)
Status" Logoff preference controlling this has been turned off. (You will be prompted to confirm the
deletion however, unless another Logoff preference controlling the prompt has been turned off.)

Maintaining Status Codes

1 Choose Tools > Dropdown Lists > Status Codes. 

2 The Maintain Status Codes list enables you to Add, Edit, or Delete any entry. 
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3 Choose the appropriate option. If you are adding or changing an entry, the window either
appears as normal window, or as a window with multiple tab pages on it, depending upon
whether you are using the standard or professional version of the software. If you are using the
standard version, there are no tabs, and the window displays the fields listed under the "General
Settings" heading below:

General Settings Tab

These settings control the basic behavior of the status. If you are using the standard version of
MemberTies, this is the only tab you will see.  The following fields are available:

Status Name - The name to display for the status in dropdown lists.

Code - An abbreviation or code representing the status.  You can use this as you wish,
typically on reports when you don't want to display the full name.  The system automatically
assigns a code based on the first three letters of the Status Name, but you can change it to
anything you wish (and it must be unique when you eventually save the record).

Membership Type - Indicates whether the status represents an Active or Inactive member.
This setting is used when choosing statuses as report criteria, enabling you to choose "all
active statuses" for example. Otherwise, it is purely informational.

Relationships - Select the relationship type(s) that must be created for any record with this
status. This might be used for a "family" status, to require that the member be related to at least
one other person. You can require a relationship with another membership record, group record,
or both.

Include in Mailings (MemberTies Professional only) - Select this option if the corresponding
"Include in Mailings" field should be selected automatically on the membership record when this
status is chosen.

Include on Reports  (MemberTies Professional only) - Select this option if the corresponding
"Include on Reports" field should be selected automatically on the membership record when this
status is chosen.

Dues Prorate Options - This setting is used by the Dues Calculator to pre-select the dues
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proration option. If you expect to prorate dues on a monthly basis, setting this option makes it
easier to remember to do so when using the calculator.  Note that you can override this setting
on the calculator if you wish.

Yearly Dues - The yearly dues amount. This amount is used on the Dues Calculator, as well as
when entering dues payments manually.  When a status is selected when posting dues, this
amount is displayed for quick entry.

Custom Amt - If you decide to prorate the yearly dues amount, it will do so based on 12 months
or 365 days, as appropriate.  If you enter an amount here, then this amount will be used instead
of the amount calculated by dividing the amount by 12 or 365. (Of course, if you enter a custom
prorate amount based on monthly proration, and then change to daily when using the dues
calculator, you may get unpredictable results.)

Expire On - If you want the system to automatically change the status of the member record,
select the "trigger" for the change.

End Date -- causes the status to change when the End Date arrives. Note that the Reset
End Date membership preference controls whether the End Date is reset when the status
changes.

Age -- causes the status to change when a person reaches a certain age. i.e., you could
have a "Junior" status that automatically changes to "Adult" status when the member
reaches the age of 18 .

Start +Days -- causes the status to change X days after the member's Start Date. i.e., you
could have a "Probation" status that automatically changes to "Active" after 90 days.

Note that the appropriate data must be available for each option to work. i.e., if you choose
End Date, it won't apply to records without an End Date value; if you choose Age, it won't
apply to members without a full birthdate; and if you choose +Days, it won't apply to
members without a Start Date.

Status changes are processed when MemberTies starts.

Next Status - The next status to set for the membership record when it expires.

Grace Period ... Day - The number of days after the End Date to wait before initiating a status
change.  This can be used to provide members with a few weeks to "come current" with their
dues before they're changed to another status.  An entry of "0" (zero) or blank will cause status
changes to occur immediately when the End Date passes. Note that the "Reset End Date on
Expire" membership preference controls what happens to the End Date when such a status
change occurs.

Activity Limit (MemberTies Professional only) - Enter a number here if you want to limit the
number of activities a member with this status can attend.  When a person is about to exceed
this limitation at check-in time, the system will display a warning, at which time you may
choose to allow the check-in to proceed.

Note: You can also specify a per-activity attendance limit by status.  Any limit defined here will
take priority over any per-activity limit. In addition, each activity has an option that controls
whether limits apply to it at all. See Working with Activities for more information.
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Default - Select this option if you want this status to be selected automatically for new
membership records.

Hide - Select this option if you do not want this status to be available for use on membership
records.  (The status will remain on any records that currently use it, but it won't be available for
any other records.)  This is intended as a way to "retire" an old status that is no longer needed.

Interest Charge Tab (MemberTies Professional)

If your organization charges interest on past-due accounts, this tab enables you to set up how
interest will accrue. (A "past-due" account is defined as any account with a debit account
balance. It is assumed that if you choose to use this feature, dues accounts will be considered
"current" whenever the account has a zero balance or a credit balance (indicating an over
payment for example).

An interest setting is tied to a particular membership status so you can charge different interest
rates for different membership types. Perhaps an active member would be charged interest at a
rate of 5% annually, but an inactive member would only be charged 2% because it isn't as
important that they keep their account current.  One interest setting can be defined per status.

The following fields are available:

Posting Type - The (dues) posting type that should be used when the system posts automatic
interest charges. Only debit action posting types are available. Is recommended that a posting
type called "Interest" be used for clarity, but the choice is yours.

Annual Percentage Rate (APR) - The annual percentage rate for the interest charges. This
value will be used to determine the actual rate applied for the compounding period. Enter the full
percentage as a number, not as a decimal. i.e., for 9.5%, enter 9.5, not .095.

Compounding Period - Interest is calculated based on the compounding period as follows:

- Daily: ((APR / 100) / 365) x (outstanding balance)
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- Monthly: ((APR / 100) / 12) x (outstanding balance)

- Yearly: (APR / 100) x (outstanding balance)

Accrual Date - The entry in this field depends upon the selected Compounding Period: 

- Daily: this field is automatically set to ALL, because daily compounding means interest is
posted every day.

- Monthly: this field enables you to enter the day of the month on which charges should be
posted. The default is the first day of the month.

- Yearly: this field enables you to enter the month and day on which charges should be posted. 

Minimum - If you require a minimum charge whenever interest is applicable, enter the minimum
amount here. For example, you may charge 5% interest, with a minimum of $10.00 due
whenever an account is outstanding. In this case, if the interest charges due came to $7.50, the
system would post $10.00 instead.

Comments - Enter any comments that should appear on the interest posting.

Last Check - This field determines the point in history on which the interest charges will begin
to be checked and/or posted. Enter the date through which interest charges on this status
should be considered to be current.  This field defaults to the current date when a new setting is
created. If you want the system to go back and post interest beginning at an earlier date,
change this value to a date in the past. Likewise, if you don't want interest posting to begin until
a future date, enter a future date. 

Be very careful about entering a date in the past! If, for example, you enter a date a year in the
past, the system will begin at that date and will check every membership record of the selected
status for every missed compounding period and post interest appropriately until the account is
current.

 Last Post - Displays the last date interest charges of this type were posted to an account.

Scheduled Postings Tab (MemberTies Professional)
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To simplify repetitive charging of dues or other fees, you can schedule one or more automatic
postings for any status. For example, if all Regular status members are charged an account
maintenance fee of $10.00 on the first of each month, and a yearly renewal of $200.00 on the
day their End Date is reached, you can create two scheduled postings to handle this
automatically!

To add or modify a scheduled posting, click the Add or Open icon at the bottom of the list.
When the scheduled posting window opens, the following fields will be available:

Posting Type - The posting type that should be used when the system posts the charge. You
can choose from any available posting type. 

Amount - The amount to be posted.

Target Date - Choose an option to indicate when the amount should be posted.

End Date - amounts are posted when the End Date arrives

Start Date - amounts are posted when the Start Date arrives

New Record Save -- amounts are posted when a new membership record is first saved (by
clicking Apply or OK).

Specified Date -- amounts are posted on the chosen date. If you choose this option, you
must at least choose a Day; but, the month and year are optional.  This enables you to
create a rule that posts an amount on the 1st of every month, or on the 12th of every
February, or specifically on the 23rd of March, next year. 

Comment - Enter any comments that should appear on the dues posting.

Last Check - This field determines the point in history on which the system will begin to check
records and make automatic postings. Enter the date through which scheduled postings on this
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status should be considered to be current (note that this only applies to scheduled postings that
are not for a specific day, month, and year).  This field defaults to the current date when a new
setting is created. If you want the system to go back and post  beginning at an earlier date,
change this value to a date in the past. Likewise, if you don't want posting to begin until a future
date, enter a future date here. 

Be very careful about entering a date in the past! If you enter a date a year in the past, the
system will begin at that date, and will check every membership record of the selected status
for every missed date and post amounts appropriately until the account is current. 

Last Post - Displays the last date a scheduled posting for this status was posted to an account.

4 When you are finished making changes, click OK to save the status.

17.25 Stored Comments

Stored comments enable you to set up and save common text entries for use in various freeform
Comments fields throughout the system. Such fields exist on membership, group, and activity records,
dues entries, and the Account Statement report, for example.  The stored comment can be anything you
type frequently, such as "Sent welcome letter." or, "Your account is past due. Please remit payment
immediately to avoid cancellation."

A Stored Comments icon will be displayed next to comments fields. Clicking this icon will display the
list of comments, from which you can select an entry to insert into the field. When selecting a stored
comment, you can also select the "Include Current Date" option to prepend the selected text with the
current date. 

This is how the window appears when maintaining the stored comment list. There is no "Include Current
Date" option available in this case.

Maintaining Stored Comments
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1 Choose Tools > Dropdown Lists > Stored Comments.

2 The Maintain Stored Comments list enables you to Add, Open, or Delete any entry. 

3 Choose the appropriate option. If you are adding or changing an entry, the following fields are
available:

Comment - The text of the comment. Remember that some comment fields only allow 250 total
characters, while others allow more than a thousand. Keep texts short for the greatest usability.
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18 Membership Records

18.1 Overview

A membership record represents a person relevant to your organization. Despite the name, "membership
record," the record does not necessarily have to represent an actual "member" in terms of a class of
membership. In other words, a prospective member, as well as a "person who gets our newsletters," is a
candidate for a membership record. 

You work with members via the Membership List. To get to the Membership List, choose File >
Workspace > Membership List, or click the Membership List toolbar button.

Membership Record Basics

Name - Each membership record must have either a First and Last Name, or a Company Name.
If you want to have the system display the Company Name instead of the first and last name,
leave the name fields blank and enter only a company name as shown:

Another common need is to enter the normal first and last name, but to send mailings to a
"family" name. This is done with the Alternate Mail Name field as shown below.  The value in the
Alternate Mail Name field will be automatically used instead of the name or company name on
system defined mailing label reports.
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Address - You don't have to enter any address information except the Country.  

Status - The membership status is required. If you don't like the status options that come with
MemberTies, you can create your own.

Start Date and End Date - Every record must have a Start Date, but an End Date is only required
if the status has been defined as one that expires (expiration is assumed to take place on the End
Date, so the system needs to know when that occurs). The Start Date represents the date the
person first became a member (or became associated with the group). Typically, the Start Date
never changes, but the End Date is updated each time dues are renewed.

Dues and Donations - Monies received from the member are recorded as dues charges and
payments, or as donations (Professional version only). Dues are tracked on a separate tab from
Donations, to prevent donation funds from being added as a credit to a member's dues account.  

Relationships - Members are often related to each other, as family members, sponsors,
teammates, etc.  You can tell the system to always require a relationship for certain membership 
statuses. For example, a "family" status might logically require that the person assigned that
status be related to at least one other member.

Items - The "items" tab is useful for tracking things that can be assigned to a member more than
once.  Offices a member has held, or awards a member has won are good candidates for "items"
because one person could have held many offices. Other simple data like "nickname" or "hair
color" do not need to be set up as Items, because they are normally only assigned once.  See 
Categories & Items for more details.

18.2 About Member IDs

The Member ID field, specifically the way it is populated, is a frequent source of confusion. The goal of
this topic is strictly informational -- to explain what the field is for, how it is populated, and why it looks
odd sometimes.

Some Basic Facts

1 The Member ID is a required field, and it should be unique. You can put anything you like into
this field, but by default the system will assign a unique number to the field that matches the
internal id of the membership record. This is done simply to save you the trouble of deciding on
a unique value if you don't care about the contents of the field.

2 The internal system IDs is a "database sequence." A sequence is essentially a running counter
that is maintained internally by the database engine. It never "backs up" and there is no "undo"
button. Every time a new record is created, the database increments the appropriate counter
and assigns that value. The next time a new ID is needed, it will increment the number again.
The system doesn't know whether you actually used it, it only knows that you asked for a
number, and it provided one.

3 Because internal ID numbers are just dumb counters, they cannot be relied on as a means to
determine how many members are in the system. To get an accurate count of members, you
should use statistics reports, or simply look at the total of the Results tab on the Membership
List when querying for all records.

What Causes Confusion?



Membership Records 270

©1998-2014 Myrro International

Suppose you add 10 members one after another in a new database. Their internal IDs will be 1 - 10.
Likewise, the defaulted member ID numbers will be 1 - 10. At this point everything looks good.

Now let's say you realize that member number 5 actually never joined, and shouldn't even be in the
database. Thus, you delete that member. Now the problems begin...

When you add another member, what should the system do? There are currently 9 records, lowest ID is
1, highest ID is 10. Should the system:

Assign the number 11 to the new record, because that's the number immediately following the
largest ID? Ok, but there really aren't 11 members, there are only 10.

Assign the number 10, because there are currently only 9 members, and this is the 10th? Ok, but
that would mean there are now two number 10s in the database, which is wrong.

Reassign number 5, because it's an empty slot? Ok, now the count matches the actual number of
members, but number 5 really didn't come before number 6, it came after number 10. Now the
sequence doesn't make sense anymore. This gets even more complicated if you delete two or
three members.

The Solution

The only logical solution was to leave it up to you to tell us what you want to see. Therefore, if you don't
want to use a random value for the Member ID, and don't want to type it in each time, we let you build
your own list of "preloaded" member ID numbers. This enables you to define a list of ID numbers for the
system to use. You can set up a simple list of 1 - 10000, or a more complicated list like, "13JEU4R5,
12JEU4R6, 12JEU4R7", or whatever you wish). The system won't care what the IDs are, it will just use
one after another as you create new members. (See Preloaded Member IDs for more information.)

Every time you add a new member, the system looks at the preloaded ID's table and if there is anything
available, uses the next value. You can even manually mark Preloaded IDs as active or used (they're
automatically marked as Used when the system picks one). More importantly, if you start a new record,
then cancel it, the system will go back and reset the ID it started to use, making it available again.

In addition, there is a preference that controls whether the system should recycle old IDs when the
records that used them are deleted. (This is the scenario described above when record 5 was deleted.) If
the preference is on, then when record 5 was deleted the system would find the entry in the Preloaded
IDs table and mark it as available again. Then it would be used again by the next record.

Before You Ask...

The obvious question then is, "why don't we just do this automatically instead of expecting you, the
user, to populate preloaded ID numbers?"

There are several reasons:

1 Not everyone cares about the member ID.

2 Not everyone uses numeric IDs.

3 Not everyone uses sequential IDs.

4 Some people want the ID to match the internal system ID.
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Hopefully this information helps clarify how and why the Member ID field behaves the way it does.

18.3 Photos

You can associate a .bmp, .gif, .jpg, .jpeg, .wmf, or .rle photo file to any membership record. 

Note: The database will either contain the path to the file, or the actual file itself, based on the File &
Photo Storage database preference.  If you choose to store  the path to the file it is important to
remember to move all photo files if the database is ever moved to another machine.  This also means
that updating an existing photo is as easy as putting the new file in your photos directory. As long as
the name is the same, it will appear on the member's record automatically.  Despite this, the
recommended method is to store the file in the database, to ensure that it cannot be lost (and if you are
running multiple installations, it may be the only way other users can see the same photo).

Adding or Viewing a Photo

1 From the General Tab of a membership record, click the Photo icon, or select a membership
record on the Membership List and choose Actions > Display Photo.

2 When the Photo window opens it will automatically display the photo associated with the
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member, as well as the photos of all Friends & Family records if available.   If no photo is
available, a browse window will open automatically so you can select the photo file.

All photos are shown in miniature along the left side of the window.  The photo for the member is
always shown at the top, and then Friends/Family photos are shown below, sorted by first
name.

3 The list of photos on the left side may be scrolled using the scrollbar, and clicking any one of
them will display the larger version in the main viewing area.  Photos are automatically resized
to fit the display area. 

The following icons are also available along the right-hand edge of the window. This icons always
affect the currently displayed photo:

Toggle Size - changes the photo from a "scaled to fit" version, to the full sized version.

Print - displays a printer window and prints the full photo

Delete - removes the photo from the associated record

Browse - enables you to assign a different file to the currently displayed photo

4 When you're finished, click OK.

Other Notes:

If you are storing photos in the database, the name of the photo will change to something
like, "Stored ID: 36" after it has been successfully saved.  When opening a stored photo,
the system recreates the photo file in a temporary directory and then displays it.

This window uses a powerful image viewer to display photos.  However, the Photo ID Card
report doesn't have this capability. The report will always display photos in a normal portrait
(taller than wide) format. So while you can store any size of photo and display it on this
window, only normal ID card style photos will look good on the report.

Digital cameras can be set to take very high resolution photos capable of filling a large
computer monitor with a razor sharp image.  This is great for photos that may be enlarged
or printed, but it will require a lot of disk (or database) storage, and is overkill for an ID card.
 We strongly recommend using a graphics tool to resize photos to approximately 2" x
3" (144 x 216 pixels, 5.0 x 7.6 cm). This is enough for excellent clarity while only requiring
about 50 KB of storage or less. 

18.4 Preloaded Member IDs

With MemberTies Professional , if your organization is required to use a pre-defined set of membership
IDs, you can pre-load these into the system so that each time you create a new membership record, the
next available ID will be used automatically.  You can enter IDs manually, or you can import them from a
text file.

As long as the Member ID list contains active, unused IDs, the next ID will be automatically entered on
new membership records. (This can also be a convenient way of ensuring sequential IDs.)
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You are allowed to change this value to anything you wish, or you can have the system automatically
assign an ID selected from a predefined list. (For general information about Member IDs, see, About
Member IDs.)

Note: The Preloaded Member ID window includes an option to require an ID from the list for all new
member records.  If this option is set and the last ID is used, the system will not allow new member
records to be created until new IDs are added to the list.

Adding New Member IDs Manually

1 Choose Tools > Preloaded Member IDs. 

2 When the Maintain Preloaded Member IDs list opens, click Add. 

3 On the New Preloaded Member ID window, the following fields are available:

Member ID - The member ID.

Active - Indicates whether the member ID will be available to the system for selection. Clear this
box to temporarily prevent an ID from being chosen. This should normally be checked for new
records.

Used - Indicates whether the ID has already been used in the system. This should normally be
left blank (indicating the ID has not been used) for new records. The system will set this option
automatically as IDs are used.
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Importing Member IDs from a File

You can quickly load a list of IDs from a text file.  The file should list IDs one per line, in the order they
should be used. If you are creating a list of numeric IDs (i.e., 1-100) it may be easier to have the system
generate them automatically. See "Generating Member IDs" below for details.

1 Choose Tools > Preloaded Member IDs. 

2 When the Maintain Preloaded Member IDs list opens, click the Import IDs icon. 

3 On the Select Member ID Text File window, navigate to the text file containing the list of
member IDs, then click Open

4 A message will be displayed indicating the success or failure of the import, and all imported IDs
will be added to the list.

Generating Member IDs

1 Choose Tools > Preloaded Member IDs. 

2 When the Maintain Preloaded Member IDs list opens, click the Generate IDs icon. 

3 On the Generate Member ID Series window, enter the starting and ending ID number, then click
OK.

Note: You can generate up to 9,999 IDs. It is recommended that you only generate the IDs you
need. i.e., if you expect to have 1000 members, don't generate 10,000 ID entries, because it will
only waste table space and increase the size of the database unnecessarily.

4 A message will be displayed indicating the success or failure of the process, and the IDs will be
added to the list.

Changing a Preloaded Member ID

1 Choose Tools > Preloaded Member IDs.

2 When the Maintain Preloaded Member IDs list opens, select the ID you want to change, then
click Open. 

3 When the Edit Preloaded Member ID window opens, make your changes, then click OK.

Note: Once an ID has been saved, only the Active/Used setting can be changed.

Deleting a Preloaded Member ID

1 Choose Tools > Preloaded Member IDs.

2 When the Maintain Preloaded Member IDs list opens, select the ID you want to delete, then
click Delete. 

3 Confirm the deletion.

Note: Deleting a preloaded member ID that has already been used will not affect a record that
has already used the ID.
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Synchronizing IDs with Membership Records

If you believe the list of preloaded IDs contains entries that are marked incorrectly based upon whether
the do or do not on a membership record, you can synchronize the list.

1 Choose Tools > Preloaded Member IDs.

2 When the Maintain Preloaded Member IDs list opens, use the right-hand mouse button to click
the list, and choose  "Synchronize" from the popup menu.  The system will check each
preloaded ID against the membership records in the database update it accordingly.

Note: This process is controlled by the Recycle Preloaded IDs membership preference.  If the
preference is turned on, the synchronize process will look at both used and unused IDs.  If the
preference is off, the process will only update Unused IDs to Used.  i.e., if you aren't recycling
IDs, the system won't make them available again.

3 Click OK to confirm the change. A message will be displayed indicating the number of changes
made.

18.5 Using the Membership List

18.5.1 Overview

The Membership List lets you access all of the membership records in the database. It enables you to
define, store, and load search criteria, as well as access the membership records themselves. You can
also set up a specific search to run each time the list opens.

The Membership List is made up of two tabs, Search and Results.

The Search Tab
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The Search Tab is used for entering criteria to restrict the records that will be found and displayed on the
Results tab.  In the sample above, only members with an address containing "main" who live in the city
of "Anytown" will be found.

If no criteria is specified, all records will be displayed. If you have a large number of membership records
(more than 1000), using some criteria to limit the number of records found will improve the search speed.

The Results Tab
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The Results tab displays the record(s) that matched the criteria entered on the Search tab.  In the above
sample, three members were found in Anytown with an address containing the word "main."

The Results tab is used for accessing individual records, and for performing certain tasks that can affect
multiple records, such as building an email list.

18.5.2 Search Tab

You can use the Search tab on the Membership List to search for records based on your own criteria,
and then display the records found on the Results tab. Refer to the Overview for a quick description of
the types of searches.

Searching for Records

1 Choose File > Workspace > Membership List.

2 When the Membership List appears, choose the Search tab.

3 Determine whether you want to run a basic or advanced search:

Entering Basic Search Criteria 

Entering Advanced Search Criteria

4 When you have finished entering criteria, click Search to tell the database to find the records
that fit the criteria you created.  The matching records will be displayed on the Results tab.

Tips

Multiple Addresses: With MemberTies Professional you can assign a record more than one
address. When you do this, you will also want to use the "Addresses" field on the Search tab to
specify which address to use for the results. If you choose "All Addresses" you might see the
record more than once in the list -- once for each of its addresses.
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When you use Advanced search criteria you can save the search for future reuse. See Entering
Advanced Search Criteria for more information about this kind of searching.

18.5.3 Results Tab

The Results tab displays the record(s) that matched the criteria entered on the Search tab, whether
basic or advanced.

If you're not familiar with selecting records in lists, please see this topic on how to select records from
lists in Windows.

Finding a Record in the List

When the Results list is displayed, you can quickly find a member by simply typing the last name. As
you begin to type, a field labelled, "Last Name Search" will appear above the list and will contain the
letters you type. Type enough of the last name to identify the record, then press Enter. The current list
will be searched for that name and if found, the record will be highlighted for you. If no Last Name is
found, the system will also look at the Member ID column for a match (if that column is part of the list).

Note that the list will be searched in the order that it is currently displayed, from top to bottom. 

Also, use the Page Up/Page Down and Arrow keys to move through the list, or use CTRL+Home and
CTRL+End to scroll to the beginning or end of the list, respectively.

Changing the Sort

Click the column heading of any column to sort the list by that column. For example, to sort the entire
list by email address, click the Email column heading:
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The first click will sort the column in ascending order, the second click will sort the column in
descending order. 

Sorting by Member ID

The Member ID column sorts differently depending on a preference setting.  If you have the "Require
Numeric Member IDs" Membership preference turned on, then the column will sort in numeric order (and
you will only be allowed to enter numeric IDs on the membership record itself).  However, if the
preference is off, the column will sort alphabetically. For example:

On (numeric sort) Off (alphabetic sort)

 1
 2
 3
 10
 11
 25
 100
 110
 200

 1
 10
 100
 11
 110
 2
 200
 25
 3

Widening a Column

If you need to read especially long entries, just position your mouse pointer between the column
headings until the cursor changes to a double-headed arrow, then drag the column to the size you want.
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Dividing the View

Divide the list into two sections by using the split-scroll bar so you can see two different parts of the list
at once. 

Choosing a Preview Display

With MemberTies Professional you can choose up to two "previews" of the selected membership record.
A preview is a synopsis of a certain portion of the overall data, displayed at the bottom of the results list.
 Each time you click on a record in the list, the appropriate preview information displays.  This enables
you to make certain types of information immediately available without having to actually open the
record.

See Working with Previews for more information.

Refreshing Data

Depending on the setting of the "Refresh Lists Automatically" preference, the list may or may not
redisplay to show changes each time you add or modify a record. If the preference to automatically
refresh has been turned off, you can press F5 or choose Actions > Refresh Display to re-retrieve data
from the database. Note that the number of records matching the search criteria is always displayed on
the Results tab. 
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Working with Records

Press Enter to open the currently highlighted record for editing.

Press the plus ( + ) key to add a new record. 

Quickly display or copy contact information for a selected record by highlighting the row and
choosing Actions > Display Contact Info.

Duplicate a selected record by highlighting the row and choosing File > Copy Member

Toggle the Include in Mailings checkbox by selecting any number of records and choosing
Actions > Include in Mailings or Actions > Exclude from Mailings

Build an Email List by selecting any number of records and choosing Actions > Build Email List

Select any single record that contains a Website entry, and then choose Actions > Open Website
to open your default web browser and go to the web page.

Assign one or more members to an existing group record by selecting the desired records and
choosing Actions > Assign Group

Assign one or more members to an existing activity record by selecting the desired records and
choosing Actions > Assign Activity

Update multiple fields on selected records at once by choosing Actions > Change Data (Bulk)

Additional options are available either from the Actions menu, or from the popup menu accessed
by right-clicking a row in the list.

 

18.5.4 Building an Email List

You can build an email list from a selection of records. The list can be saved as a text file, or copied
directly to the clipboard so you can paste it into an email program. Only unique email addresses are
included in the list. If more than one record has the same address, the address will only appear in the
list once.

When the email list is created, only records containing an entry in the Email field will be used. If you
select records that do not contain an email address, the list will be empty.

Building an Email List

1 Search for the appropriate records on the membership or group list. (This procedure applies to
both the membership and group lists.)

2 On the Results tab, select one or more records to use for the email list.

3 Choose Actions > Build Email List.
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4 When the Build Email List window opens, select the following:

Separator - The type of separator, or delimiter, to place between names in the list. The list will
be generated as one long line (unless you choose a carriage-return separator), with each email
address separated from the previous one by the separator you choose. The type of separator to
choose will depend upon what you want to do with the list and/or what your email software
requires.  

Output - Choose the way you want to handle the finished list. You can copy the list
immediately to the clipboard, so you can open your email program and paste the whole list into
an address field, or you can save the list to a text file for future use. 

For example, if your email program expects a semicolon between each address, you would use
the semicolon separator, and then you could choose an output to the clipboard so that you
could immediately paste the results into the "To:" field of your email program.

5 Click OK to build the list.

If you selected to save the list as a file, MemberTies will try to open a text editor to display the file
(typically Notepad). If a text editor cannot be found, a message will tell you where the file is located so
you can open it in another program.

 

18.5.5 Adding Members to a Group

Whenever the Membership List is open, you can assign one or more members to one or more groups
with just a few clicks.
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Adding Members to a Group

1 Search for the appropriate records on the Membership List.

2 On the Results tab, select one or more records to be assigned to a group or groups.

3 Choose Actions > Assign Group.

4 Search for and select one or more Groups.

5 Click "Use Selected Results" to assign all selected members to the selected Group(s).

18.5.6 Adding Members to Activities

With MemberTies Professional , you can assign one or more members, including an activity posting and
amount, to one or more activities, directly from the Membership List results window.

Adding Members to Activities

1 Search for the appropriate records on the Membership List.

2 On the Membership List, select one or more records to be assigned to the activity(s).
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3 Choose Actions > Assign Activity.

4 To assign members to a single activity, select the desired activity in the Activity field, then
continue to step 6. 

To assign members to more than one activity, click the "[+...]" button to the right of the activity
field to access the Select Multiple Records window.

5 Select all the activities to which the member(s) should be assigned, then click OK.
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6 On the Assign Activity window, finish completing the desired fields. (Posting data is optional.)

7 Click OK to assign all selected members to the activity and create (if appropriate) a posting for
each. 

8 After assignment completes, you can review the Results tab to see what was done, or just click
Cancel to close the Assign Activity window.

System Overrides

It is possible that the system will override some entries provided on this window to ensure that activity
settings are enforced if applicable. In addition, it is possible that some members will not be successfully
assigned to one or more activities.  If errors occur, they will be displayed in the log file available after the
process completes.  

Some things that will cause the system to override settings include:

If the activity has a specific capacity (and does not allow over-booking), and the capacity is
reached either before or during the assignment process, all subsequent members will be ignored.

If a member has a status that is not allowed to attend activities, the member will be ignored.

If the Start or End Date provided falls outside the range required by the activity, the Start and/or
End Date of the activity will be substituted for all members for that activity

If the Start or End Date of the activity is to be copied to the attendance record, the Start and/or
End Date of the activity will be substituted for all members for that activity

Results

Since this window enables you to assign multiple members to multiple activities, the success or failure
of each assignment is written to the Results tab for easy review. 

18.5.7 Choosing Random Members

Have you ever received a request to "choose 3 random members" as winners of a monthly drawing? 
This features simplifies this process.

Choosing Random Members

1 Search for appropriate records on the membership list. For example, if you want to give a free
pass to a dinner party to some people who joined this month, retrieve members using criteria
like: "Start Date = Current Month"

2 Choose Actions > Choose Random Members
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3 On the Choose Random Members window, enter the number of records you want to select, then
click Go. You can enter any number of members up to the total number of records in the
Results List.

4 If you want  a simple screen print of the results, click Print.

5 When you are finished, click Close.

 

18.5.8 Sending Email

With MemberTies Professional you can send email to members, groups, and attendees of activities
using your Internet account.  When you open the email window, it will automatically populate itself with
email addresses based on where you were when you opened the window, as described below.

When email is sent, there are various ways to address the message(s). You can choose to put email
addresses in the "To", "CC", or "BCC" fields of the message (i.e., the old-fashioned way), or you can
have MemberTies generate separate, individually addressed messages, one for each person on your
address list (i.e., the more modern way).  The second, more modern method is normally preferred,
because it looks more professional and prevents others from seeing the email addresses of your other
members.

Warning: SPAM email (also known as unsolicited commercial email) is a growing problem on the
Internet today.   If we determine that you are using MemberTies Professional to send SPAM, we will
terminate your license and report you to the appropriate authorities. Using MemberTies Professional to
send unsolicited email (SPAM), or to transmit illegal content is expressly forbidden.

Note: You must have your own Internet connection in order to send email.
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Sending Email

1 All email activity is performed on the Send Email window. There are several different ways to
open this window, depending on what you want to do. If you want to send email to:

The contact email addresses for one or more groups - select the desired group(s) on
the Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Only". The
contact email address for each selected group will appear in the Addresses tab.

The associated members of one or more groups - select the desired group(s) on the
Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Members".
The contact email address for all membership records associated with each selected group
will appear in the Addresses tab.

One or more membership records - select the desired member(s) on the Membership
List,  then click the Email toolbar button or choose Actions > Send Email.  The email
address for all selected records will appear in the Addresses tab.

The attendees of one or more activities - select the desired activity(s) on the Activity
List, then click the Email toolbar button or choose Actions > Send Email.  The email
address for all attendance records associated with each selected activity will appear in the
Addresses tab.

There are also various places in the system where an email address is displayed as a data-
entry field. When an Email icon appears next to a field, you can click the icon to open the Send
Email window with the current address displayed.  In addition, the Email toolbar button is
always available even when no list is open. This enables you to open the Send Email window
and enter your own addresses, i.e., without bring in any existing email addresses.

2 Once the Send Email window opens, there are several tabs available that affect or control the
sending of the message:

Message Tab - This tab is used to define the email message text, add attachments, and select
the email Profile that will be used to send the message.
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Pasting In Message Text

While it is possible to cut/paste an email message from another source, such as a word
processing document, another email client, etc., you should be sure to send a test message to
see how it converts.  There are hundreds of character sets, fonts, and formatting tools out there,
and their output may not convert neatly to HTML email.  For things like bulleted and numbered
lists, put the mouse cursor on a bulleted line and see if the Bullet toolbar button activates.  If it
doesn't, then it isn't "really" a bullet and may not substitute neatly.  Reformat the pasted text as
necessary.

Message Options

Options on this tab that apply to creating the email message:

To save the email message for later reuse (including all text and attachment links) click the
Save button located to the right of the Subject line. (Messages are stored in the database,
so they are available to all users.)

To load a previously saved email message, click the Load button located to the right of the
Subject line. (See Loading Email Messages for details about the Load Message window.)

To Insert database fields in the email message so that MemberTies will use the appropriate
data for the current member, click  the Fields button to display the list of fields. Note that
database fields can only be used if you are using the Multiple Messages addressing
method (see Addresses Tab below). This restriction exists because if you are using the
Single Message method to send one message with everyone listed in the To/CC/BCC
fields, MemberTies will not know which recipient's record to use for the data.



MemberTies289

©1998-2014 Myrro International

See Using Database Fields for more information.

To add an attachment, click the Open File icon located to the right of the Attachment List.

To remove an attachment, select the unwanted attachment in the Attachment list, then
click click the Delete icon located to the right of the Attachment List.

To send an HTML formatted email, you must set the Format option to, "Send as HTML." 
This will cause the email engine to reformat the convert the message to HTML before
sending.  The formatting toolbar will also only display when this option is set to send as
HTML. Please also see the note above about pasting in text!

Additional options are available by right-clicking the message itself:

Insert Image - enables you to choose an image to be embedded into the message.
Note that some older email clients (software that reads email) will filter out embedded
images.

Insert Table - enables you to create a table

Insert Link - enables you to enter a URL or Email hyperlink:

Address - The actual URL or email address

Link Text - Typically identical to the Address, but can be different, such as "Click
Here". Note that any recipient who displays the email as text instead of HTML will
not be able to determine what the address would have been, as they will only see
the Link Text. 

Format Bullets and Numbering - opens the standard bullets and numbering dialog

Format Font - opens the standard font dialog

Options on this tab that apply to sending the email message:

To select an existing Email Profile, which determines what the return email address will be,
as well as the server through which the email will be sent, use the Email Profile dropdown. 

To open the list of Email Profiles so you can create a new profile or manage existing
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profiles, click the Open icon located to the right of the Email Profile dropdown. See
Working with Email Profiles for more information.

To change the priority with which the email will be sent (this may or may not be respected
by all email servers), use the Email Priority dropdown.

To cause MemberTies to open a read-only email preview window for each message before
it is sent, select the Preview checkbox (this option is only available when using the Multiple
Messages addressing method (see Addresses Tab below).

Addresses Tab - This tab is used to identify the email addresses to which the email message
will be sent.

The most important setting on this tab is the Addressing Method. There are two methods
available:

Multiple Messages - Selecting this option causes MemberTies to format a separate
message for each person in the address list.  Only one address is used per email. When
this option is selected, the list of database fields on the Message tab is available. This is
normally the preferred option.  This is the preferred option, because each person gets a
uniquely addressed email, and never sees the addresses of any other recipient. 

Single Message - Selecting this option enables you to choose which field (TO/CC/BCC) to
use for each address. The "TO" field is normally used for the primary recipient(s) of the
message; the "CC" field is normally used for people of secondary importance (i.e., people
being "copied" on the message); the "BCC" field is used for people who need to see the
message but whose addresses should be invisible to all other recipients (i.e., people being
"blind copied" on the message).  Note that this method is often faster when sending an
attachment, because only the attachment only has to be processed one time, rather than
once per recipient.

Note that you can use the "BCC All" button that displays when you choose this option to
automatically move the entire list of addresses to the BCC field.

After the Addressing Method is selected there are several icons below the Recipients list that
control additional options:

To prevent the member name from being displayed with the email address (i.e., to show
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"jsmith@myisp.com" instead of "John Smith <jsmith@myisp.com>", clear the "Show
Name with Address" checkbox.

To search for one or more membership records and automatically add their email address
(es) to the list, click the Search icon.

To manually add a new recipient to the list, click the Add icon. You will be prompted for the
name and email address.

To change a recipient, select it and click the Open icon.

To delete one or more recipients, select the ones you want to remove and click the Delete
icon.

To save the recipient list for future reuse (including the designations for the TO/CC/BCC
fields if appropriate), click the Save icon. Enter a file name when prompted.

To reload a saved recipient list, click the Open File icon. Note that reloading a save list
causes all addresses to be appended to the existing list. This enables you to open several
saved lists to create a combined list.

If the Recipients list contains duplicate addresses, you can clear them automatically by
choosing Remove Duplicates from the right-click menu.

Settings Tab - This tab is used to control miscellaneous mail sending options.

Enable Log - To generate a log of all communication with the email server (useful for tracking
down problems), select the Enable Log checkbox. The current log file may be viewed by clicking
the Open File icon to the right of the Enable Log checkbox. Note: Your password may appear in
the log in plain text.

Include Timestamp in Log File Name - Select this option to cause the log file name to
include the current timestamp, for example, "mtemail071405183025.log" for a log generated July
14, 2015 at 18:30:25.



Membership Records 292

©1998-2014 Myrro International

Validate Address List(s) before Sending - Select this option to have the system check each
email address for technical accuracy, i.e., the format of the address will be verified to conform to
the requirements of a valid email address. This does not insure that the address itself is valid or
that the mail will be delivered, only that the address is formatted correctly.  If this option is used,
the check will occur just before beginning the sending process. If any problems are found, the
offending address(es) will be highlighted in red italic text for easy identification, and you will be
given the opportunity to stop the process to correct them.

Transmission Control - If your ISP limits the number of messages you can send per minute,
per hour, or per connection, typically to try to prevent mass unsolicited email distribution, you
can enter the appropriate settings here to comply. 

Select the "Restrict the number of messages sent" checkbox, then enter the maximum number
of messages that can be sent in a minute, hour or in a given connection (email session). If you
select "per minute" or "per hour" the system will send up to the max messages allowed that
period, and then pause until the end of the minute/hour before starting the next batch. If you
select "per connection", the connection with the server will be broken and restarted for each
batch.

Note: If you are sending in Single Message mode with a number of addresses in the TO, CC, or
BCC fields, "one" message can contain an unlimited number of recipients, unless limited by the
"Max Recipients" setting (see below).

Max Recipients - This option only applies when sending in "Single Message" mode. If your ISP
limits the number of recipients that can be in a single email message, set the value here. If you
enter 10 for example, the system will process the message several times, adding recipients
from the To list, then the CC list, then the BCC list, until the maximum number is reached. Then
the message will be sent, and it will start a new message and select new people from each list
in turn, repeating the process until all addresses in the TO, CC, and BCC lists have been
accounted for.

Control Address - If you would like the system to send a final email to a specific address (as a
check to verify that all messages were processed) enter that address here.  The email will be
addressed to a person called, "Control Address" at the address you specify.  Note that if you
are using the "Single Message" addressing option, this address will be added to the BCC list.

Save Messages to Sent Mail - Select this option to save a copy of the mail message to the
Sent Mail list. Note that it is important to understand that a message will be saved to the Sent
Mail list regardless of whether it is successfully delivered. All the system knows is that the
message was sent to the specified mail server for delivery. It does not know whether the server
ever delivered it, whether it bounced back, or whether or not it was read.

Request Read Receipt - Select this option to send a request that the receiving email program
notifies you when the message is opened/viewed. Note that this is NOT fool-proof, and does
NOT guarantee in any way that a message has or has not been received.  Many people turn off
read-receipts because automatically returning receipts is guaranteed to increase the amount of
junk email you receive (because that automatic reply tells the spammer that your address is a
real or "live" one, and therefore a good candidate for even more junk mail). But if the recipient
has their email software configured to allow receipts, this option will request one.

3 The final tab is the Sent Mail Tab. This tab displays copies of email messages that were sent
while the "Save Messages to Sent Mail" setting was selected. See Viewing Sent Mail for
complete information about this tab.
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You can filter the list to only messages containing specific text. Enter the text to be found in the
Find Text field, and choose the field (or all) to be searched. Click Search to filter the list, or
Reset to clear the filter and show all messages again.

 

18.5.9 Working with Previews

With MemberTies Professional, you can define one, two, or three data previews each for the membership
list, group list, and activity list. A preview is a quick synopsis of additional information about the currently
selected list record.  Different lists have different preview data available. This example shows two of the
available previews for the Group List.

Setting or Changing Previews

1 Open the desired list (this procedure applies equally to the membership, group, and activity
lists).

2 Choose Actions > Preview

3 When the Setup Preview Display window opens, select the "Enable Preview Display" option.
This will enable the list of available preview choices.

4 You may choose a Left, Center, and Right preview. The previews correspond to the left, center,
and right thirds of the preview display area on the list.  

Note: Depending on the resolution of your computer monitor, three previews may not fit.

5 When you have made your selections, click OK.
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Disabling Previews

1 Open the desired list.

2 Choose Actions > Preview.

3 When the Setup Preview Display window opens, select the "Disable Preview Display" option.  

4 Click OK. The list window will redisplay, hiding the preview area.

18.5.10 Viewing Contact Information

You can quickly display contact information for a given membership or group record.

Viewing Contact Information

1 Open the List containing the appropriate record:

For a Membership record, choose File > Workspace > Membership List.

For a Group record, choose File > Workspace > Group List.

2 Select the record you want to display.

3 Choose Actions > Display Contact Info.

The window is divided into three tabs:

Address -- Shows the current address.

Phone List -- Shows all phone numbers
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Email/Web -- Shows the email address and website

All tabs have a "Copy" button enabling you to copy only the data on that tab. An additional
"Copy All" button is provided to copy all data from all tabs at once.

18.6 Working with Views

18.6.1 Overview

A "View" is simply a layout of either the Activity, Membership, or Group List consisting of one or more
columns of data representing the fields you want to see.

Note: The Views topics appear under help chapters for each type of list. The process for using views is
the same regardless of the list the view is for.

You work with views via the Maintain Views window. To open this window for the list you're on, click the
Views toolbar button.

MemberTies ships with a single view of both lists, designed to display the most common information
about a record. The default views do not include all available fields, because displaying more fields
means retrieving more data from the database for each record, and retrieving data takes time.  Of
course, you know your computer better than we do, so if it's happy retrieving more fields and more data,
we're happy too.

With MemberTies Professional, you can create your own views to use with the Activity, Membership,
and Group List. This powerful feature puts the decision making totally in your hands, allowing you to
choose whatever fields you want. You have the ability to place them in any order, set both a primary and
secondary sort order (i.e., by City, then by Last Name), and even change the text displayed for the
column headings.
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The Views you define will work just like the standard lists. Clicking a column heading will still sort the
whole list, menu options will remain the same, and you can still open and add records normally. Even if
you create a view that only shows the City (which would make it very hard to distinguish one record from
another), if you select one of the rows in the list and open it, MemberTies will still know what record it is
and will open it normally.  

Tip: You can rename a view from the Maintain Views window. Just right-click the view you want to
change and choose Rename from the popup menu.

  

18.6.2 Working with Views

You can create views for the Group List and the Membership List by opening the Maintain Views
window. 

Adding a View

 1 Open the List to which the View will apply.

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
This window displays all views that are currently available for the list you are on. In other words,
if you open the window from the Group List, you won't see any membership views.

 3 When the Maintain Views window appears, click Add. This will open the Add View window for a
new view.

 4 The details of using the Add View window are fairly extensive, so it is described on a separate
topic. See Maintaining Views for complete information about adding, editing, or previewing a
View.

 5 If you want the view to be applied when you close this window and return to the Membership or
Group List, be sure the "Apply Selected View on Close" checkbox is selected before you close
the window.

Changing a View

 1 Open the List to which the View will apply.

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, or click the Views toolbar button to open the Maintain Views window.
This window displays all views that are currently available for the list you are on. In other words,
if you open the window from the Group List, you will see Group List views, not membership list
views.

 3 When the Maintain Views window appears, select the view you want to change, then click Open
.  This will open the Edit View window.
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 4 Make your changes, then click OK.

Deleting a View

 1 Open the List to which the View will apply.

For a Membership List view, choose File > Workspace > Membership List.

For a Group List view, choose File > Workspace > Group List.

 2 Choose Actions > Views, to open the Maintain Views window.  This window displays all views
that are currently available for the list you are on. In other words, if you open the window from
the Group List, you won't see any membership views.

 3 When the Maintain Views window appears, select the view you want to delete, then click Delete
.

 4 Confirm the deletion.

Note: If the deleted view was currently in use, it will remain active until the Membership/Group
List is closed and reopened. At that time, the system will use the new default view if one is
available, or will revert to the system-defined view if there is no default.

18.6.3 Using the Add/Edit View Window

This window is divided into two tabs. The Define Fields tab must be completed and changes applied
before the Preview tab is available. If you have opened an existing View, the Preview tab is available
immediately, but if you make any changes on the Define Fields tab, the Preview tab will be disabled
again until the new changes are saved.

Note: This procedure assumes that you have already opened or started a new View; if not, see Working
with Views for details. 

The Define Fields Tab
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 1 If you are creating a new View, enter a name in the "View" field. 

 2 To make this View appear immediately whenever the list is opened, select the Default View
checkbox.

 3 Select fields for the view. Use the left and right arrow buttons to move fields back and forth
between the Available Fields list and the Selected Fields list. All fields that are visible in the
Selected Fields list will be shown on the completed View.

 Note: The top-to-bottom order of fields in the Selected Fields list represents the left-to-right
order the columns will take on the View. In other words, the first (top) field in the Selected Fields
list will appear as the left-most column on the View.

Things to Consider when choosing fields:

When choosing fields, it is very important to consider the primary data type of the view you are
creating.  Even though you can choose almost any activity, group, or membership field, they
can change the behavior of the view based on the primary data type.  For example, if the primary
data type is Membership Data, adding activity fields will convert it into an "activity attendance"
style of view, where only members who have attended an activity will display. Likewise, adding
dues posting fields to a membership view will turn it into a dues postings view, and only
members who have dues postings will be considered.
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Primary Data
Type

Type of Field
Added

Restricts the View to:

Membership Membership No Restriction

Activity Members who have attended at least one activity.

Posting (Dues) Members who have at least one dues posting.

Posting
(Donations)

Members who have at least one donation posting.

Group Members who are assigned to at least one group.

Activity Activity No Restriction

Membership Activities with at least one attendee

Posting
(activity)

Activities with at least one posting (attendee or non-attendee)
unless a membership field is also used, in which case the
postings must be tied to an attendee.

Custom Field Activities with at least one attendee (custom fields represent
membership custom fields when used on an activity report).

Group Group No Restriction

Membership Groups with at least one assigned member.

 4 If you want to adjust attributes for a field in the Selected Fields list, select the field you want to
change and click Open to open the Field Properties window. See Changing Field Properties for
complete details. Make the desired changes, then click OK to save the new properties.

 5 Adjust fields up and down in the Selected Fields list to put them in the correct left-to-right order.
The top of the list is the left-most column, and the bottom of the list is the right-most column.

 6 When you are ready to display the View, click Apply to save changes, then click the Preview
tab.

The Preview Tab

The Preview tab enables you to see what the View will look like, to make changes to the widths of
columns, and even adjust the column order again.



Membership Records 300

©1998-2014 Myrro International

 1 The Record Limit field below the list can be used to prevent the preview window from returning
an unnecessarily large number of records for viewing. This setting has no effect on the way the
View will work on the list -- it only applies to the Preview. 

 2 Click the Adjust Column Widths button to shift the preview into editing mode. In this mode you
can:

Drag the border between column headings to resize the column.

Drag an entire column by its heading to change its position.

Tip: To adjust the width of the right-most column, drag the whole column to the left one column
position by clicking and holding the column heading. That will enable you to "grab" the right-
hand edge with the mouse, adjust the width, then drag it back to its former position on the right.

 3 When you're finished, click the Return to Preview button.

Once you have the view the way you like it, close the window and return to the Maintain Views list. From
there, you can select the new or modified view and apply it to the current list.

 

18.6.4 Changing Field Properties

The Field Properties window is available for any field on a user-defined report, label, or view.  
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To change the properties of a field on a user-defined report, select the desired field in the Selected Fields
list, then click Open.

The properties vary by type of report/view, as described below.

The following fields are available:

Name: The name may be changed for your own reference, even if it doesn't appear on the report
(such as for a mailing label).

Hide Data - Select this option to hide the entire field. This is helpful if you only want to use the field
for sorting, but don't want to actually see it. For example, suppose you use the combined First
Name/Last Name smart field on the report, but want to sort on the last name only. Since the
combined field shows the first name first you can't sort on the last name portion; instead, add the
last name field and mark it as the appropriate sort, and then make it hidden to solve the problem.

Hide Heading: If you want to see the field, but want the heading left blank, select this option. This
field is not available to mailing labels or other report that don't have column headings.

Sort: Choose the sort order if this field should be used for sorting. It is important to at least choose
one sort field (1st). If no sort is chosen, the records will be returned in the order they are found in the
database, which may not be the way you want to see them. You do not have to use every available
sort order.

Bold: Select this option to display bold text.

Italic: Select this option to display italic text.

Underline: Select this option to display underlined text.

Font: Choose a specific font face and height for this field, or select "Use Default" to take the default
font settings  from the Define Fields tab.

Font Color: Defines the color used for the field data.
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Back Color: Defines the color used for the field background. This option is not available to Views.

Case: Choose whether data should be forced to appear in uppercase, lowercase, or "any" case (i.e.,
as entered in the database).

Alignment: Choose the alignment setting for data in the field. 

Calculate: For numeric data fields, you can choose to produce a total or average of the column in
the summary area of the report. This option only applies to standard columnar reports, not to labels
or directories.

PreText: Text entered here will be displayed to the left of the data for this field (you can leave
leading or trailing spaces in this field). Tip: If you want to force a blank line to appear above a
particular line (for a Roster style report), enter "~r~n" (without the quotes) in the pretext field. This
code means "carriage return/line feed" and will cause a blank line to be produced before the data of
the field. This field is not available to Views.

PostText: Text entered here will be displayed to the right of the data for this field (you can leave
leading or trailing spaces in this field). This field is not available to Views.

PreText and PostText are designed to be used however you choose. One possibility is to use
PreText in place of the column heading. In other words, if the column's "Hide Heading" checkbox is
checked, no heading will appear. Instead, you could use PreText to show the same "heading" in
front of each field to display. For example, a telephone entry on one line might show, "Tel: 123-456-
7890" by using a pretext value of. "Tel:".

18.6.5 Exporting Data with Views

The easiest way to export data from MemberTies is to use Views. You can create a view that contains
exactly the fields you want to export and then use Save As to save the data to a file. The file created will
contain the same data that is displayed on-screen.

To Export Data from a View

 1 Open the Membership or Group List and apply the View of your choice. For instructions on
creating or applying Views, see Working with Views.

 2 Search for the data that you want to export. For example, to export members living in "Anytown,
USA", enter the appropriate search criteria and  display those records.

 3 Select the Results tab, then choose File > Save As > [file type] to save the data to a file.

Note: The best format to export data to is Text. Text files are universal, and can be read by
almost any program. The text file export was written by Myrro International for use in
MemberTies, and it will try to use the names of fields as you see them on-screen, rather than
the database names. i.e., you will normally see "Last Name", not "lname".

You can save data in other formats, but the results may vary widely. In addition, formats other
than "Text" will use the database column names, not the field names you see on-screen. This is
because these are not formats controlled by us, and we can only "dump" data directly to them
without any manipulation.
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18.6.6 Exporting or Importing Views

Any user defined report, card, label, view, etc., can be exported to a file and then imported by another
user.

Exported reports/views are saved to a special ".mtx" (meaning "MemberTies export") file. These files can
be used to import the report later, as long as no report or view already exists by the same name (unless
you want to overwrite it).

Note: Do not attempt to modify the exported file using any kind of word processor or text editor.  It
contains some fairly complex data structures, and altering the file may render it unusable.

Exporting a User Defined Report or View to a File

1 For reports, choose File > Workspace > Reports, then choose Actions > User Reports, 

or...

For views, choose File > Workspace > Membership List or Group List, then choose Actions >
Views.

2 When the list of views or reports appears, use the right mouse button to click the one you want
to export, then choose "Export to File..." from the popup menu.

3 Click OK when prompted to confirm the export.

4 When the "Save As" window opens, enter the name of the export file you want to create, then
click Save. (It is a good idea to name the file similar to the report or view, so you can tell what it
is later.)

Importing User Defined Reports or Views

Exported reports and views can only be imported to the same software version that was used to export
it.  That means if you export a file using MemberTies version 6.0, you cannot import it to version 6.1.
This prevents potential conflicts that could arise due to database or programming changes.

1 Choose File > Workspace > Reports, then choose Actions > User Reports, 

or...

Choose File > Workspace > Membership List or Group List, then choose Actions > Views.

2 When the list of views or reports appears, use the right mouse button to click anywhere on the
list, then choose "Import from File..." from the popup menu.

Note: It does not matter whether you click on a row or not, just click anywhere in the list.

3 Click OK when prompted to confirm the import.

4 When the "Select File" window opens, enter the name of the previously exported file you want to
import, then click Open.

5 A message will be displayed for you to confirm the import. If you want to continue, click OK.

6 If the report or view being imported already exists, you will be prompted to overwrite the existing
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data.

7 If the import is successful, the new report or view will appear in the list and will be immediately
ready for use.

18.7 Maintaining Member Records

18.7.1 Working with Members

New membership records can be added to the database whenever the Membership List is active.  

Note: If you are using a database that does not have a license assigned to its profile, you are limited to
twenty (20) membership records. See Registering for more information.

When a new record is created, the system will populate some fields by selecting the default codes
specified in your database. This applies to the Address Name (for MemberTies Professional), State/
Province, Country, Reference, Phone Type, and Status fields. In addition, new records are automatically
tied to any group records that have been set as Auto Relate groups.

Adding a Member

1 Choose File > Workspace > Membership List.

2 When the Membership List appears, choose File > Add Member.  You can also click the Add
toolbar button. This will open the Details window for a new record.

3 The Details window consists of several tabs, each of which are designed to track a certain type
of information.

General Tab - Contains basic name, address, and phone number information.

Status Tab - Contains information about the current status of the membership, including
the status itself, the start and end dates (typically the date the person joined the group or
was entered in the database, and the date on which their current membership will expire). 

Note: If your computer monitor has a high enough resolution (1024 x 768 or higher) this tab
is hidden and its information is included on the General Tab.

Private Tab - Displayed for MemberTies Professional only, this tab contains private or
confidential information that will not appear on system reports or searches (though you can
add it to user-defined reports if you wish).

Dues Tab - Contains the financial record for the member. It is simply referred to as "Dues,"
but it really represents the member's "account" with the group.

Donations Tab - Displayed for MemberTies Professional only, this tab contains the
donation record for the member. Entries are separate from Dues to avoid affecting the dues
balance.

Items Tab - Contains a record of Items that have been assigned to this member.

Related Tab - Contains lists of other members and groups to which this record is related or
associated in some way.
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To Do Tab - Contains a list of To Do items that have been assigned to this member.

Custom Tab - Contains custom fields that can be used for whatever data you desire.

Activities Tab - Displayed for MemberTies Professional only, this tab contains information
about activities the member has attended, and enables you to add the member to
additional activities.

4 Complete all appropriate information, then click OK.

Tips

If you would prefer that the cursor begin new records in the First Name field instead of the Prefix,
you can specify this with a Membership Preference. See Membership Preferences for more
information.

Your changes may not appear in the Membership List until it is Refreshed.

Select the Add Another checkbox before you save the record if you plan to add several records.

You can load or update member information from a scanned driver license. See Scanning a Driver
License for details.

Changing a Member

1 Choose File > Workspace > Membership List.

2 Select the member you want to change, then choose File > Open Member, or click the Open
toolbar button. This will open the Details window for the record.

3 Make your changes, then click OK.

Deleting a Member

1 Choose File > Workspace > Membership List.

2 When the Membership  List appears, select the record(s) you want to delete, then choose File
> Delete Member, or click the Delete toolbar button.

With membership records, the message you receive when you click delete depends upon the
Delete Action membership preference. There are two settings for this preference, which cause
different behaviors:

Delete Immediately - The system treats the record just like any other type of record -- you
receive a prompt as shown above, and may click OK to permanently delete the record.

Change to (Delete) Status - The system checks the status of the record first and acts based
upon the current status: 

If the status is anything other than "(Delete)," the record is changed to the (Delete) status. This
essentially places the record in a "delete queue." All records with a status of (Delete) will be
deleted automatically by the system when you exit MemberTies.

If the status is already "(Delete)," you will receive the standard prompt and if you click OK, the
record will be permanently deleted. In this case, you are essentially deleting a record from the
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queue before the system gets a chance to do so.

Note: There are two other Logoff preferences that apply to records in the (Delete) status: "Auto-
Delete (Delete) Status" and "Prompt Before Deleting." These control whether the system even
has the right to delete records in the (Delete) status and whether you should be prompted before
it does. See Logoff Preferences for more information.

 

18.7.2 Friends and Family

One of the most common questions we receive is, "how should I track spouses and children?" 

There are two primary methods of tracking these "other people", and the method that works best for you
depends on how you classify these people, and what you need to track.

Associated Members

An associated member is normally used when the "other" member is a true dues-paying member of
your organization. 

This kind of record has its own Member ID, they receive mailings and email, they can pay dues,
make donations, have their own To Do items, etc.  Associated members are full membership
records.

Normally, an Associated member record would be a mentor, a golf partner, a spouse who is a full
member, a referring member, etc.

See the Associated Tab for more information about adding this kind of record.

Friends/Family 

A Friend/Family record is normally not a member of the organization. These are the children,
spouses, etc., of your true members whose information you need to know for various reasons; but,
are not actual dues-paying members.

All Friend/Family records are subordinate to the master Member record. In other words, the system
assumes that they are never contacted directly, queried for (with the exception of activity
attendance, see below) or reported on.  Email and mailings would go to the main dues-paying
member. 

Friends/Family records have only a few fields of key information, such as name, birthdate, sex,
photo, and a contact name and phone number (i.e., an emergency contact).

Friends/Family records can be checked-in to activities just like regular members, to allow situations
where the member's family attends the gym, pool, etc. But even in this situation, associated activity
income and expenses tie back to the main member because that is the person the system
assumes pays the bills. (Note that the "Allow Check-In" checkbox can be cleared on any Friends/
Family record that should not be available to activity check-in searches.)

Normally, a Friend/Family record would be a non-member spouse, a child, or another person of
interested that is linked to the member..
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See the Friends/Family Tab for more information about adding this kind of record.

18.7.3 Building an Email List

You can build an email list from a selection of records. The list can be saved as a text file, or copied
directly to the clipboard so you can paste it into an email program. Only unique email addresses are
included in the list. If more than one record has the same address, the address will only appear in the
list once.

When the email list is created, only records containing an entry in the Email field will be used. If you
select records that do not contain an email address, the list will be empty.

Building an Email List

1 Search for the appropriate records on the membership or group list. (This procedure applies to
both the membership and group lists.)

2 On the Results tab, select one or more records to use for the email list.

3 Choose Actions > Build Email List.

4 When the Build Email List window opens, select the following:

Separator - The type of separator, or delimiter, to place between names in the list. The list will
be generated as one long line (unless you choose a carriage-return separator), with each email
address separated from the previous one by the separator you choose. The type of separator to
choose will depend upon what you want to do with the list and/or what your email software
requires.  

Output - Choose the way you want to handle the finished list. You can copy the list
immediately to the clipboard, so you can open your email program and paste the whole list into
an address field, or you can save the list to a text file for future use. 

For example, if your email program expects a semicolon between each address, you would use
the semicolon separator, and then you could choose an output to the clipboard so that you
could immediately paste the results into the "To:" field of your email program.

5 Click OK to build the list.

If you selected to save the list as a file, MemberTies will try to open a text editor to display the file
(typically Notepad). If a text editor cannot be found, a message will tell you where the file is located so
you can open it in another program.
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18.7.4 Changing Data (Bulk)

You can change a number of fields' data for multiple records at once from the Membership List.

This window includes three tab pages, each enabling you to modify a different type of data.  Any
changes made on any tab page will affect all selected membership records when you click Update.

Changing Data in Bulk
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1 Choose File > Workspace > Membership List.

2 Select the record(s) you want to change.

3 Choose Actions > Change Data (Bulk).

4 When the Mass Data Change window opens, enter data in any field you want to change.

Note: To clear a field, select the "Clear" checkbox to the right of the field.  If no checkbox is
available, the field may be a required system field, defined as required (for a custom field) or
may require a choice from a dropdown list of options. 

Note: Each membership record must have either a first and last name, or a company name.  If
you choose to clear one of these fields, the system will not update the record if doing so would
violate this rule. i.e., if you try to clear the company name, and one of the selected records has
no first or last name, the update will be ignored on that record.

5 When you are ready to apply changes, click Update.

 

18.7.5 Maintaining a Member Photo

You can associate a .bmp, .gif, .jpg, .jpeg, .wmf, or .rle photo file to any membership record. 

Note: The database will either contain the path to the file, or the actual file itself, based on the File &
Photo Storage database preference.  If you choose to store  the path to the file it is important to
remember to move all photo files if the database is ever moved to another machine.  This also means
that updating an existing photo is as easy as putting the new file in your photos directory. As long as
the name is the same, it will appear on the member's record automatically.  Despite this, the
recommended method is to store the file in the database, to ensure that it cannot be lost (and if you are
running multiple installations, it may be the only way other users can see the same photo).

Adding or Viewing a Photo

1 From the General Tab of a membership record, click the Photo icon, or select a membership
record on the Membership List and choose Actions > Display Photo.
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2 When the Photo window opens it will automatically display the photo associated with the
member, as well as the photos of all Friends & Family records if available.   If no photo is
available, a browse window will open automatically so you can select the photo file.

All photos are shown in miniature along the left side of the window.  The photo for the member is
always shown at the top, and then Friends/Family photos are shown below, sorted by first
name.

3 The list of photos on the left side may be scrolled using the scrollbar, and clicking any one of
them will display the larger version in the main viewing area.  Photos are automatically resized
to fit the display area. 

The following icons are also available along the right-hand edge of the window. This icons always
affect the currently displayed photo:

Toggle Size - changes the photo from a "scaled to fit" version, to the full sized version.

Print - displays a printer window and prints the full photo

Delete - removes the photo from the associated record

Browse - enables you to assign a different file to the currently displayed photo



MemberTies311

©1998-2014 Myrro International

4 When you're finished, click OK.

Other Notes:

If you are storing photos in the database, the name of the photo will change to something
like, "Stored ID: 36" after it has been successfully saved.  When opening a stored photo,
the system recreates the photo file in a temporary directory and then displays it.

This window uses a powerful image viewer to display photos.  However, the Photo ID Card
report doesn't have this capability. The report will always display photos in a normal portrait
(taller than wide) format. So while you can store any size of photo and display it on this
window, only normal ID card style photos will look good on the report.

Digital cameras can be set to take very high resolution photos capable of filling a large
computer monitor with a razor sharp image.  This is great for photos that may be enlarged
or printed, but it will require a lot of disk (or database) storage, and is overkill for an ID card.
 We strongly recommend using a graphics tool to resize photos to approximately 2" x
3" (144 x 216 pixels, 5.0 x 7.6 cm). This is enough for excellent clarity while only requiring
about 50 KB of storage or less. 

18.7.6 Using Multiple Addresses

With MemberTies Professional, you can assign more than one address to membership and group
records. Each address can be given a unique name such as "Summer Home," "Winter Home", "Billing,"
"Mailing,", etc. Each address appears as a separate address tab so you can switch between addresses.
 

In the following example, the record includes two addresses, one called "Main Address", and another
called "Summer Home."

Multiple addresses and the date ranges assigned to them can greatly simplify the task of keeping track
of which address to use when members have both summer and winter homes.  The primary rule involved
with multiple addresses is that one (and only one) address must be "Current" at all times.
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Adding a New Address

1 Right-click the address tab, and choose the New option from the popup menu. (This is also
where the option to delete an address is found.)

 

2 A new tab will be created with a name of "<New Address>".

The text on the tab will match the Address Type on the address. You may either type a new
address type, or select an existing predefined address type from the dropdown in the Address
Type field. After you enter or choose a type and move to another field, the tab will be updated to
reflect the change.

3 Since this is a new address, the "Current" checkbox is not checked. The system assumes the
first address will remain the current, active address.  If you want this address to be current
instead, select the checkbox. See below for more information about the current address.

4 Complete the address fields appropriately.  The record now has multiple addresses, and you
can switch between them by clicking the tab for the desired address.

Renaming an Address

1 Use the Address Type dropdown to choose the new Address Type. The tab will be updated once
the change is applied.
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Deleting an Address

1 Right-click the tab for the address you want to remove.

2 Choose the Delete option from the popup menu.

3 Confirm the deletion. The system will change to a different existing address if the record has
one. (Note that at least one address must exist, so the system won't let you delete the last
address.).

The Current Address

When generating reports, the current address will always be used by default. However, many reports
enable you to build your own criteria, in which case you can choose to select all addresses, or only non-
current addresses. In addition, you may be able to further qualify the selection by requiring a specific
Address Type.  In general though, the Current Address should represent the address to which mailings
should be sent.

For example, you could create report criteria that always uses the Current address, OR any address
called "Additional Mail", which might represent people who have requested two copies of a newsletter,
one to their home, and one to another (the Additional Mail) address.

Setting the Current Address

The current address can either be set manually by choosing the "Current" checkbox, or automatically by
the system based on date ranges. 

Manual: Select the "Current" checkbox on the appropriate address on the record.  In order to use
the Current checkbox, there cannot be any date ranges assigned to any address associated to
the record.

Automatic: For each address on the record, create a date range within which the address is
current (i.e., a person's summer address might be valid from June 1st to September 1st).  Each
time the application is started, all ranged addresses are checked and the appropriate address is
made current.  A record cannot be saved until all 365 days of the year are covered by an address
range (February 28 and 29 are considered the same) without any overlapping. This ensures that
on any given day, a single address will be current.

Note: Do not create date ranges unnecessarily. If a record only has a single address, don't create a
range that covers the entire year. Doing so will cause the record to be checked by the system every
time the application starts to see if it is current or not. Since it will always be current, this is a waste of
system processing time.

Address Types

Each address should have a unique type. To ensure consistent naming, you can predefine a list of
Address Types and set one of them as the Default. The system will assign the default address type to
the first address created on any record. See Maintaining Address Types for more information. 

Multiple Addresses and Searching for Records

When searching for records, you can use the Addresses dropdown on the Search tab to restrict the
search to only the Current address, Non-Current addresses, or all addresses. If a record has more than
one address and you choose "All Addresses", the record will appear in the Results list once for each
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address that is found.

18.7.7 Scanning a Driver License

If you have a magnetic card scanner, you can fill or update the fields on a member record by using the
Scan Driver License window from the member record.

Note: The Enable Driver License Scan membership preference must be turned on before the Scan
button will appear on the member Details window. 

Scanning a Driver License

1 Create a new member record, or open an existing one that you want to update with scanned
information.

2 Click the "Scan" button in the lower left corner.  If this button is not available, check the
preference. The Scan Driver License window will open.

3 The cursor should start in the "Scan" field at the top of the window. If you clicked one of the
other fields by mistake, click the Reset button.

4 Scan the driver license. The data will feed into the Scan field and when the scan is finished, the
data will be removed, parsed, and loaded into the appropriate fields.
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Note: If no data appears when the card is scanned, or if nothing is read, the card probably
doesn't follow the AAMVA Specification. Since states can choose not to follow this
specification, the system has no way of knowing how to deal with the incoming data, so it must
be ignored.

5 The system automatically uses the name, address, birthdate, and sex information. You have the
option of using any or all of the License Number, Height, Weight, Hair Color and Eye Color data.
 To use this data, you must choose the destination field on the right. For the License Number,
you can use the Member ID, or any custom field. The other fields can only be directed to
custom fields.  If you don't want to use the field data at all, leave the destination blank.  Your
settings will be stored for future use.

Note: If the city on the driver license is not in the database, the system automatically adds it
without any prompt.

6 When you are happy with the settings, click Use to close the window and send the data to the
member record.

18.7.8 Sending Email

With MemberTies Professional you can send email to members, groups, and attendees of activities
using your Internet account.  When you open the email window, it will automatically populate itself with
email addresses based on where you were when you opened the window, as described below.

When email is sent, there are various ways to address the message(s). You can choose to put email
addresses in the "To", "CC", or "BCC" fields of the message (i.e., the old-fashioned way), or you can
have MemberTies generate separate, individually addressed messages, one for each person on your
address list (i.e., the more modern way).  The second, more modern method is normally preferred,
because it looks more professional and prevents others from seeing the email addresses of your other
members.

Warning: SPAM email (also known as unsolicited commercial email) is a growing problem on the
Internet today.   If we determine that you are using MemberTies Professional to send SPAM, we will
terminate your license and report you to the appropriate authorities. Using MemberTies Professional to
send unsolicited email (SPAM), or to transmit illegal content is expressly forbidden.

Note: You must have your own Internet connection in order to send email.

Sending Email

1 All email activity is performed on the Send Email window. There are several different ways to
open this window, depending on what you want to do. If you want to send email to:

The contact email addresses for one or more groups - select the desired group(s) on
the Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Only". The
contact email address for each selected group will appear in the Addresses tab.

The associated members of one or more groups - select the desired group(s) on the
Group List, then click the Email toolbar button or choose Actions > Send Email.  When
prompted to send to either the group or the groups members, choose "Group Members".
The contact email address for all membership records associated with each selected group
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will appear in the Addresses tab.

One or more membership records - select the desired member(s) on the Membership
List,  then click the Email toolbar button or choose Actions > Send Email.  The email
address for all selected records will appear in the Addresses tab.

The attendees of one or more activities - select the desired activity(s) on the Activity
List, then click the Email toolbar button or choose Actions > Send Email.  The email
address for all attendance records associated with each selected activity will appear in the
Addresses tab.

There are also various places in the system where an email address is displayed as a data-
entry field. When an Email icon appears next to a field, you can click the icon to open the Send
Email window with the current address displayed.  In addition, the Email toolbar button is
always available even when no list is open. This enables you to open the Send Email window
and enter your own addresses, i.e., without bring in any existing email addresses.

2 Once the Send Email window opens, there are several tabs available that affect or control the
sending of the message:

Message Tab - This tab is used to define the email message text, add attachments, and select
the email Profile that will be used to send the message.

Pasting In Message Text

While it is possible to cut/paste an email message from another source, such as a word
processing document, another email client, etc., you should be sure to send a test message to
see how it converts.  There are hundreds of character sets, fonts, and formatting tools out there,
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and their output may not convert neatly to HTML email.  For things like bulleted and numbered
lists, put the mouse cursor on a bulleted line and see if the Bullet toolbar button activates.  If it
doesn't, then it isn't "really" a bullet and may not substitute neatly.  Reformat the pasted text as
necessary.

Message Options

Options on this tab that apply to creating the email message:

To save the email message for later reuse (including all text and attachment links) click the
Save button located to the right of the Subject line. (Messages are stored in the database,
so they are available to all users.)

To load a previously saved email message, click the Load button located to the right of the
Subject line. (See Loading Email Messages for details about the Load Message window.)

To Insert database fields in the email message so that MemberTies will use the appropriate
data for the current member, click  the Fields button to display the list of fields. Note that
database fields can only be used if you are using the Multiple Messages addressing
method (see Addresses Tab below). This restriction exists because if you are using the
Single Message method to send one message with everyone listed in the To/CC/BCC
fields, MemberTies will not know which recipient's record to use for the data.

See Using Database Fields for more information.

To add an attachment, click the Open File icon located to the right of the Attachment List.

To remove an attachment, select the unwanted attachment in the Attachment list, then
click click the Delete icon located to the right of the Attachment List.

To send an HTML formatted email, you must set the Format option to, "Send as HTML." 
This will cause the email engine to reformat the convert the message to HTML before
sending.  The formatting toolbar will also only display when this option is set to send as
HTML. Please also see the note above about pasting in text!

Additional options are available by right-clicking the message itself:

Insert Image - enables you to choose an image to be embedded into the message.
Note that some older email clients (software that reads email) will filter out embedded
images.

Insert Table - enables you to create a table

Insert Link - enables you to enter a URL or Email hyperlink:
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Address - The actual URL or email address

Link Text - Typically identical to the Address, but can be different, such as "Click
Here". Note that any recipient who displays the email as text instead of HTML will
not be able to determine what the address would have been, as they will only see
the Link Text. 

Format Bullets and Numbering - opens the standard bullets and numbering dialog

Format Font - opens the standard font dialog

Options on this tab that apply to sending the email message:

To select an existing Email Profile, which determines what the return email address will be,
as well as the server through which the email will be sent, use the Email Profile dropdown. 

To open the list of Email Profiles so you can create a new profile or manage existing
profiles, click the Open icon located to the right of the Email Profile dropdown. See
Working with Email Profiles for more information.

To change the priority with which the email will be sent (this may or may not be respected
by all email servers), use the Email Priority dropdown.

To cause MemberTies to open a read-only email preview window for each message before
it is sent, select the Preview checkbox (this option is only available when using the Multiple
Messages addressing method (see Addresses Tab below).

Addresses Tab - This tab is used to identify the email addresses to which the email message
will be sent.
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The most important setting on this tab is the Addressing Method. There are two methods
available:

Multiple Messages - Selecting this option causes MemberTies to format a separate
message for each person in the address list.  Only one address is used per email. When
this option is selected, the list of database fields on the Message tab is available. This is
normally the preferred option.  This is the preferred option, because each person gets a
uniquely addressed email, and never sees the addresses of any other recipient. 

Single Message - Selecting this option enables you to choose which field (TO/CC/BCC) to
use for each address. The "TO" field is normally used for the primary recipient(s) of the
message; the "CC" field is normally used for people of secondary importance (i.e., people
being "copied" on the message); the "BCC" field is used for people who need to see the
message but whose addresses should be invisible to all other recipients (i.e., people being
"blind copied" on the message).  Note that this method is often faster when sending an
attachment, because only the attachment only has to be processed one time, rather than
once per recipient.

Note that you can use the "BCC All" button that displays when you choose this option to
automatically move the entire list of addresses to the BCC field.

After the Addressing Method is selected there are several icons below the Recipients list that
control additional options:

To prevent the member name from being displayed with the email address (i.e., to show
"jsmith@myisp.com" instead of "John Smith <jsmith@myisp.com>", clear the "Show
Name with Address" checkbox.

To search for one or more membership records and automatically add their email address
(es) to the list, click the Search icon.

To manually add a new recipient to the list, click the Add icon. You will be prompted for the
name and email address.

To change a recipient, select it and click the Open icon.

To delete one or more recipients, select the ones you want to remove and click the Delete
icon.
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To save the recipient list for future reuse (including the designations for the TO/CC/BCC
fields if appropriate), click the Save icon. Enter a file name when prompted.

To reload a saved recipient list, click the Open File icon. Note that reloading a save list
causes all addresses to be appended to the existing list. This enables you to open several
saved lists to create a combined list.

If the Recipients list contains duplicate addresses, you can clear them automatically by
choosing Remove Duplicates from the right-click menu.

Settings Tab - This tab is used to control miscellaneous mail sending options.

Enable Log - To generate a log of all communication with the email server (useful for tracking
down problems), select the Enable Log checkbox. The current log file may be viewed by clicking
the Open File icon to the right of the Enable Log checkbox. Note: Your password may appear in
the log in plain text.

Include Timestamp in Log File Name - Select this option to cause the log file name to
include the current timestamp, for example, "mtemail071405183025.log" for a log generated July
14, 2015 at 18:30:25.

Validate Address List(s) before Sending - Select this option to have the system check each
email address for technical accuracy, i.e., the format of the address will be verified to conform to
the requirements of a valid email address. This does not insure that the address itself is valid or
that the mail will be delivered, only that the address is formatted correctly.  If this option is used,
the check will occur just before beginning the sending process. If any problems are found, the
offending address(es) will be highlighted in red italic text for easy identification, and you will be
given the opportunity to stop the process to correct them.

Transmission Control - If your ISP limits the number of messages you can send per minute,
per hour, or per connection, typically to try to prevent mass unsolicited email distribution, you
can enter the appropriate settings here to comply. 

Select the "Restrict the number of messages sent" checkbox, then enter the maximum number
of messages that can be sent in a minute, hour or in a given connection (email session). If you



MemberTies321

©1998-2014 Myrro International

select "per minute" or "per hour" the system will send up to the max messages allowed that
period, and then pause until the end of the minute/hour before starting the next batch. If you
select "per connection", the connection with the server will be broken and restarted for each
batch.

Note: If you are sending in Single Message mode with a number of addresses in the TO, CC, or
BCC fields, "one" message can contain an unlimited number of recipients, unless limited by the
"Max Recipients" setting (see below).

Max Recipients - This option only applies when sending in "Single Message" mode. If your ISP
limits the number of recipients that can be in a single email message, set the value here. If you
enter 10 for example, the system will process the message several times, adding recipients
from the To list, then the CC list, then the BCC list, until the maximum number is reached. Then
the message will be sent, and it will start a new message and select new people from each list
in turn, repeating the process until all addresses in the TO, CC, and BCC lists have been
accounted for.

Control Address - If you would like the system to send a final email to a specific address (as a
check to verify that all messages were processed) enter that address here.  The email will be
addressed to a person called, "Control Address" at the address you specify.  Note that if you
are using the "Single Message" addressing option, this address will be added to the BCC list.

Save Messages to Sent Mail - Select this option to save a copy of the mail message to the
Sent Mail list. Note that it is important to understand that a message will be saved to the Sent
Mail list regardless of whether it is successfully delivered. All the system knows is that the
message was sent to the specified mail server for delivery. It does not know whether the server
ever delivered it, whether it bounced back, or whether or not it was read.

Request Read Receipt - Select this option to send a request that the receiving email program
notifies you when the message is opened/viewed. Note that this is NOT fool-proof, and does
NOT guarantee in any way that a message has or has not been received.  Many people turn off
read-receipts because automatically returning receipts is guaranteed to increase the amount of
junk email you receive (because that automatic reply tells the spammer that your address is a
real or "live" one, and therefore a good candidate for even more junk mail). But if the recipient
has their email software configured to allow receipts, this option will request one.

3 The final tab is the Sent Mail Tab. This tab displays copies of email messages that were sent
while the "Save Messages to Sent Mail" setting was selected. See Viewing Sent Mail for
complete information about this tab.

You can filter the list to only messages containing specific text. Enter the text to be found in the
Find Text field, and choose the field (or all) to be searched. Click Search to filter the list, or
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Reset to clear the filter and show all messages again.

 

18.7.9 Status Change History

Each time the status of a membership record changes, whether manually, or via an automatic change
based on status expiration settings (see Maintaining Status Codes for details), the change is recorded in
the Status Change History.

The Membership History report uses this data to show the number of members who held each status in
a given year.

Viewing Status Change History

1 Choose File > Workspace > Membership List, or click the Membership List toolbar button.

2 Select the member for which you want to view status change history.

3 Choose File > Open Member.  You can also click the Open toolbar button. This will open the
Details window for the member.

4 Select the Status tab and click the Status History icon to open the  Maintain Status Change
History window

Notice that the "To Date" is blank on the History list for the current status. This will be filled in
by the system when the next status change occurs.
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5 When you are finished, click OK.

Adding or Changing a Status Change History Entry

You can add new entries or change existing entries at any time. This is helpful to remove an accidental
change, or to add historical entries (things that happened prior to using MemberTies, for example).

1 Open the status change history for the desired membership record.

2 To add a new entry, click Add; to change an existing entry, select it and click Open.

3 The following fields are available:

Status - The membership status the entry is for.

From - The date the member was assigned the selected status.

To - The date the member ceased to be assigned the selected status.

4 When you are finished, click OK.

18.7.10 Default Membership Statuses

Several sample statuses are predefined in MemberTies. You can keep these statuses, modify them, or
delete them entirely and add your own.  See Maintaining Status Codes for more information.

The following explains the intended use for each of the default statuses, 

Alumni - an inactive regular member whose normal term of membership ended. This is essentially
an entry in the membership archives. This is a member we want to keep track of, but is someone
who no longer attends events regularly. The alumni status is not setup to expire or pay dues, and
is marked as Inactive.
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Couple - one of a pair of active members. The couple status is setup to require a relationship to at
least one other membership record. In addition, a member with this status will automatically
change to an Alumni 90 days after their membership ends.

Note: Each record in a relationship is controlled by its own End Date. If a record with one date is
related to another record with a different End Date, they will expire and change statuses (if
appropriate) as their individual dates arrive, not together.

Distinguished - this is an active member whose dues are paid for life by the organization.

Dropped - this is used for members who have reached their End Date, but are not to be deleted
from the database. Prospect, Newsletter, and Social members become Dropped members when
their End Date is reached.

Honorary - this is a person affiliated with the group, but who does not pay dues and cannot vote.
They are still considered active members in every other way.

On Leave - this is used for members who are "on hold". We don't want to make them Alumni, or
Dropped, because we expect them to return.

Prospect - this is a new potential member. If they do not choose to join, they will be automatically
changed to Dropped.

Newsletter - this is a non-member newsletter subscriber. If they do not choose to renew their
newsletter membership, they will be automatically changed to Dropped status after 7 days.

Regular - this is a normal active member. If a Regular member does not renew their membership,
they become Alumni after 90 days.

(Delete) - This is a system-defined status that cannot be changed or deleted. Any membership
record set to (Delete) will be automatically deleted by the system.  You can set statuses to expire
and change to this status if you want to purge them automatically.  No statuses change to this
status by default.

18.8 Membership Record Tab Pages

18.8.1 General Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The general tab contains address and contact information.
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Note: If your computer monitor is set to a resolution lower than 1024 x 768, the the right-most fields from
the General tab are moved to a separate Status page.

The following fields on this tab require some additional explanation:

Company Name - A report preference controls whether this field will display on reports along with
the member name. However, if there is no first/last name available the company name is displayed
automatically, regardless of the preference setting.

Middle Name - If a single character is entered, a trailing period will be added automatically (i.e.,
"Q" becomes "Q.", but "Quincy" is left unchanged.

Alt. Name - This field (Alternate Mailing Name) can be used to provide an alternative name for use
on mailing labels (or all address blocks, see below). For example, on the record for "John Smith",
the Alt Name could be "The John & Mary Smith Family". System mailing labels will automatically
use the value in this field if it is available.  

Note that this field will also take priority on user-defined labels and post card reports over any of the
"Name" smart fields. 

If the "Use Alt Name"  report preference is turned on, the Alt Name value will be used on ALL
address blocks on membership system reports, not just mailing labels.

Photo - The photo icon to the right of the name enables you to associate a photo file to the
membership record, or any Friends/Family record. Click the icon to open the Photo window, where
you can add or view the associated photo(s). See Maintaining a Member Photo for more information.

Prefix and Suffix - These fields are freeform data entry fields that can be used for prefixes like
"Dr.", "Mrs.", "President", etc., or suffixes such as "Jr.", "2nd", "PhD" or other titles. This data
appears with the name on all reports that show the full member name. Note that if you would prefer
to have the cursor begin in the First Name field instead of the Prefix, you can set the Starting Field 
Membership preference.

Member ID - This field is available for you to assign a customized membership ID to this record.  If
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you don't enter a customized member ID, the system ID will be used. This field is commonly used
for a social security number, driver license number, or similar unique ID. See About Member IDs for
more information.

You can also tell the system to add specific text to the front of each generated Member ID. This
would enable the New York chapter of a national organization to automatically start every ID with
"NY", for example. See the Member ID Prefix  Membership preference for details.

Note: It is a common mistake to assume that the Member/System ID represents a "count" of
records. This is not true. The system ID is a sequence of numbers maintained internally by the
database. When you start a membership record, the ID is "used" regardless of whether you
actually save the record, thus, if the ID defaults to 10 and you cancel the record, the next record
you create will be 11, not 10, because 10 is "used" and gone. 

Flag - This option provides a simple way of "marking" a record.  It is intended to provide a temporary
means of identifying certain records so they may be quickly queried for on a report. The meaning of
the "flag" is up to you. Perhaps you need to send a special mailing to new members. You could set
the Flag on new records as you enter them, then run a mailing label report using criteria that only
retrieves records where, "Flag = Selected". When you're finished, you could use the Change Data
(Bulk) option on the membership list to clear all the flags. If you would like the Flag to be set
automatically on all new records, enable the Set Flag on New membership preference.  You can
also clear all Flags in the database automatically using a Database Tools menu option.

Address Type - Each address must be given a type that can be used as report criteria. (This is
most useful in MemberTies Professional where multiple addresses can be created for each
membership record. It enables you to run a report to find anyone with an address called, "Work
Address" located in "MyTown", for example.) 

In the Standard version, the default name assigned to the address is defined in 
Miscellaneous Preferences. 

In the Professional version, a list of predefined address types exists, and one of them can
be set as the Default. See Using Multiple Addresses for more information.

Address Line Names - If you always plan to use Address Line 1 for a specific purpose, such as
"Mail Stop" or something similar, you can change the label name displayed for the line.  In addition,
if you have complicated addresses that require four open lines instead of three, you can tell the
system to provide a fourth line.  See the Address Lines/Names Miscellaneous Preferences for more
information.

City - This list contains the cities that are defined in the City list. These are pre-loaded, but can be
edited at any time. In addition, if you enter a city that is not already in the list, the system will
prompt you to add it automatically. This feature is only available to dropdowns that typically receive
a lot of new values (i.e., it isn't available on Country lists, since these don't change very often). See 
Maintaining City Names for additional information about maintaining this list.

County -  This list contains the counties that are defined in the County list. These are pre-loaded,
but can be edited at any time. In addition, if you enter a county that is not already in the list, the
system will prompt you to add it automatically. This feature is only available to dropdowns that
typically receive a lot of new values (i.e., it isn't available on Country lists, since these don't change
very often). See Maintaining County Names for additional information about maintaining this list.

State/Province - This list contains the states/provinces that are defined in the State/Province list.
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These are pre-loaded, but can be edited at any time. See Maintaining State/Province Codes for more
information. Note that the state/province defined as the "default" will appear automatically on new
records.

Country - Similar to the State/Province field, this list contains countries that are defined in the
Countries list. See Maintaining Country Codes for more information. Note that the Country defined
as the "default" will appear automatically on new records.

Date Ranges - (MemberTies Professional Only) If a record has addresses that are valid only at
certain times of the year, you can have the system automatically keep the proper address current
by creating one or more date ranges within which each address is valid. See Using Multiple
Addresses for more information.

Phone - All telephone number fields have a small Dial Phone icon displayed next to them. If your
computer has a modem installed, clicking this icon will tell Windows to use your modem to dial the
associated phone number. This will typically cause the Windows Phone Dialer utility to open and
dial the number.

Phone Type - These lists contain supplemental telephone type descriptions (phone type codes)
that are defined in the Phone Type Codes list. Refer to Maintaining Phone Type Codes for more
information. Note that the phone type defined as the "default" for the appropriate type (home, work,
other) will appear automatically on new records. The phone type enables you to identify a phone as
a mobile number, pager, etc.

Email - (MemberTies Professional Only) The Email icon next to the email field will launch the Send
Email window with the member's email address(s) already listed in the addresses list. (Enter
multiple addresses separated by commas.) The Sent Mail icon will display the list of email sent with
the current member as one of the recipients.

Website - (MemberTies Professional Only) The Open URL icon next to the website field will launch
your default web browser and open the group's website.

Scan button - If the Enable Driver License Scan membership preference is enabled, clicking this
button will open the Scan Driver License window. If you scan a driver license that follows the
AAMVA specification, you can load the data into the member record. See Scanning a Driver License
for details. 

18.8.2 Status Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Status tab is used to record the starting and ending date of the membership, the current status,
whether this record should be included on mailing labels, as well as other miscellaneous options. This
page is only displayed if your monitor is set to a resolution less than 1024 x 768.
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Note: If your computer monitor supports a higher resolution, the General and Status tab pages will be
combined into one "General" page.

The following fields on this tab require some additional explanation:

Status - This indicates the current membership status of the record. You can have up to 25 separate
membership status codes defined, each of which can have many properties of its own. For example,
the status can be updated automatically by the system if set to Expire. See Maintaining Status
Codes for more information. Note that if you choose a status that requires a related record (this is
another property of the status code you can define), you will have to go to the Related tab and
create the required member and/or group relationship before saving the record.

Status History icon - Click the Status History icon to open the Maintain Status Change History
window, where you can view and change the record of status changes that have been applied to the
current member. See Status Change History for more information.

Start Date - This date typically represents the original date the person joined the group, regardless
of their current status. This is the date the Retention report looks at when determining who joined
when. If you want this field to indicate the starting date of the current status, you may do so, but the
reports based on this date may be inaccurate. The start date is populated automatically by the
setting in the Default Start Date Membership Preference.

End Date - This date typically represents the date on which the person's membership expires. This
field is required if you select a status that has been setup to Expire (because a status that expires
will have a "next status" defined, and the system needs to know when to change the record to the
"next status") If the status does not expire, the End Date is optional. The end date can be populated
automatically by the setting in the Default End Date Membership Preference.

Include in Mailings - The behavior of this field is controlled by the "Use Include Criteria" report
preference. If the preference is on, then mailing label reports will only include this record if this
checkbox is selected.  If the preference is off, this checkbox has no effect unless you manually use
the "Include in Mailings" field as part of your report criteria.

This checkbox can also be cleared automatically by the system if the status is automatically
changed to an Inactive status. To enable this feature, see the Clear Mailing Flag setting in 
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Membership Preferences. .

This setting can also be changed automatically based on the status you select. See Maintaining
Status Codes for more information.

Include on Reports - This field works like the Include in Mailings field, but applies to all non-label
style reports that include member data. 

This setting can also be changed automatically based on the status you select. See Maintaining
Status Codes for more information.

Head of Household - If you enter all members of a household, you can use this setting to
designate a particular contact person. There is no special processing tied to this field by the
system.

This setting can also be changed automatically based on the status you select. See Maintaining
Status Codes for more information.

Birthdate - If you do not know the birth year, you may enter "9999" as the year.  A 9999 year will
appear on this window, but on other system-defined reports, the 9999 will be suppressed.  On other
reports and views, the 9999 is only suppressed in the "Birth Year" component, since 9999 is the
same as "no year."  When creating user-defined reports and views, various smart fields are available
to show birthdate component values.

Age - The age of the member is computed automatically and displayed to the right of the Birthdate
field.

Anniversary - Can be used to represent the wedding anniversary of a married couple, or any other
anniversary that is appropriate to your organization.

Occupation - Similar to the City and County fields, this dropdown contains the names of all
occupations that already exist on any membership record. In other words, once an occupation has
been added to a record and saved, it becomes available to all other records. This is designed to help
keep spelling and naming consistent You can also pre-define occupation names. See Maintaining
Occupation Names for additional information.

Title - The member's official title, either within your organization or their occupation. This field is not
used on any system reports, but is available for criteria and for use on user-defined reports.

Reference - This dropdown contains the codes that are defined in the Reference Codes list.
Reference codes intended to indicate the manner by which a person heard of your group, i.e., via a
friend, newspaper advertisement, etc. See Maintaining Reference Codes for information about
maintaining this list.

18.8.3 Private Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Private tab is used for highly private information. This information is not available on any system
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report, and cannot be used as criteria without the appropriate security settings.  Note that you can
create a user-defined report that includes private data if you choose.  Security rules are also available to
prevent certain users from viewing the Private tab at all.

Important: Your data is only as safe as your computer.  If critically confidential data is stored in
MemberTies Professional, or any other program, it is only protected to the degree that your computer is
protected.  If someone has access to the physical machine, they can eventually get to any data stored
on it. Myrro International cannot guarantee the privacy of any data in the database, because we cannot
control the access to the machine where it is stored.

The tab includes eight fields that can be labeled however you wish (similar to the fields on the custom
tab, but only the names can be changed), and one large Comments field.

You can change a private field label directly on the Private Tab. In the example above the first three
private fields have been renamed.  To change the name of a field, click the label (i.e., "Private Field 01").

See Private Field Labels for additional information about changing field names.

18.8.4 Dues Tab

The Dues tab is used to record postings to a member's "dues" account. The current account balance is
displayed at the bottom of the list, as well as a subtotal if the list is filtered by Posting Type (posting
types, shown in the example below, only apply to MemberTies Professional). 

Note: If you are creating a new record, the member must be saved first (click Apply) before you can
access this tab unless you turn on the "Auto Save New Members" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via Membership
Preferences.
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Filtering the Display

If you are using MemberTies Professional, you can create a system of dues "posting types" to better
categorize the type of payment or charge being posted (such as Dues Charge, Dues Payment, Refund,
T-Shirt Sale, Food Order, etc.). If you are using corresponding debits and credits to balance the
member's account, the number of entries can become fairly lengthy; therefore, the Dues tab includes a
dropdown at the top labelled, "Show by Posting Type," which enables you to filter the display by a
specific type. (The dropdown is not displayed in the standard version, which does not use posting
types.)

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
type or choose "(All)".

Adding (posting) Dues

1 On the Dues tab, click Add.

2 The following fields are available:

Posted - The date on which the dues entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone pays for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this dues entry, even though it was actually posted the year
before.

Posting Type - (MemberTies Professional only) the posting type to be applied to this entry. The
debit/credit action of the type is displayed in the dropdown, and any minimum or maximum
amount requirement is displayed to the right of the field. See Maintaining Posting Types for
more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the Dues
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tab if the display is being restricted to a particular posting type, or b) the default posting type
specified in the Posting Types list, if available. If neither of these apply, no default value will be
entered.

Status - The membership status being purchased. You do not have to enter the status of the
actual membership record (you might be entering a historical dues payment for a previous
status, such as "prospect", even though the member is actually a full member now). There is no
connection between the status entered here and the status of the main record, though you can
have the system synchronize them (see below). 

Update Record - (MemberTies Professional only) Select this option if you want to synchronize
the status of the record with the status being purchased. If they already match, this will have no
effect. Note that this option does not create a "link" between the statuses. If you subsequently
change the status on the main record, it will not have any effect on the dues entry that updated
it.

Amount - The amount to be recorded. Only positive numbers may be used. In the professional
version, the posting type determines whether the amount is applied as a debit or credit to the
account. 

If you have entered yearly dues values for your statuses, you can click the calculator button to
the right of the Amount field to use the Dues Calculator to quickly determine the prorated (or
normal) amount to charge. See Using the Dues Calculator for more information.

In MemberTies Professional there are several ways to enter the amount. In addition to typing in
an amount, you may have other options depending upon the way you set up your Posting Types
and Status codes. If you associated minimum or maximum amounts for the posting type, or a
yearly dues amount for the status code, you can quickly enter any of those amounts by clicking
the appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the member, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Member Credit Card Data for
more information.

Receipt Number/Book - (MemberTies Professional only) These fields are enabled whenever the
selected posting type is one that has been defined to generate a receipt number. The fields are
disabled for all other posting types.  The Receipt Number is a sequential number generated by
the system. The Receipt Book is the value set as the Dues Receipt Book Nbr in preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - (MemberTies Professional only) Click this option if you want to force the system
to generate the next receipt number immediately. Note that once a receipt number has been
generated, it is "used" permanently, even if you choose not to save the entry.  The only way to
reset it is via the Dues Receipt Book Nbr preference.  If you want to "regenerate" a new number
for an entry that already has a receipt number, you must clear the field first, then click Assign
Now to generate a new number.  If you do not want the Assign Now option to be available at all,
it can be turned off via the Allow Assign Now preference.
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Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report  (MemberTies Professional only) if you wish.

Print Receipt - (MemberTies Professional only) This option controls when a receipt should be
printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Dues tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Dues Print Receipt = Selected" to
print all marked receipts at once.  

Update the Start Date To - If the member should receive a new Start Date because of this
entry, select this option and enter the new date. The system will update the date on the member
record automatically.

Update the End Date To - If the member should receive a new End Date because of this entry,
select this option and enter the new date. The system will update the date on the member
record automatically.

The Suggest New End Date dues preference (MemberTies Professional only) can be set to
make the system automatically select this option and enter a suggested date in the "Update
End Date To" date field. This preference lets you specify the number of months the End Date
should advance when posting debits or credits. If you set this preference and then use the
appropriate debit or credit posting type, the system will automatically fill in the date (though you
can override it by clearing the checkbox).

4 When you're finished, click OK to save.

5 If you have filtered the display by Posting Type (MemberTies Professional only) and you add a
dues entry that uses a posting type that has been filtered out, the new entry will not appear until
the filter is changed to one that will include it.

Changing a Dues Entry

1 On the Dues tab, click the entry you want to change, then click Open.

2 When the Edit Dues window opens, make your changes, then click OK. The current balance will
recalculate automatically if necessary.

Deleting a Dues Entry

1 On the Dues tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple



Membership Records 334

©1998-2014 Myrro International

Records.

Printing Receipts as a Group

(MemberTies Professional only)  As described above for the, "Printed Receipt" field, you have the option
of marking many entries for future receipt printing. Any entry that has been marked for printing will
include a checkmark in the "Rcpt" field on the list. (Note that this checkmark does not prevent you from
selecting an entry on the list and printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

Additional Dues Capabilities

If you are using MemberTies Professional, there are some other dues-related options:

You can post dues directly from the Membership List to any number of selected records, or
records with a specific status. See Posting to Multiple Records for more information

The system can automatically post dues on new records, the start date, the end date, or on
specific dates, all based on the member's status. See Maintaining Status Codes for more
information.

The system can automatically post interest charges to past-dues accounts based on the
member's status. See Maintaining Status Codes for more information.

You can maintain a separate list of Donations that do not affect the dues account at all. See the 
Donations Tab for details.

You can create a Deposit containing any number of Dues, Donation, and Activity Income entries.
See Tracking Deposits for details.

You can clear ALL Print Receipt checkmarks for the entire system by choosing Tools > Database
Tools > Clear Print Receipt Settings.

18.8.5 Donations Tab

The Donations tab is used to record donations or gifts the member has made to the organization that
should not be reflected in the Dues account.  This tab works essentially the same, but separate from,
the Dues tab. The current account balance is displayed at the bottom of the list, as well as a subtotal if
the list is filtered by Posting Type. 

Note: If you are creating a new member record, the member must be saved first (click Apply) before you
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can access this tab unless you turn on the "Auto Save New Members" Financial preference.

Note: The tab pages to display, and the order in which they appear, are controlled via Membership
Preferences.

Filtering the Display

You can create a system of donation "posting types" to better categorize the type of donation received if
you don't want to use the standard "donation" entry. Using the dropdown at the labelled, "Show by
Posting Type," enables you to filter the display by a specific type. 

Note: If you add or change an entry and give it a different posting type than the one currently being used
to filter the display on the tab, the entry will not appear in the list until you select the appropriate posting
type or choose "(All)".

Adding (posting) Donations

1 On the Donations tab, click Add.

2 The following fields are available:

Posted - The date on which the donation entry is recorded.

Recognized - The date on which you want the amount to apply to your organization. i.e., if
someone donates for the following year on December 15th, you might want to leave the Date
Posted as Dec. 15, but set the Date Recognized to Jan. 1.  That way, a report run for the first
quarter of next year will show this entry, even though it was actually posted the year before.

Posting Type - The posting type to be applied to this entry. The debit/credit action of the type
is displayed in the dropdown, and any minimum or maximum amount requirement is displayed
to the right of the field. See Maintaining Posting Types for more information. 

The posting type will be defaulted to either, a) the currently selected posting type on the
Donations tab if the display is being restricted to a particular posting type, or b) the default
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posting type specified in the Posting Types list for donation entries, if available. If neither of
these apply, no default value will be entered.

Amount - The amount to be recorded. Only positive numbers may be used. The posting type
determines whether the amount is applied as a debit or credit to the account. 

There are several ways to enter the amount. In addition to typing in an amount, you may have
other options depending upon the way you set up your Posting Types. If you associated
minimum or maximum amounts for the posting type you can quickly enter those by clicking the
appropriate icon next to the amount.

Cheque - The cheque number or other identifier for the entry.  If you have stored credit or debit
card data for the member, you can click the credit card icon next to the Cheque field to select a
stored card. A representation of the card number will appear in the Cheque field (so that the card
number itself is not visible on standard reports. See Maintaining Member Credit Card Data for
more information.

Receipt Number/Book - (MemberTies Professional only) These fields are enabled whenever the
selected posting type is one that has been defined to generate a receipt number. The fields are
disabled for all other posting types.  The Receipt Number is a sequential number generated by
the system. The Receipt Book is the value set as the Donations Receipt Book Nbr in 
preferences.

The receipt number is not automatically generated until the record is saved or a Receipt is
printed via the Receipt button.  This ensures that the next receipt number is not used until it is
needed. 

Assign Now - (MemberTies Professional only) Click this option if you want to force the system
to generate the next receipt number immediately. Note that once a receipt number has been
generated, it is "used" permanently, even if you choose not to save the entry.  The only way to
reset it is via the Donations Receipt Book Nbr preference.  If you want to "regenerate" a new
number for an entry that already has a receipt number, you must clear the field first, then click
Assign Now to generate a new number. If you do not want the Assign Now option to be available
at all, it can be turned off via the Allow Assign Now preference.

Print Receipt - (MemberTies Professional only) This option controls when a receipt should be
printed for the entry:  

No Receipt - indicates that no receipt needs to be printed at all

Print on Save - indicates that a receipt will be automatically printed when the OK button is
clicked to save the entry. Note that the system will automatically switch the setting to "No
Receipt" after printing. You can also print a receipt by selecting the saved record on the
Donations tab list.

Mark for Printing - indicates that the record should be marked so that you can run a receipt
report from the Reports window, and use report criteria, "Donations Print Receipt =
Selected" to print all marked receipts at once.

Comments - General comments about the entry.

Private Comments - Comments in this field are not printed on any system report.  They can be
placed on a user-defined report  (MemberTies Professional only) if you wish
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3 When you're finished, click OK to save.

4 If you have filtered the display by Posting Type (MemberTies Professional only) and you add an
entry that uses a posting type that has been filtered out, the new entry will not appear until the
filter is changed to one that will include it.

Changing a Donation Entry

1 On the Donations tab, click the entry you want to change, then click Open.

2 When the Edit Donation window opens, make your changes, then click OK. The current balance
will recalculate automatically if necessary.

Deleting a Donation Entry

1 On the Donation tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.

If you need to delete multiple postings from multiple records, see Deleting Postings from Multiple
Records.

Printing Receipts as a Group

(MemberTies Professional only)  As described above for the, "Printed Receipt" field, you have the option
of marking many entries for future receipt printing. Any entry that has been marked for printing will
include a checkmark in the "Rcpt" field on the list. (Note that this checkmark does not prevent you from
selecting an entry on the list and printing it immediately.)

If you choose to print a batch of receipts via the Reports window, you will probably want to clear the
"Print Receipt" checkmark from your records. This is not done automatically because the system has
no way of knowing whether or not the printing was successful. Your printer may have jammed, been out
of ink, printed poorly, used the wrong paper, etc., so you must clear the checkmarks manually.  To clear
the checkmarks from the tab, simply right-click the desired entries and choose "Toggle Print Receipt
Option" from the popup menu. Of course, it is more likely that you will want to clear ALL Print Receipt
entries for the entire system at once. To do this, choose Tools > Database Tools > Clear Print Receipt
Settings, and the database will be updated automatically. 

18.8.6 Items Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Items tab displays all Items that have been assigned to the member. Items, or "categories and
items" as they are commonly referred, are a very powerful and flexible feature. 
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Items are used for situations where you need a "one to many" data relationship. In other words, one
member (the "one") may hold multiple titles, win multiple awards, have multiple skills, etc. (the "many").
Custom fields don't work very well for this, because each field only holds one piece of data. Items, on the
other hand, work perfectly because you can create any number of items, linked to any number of
categories, and assign them any number of times to a given record. In the sample below, this member
has been assigned multiple items, including two from the Skills category. 

By default, an assigned item includes only a Date and a Comment, but with MemberTies Professional
you can turn on several more date, text, and numeric fields for your use if necessary.  See Categories &
Items for more information.

Filtering the Display

By default, all items are displayed. If the member has a large number of Items assigned to from various
categories, you can filter the list down to just items from a specific category using the Show By
Category dropdown.

Note: If you add or change an Item and give it a different category than the one currently being used to
filter the display on the tab, the item will not appear in the list until you select the appropriate category or
choose "(All)".

Adding an Item

1 On the Items tab, click Add.

2 When the Add Item window opens, the following fields are available:

Category - The category you select determines which items will appear. 

Item - The item to assign.

Date - The date to associate with this item. This may not apply if the item you created is not
date-related.



MemberTies339

©1998-2014 Myrro International

Comments - General comments. Since items may be used multiple times, the combination of
date and comment help distinguish one from another.

Note: If no items (or categories) are available in the dropdowns, you will need to create them
first. See Maintaining Items for more information.

3 When you are finished, click OK.

Changing an Item

1 On the Items tab, select the item you want to change, then click Open.

2 When the Maintain Item window opens, make your changes, then click OK.  

Deleting an Item

Deleted items are removed from the current member only. To permanently remove an item from the
database (and from all members) you must delete the Item from the system list. See Maintaining Items
for more information.

1 On the Items tab, select one or more items to delete.

2 Click Delete. 

3 Confirm the deletion.

 

18.8.7 Associated Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Associated tab displays all membership records, group records, and files that have been related to
this member. Associated members may be any other member record that is in some way tied to the
current member. Typically this includes family members that have their own membership (see Friends
and Family also), golf partners, referring members, etc.

Note: See Friends and Family for a discussion of the differences between associating members and
storing them as friends/family records. Associated members can be converted to Friends/Family records
via the right-click menu on this tab.
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There are two ways to add a associated member; by searching for an existing record, or by adding a
new record that will be automatically tied to the current record. Associated group records must already
exist in the database.

Adding a New Associated Member
...by creating a new record

1 In the Associated Membership Records section, click Add.  If you would like the new record to
be based on the current member, answer yes when prompted. (The main address, last name,
company name, alt mail name, start date, end date, and status are copied if you choose this
option.)

2 When the new member window opens, create the new record normally, completing all
appropriate tabs.

Since this record is already part of an association process, there is no option on the Associated
tab of this record to create another new record. This prevents a circular creation of records-
within-records-within-records.

3 When you are finished, click OK. The current record will save and close, and it will appear as a
new association on the original record.

4 If you would like to enter optional association details, select the associated record and click
Open. You can specify the manner in which the record is linked to the current member, and visa
versa.

Adding a New Associated Member
...by searching for an existing record

1 In the Associated Membership Records section, click Search.

2 When the search window opens, enter criteria that will help you find the records you want to
relate, then click Search.  
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When creating membership associations, the last name of the current record is entered
automatically as search criteria, and if no associations have been established yet, the initial
search is also executed for you.  This is designed to simplify searching for existing family
members.

3 You can search for as many records as you need. Each time you click Search, the results of
the previous search are replaced with the results of the new search. Select the Append
checkbox to cause the new results to append to the existing results list. 

4 Choose the records to be brought back as associations, then click the Select button. All
selections will be added as new associated records if they don't already exist.

5 If you would like to enter optional details, select the associated record and click Open. You can
specify the manner in which the record is linked to the current member, and visa versa.

Adding a New Associated Group

Group associations are always added by searching for an existing group record. Group records cannot
be created directly from the member record.

1 In the Associated Group Records section, click Search.

2 When the search window opens, enter criteria that will help you find the records you want to
use, then click Search.  

3 You can search for as many records as you need. Each time you click Retrieve, the results of
the previous search are replaced with the results of the new search. Select the Append
checkbox to cause the new results to append to the existing results list. 

4 Choose the records to be brought back as associations, then click the Select button. All
selections will be added as new associated records if they don't already exist.

Deleting an Association

Deleting an association from this tab merely destroys the relationship between the two records. The
actual records themselves are unchanged, and nothing is deleted.

1 Select one or more membership or group association to delete.

2 Click Delete in the appropriate section (members or groups). 

3 Confirm the deletion.

Associating a File

Any file stored on your computer can be associated with the membership record.  The file is either
stored as a link to the physical file, or stored in the database, depending on the File & Photo Storage 
database preference.  If you are storing files and photos in the database, be sure to keep file sizes as
small as possible to avoid dramatically increasing the database size.

1 In the Associated Files section, click Add.

2 When the file browsing window opens, navigate to the file to be used, then click Open.  
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3 The path to the selected file will appear in the New File window, and you can enter an optional
description of the file. This is helpful to simplify the name of the file. i.e., \my documents\
MemberTies\membership_report_04.doc can be described as "April Membership Report".

4 When you're finished, click OK to save the association.

Changing an Associated File

1 In the Associated Files section, select the file to be changed, then click Open.

2 Make your changes, then click OK.

Deleting an Associated File

1 In the Associated Files section, select the file to be deleted, then click either:

Delete - To delete the association, leaving the physical file in its current location.

Delete File - To delete the association and the physical file itself.

Note: If files are stored in the database, deleting the association always deletes the stored file
as well. Otherwise, the orphaned file would sit in the database forever.

2 Confirm the deletion.

18.8.8 Friends/Family Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Friends/Family tab contains a list of non-member "people" who are tied to the member record, but
do not have complete membership records of their own. Typically this includes spouses, children, etc.
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Adding Friends/Family 

Records can be added directly on the Friends/Family tab, and can also be created by converting an
existing associated member (see below).

1 On the Friends/Family tab, click Add to open the New Person window.

2 The following fields are available:

Name - The full name can be entered. Like the main member record, if a single character is
entered for the Middle Name, a trailing period will be added automatically (i.e., "Q" becomes
"Q.", but "Quincy" is left unchanged.
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ID - This is similar to the Member ID, and it defaults to the ID of the main record. Unlike the
main record however, this field can be left blank. If it has a value it can be used when searching
for an activity attendee on the activity Front Desk window.

Association - The relationship this person has to the main member record (daughter, son, etc.)

Birthdate - The person's date of birth. Once entered, the Age is calculated automatically.

Sex - The person's gender

Contact Name - The emergency contact person. For example, a child may be listed on his
father's record, but if his father travels a lot, it could be the mother or other relative listed here.

Contact Phone - The corresponding emergency contact phone number.

Comments - General comments

Allow Check-In - Select this option to allow this person to be found in a search and available
for check-in via the activity Front Desk window. This option is selected by default, but if the
person being entered is someone who would never attend anything, clearing this option may
make search results cleaner.

Photo - The photo icon to the right of the name enables you to associate a photo file to the
record. Click the icon to open the Photo window, where you can add or view the associated
photo. See Maintaining a Member Photo for more information.

3 When you're finished, click OK to save.

Converting an Associated Member to a Friends/Family record

If a person was originally created as an associated member record, it can be converted to a Friends/
Family record automatically. Only data fields found on the Friends/Family record window will be
converted however -- all other data (dues/donations/custom fields, etc) will be lost.

Note: Converting a member record to a Friends/Family record causes the original associated member
record to be deleted. This process cannot be undone.

1 On the member Associated tab, right-click the associated member to convert.

2 Choose "Convert to Friends/Family" from the popup menu.

3 Follow the prompts. When the record has been converted, the old member record will be deleted
automatically.

Changing a Friends/Family record

1 On the Friends/Family tab, click the entry you want to change, then click Open.

2 When the Maintain Person window opens, make your changes, then click OK. 

Deleting a Friends/Family record

1 On the Friends/Family tab, click the entry you want to remove, then click Delete.

2 Confirm the deletion.
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18.8.9 ToDo Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

A To Do entry is simply a reminder of something the that needs to be done for this member. It doesn't
normally represent something the member personally needs to do, because the members don't normally
see this data, but you can use it any way you wish.

Note: If you want to be notified of open To Do items when MemberTies starts, the  Login Preference to
display open To Do's on startup must be turned on

Adding a To Do Item

1 On the To Do tab, click Add.

2 When the New To Do window opens, complete the following fields:

Description - A brief description of the required action

Due Date - The date the To Do is to be completed

Prompt - The number of days ahead of the Due Date you want to be reminded of the To Do
Item.

Complete - Select this option if this item has already been completed (perhaps you're entering
it for historical purposes). This causes the Completed Date field to be filled in with the current
date.

3 Click OK.

Changing or Completing a To Do Item

1 On the To Do tab, select the entry you want to change.
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2 Click Open. This will open the maintenance window for the selected record.

To complete the item, mark the Complete checkbox

To reopen the item, clear the Complete checkbox

3 Make your changes, then click OK.

Changing the Completed Date

The system enters the data automatically when the Completed checkbox is marked, but if you want to
change the date, you can click in the Completed Date field and type a new date. You can also change
the name in the Completed By field if necessary.

Deleting a To Do Item

1 On the To Do tab, select the entry or entries you want to delete.

2 Click Delete.

3 Confirm the deletion.

18.8.10 Custom Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

The Custom tab displays custom field data. Custom fields can be used for nearly any sort of data you
wish, and they can be customized to become dropdown lists, editable lists, checkboxes, and ordinary
text fields.  

You can create as many custom fields as you wish, and you can choose where and how they will be
used and displayed.  This example shows a simple text field, two dropdown lists (one for text, one for
decimal values), a simple number field, and a checkbox.
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See Maintaining Custom Fields for information about changing the definition of a field.

Note: If you use custom fields a lot, you may wish to change the Tab Order preference to make this tab
appear next to the General tab.  You can also (using the Professional version) display any custom field
on the main Membership List by creating a view of your own.

18.8.11 Activities Tab

Note: The tab pages to display, and the order in which they appear, are controlled via Preferences.

With MemberTies Professional, an additional tab appears on the membership record for activities. The
Activities Tab contains a list of all activities to which the member has been entered as an attendee.
Clicking any activity causes the Activity Attendance section in the lower half of the window to display all
associated check-in/check-out attendance data for that activity.

Opening an Existing Activity

1 In the Associated Activities section, select the activity you want to open.

2 Click Open.

3 When the Activity Details window opens, make your changes, then click OK. See Working with
Activities for more information.

Associating the Member to an Activity

You can assign the member to any number of existing activities

1 In the Associated Activities section, click Search.



Membership Records 348

©1998-2014 Myrro International

2 When the Assign Activity window appears, choose the appropriate activity (or activities), and
enter an additional data for attendance or posting data, then click OK.  The system will assign
the member to all selected activities.

Note: The Assign Activity window is also available directly from the Membership List. For more
information about the Assign Activity window, see Adding Members to Activities.

Disassociating the Member from an Activity

1 In the Associated Activities section, select the activity to be removed.

2 Click Delete to delete all associations between the member selected activity.

3 Confirm the deletion.



Part

XIX
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19 Preferences

19.1 Preferences Overview

You can change a number of Preferences to control various aspects of the way the MemberTies
behaves. Many of the Preferences, such as the database profiles, are required, and MemberTies will not
run correctly if they are not provided. 

Preferences are divided into various categories, which represent the area of the application most affected
by the setting. Things that do not fit a specific area of the application are found in Miscellaneous
preferences. Within each category there are normally one or two types of preferences:

 User Preferences - identified by the "person" icon, are specific to a given user name. If you log in as
"bob" and set a user preference to "A", someone else can login as "john" and set the same preference
to "B".  The system will use the appropriate setting based on whether Bob or John is logged in at the
time.

 System Preferences - identified by the "computer" icon, are global across the application, and
apply to every user. Following the above example, if user "bob" logs in and changes a system preference
to "A", and later user "john" logs in and changes the same setting to "B", the setting "B" will be used
the next time Bob logs in as well, because John has changed the setting for everyone.

Note: In a multi-user installation, a change to a System preference made by one user may not be
noticed by the other users until they log in again.  This is because preference settings are stored in
memory at the time of Login, and only refreshed from the database periodically.

If you're the only user on the system, then there isn't really any difference between User and System
preferences. You just need to be aware that if you create a new user and start logging in under that ID, it
will have its own set of preferences.
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Note that if your security group settings prevent you from editing system preferences, no system
preferences will appear for you. This could leave some categories completely empty.

Preference settings vary from simple On/Off settings, to complete data-entry screens to control more
complicated features.  The example above illustrates the (user) preference to control alternating row
stripe colors on lists.

19.2 Activity Front Desk Preferences

These preferences control various features of the Activity Front Desk window. See Using the Activity
Front Desk for more details.

Setting Activity Front Desk Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Activity Front Desk section by double-clicking it, or by clicking the [+] symbol.

3 The following preferences are available:

Allow Check In - controls whether a member can be checked in to the activity directly on the
Front Desk window. If, for example, your organization requires pre-registration for activities, you
might want to disable this preference. Then, when you query for a member using the Front Desk
window, if they are not already registered (check-in earlier), it will not be possible to check them
in at that time.

In this case, you could update the existing check-in displayed on the front desk window to
reflect that the person has actually attended. 

Allow Dues Entries - controls whether new dues entries can be created on the Front Desk
window for the selected attendee. If enabled, a Dues icon will be displayed in the Activity
Synopsis area. 

Limit Synopsis Data - prevents the display of personal information in the Activity Synopsis area
of the Front Desk window. If the person(s) using the Front Desk should not be allowed to view
address and phone number information for attendees, enable this option. 

End Date Validation - disables the Check In button if the selected member has an End Date in
the past.

End Date Warning - controls whether a popup warning message is displayed when the
selected member has an End Date in the past.  This message is only a warning; it does not
prevent the user from proceeding. Use the End Date Validation preference to stop the check-in
entirely.  Note that in Unattended Mode, the message will not be displayed.

Multiple Check-In Warning - controls whether a popup warning mesasge is displayed when a
member checks-in prior to being checked-out of an existing entry on the same date. This can be
used to prevent duplicate entries.

Show Company in Results - controls whether the Company Name is included in the results
list when multiple records match the search criteria.  If this option is off, the company name will
only display if there is no member name.  If you rarely use the company name and therefore do
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not need it as a way to help identify the correct member when multiple matches are found, turn
this option off..

Use Unattended Password - controls whether an optional password is available when using
Unattended Mode.

4 When you're finished changing preferences, click OK.

19.3 Database Preferences

In addition to general database settings, these preferences enable you to apply a registered license to a
database profile and perform additional database profile maintenance.

Setting Database Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Database section by double-clicking it, or by clicking the [+] symbol.

3 The following preferences are available:

Auto-Login - enables you to specify the user name, password, and/or database entries for the
Login window.  If you specify all three, the system will not stop at the Login window on startup.
Instead, the fields on the Login window will be completed for you using these entries, and the
login process will start automatically as if you had clicked the Login button yourself.  Note that if
you use more than one user name, you probably shouldn't set all three options, or you won't be
able to login as anything different without changing the preference setting.  These settings are
stored in the mtie.ini file, so they are specific to each user.

Note that this preference is considered to be user-specific, but it really is "computer" specific.
Since the login preference obviously can't be stored in the database (because you'd have to log
in before you could get to the data to see how you'd prefer to log in), it is stored in the
application's .ini file on the computer. Thus, it is read and used prior to the database connection
being established.

Backup Prompt (Days) - specifies the number of days after which you wish to be prompted to
backup the database. When prompted, you can choose to initiate the backup, or cancel the
process. Set the value to zero (0) to prevent prompting. (This preference is not availble if you are
connected to a remote database.)

Note that regardless of the setting, you can always start a manual backup by choosing Tools >
Database Tools > Backup Database.

Backup/Restore Timeout - specifies the number of seconds the system will wait for the
backup or restore process to finish before assuming that an error has occurred.  The default is
120 seconds.  If you have a very large database (or slow computer) and experience a timeout
when running a backup or restore process, increase this value.

File & Photo Storage - controls whether member photos, and related files (i.e., files linked to
members and activities via the Related tab) are stored in the database, or stored as links to the
physical files.  When setting this preference, you must specify the maximum file size that can
be stored. The default is 50 KB each, and this is really a pretty large number.  Most digital
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cameras take very large photos by default that would dramatically exceed the 50 KB limit; but,
if you reduce the photo to a standard 1.5" x 2" wallet sized photo such as would appear on an
ID card, the file size will be reduced as well.

Here are the Pros and Cons to keeping the file on the computer:

Pro Con

The database remains smaller in size,
because only the path to the file is stored.

Physical files can be lost.

Photos, or reports that include photos, will
open faster, because the file already exists
and is ready to display.

If you have multiple users, each user must
store copies of the files on their computer, or
the files must be stored on a network drive
that is mapped the same on all user
computers.

When the database is moved, all files must
be moved as well, and must be returned to
the same named location on the new
computer, making the database less easily
portable.

A computer crash or virus could destroy files
on the computer.

Here are the Pros and Cons to storing the files in the database:

Pro Con

Files always travel with the database because
they are stored in a table in binary form.

Large files will slow down the database in
some cases while the data is being retrieved.

If you have multiple users, each user will
automatically be able to see files as soon as
they are stored in the database.

A major database problem could corrupt files
stored in the database.

If the same file/photo is used on more than
one record, it must be stored once per usage.

Larger files must be reduced before they can
be stored unless you increase the allowed file
size.

Note:  The system automatically stores email messages and report logo files in the database
regardless of this preference setting.

Maintenance Prompt (Days) - specifies the number of days after which you wish to be
prompted to run table maintenance (sometimes referred to as "housekeeping") on the database.
When prompted, you can choose to initiate the maintenance, or cancel the process. Set the
value to zero (0) to prevent prompting. (This preference is not available if you are not running as
the mtadmin user, since the Maintain Tables option is under the Database Admin Tools menu,
which is only accessible by the administrator.) The default value for this preference is 30 days.

Note that regardless of the setting, you can always run maintenance manually by choosing
Tools > Database Admin Tools > Maintain Tables, or via the Server Utility.

Profiles - enables you to manage database profiles and licenses. See Maintaining Database
Profiles for details.
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4 When you're finished changing preferences, click OK.

19.4 Financial Preferences

Financial preferences control various options associated with dues, donation, and activity postings.
(Donation and Activity postings are only available with MemberTies Professional.)

Setting Financial Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Financial section.

3 The following preferences are available:

Activity Receipt Book Nbr - Controls the optional "book number" assigned to receipt numbers
generated by the system for activity postings.  The "book number" is a way of grouping receipt
numbers together.  It may represent a physical receipt book that has a finite number of pages,
or you might use "2005" as the book number for all entries in the year 2005.  This preference
also enables you to change the receipt number that will be used next.  That way, if you change
the receipt book number, you can reset the receipt numbering to 1 to represent the start of a
new book.

The receipt book/number is used on entries when an appropriate posting type is selected.
(Posting types can be defined as generating a receipt number.)

Application Fee - controls the application fee (if any) displayed on the Dues Calculator. This
fee normally represents a one-time charge to new members of the organization. The Dues
Calculator is accessible whenever new dues entries are being added to a membership record.

Allow Assign Now option - controls whether an Assign Now option is displayed next to the
Receipt Number and Book fields on a new posting, when the selected posting type is configured
to generate receipts.  Clicking "Assign Now" causes the system to automatically generate the
Receipt Number.  If you don't click it, the number isn't generated until you click OK to close the
posting window; but if you do click it, the number is generated and "used" right then. It's
analogous to starting to write on a physical receipt.  If you decide to "cancel" and throw it away,
the receipt has still been written on and is used, so likewise the number is still used. 

Auto Save New Members - controls whether the system should automatically save before
accessing the Dues or Donations tab for the first time on a membership record. Turn this option
off if you prefer to receive the "Save Changes" prompt.

Auto Save New Groups - (MemberTies Professional only)controls whether the system should
automatically save before accessing the Dues tab for the first time on a group record. Turn this
option off if you prefer to receive the "Save Changes" prompt.

Debit/Credit Action - controls the way debit and credit entries (Posting Types) affect accounts.
This setting enables you to make them work according to your organization's accounting
practices. Note that if you have existing posting entries, changing this setting may cause all
balances to be recalculated.

This option only applies to the Professional version, but it should be set properly in the standard
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version so that balances will be calculated properly if the system is ever upgrade to MemberTies
Professional. (All entries in the standard version are debit entries by default.)

Donations Receipt Book Nbr - This is identical to the Activity Receipt Book Nbr preference
described above, but it applies to donation entries.  

Dues Receipt Book Nbr - This is identical to the Donations Receipt Book Nbr preference
described above, but it applies to dues entries.

Negative in Red - controls whether negative numbers are displayed in red text on windows (not
reports) containing a list of postings. 

Suggest New End Date - controls whether the system should automatically suggest a new
End Date for the membership record when dues are added. The suggested date will be the
current End Date plus an indicated number of months. You can then choose to ignore or apply
the incremented date. This can simplify data entry if a typical dues payment is going to extend
the membership by a standard number of months.

Note: In the Professional version, an additional option lets you specify whether a new date
should be suggested for debits, credits, or both posting type actions. The initial setting of the
"Update the End Date" checkbox on the Dues window will be based on the default posting type,
if any. After that, the checkbox will be turned on and off based on the debit/credit setting of the
selected posting type -- unless you have manually selected or deselected the checkbox, in
which case it will not be changed again by the system.

Update Status - controls whether the Update Status checkbox is selected by default when
posting new dues entries.

4 When you're finished changing preferences, click OK.

19.5 Group Preferences

Setting Group Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Group section. (This name might be different if you have changed the word for Group
in the system.)

3 The following preferences are available:

Tab Order - controls the visible tabs and their display order for the details window.  For a tab to
display, it must be set to Active and be given a tab order greater than zero. (The Order numbers
themselves are not significant. Use whatever numbers you need to put the tabs in the order you
desire. i.e., 10, 20, 21, 25, 56, 110 is no different than 1, 2, 3, 4, 5, 6)

Note: The General/Status tabs cannot be turned off, and are always the first tabs displayed. 

4 When you're finished changing preferences, click OK.
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19.6 Login Preferences

Login Preferences control behavior that occurs as you login and MemberTies starts.

Changing Login Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Login section.

3 The following preferences are available: 

Check Addresses at Login - controls how often the system will verify that the correct address
is marked 'Current' based on available address date ranges. By default, this check occurs only
once per day when you log in. This setting has no effect if address date ranges are not used.
This preference is normally only changed if a large number of date ranges have been changed,
or if the system date has been changed and you need the system to update immediately. In
such a case you could change the setting to "Every Time", then logoff and on again, then
change the preference back.

License Update Prompt - A registered license is valid for free updates to the software for a
period of one year. If this preference is enabled, a message will be displayed beginning 30 days
prior to the end of the "free updates period". Once the update period has ended, or this
preference is turned off, the message will no longer appear.

Message of the Day - controls the message displayed to all users on startup.  Access to this
preference can be controlled by a special Security Setting.

Opening Window - controls the window that is first displayed when the application starts. You
can choose any of the major lists, the reports window, or you can choose to start a new
membership or group record immediately.

Show Tip of the Day - controls whether the Tip of the Day is displayed automatically.

Show To Do List - controls whether the To Do List is displayed automatically when there are
outstanding To Do items.

4 When you're finished changing preferences, click OK.

Window Startup Order

For reference, the actual order in which windows appear after login is: 

1. Tip of the Day (if enabled)

2. To Do List (if open items are available)

3. Opening Window
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19.7 Logoff Preferences

Logoff Preferences control behavior that occurs as you log off MemberTies.

Setting Logoff Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Logoff section.

3 The following preferences are available:

Auto Delete (Delete) Status - if this setting is active, any membership record with a status of
(Delete) is automatically deleted from the database when the application closes. See 
Maintaining Status Codes for more information about the (Delete) status. Note that the "Prompt
Before Deleting" preference (see below) controls whether you are notified before this occurs.

Automatic Logoff - controls whether the system will automatically return to the Login window
after a specified period of inactivity. If used, the timeout period must be at least 0.5 minutes (30
seconds). This can provide a measure of security against snooping if the system is located in a
public area.

Prompt Before Deleting - if this setting is active, a message will appear asking you to confirm
the automatic deletion of membership records that have a status of (Delete). If you answer No to
the prompt, the records will be left in the database. Note: If the"Auto Delete (Delete) Status" 
preference (see above) is not active, this preference has no effect.

Prompt on Exit - if this setting is active, you will be prompted with a confirmation message
each time you attempt to exit MemberTies. This can avoid disconnecting from the database and
canceling your changes if you accidentally try to exit the program.

4 When you're finished changing preferences, click OK.

19.8 Membership Preferences

Setting Membership Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Membership section.

3 The following preferences are available:

Clear Dues Entries on Expire - if this setting is active, when a record is updated by the
system to an inactive status (based on status code settings), all of the record's associated dues
entries will be deleted.

Default End Date - controls the default entry in the End Date field on all new membership
records. 

If you choose to set a number of months to add to the Start Date, the End Date will be
blank until the Start Date is entered.
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If you choose to set a month and day combination, the system will check to see whether
the day has already passed before using it. In such a case, the date will be moved to the
following year.  If the selected date is February 28th, and the current year is a leap year,
the date will be changed to February 29th.

Default Sex - controls the default entry in the Sex field on all new membership records. The
entry can still be changed after it is defaulted.

Default Start Date - controls the default entry in the Start Date field on all new membership
records. 

If you choose to use the Current Date, the Start Date will always be set to the current
system date at the time the record is created.

If you choose to set a month and day combination, the system will always set the year to
the current year, even if the date will be in the past.  i.e., a setting of Feb. 15 will always be
entered as Feb. 15, 2004 for every record created anytime in 2004.

Delete Action - controls what happens when a membership record is selected and deleted.
There are two possible outcomes:

If you choose to Delete Immediately, after you confirm the deletion the record will be
permanently removed from the database. This is the normal behavior of the system.

If you choose to Change to (Delete) Status, then rather than removing the record from the
database, the system will only change it's status to "(Delete)". Any record set to this
status will be permanently deleted by the system when you exit MemberTies (unless you
have set the Auto-Delete preference to prevent this). Thus, the Delete Action preference
essentially gives you a chance to change your mind, because prior to exiting the system
you can still change the record to some other status and prevent it's deletion.

Enable Driver License Scan - controls whether the "Scan" button is displayed on the Member
window to allow using a magnetic card scanner to import driver license data into the member
record. Note that only the AAMVA (American Association of Motor Vehicle Administrators)
specification is supported. See http://www.aamva.org/ for the current specification.

Member ID Prefix - if specified, the system will automatically begin each new Member ID with
the desired prefix text. If Member IDs have been preloaded, the prefix value will be added to the
preloaded ID value when it is selected for use. 

Note that if this preference is used, the Require Numeric IDs preference will automatically be
turned off.

Recycle Preloaded IDs - controls whether a preloaded member ID that has been used will be
marked as Unused if the corresponding membership record is deleted. For example, if preloaded
ID number 100, was automatically assigned to a membership record (and therefore marked as
Used), it would normally remain unavailable for reuse forever. If this preference is enabled, then
when the membership record using that ID is deleted the ID will be marked as Unused and will
be selected again when a new record is created. This can be helpful if your organization has a
finite pool of ID numbers and the order in which they are used does not matter (i.e., if it is ok
that ID 100 might get assigned to a new record that would otherwise have been number 1923
had ID 100 not been marked as Unused again).  This preference also affects the behavior of the
"Synchronize" action available on the Preloaded ID list.

http://www.aamva.org/
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Reset End Date on Expire - controls what happens when the expiration behavior of a Status
Code is based on the End Date, and it causes the system to change the status of a
membership record. By default, the system will reset the End Date of the affected record to the
date the status change occurred. This is designed to allow the grace period of a subsequent
status to begin calculating from the date the member actually changed to the new status.  If you
would prefer to have all calculations use the original End Date, turn this preference off. Other
status expiration behaviors, by Age or by Days do not affect the End Date.

Require Numeric IDs - if this setting is active, it prevents the entry of non-numeric data into the
Member ID field on membership records. In addition, if numeric IDs are required the Member ID
column will use a numeric sort when it appears on the Membership List or a report. Otherwise,
the column will use an alphanumeric sort. (To understand the difference between a numeric and
alphanumeric sort, consider the following list of numbers:

1, 5, 11, 12,14, 100

A numeric sort will maintain this numerical order: 1, 5, 11, 12,14, 100

But an alphanumeric sort will change the order to: 1, 100, 11, 12, 14, 5

You will need to close and reopen the Membership List for sorting changes to take effect.

Note that if the Member ID Prefix preference is used, this preference will be turned off.

Set Flag on New - controls whether the system automatically selects the Flag checkbox when
creating a new membership record.  This can enable you to easily query for new records if you
need to run a special report or mailing list for new members.

Starting Field - controls where the cursor begins in new membership records: the First Name
field or Prefix.  If the Prefix field is rarely used, choose the First Name option to speed data
entry.

Tab Order - controls the visible tabs and their display order for the details window.  For a tab to
display, it must be set to Active and be given a tab order greater than zero. (The Order numbers
themselves are not significant. Use whatever numbers you need to put the tabs in the order you
desire. i.e., 10, 20, 21, 25, 56, 110 is no different than 1, 2, 3, 4, 5, 6)

Note: The General/Status tabs cannot be turned off, and are always the first tabs displayed. 

4 When you're finished changing preferences, click OK.

19.9 Miscellaneous Preferences

Miscellaneous Preferences either apply to more than one area of the application, or just do not merit a
category of their own.

Setting Miscellaneous Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Miscellaneous section.
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3 The following preferences are available:

Address Lines/Names -  controls the labels to display next to freeform address lines. By
default, the first address line is called simply, "Address Line 1"; but, if you always plan to use
that line for the department number, you could change the name of the field to reflect that and
simplify data entry.  A fourth address line is also available and can be enabled (and renamed if
desired) by selecting the "Display Additional (4th) Address Line" checkbox.

Custom Tools Menu Options - There are three user-definable menu options listed under the
Tools menu. This preference enables you to specify the menu text and corresponding program
for each option. Three customizable options are available, which can be set up as shortcuts to
start any program on your computer, or any other file that your computer recognizes (for
example, you could point an option to a document containing your organization's bylaws, and
your computer would probably know to open it with your favorite word processor, such as
Microsoft Word). 

Default Item Date - controls whether the Date field on new membership or group Item entries
defaults to the current date.  (This is a Miscellaneous preference because it applies to both
membership and group records.)  Turn this option off to leave the Date field blank.

First Address Name - (standard version only) controls the default name to be used for the first
address created on a membership or group record. This defaults to "Main Address." Note: In the
Professional version, this preference is replaced by a list of predefined address types, one of
which is set as the default.

List Colors - controls the colors used for the display of non-editable lists such as the
Membership List, Group List, Dues List, etc. Choose a color for both odd and even numbered
rows. This is for appearance only -- there is no program functionality tied to the colors of the
lists. Note that when the Color dialog opens, there are five colors predefined in the Custom
Colors section. They are from the left: the system "Window Background" color (often white),
Light Gray, Light Olive, Sky, and Cream. When selecting a light and dark color, it often looks
best to use the darker color for odd numbered rows.

Live Scrolling - controls whether large lists and reports will scroll up and down while you 'drag'
scroll bar with the mouse. Turn this off if your computer has limited video capability or if the
display becomes erratic when scrolling through large quantities of data (i.e., if you have limited
video memory, a large list containing a lot of data may suddenly shift to a boldface-like display,
go blank, etc., as Windows runs out of resources). When this option is off the display will not
scroll until the mouse button is released.

Prompt on Cancel - controls whether the system will display a "Save Changes?" prompt when
you click the Cancel button with unsaved changes.  When this option is off, the system
assumes when you click Cancel you want to abandon all changes and close the window.  

List Refresh Style - controls how much of the Membership, Group, or Activity list is refreshed
when a record is opened and edited and you return to the list. The default option of "Targeted" is
best in most cases. This means that only the record (row) you were on will be refreshed when
you return to the list.  When you have a list of 50,000 members, this will be dramatically faster
than refreshing the entire list.  However, if you have a multi-user system where many people are
making changes at once, and you need to see all of their changes as soon as possible, a
Complete refresh will ensure that the entire list is refreshed -- picking up any other changes from
other users in the process. To perform a complete refresh manually, press F5 or open the
Actions menu and choose Refresh Display. Note: Neither option has any effect on the actual
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saving of data. This only controls the refresh of the display on-screen.

Time Format - controls whether times are displayed in 12 hour format (07:30 pm) or 24 hour
format (19:30).

4 When you're finished changing preferences, click OK.

19.10 Organization Preferences

Setting Organization Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.

2 Expand the Organization section.

3 The following preferences are available:

Name of Organization - sets the name of the your organization as it should appear on all
reports. If you have a license and have applied it to a database profile, the organization name is
preset to the organization the license is registered to and cannot be changed.

See Registering for more information about registration and licensing. See Maintaining Database
Profiles for information about applying licenses to database profiles.

Return Address - (MemberTies Professional only) controls the return mailing address for the
organization. This address is used in conjunction with the organization name on the Dues
Account Statement report, for example.

Word for 'Group' - sets the name to be used for the "Group" section of the system. The word
used here ("Group" by default) will appear in everything related to groups, including menus,
buttons, reports, field names, etc. This must be entered in the singular form, i.e., use "Group"
not "Groups" because the system will automatically add the "s" when appropriate. You may
have to restart the program for all menus and buttons to reflect the change.

Fiscal Year - controls the month on which the organization's year begins. This is used on the
Dues Calculator when prorating dues, and for the "Fiscal Year" date ranges (i.e., current fiscal
year, etc.).  If this preference is not set, the default is January. 

Global Email Signature - (MemberTies Professional only) enables you to define a signature
that will automatically display on emails, appearing below any profile-specific signature block. 
This is typically used for general information that needs to automatically appear on emails
regardless of who is sending it via what profile.

4 When you're finished changing preferences, click OK.

19.11 Report Preferences

Setting Report Preferences

1 Choose Tools > Preferences, or click the Preferences toolbar button.
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2 Expand the Reports section.

3 The following preferences are available:

Active Reports - controls the reports that you want to be active and available. Clearing the
checkbox for a report prevents it from appearing in the report selection dropdown on the Reports
window. 

Add Current Resident - if this setting is active, the text "or Current Resident" is appended to
the name on mailing label reports. This may help ensure delivery of mail in countries like the
United States even if the name on the piece is incorrect.

Default Address Format - controls the address format used on reports that do not have a
predefined address structure. You can override this setting on the Report Settings window for
customizable reports. Note that the "generic" format is an attempt to provide a format that will
allow mailing labels to be generated with an acceptable address format when members are in
multiple countries.

Default Logo - sets the logo graphic that will be displayed on all system and user-defined
reports that can display a logo.  The graphic must be square, preferably 144 x 144 pixels. Note
that any shape of logo can be stored as a square graphic. Just create a square white box, and
place the logo inside it. For example, each of these "logos" are saved as square images. If you
don't include a border on your image, nobody will be able to tell that the white space is part of
the image:

Note that the logo will be stored in the database when you save preference changes. After
saving, the filename will display as something like, "Stored ID: 36" instead of the original name.

Extra Label Info - controls the information to be displayed in the upper right corner of system-
defined mailing labels. When you make a selection, an example of the data that will appear on
the sample label.  If you choose "Text", you can type up to 20 characters in the Text field to be
used for display. Remember, uppercase letters take a lot more room! 

Font Settings - controls the font face and height used for various parts of reports and labels.

Organization Name Font Height - controls the font height to be used for the display of your
organization name at the top of reports. The default is 18. If your organization name is
exceptionally long, it may help to reduce this size by one or two points so the name will fit on
one line.

Report Font Face & Height - controls the font used for reports.

Label Font Face & Height - controls the font used for mailing labels. 

Note: The default font for both Reports and Labels is 9pt Arial. This font was chosen because it
looks good both on screen and printed, and is available on all Windows systems. Select from
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the list of available fonts, then choose a font height. Note that a font similar to Arial, Helvetica, or
Times New Roman at 9-11pt is highly recommended to avoid overflowing some report fields. To
reset the font to the installed default, click the Default button.

Hide Default Country - if this setting is active the system will prevent the country name or
code from displaying on addresses if the country matches the default country code. See 
Maintaining Country Codes for more information. If you have set the default country to be your
own country of residence, selecting this option essentially means the country will only be
displayed for foreign addresses.

Paper Sizes - The list of mailing label and card formats includes common USA and European
sizes. This preference enables you to restrict the formats that will be displayed based on paper
size, so you can hide formats that use sizes that don't apply to you.

Receipt Tag Line - controls whether the Tag Line text (see Tag Line below) is printed on
receipt reports.  This preference is off by default, since the tag line often doesn't really apply to a
receipt.

Tag Line - controls the default tag line to be displayed at the bottom of printed reports. To use
the system default, click the Default button. The number of characters available for this is
limited. The current number of available characters is displayed below the data entry field. Note:
Depending on the report font used and the letters in the text, all characters may or may not fit in
the available space on the report (i.e., a letter "i" takes much less space than a letter "W")

Total Records Line - controls the summary text displayed at the bottom of many reports, just
above the tag line. Options include the time and date the report was printed, and/or the number
of records on the report.

Use Alt Name - controls when the Alt Name on a member record takes precedence over the
first/last name on reports and documents (in the Professional version).  The following options are
available:

User-Defined Labels/Post Cards - Replaces any "name" Smart Field on mailing labels and
post cards

Other User-Defined Reports - Replaces any "name" Smart Field on other user defined
reports

Documents - Replaces any "name" Smart Field on the document

System Labels/Post Cards - Replaces the name on pre-defined label and post card reports

Other System Address Blocks - Replaces the name on other reports containing an
address block, such as a Dues Account Statement or a Receipt.

Use Include Criteria - there are two fields on the membership record (Include on Reports and
Include in Mailings) that imply that they are automatically honored by the system when running
reports and labels. This preference controls this behavior.  If turned on, the system will
automatically require that member records being displayed on mailing label reports have the
Include in Mailings check box selected, and on any other report that the Include on Reports
check box is selected.  If you would prefer more control, turn this preference off; the system will
not require either setting unless you add the criteria manually. (Note that this normally only
applies to member records, but group records also have an Include in Mailings checkbox that
works similarly.)
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4 When you're finished changing preferences, click OK.
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20 Documents

20.1 Overview

With MemberTies Professional  you have the ability to create formatted documents similar to what you
could create in dedicated word-processing software. The following features are supported:

Paragraph Formatting
Paragraph Styles
Font/Character Formatting
Font/Character Styles
Multi-column layouts
Bullets & Numbering
Tables
Text Frames
Images
Page Headers/Footers
Section Formatting
Find/Replace
Embedded database fields

The word processing software is actually a 3rd party tool has been built into MemberTies Professional. 
As such, we cannot make it do things it doesn't already do. However, it is a very powerful tool that
provides significant of flexibility and features.

Units of Measure

The word processor displays everything in inches. You can use the Page Setup menu option to change
the document size to a European format (i.e., A4), but all measurements will still display in fractions of
an inch (i.e., the paper width will display as 8.268 inches for A4, rather than 210 mm). We are not
currently able to change this behavior as it is embedded in the tool.

20.2 Working with Documents

The Documents window is sort of a combination of the Reports and User Defined reports.  On the
Reports window, the report on display can't be changed -- it is only there for display and printing.  To
create a new report, you use the User Defined reports window to create and save the report, and then
you open it on the Reports window like other reports.

With Documents, you are working with a "live" document on-screen all the time.  If you open a previously
saved document, you can make changes to it immediately on-screen, and then save or print it as you
wish.

Adding a New Document

1 Choose File > Workspace > Documents

2 When the Documents window opens, a new empty document is automatically created. You can
save this as a new document by clicking Save. 
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If you already have a document open and want to add a new one, click Add.

Opening an Existing Document

1 Choose File > Workspace > Documents

2 On the Documents window, open the "Select the document to view or print" list and choose a
saved document to open. If no documents have ever been saved, the list will be blank.

Deleting an Existing Document

1 With the desired document to be deleted open on the Documents window, click Delete, 

2 Confirm the deletion when prompted.

Saving a Document

1 Open the desired document on the Documents window

2 Choose File > Save

- or - 

Choose File > Save As > New Document to save a new copy.

3 Enter the desired document name if prompted.

Copying/Renaming an Existing Document

To rename a document, you must save it under a new name, then delete the old version.

1 With the desired document to be copied/renamed open on the Documents window, choose File
> Save As > New Document.

2 On the New Document window, provide a name for the document.

3 Click OK. The document will be saved under the new name and the new document will be
displayed.
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20.3 Find & Replace

The Find/Replace window enables you to quickly search for and optionally replace text in the document.

Note: You cannot find or replace text within a Text Frame. 

Using the Find Text window

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Choose Actions > Find Text

4 The following fields are available:

Find What - The text to locate

Match Case - Select this option to require an exact match of the text. i.e., "This" is not the
same as "this"

Direction - Select the direction the search should proceed from the current cursor location.

5 Click "Find Next." The first occurrence of the text will be highlighted.

6 When you are finished, click Cancel.

Using the Replace Text window

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Choose Actions > Replace Text
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4 The following fields are available:

Find What - The text to locate

Replace With - The new text to use

Match Case - Select this option to require an exact match of the text. i.e., "This" is not the
same as "this"

5 Choose the appropriate button:

Find Next - Highlights the first occurrence of the text but does not replace it.

Replace - Replaces the found text and highlights the next occurrence

Replace All - Replaces all occurrences throughout the document automatically

6 When you are finished, click Cancel.

20.4 Page Settings

The Page Setup dialog enables you to set margins, paper size, orientation, header & footers, and multi-
column modes.

Note: All settings are entered in inches, even if the selected page format is a European measurement.
This is a function of the word processing tool that we cannot modify at this time.

Modifying Page Settings

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Choose File > Page Setup
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4 The Page Setup window includes three pages of settings:

Margins and Paper - enables you to set document margins, choose the paper format (size)
or set a custom size, and set the orientation.

Headers and Footers - enables you to turn on or off the header and/or footer for the current
page or the entire document. You can also specify how far the header/footer starts from the
top/bottom of the page, and set a special value just for the first page if necessary.

Note: If headers or footers are turned on, you can access them by double-clicking in the
header/footer area.  Then double-click in the body of the document to return. Database
fields are not supported inside header or footer regions.

Columns - enables you to change the document into a multi-column layout. Several column
count options are provided, or you can specify a custom number of columns, in which case
you can also set custom widths and spacing for each column. You can also choose to
have a vertical line displayed between the columns, using a specific width and color.

5 Make your changes, then click OK to apply the changes
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20.5 Paragraph & Font Settings

Paragraph settings provide substantial control over the look of paragraphs, from line spacing to special
borders and indents.  

Note: All settings are entered in inches, even if the selected page format is a European measurement.
This is a function of the word processing tool that we cannot modify at this time.

Modifying Paragraph Settings

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Place the cursor in the paragraph you want to modify, then choose Actions > Format >
Paragraph.
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4 The Paragraph settings window includes two pages of settings:

Formatting and Indents - enables you to control alignment, line spacing, indents, and
automatic distance before and after the paragraph. (Using the before and after distance for
a paragraph eliminates the need to key a blank line between paragraphs and makes for a
much more professional document.)

Frame and Page Breaks - enables you to surround a paragraph with a border one one or
more sides, and control pagination effects (you can force a page break before the
paragraph, prevent the paragraph from breaking across pages, etc.). The Widow/Orphan
control option lets you specify the minimum number of lines that can be left on a page.

5 Make your changes, then click OK to apply the changes

Modifying Font Settings

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Select the text you want to modify, then choose Actions > Format > Font.
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4 Make your changes, then click OK to apply the changes to the selected text.

20.6 Bullets & Numbering

Several options are available for creating bulleted or numbered lists of one or more levels.

Modifying Bullet and Numbering Settings

1 Choose File > Workspace > Documents

2 Open the document you want to work with.

3 Place the cursor in the paragraph you want to modify, then choose Actions > Format > Bullets
and Numbering > Properties.
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4 The Bullets and Numbering settings window includes many settings to control the display:

Choose the style of list by clicking the appropriate graphic (None, Bullets, Numbers, or
Multi-Level

Bullet/Number Position - controls where the actual "bullet" displays relative to the margin

Text Position - controls where the text begins after the "bullet"

Separating Character - controls the "gap" between the bullet and the text

Level - sets the indent level

Bullet (these settings apply when a bullet style is chosen)

Character - the "bullet" to use

Size - the size of the bullet character in points

Number Format (these settings apply when a number style is chosen)

Number Style - the style used for the "numbers"

Text in Front - optional text to precede the number
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Start At - the starting "number" for the number series (normally 1)

Text After - optional text to follow the number (normally a period)

Restart Numbering/Continue List - whether the number series continues or restarts with the
"Start At" number at the selected paragraph

5 Make your changes, then click OK to apply the changes to the selected paragraph(s).

20.7 Using Database Fields

Inserting database fields into a document means that the appropriate data for the record being printed
will be substituted for the field name. In other words, if a document uses Membership Fields, you could
select the First Name field from the field list. This would create something like:

When the document is printed, the system will substitute "John" for "<<First Name>>" when it prints a
letter for the "John Smith" record.

Database fields can be used anywhere in the document (including within tables) with the exception of
Text Frames.  Embedded fields will not work inside a Text Frame because the frame isn't treated as a
part of the document for finding/replacing text.

Using database fields involves:

Adding fields to the document from the Field List

Choose the records to be printed by entering criteria settings

Adding Fields to a Document

1 Choose File > Workspace > Documents

2 Click the Show Fields button. The field list will contain the fields appropriate to the type of
document.
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Note: The default document that is automatically created when the Documents window opens
uses Membership Data. To use Group data instead, create a new document and pick Group
Data for the available fields.

3 Place the cursor where the field should go, and then click the field name in the list. The field
name will appear in the document.

Choose the Records to Print (criteria)

1 Click the Settings button to open the criteria for the document.

2 Document criteria works just like report criteria, or search criteria on the membership/group list.
For more information and examples see Entering Advanced Search Criteria. 

Use the settings window to enter the required criteria, then click Save to return to the document.

3 To see the records that will be found by the criteria, click the Show Data button.

Note: The columns displayed are only to help verify that the correct records were selected. They
do not necessarily correspond to the fields that have been used on the document.

 There are two Processing Style options on the Show Data window that control how the
document will print:

Generate and print each document immediately - this is the default option, simply
meaning that the system will generate a document, fill in any embedded fields, and
preview/print it immediately.

Generate all documents and print as one - this options causes the system to append
every document for every record into one large "master" document, and then send that
one large document to the printer.  This only makes sense on small jobs, when printing
to a PDF file.

4 To return to the document, click Hide Data.

Preventing Blank Lines

There are situations where telling the system to "delete the line" when the only thing on it is blank,
is helpful. We cannot force the software to do this automatically though, because there are times
when it wouldn't be appropriate. So this section explains how to "tell the system" what you want to
do.  For example, consider an address block like this:

<<Name (First/Last Name)>>
<<Address Line 1>>
<<Address Line 2>>
<<City/State/ZIP Code>>

If a record is missing data for Address Line 2, the output will show a blank line, like this:

John Smith
100 Main Street

Dallas, TX 75025
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In order to prevent this, create the address block and add a leading "@" symbol ahead of any field
that should get special treatment when blank, like this:

<<Name (First/Last Name)>>
@<<Address Line 1>>
@<<Address Line 2>>
@<<City/State/ZIP Code>>

The "@" symbol is never printed, but instead causes the system to effectively hit the backspace
key. So if the field is the first thing on the line, the "backspace" causes it to delete the line break
and jump up to the previous line.  The resulting output looks like this:

John Smith
100 Main Street
Dallas, TX 75025

This trick can also be used when fields are lined up on the same line.  For example:

Hello @<<First Name>>!

Becomes:

Hello John!

or if there is no first name,

Hello!

20.8 Using Criteria

The Report Settings window will contain two or more tab pages, depending on the report or document
you have selected. At a minimum, the General Settings tab and the Report Criteria tabs will be
available. 

The Criteria Settings tab enables you to restrict the records that will be shown on a report report by
entering one or more "Criteria". You have tremendous flexibility with these queries, and can create very
complex statements to precisely control which records are found and displayed on the report.

If you just want to see some examples, see Search Criteria Examples.

The Criteria Settings Tab
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Criteria is what actually controls which records will appear on the report. Will the report show every
member, or perhaps only members that live in "Boston?"  (This example shows members who live in
Boston, aged 50 or greater.) Maybe you want to see every member with an End Date in the next 30
days, because they need to be contacted for renewal. Maybe you only want members who attended a
particular activity on December 15 in a role of "sponsor" who have made a donation in the last 10 days
and are NOT part of the widget analysis committee. The possibilities are nearly endless, and very
powerful. 

Building Criteria 

Criteria is created row-by-row, with each row representing another criteria (you can think of it as a "rule")
that must be true for a given record to appear on the report. For example, if you are running a
membership report and use a criteria like, Last Name = Smith, then only membership records with
"Smith" in the Last Name field will be on the report.

1 Start a new criteria line by clicking the Add icon. A new blank row will appear.

2 Click the dropdown arrow in the Field Name column to open the selection window. Then, choose
the field whose data you want to check with this criteria. For example, if this criteria will restrict
the report to members in a certain city, expand the Address section and choose "City."

3 Click the dropdown arrow in the Operator column to open the selection window. Then, choose
the method that will be used to compare the data to the selected field.  For example, if you want
the city value to be equal to, "MyTown", you would choose "Equals".  

4 Click the dropdown arrow in the Value column to open an appropriate data-entry window. Then
enter the appropriate value to be compared to the selected Field. 

More than One Criteria

When you have several criteria rules you want checked the system needs to know if you mean "this
criteria AND that criteria" or whether you mean, "this criteria OR that criteria" since there is a big
difference. To control this, there is an option to specify AND or OR at the end of each row of criteria, to
tell the system how to link that criteria rule to the next.

Also remember that when using multiple criteria, every piece of the criteria (at least those with "and")
must be true for each record being shown on the report.  Therefore, if you use criteria like:

City = MyTown AND
City = YourTown

... the report won't show anything. This makes sense if you think about it, because no member has a
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city set to MyTown AND YourTown at the same time.  There is only one city on an address.

If the criteria was changed to:

( City = MyTown OR

City = YourTown )

...the report will work, because now it can find members with a city of MyTown OR a city of YourTown --
it doesn't have to match both at once.

Using Parenthesis 

The advanced criteria list includes options for left and right parenthesis. Parenthesis are very important if
you use an OR to join your criteria rows. Consider this criteria:

State = Texas AND 
(City = Mytown OR
City = YourTown)

This will require a state of Texas, and either a city of Mytown or a city of YourTown, because the AND
refers to all of the criteria grouped by the parenthesis.  However, if the parenthesis were omitted, the
criteria would look like this:

State = Texas AND 
City = Mytown OR
City = YourTown

This can produce unpredictable behavior, because now it essentially says, "state of Texas and city of
MyTown, or the city of YourTown without regard to the state".  Thus, records could be returned for
YourTown, Washington, and YourTown, Oregon, as well as YourTown, Texas.

Special Expressions using LIKE and NOT LIKE Operators

% The percent sign is used in conjunction with the word "LIKE" to search for data that begins, ends, or
contains specific text or numbers. For example, if you selected Last Name as the field, and LIKE as the
operator, you might enter any of the following in the Value field:

"Smith%" to get "Smith", "Smithe", or "Smithington.
"%burg" to get "Sederburg", "Frankenburg", "Hidelburg"
"%der" to get "Sederburg", "Fender", and "Derston"

You can also use the opposite of LIKE, which is NOT LIKE, to reverse the search requirement.

Complex Expressions Using LIKE and NOT LIKE Operators

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
each expression below would be preceded with LIKE or NOT LIKE.

Expression Searches for... Sample Return Data

Mc% Names that begin w ith the letters "Mc" McEvoy
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%er Names that end w ith "er" Brier, Miller, Weaver, Rayner

%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]ow ell Names ending w ith "ow ell" that begin 

w ith a single letter in the range M to Z

Pow ell

M[^c]% Names beginning w ith "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas the
_ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

If you want to see some examples, see Search Criteria Examples.

Address Criteria

When using MemberTies Professional, if you use address fields as part of your criteria, i.e., "City =
MyTown", and your membership records often include multiple addresses, you may want to use a
special criteria field called "Address to Use".  With this criteria, you can tell the report which address
you want it to look at when matching the City value.

If you don't use this criteria, the system will automatically assume you want to use the Current Address
whenever it needs to look for address data.  That means if a member has a Home Address in "MyTown"
and a Summer Address in "YourTown", the record won't be found unless the Home Address is marked
as Current on the membership record.

Include in Mailings, Include on Reports

These two options are available on membership records. A report preference controls whether these
"include" options are automatically enforced on  all reports.  By default they are enforced, so no report
will show any member with the Include on Reports check box cleared. However, if you manually use the
"Include on Reports" field as part of your criteria, you will override the default behavior.  The "Include on
Reports" field applies to non-label reports. The "Include in Mailings" field applies to mailing label reports.

20.9 Printing

All documents are first generated and displayed on the Print Preview window (see Processing Style
below). 

Printing a Document

1 Be sure the correct printer has been selected. Choose File > Printer Setup if necessary to
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change the printer in use.

2 Choose File > Workspace > Documents.

3 Select the document to be printed.

4 Verify the data to be used, if you have embedded database fields, by clicking Show Data, and
modify the Settings as needed. (If there are no fields in use, no settings or data apply -- the
document will only print one time, or however many copies are requested). There are two 
Processing Style options on the Show Data window that control how the document will print:

Generate and print each document immediately - this is the default option, simply
meaning that the system will generate a document, fill in any embedded fields, and
preview/print it immediately.

Generate all documents and print as one - this options causes the system to append
every document for every record into one large "master" document, and then send that
one large document to the printer.  This only makes sense on small jobs, when printing
to a PDF file.
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5 Click Print to open the Print Preview window for the first document.

If the document contains embedded Database Fields, the system displays the document for the
first record with embedded fields replaced with data for that member.  If there are no embedded
fields, the document is displayed as-is.

6 On the Print Preview window, the following options are available:

All Pages - Select this option to print everything. Clear this option if you want to specific a
specific start and end page.

From Page - the first page to be printed, if the All Pages option is not selected.

To Page -  the last page to be printed, if the All Pages option is not selected.

Copies - the number of copies to print

Printer Setup - enables you to change the printer (the current printer is displayed above
the "Entire Document" checkbox)

7 When you are finished, click the appropriate button:

Print - to print the current document and display the next 
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Print All - to print the current document and all subsequent documents without any further
preview display

Cancel - to cancel all printing

20.10 Using Images

An image can be inserted into a document from a file, and stored either as part of the document
(meaning the original image file is no longer needed), or as a link to the file (meaning the file must
always exist in order to display in the document).

Once added to the document, various properties can be modified to change how it is displayed or saved.
 For example, the image can be resized, set to flow with the text, etc.

Adding an Image

1 Choose File > Workspace > Documents

2 Open an existing document if necessary, and put the cursor at the position where the image
should appear.

3 Choose Actions > Insert > Image.

4 On the Choose File window, select the image file to use, then click Open. The image should
appear in the document.

Deleting an Image

1 Click the image to be deleted.

2 Press the Delete key on the keyboard.

Modifying Image Attributes

1 Double-click the image.
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2 The Image Attributes window includes three tab pages of settings:

Layout and Position - enables you to control the way text flows around the image, its
position, and alignment.

Size and Distance - enables you to control the actual size and scale of the image, how
much of a gap exists between the image and the surrounding text, and whether it is
moveable or resizable with the mouse. 

Saving Options - enables you to control whether the image data is stored as part of the
document (independent of the original file) or kept as a separate referenced file.

20.11 Using Tables

Tables can be inserted virtually anywhere in a document, and can even be inserted within other tables.
By default, the grid lines that identify the borders of the table (for editing purposes) are displayed, but
they can be turned off with the Grid Lines menu option.

Note: A table cannot be inserted when text is selected (i.e., it can't be used to replace selected text). In
addition, if a table is inserted immediately above or below an existing table, it will become part of the
existing table.  There must be at least one line of normal text between tables.

Adding a Table
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1 Choose File > Workspace > Documents

2 Open an existing document if necessary, and put the cursor at the position where the table
should appear.

3 Choose Actions > Insert > Table

4 On the Insert Table window, specify the number of columns and rows the table should have.  If
any value is left blank, the default is 2.

5 Click OK to insert the table.

Deleting a Table

1 Use the mouse to select the line preceding the table, plus all rows/columns of the table itself. 

Note: The selection must include the paragraph just before the table (the "anchor" if you will) so
the software knows you are trying to delete the whole table, not just the contents of the cells.

2 Press the Delete key on the keyboard.

Note: An alternate way to delete a table is to select all rows, then choose Actions > Table > Delete
> Row.  This can be useful if the table is the very first thing on the very first page, making it
impossible to select anything ahead of the table.

Modifying Table Attributes

Any set of cells can be modified at once, as long as the entire set of selected cells are within a single
table. i.e., if the table contains another table within it, you cannot select part of both tables and modify
them at once.

1 Select the cell(s) to be modified, then choose Actions > Table > Properties.
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2 The Table Properties window includes two pages of settings:

Frame and Color - enables you to change the gridlines around the selected cell(s),
background color, and the amount of space between the edge of the cell and the text
within.

Size and Formatting - enables you to set cell height, alignment, and whether the row can
break across pages.

3 Make your changes, then click OK to apply the changes to the selected cell(s).

Splitting a Table

This enables you to divide one table into two separate tables. A table can only be split if it contains the
current input position and no further text is selected.

1 Place the cursor on the row where you want to split the table.

2 Choose Actions > Table > Split > Above (or Below) to divide the table.

Note: To restore (un-split) a table, delete the text lines between the tables.
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20.12 Using Text Frames

An text frame can be inserted anywhere in a document, and can be set up so that surrounding text flows
around it. Text Frames are often used for precise position of images, blocks of text, etc.

Text Frames are essentially separate from the document itself.  You cannot search or replace text in a
Text Frame, and embedded fields will not work in them (because the system cannot "find" the
embedded field to do the data replacement).

Once added to the document, various properties can be modified to change how it is displayed and how
text flows around it.

Adding a Text Frame

1 Choose File > Workspace > Documents

2 Open an existing document if necessary, and put the cursor at the position where the frame
should appear.

3 Choose Actions > Insert > Text Frame.

4 A default-sized text frame will appear.

Deleting a Text Frame

1 Click the border of the frame to be deleted.

2 Press the Delete key on the keyboard.

Modifying Text Frame Attributes

1 Double-click the border of the frame
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2 The Text Frame Attributes window includes three tab pages of settings:

Layout and Position - enables you to control the way text flows around the frame, its
position, and alignment.

Size and Distance - enables you to control the actual size and scale of the frame, how
much of a gap exists between the frame border and the surrounding text, and whether it is
moveable or resizable with the mouse. 

Frame and Color - enables you to control the background color of the frame, the width of
the border, and the internal margin (between the text in the frame and the frame itself)

20.13 Using Styles

Styles allow you to create a consistent look within your document by assigning a name to a specific set
of format settings. i.e., "14pt bold Arial" might be settings for the "Heading 1" style.

Once your styles are ready, you can quickly assign them to text in your document, and that text will be
changed to match the style.

Styles can include formatting for the font, paragraph, tabs, and numbering.

Adding a Style
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1 Choose File > Workspace > Documents

2 Choose Actions > Format > Styles

3 Click New.

4 On the New Style window, provide a name for the style.  

Note: In this example we are creating a Heading 1 style, and we want the following paragraph to
revert to "Normal". i.e., after we type our heading and press return, the system will automatically
use Normal as the style for the next paragraph, rather than create another Heading 1 paragraph.

5 Click the Font button.
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6 Make any changes to the font that will be used with this style, then click OK. See Paragraph &
Font Settings for more information about this dialog.

Note: In this example, we want our Heading to use 14 pt Arial font, and be Boldface.

7 Click the Paragraph button.
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8 Make any changes to paragraph formatting for this style, then click OK. See Paragraph & Font
Settings for more information about this dialog.

Note: In this example, we want our heading to be separated from the preceding and following
paragraphs by .2 inches. Also, on the Frame and Page Breaks tab, we will set the "Keep With
Next" checkbox to ensure that a heading can't be separated from the subsequent paragraph by
a page break.

9 Use the Tabs and Numbering buttons to make changes to tab stops and/or bullets and
numbering style for this paragraph.  Since this example is creating a Heading, neither of these
options will be used.

10 Click OK to save the new style.

Applying a Style

Styles can be applied to selected text using the Style dropdown on the document toolbar.

1 Select the text to which the style should be applied.

2 Open the Style list and choose the desired style.
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Applying the "Heading 1" style automatically set the Font to Arial, the size to 14, and bold.



Part

XXI
Reports
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21 Reports

21.1 Reports Overview

MemberTies includes a selection of predefined reports, designed to provide printed access to the most
common information. There are, of course, hundreds of ways you might choose to use the system to
track your data, especially when you consider the options available with custom fields or items &
categories. If you are in need of a special report that is not available and cannot be created using the
user-defined reports capabilities in MemberTies Professional, let us know.  If the report you need makes
sense for general public distribution, we'll probably add it to the system. Otherwise, we can create
reports to meet specific requirements as "custom reports" for a fee.

When you select a report, a "Settings" window will normally appear to enable you to control various
things specific to the report you chose, such as the sort, the title, the label format, etc., In addition,
most reports accept "Criteria" to control which records are displayed on the report (i.e., a criteria might
be, "City = MyTown" to only display members of a particular city. In most cases, the system
remembers the settings you selected from one use of a report to the next.

Address Format

You may have a report settings option to choose the address format. The idea behind this is that if you
have addresses for both the United States and the United Kingdom (each of which have different address
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formatting requirements), you can set the address format for the United States, select only United
States addresses, print them, and then do the same for the United Kingdom. Only one address format
can be in use on a given report.

The "Current Address"

MemberTies Professional enables you to use multiple addresses per membership record. If the report
you are printing includes address data (or even if address data is allowed as criteria) it means the
system is making an association between the main data (say membership name information) and
address data. When this happens, the system needs to know which address to use in the event that
more than one is available.  If a Settings window is available for the report, part of the available criteria
will be the "Address to Use", and it will default to "Current Address".  Since every membership record
has one address marked as "current", that's the one that will be used on the report, unless you specify
otherwise.

Preview Mode

The "Preview Mode" checkbox on the Reports window toggles the view from preview mode to data mode.
If the report you are viewing has a header row that you want to be able to see while scrolling through the
report, turn Preview Mode off. When preview mode is off, the page count displayed on the report
represents the "screen page", i.e., what can be seen on the screen at one time is considered to be a
"page." To see how many pages a report will actually be when printed, turn preview mode back on.  

Note: Multi-column reports will display as a single long column if preview mode is turned off, because it
disables the formatting.

Report Fonts

The font used for reports and labels is specified in Report Preferences.
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Report Logo

The logo specified in Report Preferences will automatically appear on system and user-defined standard
reports, rosters, directories, and cards.

Report Margins

Printers vary widely.  The system uses a general setting for report margins designed to accommodate
most printers.  If your reports print the text a little too much to the right or left, you can adjust the margin
to pull or push the data on the report as a whole. See Adjusting Report Margins for more information.

Tips

Printer settings can be changed before printing the report by choosing File > Print Setup, or by
clicking the Setup button on the Print window. This will display whatever printer setup dialog is
available for your printer on your system.

If the report contains multiple pages, you can page through it using the Page Up, Page Down,
Home, and End keys, or by using the arrow buttons on the toolbar.

To regenerate the report using the current settings, click the Redisplay button.

To change report settings, click the Settings button.

The Report Settings window includes a checkbox labelled "Display Now." If this checkbox is
checked, the report will be generated and displayed as soon as the Report Settings window is
closed. If the checkbox is cleared, you must click Display on the Reports window after the Report
Settings dialog closes. This option is provided for you in case you want to save your report
settings, but need to verify something before retrieving a large amount of data.

You can create your own versions of various system-defined reports by taking advantage of the
Saved Report feature. See Saving Custom Reports for more information.

Click here for a list of system-defined reports. 

21.2 Adjusting Report Margins

You can adjust and save new margin settings for any report.  If your report text seems to start a little too
far to the left, for example, you can increase the left margin and "push" the entire report to the right a
little. 
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The above example is from the Mailing Labels report. The "Labels" section is enabled because it is a
label report, enabling you to modify additional details besides the margins.

Note: Report margin settings are partly dependent on the settings your PC has stored for your printer.
Many printers have an "Unprintable Area" property that allocates a certain portion of the page to white
space. To check the settings stored for your printer, display the properties for your printer via Windows
Control Panel and look for a setting similar to "Unprintable Area".  If you are printing a report that
requires zero margins on all sides, be sure your PC doesn't have a portion of the page automatically
excluded from printing.

Adjusting Margins

1 Be sure the problem report is displayed on-screen.

2 Choose Actions > Adjust Report Margins.

3 The Margin Settings window is divided into two sections. 

Margins Section - applies to all types of reports and labels and enables you to adjust the left,
right, top, and bottom margins of the report. Increasing the left margin, for example, "pushes" all
data on the report to the right.

Labels Section - is only available for mailing label reports and reports of similar "grid" style like
business cards or ID cards.  This section enables you to adjust the spacing between rows and
columns, and to change the order in which the report is printed (left to right, or top to bottom).  

4 Set the new margin settings. For USA paper format reports (i.e., not A4 paper), the settings
modified in 1/1000 inch increments, so a value of 125 represents 1/8 inch, 250 represents 1/4
inch, etc. European formats are modified in 1/1000 cm increments.

5 If applicable, select new label settings. The column and row spacing settings are in the same
increments as the margin settings, i.e., 1/1000 inch or 1/1000 cm.  The Print Pattern controls
whether labels print across the page from left to right, or column by column from top to bottom.
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6 If you click "Apply", the report displayed "underneath" the margin settings window will be
modified with your current settings. You may be able to move the margin settings window to the
left or right so you can see the effect of your changes.

7 When you are finished, click OK. 

Note: You can restore the default margin settings for the report by clicking the Default button, then
clicking OK to save.

 

21.3 Using the Print Window

The Print window enables you to control the way a report is printed.

The following fields are available:

Printer - The printer to be used.

Setup - Opens the printer setup dialog for the selected printer.

Print Range - Indicates the number of pages to print



MemberTies399

©1998-2014 Myrro International

All - Select this option to print all pages displayed on the report.

Range - Select this option to specify a From and To range of pages to print.

Selection - Select this option to specify a non-contiguous set of pages to print, i.e., 1, 3, 5-7, 10

Pages to Include - Indicates whether to print odd or even pages

All Pages - Select this option to include both Even and Odd numbered pages.

Even - Select this option to only include even-numbered pages.

Odd - Select this option to only include odd-numbered pages.

Other Options (these options may or may not be supported on your printer)

Duplexing - Select whether to print one-sided (simplex) or two-sided (duplex) vertical or
horizontal

Paper Source - Select the paper tray to use on your printer

Print Quality - Select the output quality

Number of Copies - The number of copies of the selected pages to be printed.

Save Settings as Default - Select this option before clicking Print or Close to retain the selected
settings.

Print - Sends the output to the printer.

21.4 Setting the Default Club

One group record in your database can be specified as the Report Default. The group with this setting
will be the default group displayed in dropdowns when you use the group as criteria. Note that if you do
not relate any membership records to specific groups, you should not set a default group. Leaving the
default unspecified will cause reports to default to (All Groups), which just means that membership
reports won't worry about group relationships when selecting members.

Setting the Default Group

1 Choose File > Workspace > Group List.

2 Select the group you want to use as the default.

3 Choose File > Open Group.  You can also click the Open toolbar button. This will open the
Details window for the group.

4 On the Status tab, select the Report Default checkbox.
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5 Click OK.

6 If another group is currently set as the report default, you will be prompted to confirm the
change.

 

21.5 Printing a Report

All reports are essentially printed the same way.  You simply choose the report you want, retrieve it
using any appropriate criteria or settings, and then print.

Printing a Report

1 Choose File > Workspace > Reports.

2 Select the desired report from the report selection dropdown. 

3 On the report Settings window (if available for the selected report), select options to restrict the
records found by the report. See Using the Report Settings window for information about each
available setting. When you have made all your selections, click OK to display the report.

4 Choose File > Print, or click the Print toolbar button.

Did it print correctly?

You may need to compensate for printer differences by adjusting the report margins.

21.6 Deleting Report Definitions

Any report stored in the database can be deleted, even preloaded default reports. Use caution when
deleting the system-defined reports -- once they're gone, they're gone forever.  If you want to remove a
report from the dropdown without actually deleting it, use Report Preferences to change the list of active
reports.  If a report is marked as inactive, it will no longer appear in the list.

Deleting a Report Definition

1 Choose File > Workspace > Reports.

2 Select the desired report from the report selection dropdown. 
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3 When the report is displayed, choose Actions > Delete Report Definition.

4 Confirm the deletion.

Note: The report will remain on-screen until you select a different report or close the Reports
window.

21.7 Saving Report Definitions

If you select a report that can be customized via a Report Settings window, you can save the settings as
a new report definition. This is different than saving a report for reloading as a .psr formatted report.
Saving the definition enables you to select the saved report from the report selection dropdown list on the
Reports window as if it were a normal report, and even modify the settings -- just like it was a normal
system report.

This is a great way to "extend" a predefined report or save versions of it with different criteria that you
use frequently. For example, the Phone List report just prints a member's name and phone number(s).
However, if you select criteria for City, and then save the report as "Phone List for City", you can easily
return to that report and the criteria will already be there. This speeds the process of running reports,
especially if you have complex criteria defined. 

Saving a Custom Report Definition

1 Choose File > Workspace > Reports.

2 Select the desired report from the report selection dropdown. 

3 When the report is displayed, choose Actions > Save Report Definition.

4 Enter the name of the report as you would like to see it in the report selection dropdown. Keep
this name short!

5 Click OK. 

The report will appear in the report selection dropdown until deleted.

21.8 Troubleshooting

This topic is intended to provide answers to the most common problems/questions surrounding reports.

If the answer isn't here, be sure to look at available Report Preferences.

Problem Solution

Columns too Narrow System Reports: Column widths on system reports are set at the most
common width. It isn't possible to support all possible data on a generic
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report. If you find a column is grossly off on all records, contact support
and we'll see what we can do.

User Defined Reports: Column widths default to a generic width, but you
can set the width of any column using the Preview tab when maintaining
the report. See Working with User Defined Reports for more information.

Duplicate Records Typically, the criteria used, combined with the type of report causes
certain records to be matched twice.  For example, if a normal
membership report such as the Contact List is run using dues criteria
like "Dues Amount Posted = 10.00", it may show a member once for
every 10.00 posting on the member's record.  

The only solution is to add more criteria to restrict the search more
tightly. For example, you may only want to see 10.00 postings in
February, not for all time.

Incorrect Sort Order Most reports have several available sort order options, provided on the 
General Settings tab of the Settings window.

Label Not Available If you need to use an Avery label format that we don't have listed, contact
support and we can add it to the system.

Margins Incorrect See Adjusting Report Margins for more information.

Missing Records Usually caused by one of the following:

1 The criteria entered on the Criteria Settings tab of the Settings
window is excluding them. i.e., a criteria like "City = Dallas" will
exclude any member in any other city. 

Also, criteria like, "City = Dallas AND City = Austin" will
eliminate all members, because it is requiring a member be
assigned to both cities at once! In this case, the correct criteria
would be, "City = Dallas OR City = Austin" to see members from
either city.

2 The "Include on Reports" or "Include in Mailings" checkbox is
turned off on the member record(s) in question.  Clearing these
check boxes will automatically exclude a member from a report
or mailing label, respectively, unless you explicitly use the
Include on Reports or Include in Mailings field in your criteria.

i.e., if you have "Include in Mailings = Any" as a criteria on a
label report, then it doesn't matter what the checkbox is set to
on the member record. 

Multi-Column Report
Shows as One Column

Multi-Column layouts only display as multiple columns when the Print
Preview checkbox is selected in the upper-right corner of the Reports
window.
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Text Cut Off The "preview" display sometimes shows the top or bottom edge of text
slightly cut off, especially on reports where the number of lines per record
varies (i.e., on a roster or mailing label).  This normally has no effect on
the actual printed output, and turning off the Print Preview checkbox
normally shows the text is all there.

Too Many Reports The reports list shows all user-defined reports, and all reports marked as
Active in preferences. To reduce the number of reports, turn off unused
reports in Preferences. Another report preference enables you to restrict
the reports shown by restricting Paper Sizes (i.e., only A4 format, or only
US Letter).

Too Many Records Usually caused by incorrect criteria, or no Criteria Settings were used.

Report criteria is what limits the records displayed on the report.  By
default, every report displays every possible record in the system. So a
membership report will show all members that apply to the report.  But
criteria like, "Dues Balance > 100.00" will limit the report to members
with a balance over 100.00.

Database Error This rarely happens, but when it does it normally means you have found
a combination of criteria that the system didn't expect, so it didn't write
the internal query correctly.  Contact support and we will be able to
correct the problem.

21.9 Entering Report Criteria

21.9.1 General Settings

The Report Settings window will contain two or more tab pages, depending on the report you have
selected. At a minimum, the General Settings tab and the Criteria Settings tabs will be available. The
General Settings tab is used for details like the report title and sort options, while the Report Criteria tab
is used to restrict the records that will be shown by the report.

The Settings window displays immediately when a report is selected, or may be reopened by clicking
the Settings button on the Reports window.

The General Settings Tab
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This tab contains various general options for the report that do not affect which records are returned.

Report Title - If the report contains an editable title, you may change it here. 

Sort Order - If the report sort order can be changed, you may change it here. (Some complex
reports, such as reports with built-in grouping levels, have a preset sort order that cannot be
changed.)

Address Format - If the report contains an address block, this field enables you to choose the
address format to use for the report.

Label - When printing mailing labels, this field enables you to choose the label format to use. (If you
need to use a type of label that is not listed, contact us to request a new format.)

Remove Duplicate Record from Results - select this option if the criteria you are using for the
report tends to bring back duplicate results. For example, say member John Smith has attended
both Activity A and Activity B. if you run a report with criteria using an "OR", such as "(Activity A OR
Activity B)" to find members who have been part of either activity, the record for John Smith will
probably appear twice, because he attended both activities, and therefore matches both criteria. 
Selecting this option should cause the report to only show John Smith.

Note that this will only work of the records are completely identical.  If in the above example, if the
activity name itself is shown on the report, John Smith will still display twice. That's because the two
records for him on the report are not identical (the Activity Names are different) so each record in the
results is unique already unique.  In other words, this option tries to eliminate duplicate results not
duplicate members.  If instead the report was something like a membership Contact List, and you
used the activity name (which is not shown on the report) as criteria as described above, this option
would work as expected. 

Be careful using this option when posting amounts are displayed on the report!  Two entries of $10
on the same day could be reduced to one in the right situation, causing inaccurate results.

When this Report is Selected in the Future - This setting essentially determines whether or not
this settings window should open the next time you run this report. If you choose to run the report
immediately, the report will be automatically displayed using the current settings.  If you want to
change the settings, you can still do so by clicking the "Settings" button on the Reports window.
This is helpful of you do not normally need to adjust the report settings.

21.9.2 Criteria Settings

The Report Settings window will contain two or more tab pages, depending on the report or document
you have selected. At a minimum, the General Settings tab and the Report Criteria tabs will be
available. 

The Criteria Settings tab enables you to restrict the records that will be shown on a report report by
entering one or more "Criteria". You have tremendous flexibility with these queries, and can create very
complex statements to precisely control which records are found and displayed on the report.

If you just want to see some examples, see Search Criteria Examples.

The Criteria Settings Tab
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Criteria is what actually controls which records will appear on the report. Will the report show every
member, or perhaps only members that live in "Boston?"  (This example shows members who live in
Boston, aged 50 or greater.) Maybe you want to see every member with an End Date in the next 30
days, because they need to be contacted for renewal. Maybe you only want members who attended a
particular activity on December 15 in a role of "sponsor" who have made a donation in the last 10 days
and are NOT part of the widget analysis committee. The possibilities are nearly endless, and very
powerful. 

Building Criteria 

Criteria is created row-by-row, with each row representing another criteria (you can think of it as a "rule")
that must be true for a given record to appear on the report. For example, if you are running a
membership report and use a criteria like, Last Name = Smith, then only membership records with
"Smith" in the Last Name field will be on the report.

1 Start a new criteria line by clicking the Add icon. A new blank row will appear.

2 Click the dropdown arrow in the Field Name column to open the selection window. Then, choose
the field whose data you want to check with this criteria. For example, if this criteria will restrict
the report to members in a certain city, expand the Address section and choose "City."

3 Click the dropdown arrow in the Operator column to open the selection window. Then, choose
the method that will be used to compare the data to the selected field.  For example, if you want
the city value to be equal to, "MyTown", you would choose "Equals".  

4 Click the dropdown arrow in the Value column to open an appropriate data-entry window. Then
enter the appropriate value to be compared to the selected Field. 

More than One Criteria

When you have several criteria rules you want checked the system needs to know if you mean "this
criteria AND that criteria" or whether you mean, "this criteria OR that criteria" since there is a big
difference. To control this, there is an option to specify AND or OR at the end of each row of criteria, to
tell the system how to link that criteria rule to the next.

Also remember that when using multiple criteria, every piece of the criteria (at least those with "and")
must be true for each record being shown on the report.  Therefore, if you use criteria like:

City = MyTown AND
City = YourTown

... the report won't show anything. This makes sense if you think about it, because no member has a
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city set to MyTown AND YourTown at the same time.  There is only one city on an address.

If the criteria was changed to:

( City = MyTown OR

City = YourTown )

...the report will work, because now it can find members with a city of MyTown OR a city of YourTown --
it doesn't have to match both at once.

Using Parenthesis 

The advanced criteria list includes options for left and right parenthesis. Parenthesis are very important if
you use an OR to join your criteria rows. Consider this criteria:

State = Texas AND 
(City = Mytown OR
City = YourTown)

This will require a state of Texas, and either a city of Mytown or a city of YourTown, because the AND
refers to all of the criteria grouped by the parenthesis.  However, if the parenthesis were omitted, the
criteria would look like this:

State = Texas AND 
City = Mytown OR
City = YourTown

This can produce unpredictable behavior, because now it essentially says, "state of Texas and city of
MyTown, or the city of YourTown without regard to the state".  Thus, records could be returned for
YourTown, Washington, and YourTown, Oregon, as well as YourTown, Texas.

Special Expressions using LIKE and NOT LIKE Operators

% The percent sign is used in conjunction with the word "LIKE" to search for data that begins, ends, or
contains specific text or numbers. For example, if you selected Last Name as the field, and LIKE as the
operator, you might enter any of the following in the Value field:

"Smith%" to get "Smith", "Smithe", or "Smithington.
"%burg" to get "Sederburg", "Frankenburg", "Hidelburg"
"%der" to get "Sederburg", "Fender", and "Derston"

You can also use the opposite of LIKE, which is NOT LIKE, to reverse the search requirement.

Complex Expressions Using LIKE and NOT LIKE Operators

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
each expression below would be preceded with LIKE or NOT LIKE.

Expression Searches for... Sample Return Data

Mc% Names that begin w ith the letters "Mc" McEvoy
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%er Names that end w ith "er" Brier, Miller, Weaver, Rayner

%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]ow ell Names ending w ith "ow ell" that begin 

w ith a single letter in the range M to Z

Pow ell

M[^c]% Names beginning w ith "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas the
_ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

If you want to see some examples, see Search Criteria Examples.

Address Criteria

When using MemberTies Professional, if you use address fields as part of your criteria, i.e., "City =
MyTown", and your membership records often include multiple addresses, you may want to use a
special criteria field called "Address to Use".  With this criteria, you can tell the report which address
you want it to look at when matching the City value.

If you don't use this criteria, the system will automatically assume you want to use the Current Address
whenever it needs to look for address data.  That means if a member has a Home Address in "MyTown"
and a Summer Address in "YourTown", the record won't be found unless the Home Address is marked
as Current on the membership record.

Include in Mailings, Include on Reports

These two options are available on membership records. A report preference controls whether these
"include" options are automatically enforced on  all reports.  By default they are enforced, so no report
will show any member with the Include on Reports check box cleared. However, if you manually use the
"Include on Reports" field as part of your criteria, you will override the default behavior.  The "Include on
Reports" field applies to non-label reports. The "Include in Mailings" field applies to mailing label reports.

21.9.3 Selecting a Criteria Field

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.

The Select Criteria Field window enables you to choose the Field whose data you want to compare.  
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The window organizes the available fields into a simple tree display, grouping the fields by general types,
or sections. There will be one or more sections available, each containing a number of fields. The Activity
section contains fields for activities, attendance, and activity locations; the Members section contains
contact fields from the membership record, and so on.

Note: The Address, Custom Field, and Assigned Item fields are specific to the primary data type of the
report. i.e., on a Member data report, the address fields only relate to member data. Even if you select a
Group field as criteria, the fact that the report is primarily a membership report means the address fields
are for member addresses.

Special Criteria Behavior

Some types of criteria can cause more records to be excluded than expected, depending on the type of
report and the criteria used. For example, a membership report is by definition focused primarily on
membership data. However, if you use a Group Name as criteria you're bringing in a whole other area of
the system and tying it to the report. That means that now only members who are part of at least one
group can be considered at all. In other words, the system will first determine what members are tied to
ANY group, and then narrow that to those who belong to the group name you specified with your criteria.
 A member who doesn't belong to any group will be excluded before the group name is even considered.

21.9.4 Selecting an Operator

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.
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The Select Operator window enables you to specify the way the criteria value you choose will be
compared to the value of the field in the database.  For example, if the field is "Last Name" and you
choose "Not Equal (<>)" for the operator, then whatever value you enter must NOT be in the last name
field. i.e., Last Name <> Smith means "no members with a last name of smith"

The list will contain options appropriate to the field chosen. For example, if you choose a freeform text
field like "Address Line 1", all options will be available, including the LIKE and NOT LIKE operators for
expressions (see below). However, if you choose a field that uses a dropdown list of values (such as
Country), the only options will be Equal and Not Equal. As soon as you select an operator, the window
will close and the selection will appear on the list.

The following operators may be available:

Equal - indicates that the field data must exactly match the value

Not Equal - indicates that the field data must not match the value

Greater Than - indicates that the field data must be larger than the value.  For numeric values, it
means the data must be numerically larger. For text values, it means the data must sort
alphabetically after the value. i.e., "> b" means the data must start with "c-z".

Greater Than or Equal - indicates that the field data must be equal to or larger than the value. See
"Greater Than".

Less Than - indicates that the field data must be smaller than the value.  For numeric values, it
means the data must be numerically lower. For text values, it means the data must sort
alphabetically before the value. i.e., "< d" means the data must start with "a, b, or c".

Less Than or Equal - indicates that the field data must be equal to or smaller than the value. See
"Less Than".

LIKE - indicates that an expression will be used to match data to a value using the % "wildcard"
character. i.e.,  "%smith%" will search for the word "smith" within the data, since the leading and
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trailing % symbols indicate that any text can come before or after the word.

NOT LIKE -  indicates that an expression will be used to look for non-matching data using the %
"wildcard" character. See "LIKE".

RLIKE - Similar to LIKE, but with regular expressions.

NOT RLIKE - Similar to NOT LIKE, but with regular expressions.

21.9.5 Selecting a Criteria Value

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.

The advanced search list has to do a lot of thinking in the background to be sure the right options are
presented to you based on the field you select. For this reason, separate windows must pop up to help
you enter the Operator and the Value. To enter this information, simply click the appropriate field on the
list, and the necessary window will appear.

Note: To search for records with a blank value, leave the value field empty. i.e., criteria like, "Email
Address = (blank)" will find records with nothing in the email address field.

Entering a Text Value

The above example shows the entry field for a plain text value.  The Enter Criteria Value window creates
the appropriate type of entry field for the chosen Field Name. Since most fields in the system (such as
"Last Name") are standard text fields, the input field will normally let you type whatever you wish.
However, some fields have special values that must be selected in a special way. For more information
about these special values, please choose one of the following:

Entering a Checkbox Value

The available checkbox options for criteria purposes are:
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Selected - the checkbox on the record must be selected

Not Selected - the checkbox on the record must be clear

Any - it doesn't matter whether the checkbox is selected or not. This is useful when the criteria
cannot be deleted, but needs to be ignored.

Entering a Date Value

There are a number of ways to specify a date. It can be relative to the current date, a specific day, or a
specific kind of date. Please see Entering Date Criteria for details.

Entering a Status Value

When the membership status is used for criteria, the Enter Criteria Value window displays a list of all
available statuses.  You may either select the statuses individually, or the Options button will display a
popup menu of quick select choices.

Note: If you choose more than one status the criteria list will display, "Multiple Statuses" rather than
attempt to list them all.
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Entering a Dropdown List Value

Fields that display as lists in the application show similarly when used as criteria. 

21.9.6 Entering Date Criteria

There are several options available for entering a Date criteria value to provide additional flexibility. You
can specify a particular date, a predefined range of dates, or a relative date based on the current day (i.
e., today + 5 days).  

For example, these options enable you to set up a report to always retrieve records where the End Date
is less than 30 days from the day the report is run, i.e. (End Date < Current Date + 30) as shown in the
example below.

Note: "Current Date" is always the day the report is run.

The following options are available:

Use - This field determines how the date criteria is going to behave. There are several options:

No Date - to find records where the date in question is blank.

Specific Date - to find records matching a specific date

Current Date (Today) - to find records matching the current date

Tomorrow - to find records matching the current date +1 day

Yesterday - to find records matching the current date -1 day

Current Date (Adjusted +/- Days) - to find records with a date relative to the current date. A
negative number such as "-10" means the date must fall within the preceeding 10 days. A positive
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number such as "30" means the date must fall within the following 30 days.

The rest of the options are predefined ranges. For example, if the report is run on 5/28/2005, the
"Last Month" option means "4/1/2005 - 4/30/2005", and "Month to Date" means "5/1/2005 -
5/28/2005", and "Last Year" means 01/01/2004 - 12/31/2004.

Date - This field is only enabled when the "Use" field is set to "Specific Date" so you can choose the
date.  

Adjusted - This field only appears when the "Use" field is set to "Current Date (Adjusted +/- Days). Its
usage is described above.

21.9.7 Saving Criteria

Criteria can be saved and then reopened later when you want to run a particular search again.  This is
particularly helpful for complex searches that take a lot of time to set up.

Note: Reports are normally primarily geared toward activity, membership, or group data. If you save a
query for a membership report, it will be available on every other membership report as well.

Saving Report Criteria

1 After your criteria is working correctly on the Report Settings window, click the Save icon
located on the Criteria Settings tabpage.

2 When the "Save As" window opens, enter a name for the search criteria such as, "Expired
Dues" or "Committee Members".

3 Click OK.  The system will verify that the search layout is valid, and then will save it under the
specified name.  

4 To reload the search, click the Open/Browse button and select the desired search.

21.9.8 Exporting or Importing Criteria

Any report criteria, as well as criteria created on the activity, group, or membership list search tab using
the Advanced Search option can be exported to a file. This can be helpful if you need to create criteria
for another non-networked user, or if you need to send confusing criteria settings to the Support group for
analysis or help.

Criteria is saved to a special ".mtx" (meaning "MemberTies export") file. These files can be used to
import the criteria later, as long as no criteria already exists by the same name (unless you want to
overwrite it).

Note: Do not attempt to modify the exported file using any kind of word processor or text editor.  It
contains some fairly complex data structures, and altering the file may render it unusable.

Exporting Criteria to a File

Before criteria can be exported, it must first be saved.  If you haven't saved the criteria settings yet, see 
Saving Criteria for details.
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1 On the Activity, Group, or Membership List, go to the Search tab, choose Advanced Criteria if
necessary, and click the Load icon,

or...

On the Report Settings window, right-click the criteria list and click the Load icon

2 On the Saved Search Criteria window, use the right mouse button to click the saved criteria you
want to export, then choose "Export to File..." from the popup menu.

3 Click OK when prompted to confirm the export.

4 When the "Save Criteria As" window opens, enter the name of the export file you want to create,
then click Save.

Importing Criteria

Saved criteria can only be imported to the same software version that was used to export it.  That means
if you export a file using MemberTies version 6.0, you cannot import it to version 6.1. This prevents
potential conflicts that could arise due to database or programming changes.

In addition, you can only import criteria to the same place. In other words, criteria exported from the
Membership List cannot be imported to the Group List, or to Reports.  Criteria is specific to the area of
the program where it was created.

1 On the Activity, Group, or Membership List, go to the Search tab, choose Advanced Criteria if
necessary, and click the Load icon,

or...

On the Report Settings window, right-click the criteria list and click the Load icon

2 On the Saved Search Criteria window, use the right mouse button to click anywhere in the list,
then choose "Import from File..." from the popup menu.

Note: It does not matter whether you click on a row or not, just click anywhere in the list.

3 Click OK when prompted to confirm the import.

4 When the "Select Import File" window opens, enter the name of the previously exported file you
want to import, then click Open.
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5 A message will be displayed for you to confirm the criteria being imported. If you want to
continue, click OK.

6 If the criteria being imported already exists, you will be prompted to overwrite the existing data.

7 If the import is successful, the new criteria will appear in the list and will be immediately ready
for use.

21.9.9 Search Criteria Examples

This topic provides various examples of more complex Advanced searches, as sell as ways to use
complex expressions in Basic searches.

Here are some common searches:

Desired Result Criteria Example

Field Operat
or

Value

Members with a Chicago address City = Chicago

Members with an End Date in the next 30
days

End Date
End Date

>
<=

Today AND
Today +30

Members with a negative dues balance Dues Balance < 0.00

Everyone except "Alumni" status Status <> Alumni

Members with at least 2 relationships Count of Associations >= 2

Members with no email address Email = [leave blank]

Members with no email address (another
option)

Email NOT
LIKE

%@%

Members with a phone number starting with
555

Home Phone LIKE 555%

Complex Expressions

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
each expression below would be preceded with LIKE or NOT LIKE.

These can be used in any Basic search window, or when using LIKE or NOT LIKE in an Advanced
search criteria entry.

Expression Searches for... Sample Return Data

Mc% Names that begin with the letters "Mc" McEvoy
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%er Names that end with "er" Brier, Miller, Weaver, Rayner

%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]owell Names ending with "owell" that begin 

with a single letter in the range M to Z

Powell

M[ ĉ]% Names beginning with "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas the
_ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

The following examples illustrate various uses of the Advanced search criteria capability:

Finding Expired Members

This search illustrates what it might look like to search for all members whose membership (and
probably their dues) have expired.  Since MemberTies assumes that you will reset the End Date to a
point in the future when someone pays their dues, it can also be assumed that anyone with an End
Date in the past is probably past due.

The Status on the first row displays "Multiple Statuses," because we have selected each status that
pays dues. The value for End Date displays as "Current Date," meaning that the date in the query
will always be "today." The system takes care of replacing the date for you when the search runs.

With these settings, this search will only find records that pay dues and have an End Date in the
past.

Note: Using MemberTies Professional, you can post dues as debits and credits.  Therefore, it might
be equally logical to assume that any member with a Dues Balance less than 0.00 is past due.  You
could accomplish this using the Dues Balance criteria field name.

Using a Date Range

These examples illustrate two different ways to search for all records with a Start Date that falls
within the month of November.
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Example (1) uses the ">="  and "<=" operators to request any date that is greater than, or equal to
November 1, AND less than or equal to November 30. 

Example (2) accomplishes the same thing by using the ">" and "<" operators to request any date
that is greater than October 31, and less than December 1.

Both queries will only return records with a Start Date within the month of November.

Using a Relative Date

This example illustrates how to search for a relative date, i.e., all records with an End Date that
occurs within the next 30 days. 

Notice that on the Enter Criteria Value window, the Current Date option is selected, and 30 is
entered into the Adjusted field.  This tells the system to find records with an End Date starting
today, and going +30 days into the future. 

Likewise, you could enter -30 to find records with an End Date within the previous 30 days.

Correct vs Incorrect Use of "AND" and "OR"

These examples attempt to retrieve all members of the Johnson family living in Berryville and
Birmingham. 
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Example (1) is incorrect, because it is telling the system to retrieve anyone in Berryville, and then
only Johnson family members in Birmingham.

Example (2) solves this problem by simply surrounding the city portion in parenthesis. Now the
query tells the system the records must have city of (Berryville or Birmingham), and a last name of
Johnson. This query will bring back a much smaller set of records.

21.10 Report Descriptions

21.10.1 Activity Attendance

This report is groups attendance information by activity name. For each activity, attendees are listed in
alphabetical order, including their attendance dates, role, and status.

21.10.2 Activity Attendance by Group

This report displays activity attendance for members associated with one or more Groups.  

Note: If a member is not associated with a group, neither it nor its friend/family will appear on this report,
regardless of existing activity attendance.  Since a Group is the top level of the report, members (or the
parent member of a friend/family record) must be assigned to a group in order to appear.

The Activity by Group report is similar to this report but will list groups with no attendance of any
activities.

21.10.3 Activity Attendance Totals

This report provides the attendance and income/expense balance for each activity.

21.10.4 Activity Balance

This report is designed to display the overall income/expense balance for "how did this activity do"
decision making. Entries are grouped by activity name to simplify the display of activities that occur
repeatedly. Totals are shown for each activity, and an overall grand total is included.
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21.10.5 Activity by Group

This report displays activity attendance for all groups.  This report is similar to the Member Activity by
Group report, but this report will list ALL groups, and all group members who have attended an activity. If
no members have attended any activities, the report will indicate zero attendance.

21.10.6 Activity by Attendee

This report is designed to display the activities with which a given attendee has been associated. The
report groups data by attendee, and displays general attendance information about each attendee,
including start/end date, total hours, role, status, and any guest names.

21.10.7 Activity by Sponsor

This report is designed to display the activities with which a given member has been associated when
they have been associated to a specific sponsor. The report groups data by sponsoring member first,
then by activity, then by attending member. It then displays general attendance information about each
attending member, including start/end date, total hours, role, status, and any guest names.

21.10.8 Activity Counts - By Date

This report has two grouping levels, first by activity, then by month within the activity. Within each
month, the total attendance is broken down by week. Daily and weekly averages, as well as the high
and low attendance days are also provided.

21.10.9 Activity Counts - By Date/Time

This report breaks down each activity by day and provides the number of attendees per hour (based on
the start time). 

21.10.10Activity Detail

This report displays complete information about an activity. Everything that appears on the Activity
window is included, as well as additional details for the selected location.

21.10.11Activity Detail (w/Absentees)

This report is exactly like the Activity Detail report, but it also includes a section showing all members in
the database who did not attend the activity.

The "absentee" portion can be quite extensive, so running this report is not recommended for large
organizations. i.e., if the entire membership typically attends the activity you run the report for (via
Criteria), you should be fine. But if you have 100,000 members and only 50 attend the activity, you don't
want a list of 99,950 absentees, because the report will be hundreds or thousands of pages! 
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(If you have a large organization, use the normal Activity Detail report for attendees, and then run a
separate membership report like the Contact List, and use the "Absent from Activity" member criteria
to only select members who didn't attend the activity in question.)

21.10.12Activity Check-In Not Found

This report displays the contents of the Unattended Mode "Not Found" log.  

21.10.13Activity Hours by Attendee

This report is designed to display the activities with which a given member or friend/family member has
been associated. The report groups data by attendee, and displays the activity start/end dates, the
hours:minutes in attendance (based on the start/end date/time) and the role and attendance status.

21.10.14Activity List

This report provides a brief line by line listing of each occurrence of an activity, including its start/end
dates and location.

21.10.15Activity Sponsorship Counts

This report provides a brief listing by sponsor of all members they have sponsored, the activity it was for,
and the date.  Totals are provided by sponsor.

Note: The Date displays the attendance start date, or the activity start date if there was no date on the
attendance entry itself.

21.10.16Activity Summary

This report is an extension of the Activity List report. In addition to dates and locations, this report
displays the total income, total expenses, balance, and attendance.

21.10.17Activity Totals by Type

This report displays a summary of attendance by type of activity. i.e., Meeting, Dinner, Movie Night, etc.
This is designed to help you know what types of activities are more popular, for example.

The report shows the total attendance and postings balance by gender, as well as the overall balance. 

21.10.18Activity Type by Attendee

This report lists activity attendance information for each attendee, grouped by type of activity.
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21.10.19Anniversary List

This report provides a list including the anniversary date, name, and membership status of all
membership records with an anniversary date set.

21.10.20Assigned Items

There are four assigned items reports

Assigned Items (Groups) - This report lists all items, and for each item, shows the groups that have
been assigned the item.

Assigned Items (Members) - This report lists all items, and for each item, shows the members that
have been assigned the item.

Assigned Items by Group - This report lists all Groups, and for each group, shows the items that have
been assigned.

Assigned Items by Member - This report lists all Members, and for each member, shows the items
that have been assigned.

Assigned Items Phone List - This report is almost identical to the Assigned Items (Members) report,
with the addition of the Home, Work, and Other Phone number fields for each member. 

On each report, the number in parenthesis next to the category, item or member/group name indicates
the total number of items assigned beneath it. 

The categories and items displayed on these reports are sorted according to the Ranking set up for
each. See Maintaining Categories & Items for more information about ranking items.

21.10.21Birthday List

This report provides a list including the birth date, name, and membership status of all membership
records with a birthdate set.

21.10.22Birthday List (+Family)

This report provides a list including the birth date, name, and membership status of all membership and
friend/family records with a birthdate set.

Any Friend/Family records are displayed and sorted within the list by birthdate. These entries include
the association type (son, daughter, etc.).

21.10.23Group List

This report is a simple line-item listing of basic group data, including Group Name and contact
information.
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21.10.24Group Membership

This report is grouped by Group Name, and lists the name and member ID of all members assigned to
each group.  If no selection criteria is used, the report will automatically display all members for all
groups.

Note: When using report criteria with this report, any address criteria apply to the Group record, not the
members. i.e., if you use criteria like, "City = MyTown", it means the city on the Group record should be
"MyTown". Associated membership records are not examined for address criteria.

21.10.25Compact Membership List

This report is a "minimal" listing of basic address and phone number information. It provides name, home
phone, email address, street address, city, state, and postal code in a columnar format. This report will
not work for you if your address data is longer than average.

21.10.26Compact Membership List 2

This report is similar to the Compact Membership List report, but it includes a different set of fields -- the
Status, Home Phone, Email Address, End Date, and Include in Mailings fields.

21.10.27Contact List

This report lists basic membership contact information. It provides name, home phone, work phone,
email address, and membership status in a columnar format.

21.10.28Contact List (+Family)

This report lists basic membership contact information, including the names of any Friend/Family
records. It provides name, home phone, work phone, email address, and membership status in a
columnar format.

Friend/Family names are listed with the main member, indented slightly, and include the association
type (son, daughter, etc) and contact name/number.

21.10.29Credit Cards on File

This report provides the details of all credit/debit cards on file. Access to this report is controlled by the
View Credit Card Data Security Group settings. If the current user does not have access to create credit
card entries on membership records, they also do not have access to this report.

Note: Credit card information should be considered sensitive data. Myrro International cannot be held
responsible for any use or misuse of credit card data stored or printed using this software. A security
preference is available to restrict access to credit card data and reports to specific users.
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21.10.30Deposit Detail

This report prints the details of one or more Deposits.

21.10.31Directory Listing

There are four variations of the Directory Listing report, splitting the page into two, three, or four columns,
plus a "photo" version that is a two column directory with a small member photo on the left side of the
block of information.  You can choose the best report for your needs based on the format of your data
(length of addresses, etc.). All reports include name, address, phone, and email data.

The report is similar to the Roster reports, but contains more information. The Directory Listing includes
separators at each break in the alphabet, i.e., at the beginning of last names beginning with "A", "B",
"C", etc. 

Note: The on-screen display of the directory listing report often appears to be incorrect due to the
amount of formatting needed to create and organize the columns of data.  Such problems rarely appear
in the printed version.

21.10.32Donation Summary

This report provides a quick total of donations by month. Use report criteria to limit the report to certain
donation types, months, etc.

21.10.33Donations by Date

This report groups donations by the donation date, and for each date provides details about the member
who made the donation (name, id, cheque number, comments, and amount).

21.10.34Donations by Member

This report groups donations by the member name, then by posting type, and within each posting type
lists donations by date. The date, cheque number, comments, and amount are displayed.

21.10.35Donations Receipt

Both of these receipts generate the same report that can be printed directly from a dues or donations
entry, but using report criteria, it can be generated for a larger number of records.  It is formatted such
that the member's address will appear in a standard window envelope, and the return address of your
group is displayed on the report. (If you haven't set your group's return address, see Organization
Preferences.)

If you have marked dues/donation entries for receipt printing by selecting the "Mark for Printing" option
for the "Printed Receipt" field, you can use the following report criteria to retrieve all of the marked
records:
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For a Dues Receipt:

Dues Print Receipt = Selected

For a Donations Receipt report:

Donations Print Receipt = Selected

21.10.36Dues Account Statement

This report is designed to be sent to your members.  It is formatted such that the member's address will
appear in a standard window envelope, and the return address of your organization is displayed on the
report. (If you haven't set your organization's return address, see Organization Preferences.)

The upper portion of this report includes the member ID (labelled "Account Number") and their current
account balance. The lower portion of the report is their statement of account, showing account history.

When this report is selected, an additional Options tab is available on the Report Settings window, with
the following settings:

Statement Text - Optional texts to display above or below the statement.

Include Remittance Advice - Select this option to display a "tear off" remittance form for the
recipient to use to return a payment.

Return Address - The return address to display on the Remittance Advice. This enables you to
provide a different location for collection of payments rather than the default return address
specified in report Preferences.

Include Friends/Family - Select this option to display a list of the member's friends/family names
and relationships.

Include Balance Forward - Select this option to sum all postings prior to a specified date and
print it on the report separately from the postings following that date.  This setting is designed to
avoid displaying the entire posting history of a member. For example, you could sum everything
prior  to the end of the previous year, and display only entries for this year. 

After selecting the Include Balance Forward option, the following fields must also be set:

Date: The Date Recognized to use for the balance forward calculation.  All postings ON or
BEFORE the date will be summed and displayed with your Label.  Postings shown on the
rest of the report will be limited to those with a Date Recognized AFTER the date. (Other
criteria can still be used, but the Date Recognized > YourDate will be added automatically
behind the scenes.

Label: The text to display to the left of the balance.  If you choose a date of 12/31/2012, you
might want text like "Balance forward as of 1 January:" but the choice is yours.
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21.10.37Dues Account Statement 2

This report is identical to the Dues Account Statement report, except it is formatted slightly differently to
include the status from the dues entry. 

21.10.38Dues Balance

This report displays the name, ID, phone number, email address, and the sum of all dues postings that
fall within the report criteria for each member. In other words, if you include report criteria that limits the
Date Posted or Date Recognized to a particular range of dates, the balance will be calculated based on
those dates.  If no date range criteria us used, the balance will be calculated for all dues postings (for
that member).

21.10.39Dues Postings

This report displays dues entries in a one-line-per-posting format, sorted by posting date recognized by
default, though other sort options are available.

This report is primarily a standard-version report, though it is also available in the Professional version. It
is restricted to Dues postings regardless of version.

21.10.40Dues Receipt

Both of these receipts generate the same report that can be printed directly from a dues or donations
entry, but using report criteria, it can be generated for a larger number of records.  It is formatted such
that the member's address will appear in a standard window envelope, and the return address of your
group is displayed on the report. (If you haven't set your group's return address, see Organization
Preferences.)

If you have marked dues/donation entries for receipt printing by selecting the "Mark for Printing" option
for the "Printed Receipt" field, you can use the following report criteria to retrieve all of the marked
records:

For a Dues Receipt:

Dues Print Receipt = Selected

For a Donations Receipt report:

Donations Print Receipt = Selected

21.10.41Dues Schedule

This report provides a year-at-a-glance style reference of the "annual dues" settings for your status
codes. For each month of the year, the applicable dues amounts for each status is provided. See 
Maintaining Status Codes for more information about entering the annual dues amount.
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21.10.42Dues Standings

This report displays dues entries for each member, including the date, cheque, amount, posting type,
and status purchased, as well as the Start Date and End Date from the membership record itself.  This
is an older report originally designed to quickly show all dues payments for a given member.

21.10.43Liability Waiver

This report provides a basic liability waiver that includes member names and a signature line. The waiver
text can be modified On the Report Settings window to make it more specific to your organization.

Note: Myrro International does not intend the Liability Waiver report to be a substitute for proper legal
contracts or documentation, nor does Myrro International intend to imply that the Liability Waiver report
is usable or enforceable as a legal document. Consult a lawyer to discuss the legal implications of using
this report. 

21.10.44Mailing Labels (Clubs/Members)

This report provides a basic address label for either group or membership records.

Note: This report includes a small amount of "extra information" that can be displayed in the upper right
corner of the label. The information displayed in this space is defined in Report Preferences under "Extra
Label Info."

21.10.45Membership by Country

This report provides a count of members for all countries for which at least one membership record has
been created.

21.10.46Membership Cards

The membership card and photo ID card reports are both very similar. They use standard business card
paper stock (10 cards/sheet, 2" x 3.5" cards), such as the Avery® 8371 Business Card paper. Each
card will include the Name, ID, and End Date, and either a logo graphic you define (for Membership
Cards), or the  photo graphic (for Photo ID Cards).

Photo

There are two Photo ID card reports, one for Member data, the other for Friends/Family data.  There is
no report that combines both types of data on the same report, because doing this makes it impossible
to restrict the report to just one family member, or to just the main member.

For photo ID cards, the report uses the photo assigned to the record. If there is no photo assigned, the
record will not be found by the report.

If photos are stored in the database (controlled by a database preference), each photo will be recreated
as a physical file in a temporary directory for display on the report. For this reason, a large report may
take a few seconds to display while the photos are being created.
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Logo

For Membership Cards, the report uses the default logo specified in report preferences. The logo should
be a bitmap file 144 pixels square. You can use any graphics editing program to create this file and save
it to the program directory. The easiest way is to create a new graphic 144x144 pixels in size with a
white background. Add a logo to that graphic, and leave any unused area as white color. That way, the
blank space will be invisible on the finished card.

For example, these three "logos" are all placed in a graphic that is square, despite the actual shape of
the logo.

Note: Depending on the complexity of the logo graphic or photo files, your printer may have difficulty
printing the cards. This is a function of your printer memory and system resources.

21.10.47Membership Data Export

This report is designed to retrieve all "importable" data on a membership record. Only a small portion of
the data is actually displayed though, because the report is only intended to be used for exporting data.

The report essentially pulls all data from the General and Status (if displayed) tabpages of the
membership record.  

Note: Custom data cannot be automatically displayed in a pre-defined system report like this, because
you have full control over what fields you create. i.e., we pre-define a report to show fields when we do
not know what those fields will be.  To export custom fields, create a new user-defined report or view
containing the fields you want, and then use File > Save As to save that data to a file.

21.10.48Membership History

This report analyzes the membership status change history data to display the count of members that
held each status by month for a specific year.

21.10.49Membership Statistics - Brief

There are two versions of the Membership Statistics report -- Full and Brief.  Both reports group data
based on Status. The Brief report provides counts of members by sex only. The Full report provides
these counts, as well as average age, and number of expired memberships.
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21.10.51Membership Status

This report displays name, Status, Start Date, and End Date for each member.

21.10.52Multiple Group Affiliation

This report displays membership records that are assigned to more than one group record. It will not
retrieve a membership record if it is only related to a single group.

21.10.53Name & ID List

This report is a simple listing of member names and IDs. This report is good for times when you need to
provide a list of names to check off for some purpose, but don't want to display any personal or contact
information about the people on the list.

This report has a unique sort feature. If you choose to sort the report by name, the first column of the
report will show the name, and the second column will show the member ID.  Conversely, if you choose
to sort the report by Member ID, the columns are reversed. The column being sorted will always be on
the left.

Note: Be sure the Require Numeric ID preference is set correctly. This preference affects the sorting
style of the IDs on this report the same way it affects the sorting of the Membership List.

21.10.54Phone List

This is a basic listing of a member's name and home, work, and other phone number(s), as available. 

Note: If you are using MemberTies Professional, the home phone number will come from the address
record that is Current.

21.10.55Photo ID Cards

The membership card and photo ID card reports are both very similar. They use standard business card
paper stock (10 cards/sheet, 2" x 3.5" cards), such as the Avery® 8371 Business Card paper. Each
card will include the Name, ID, and End Date, and either a logo graphic you define (for Membership
Cards), or the  photo graphic (for Photo ID Cards).

Photo

There are two Photo ID card reports, one for Member data, the other for Friends/Family data.  There is
no report that combines both types of data on the same report, because doing this makes it impossible
to restrict the report to just one family member, or to just the main member.

For photo ID cards, the report uses the photo assigned to the record. If there is no photo assigned, the
record will not be found by the report.

If photos are stored in the database (controlled by a database preference), each photo will be recreated
as a physical file in a temporary directory for display on the report. For this reason, a large report may
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take a few seconds to display while the photos are being created.

Logo

For Membership Cards, the report uses the default logo specified in report preferences. The logo should
be a bitmap file 144 pixels square. You can use any graphics editing program to create this file and save
it to the program directory. The easiest way is to create a new graphic 144x144 pixels in size with a
white background. Add a logo to that graphic, and leave any unused area as white color. That way, the
blank space will be invisible on the finished card.

For example, these three "logos" are all placed in a graphic that is square, despite the actual shape of
the logo.

Note: Depending on the complexity of the logo graphic or photo files, your printer may have difficulty
printing the cards. This is a function of your printer memory and system resources.

21.10.56Postings - by Date

This report groups information by date, and within each date provides name, member ID, cheque,
comments, and amount information.

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.57Postings - by Payment Method

This report groups information by payment method, and within each method provides the date, name,
cheque, posting type, comments, and amount information.
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Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.58Postings - by Month

This report groups information by date, by month. Within each date, the name, member ID, cheque,
comments, and amount are provided.

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.59Postings - by Source

This report groups information by posting source, i.e., the member or activity or activity attendee the
posting is tied to. Within each source, the date, cheque, posting type, amount, and comments are
provided.

Using Postings Criteria
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This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.60Postings - by Type

This report groups information by posting type. Within each type, the date, name, member ID, cheque,
comments, and amount are provided.

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.61Postings - Listing

This report provides a simple line-by-line detail of postings, with an overall total at the end. It sorts by
date in descending order by default.

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.
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21.10.62Postings - Statement

This report provides is a "generic" version of the Dues Account Statement report.  It will include both
dues and activity postings for the member.  

Note: Donations are intentionally excluded, since as a donation the amount should not logically affect a
member's amount owed.

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

Note: The Include Balance Forward option will sum dues and activity postings, but otherwise works the
same as the Dues Account Statement report. 

21.10.63Postings - Totals by Year

This is an all-inclusive report that combines all posting data together in one report. The report lists total
amounts for each posting type, per year. 

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the



MemberTies433

©1998-2014 Myrro International

"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.64Postings - Totals by Yr/Month

This is an all-inclusive report that combines all posting data together in one report. The report lists total
amounts for each posting type, per month, per year. 

Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.65Postings - Type Grid

This is cross-tab style report that displays the date and member name, and then a column for each
posting type on the report.  Each row is totalled to the right, and each column is totalled at the bottom,
creating a "grid" of posting type total data.

Due to space limitations on the report, six posting types is about the most that can be displayed.  If you
choose more posting types with your criteria the report may flow into a second page.

You will need to use Advanced Criteria in order to select multiple posting types.
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Using Postings Criteria

This is a non-specific posting report.  If you use report criteria, choose posting criteria fields from the
"Postings  (Any)" category to keep it non-specific.  If you choose criteria from, "Postings (Dues)" for
example, the report will focus only on Dues information.

21.10.66Receipt Listing

This report displays all postings for which a Receipt Number (and optional Receipt Book Number) was
assigned.

21.10.67Retention

This report provides a look at your membership renewal history. For a given date range, the report groups
membership records by year joined, followed by membership status. For each person displayed, the
name, start date, end date, sex, and birth date are provided.

21.10.68Related Members

This report provides information about established relationships between membership records.  This
report is most useful when run for a specific member, or other criteria that limits the number of members
found. Otherwise, each member will appear twice, once as the "main" member, and again elsewhere as
the "related" member to a different main member.

Note that the Related Members (Contact) report is a copy of this report, but includes address information
for each member.

21.10.69Related Members (Contact)

This report is a copy of the Related Members report, but it also includes the address information for each
member.
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21.10.70Return Address Labels

This report provides a set of return address labels, using the organization name and return address
specified in Organization Preferences.

21.10.71Roster

There are several predefined versions of the Roster report. Each prints a three-column list of membership
records. Only the report called "Roster - Custom" can be modified with your own report criteria. The
others are designed to display specific things:

Roster - Active Statuses - Includes all members with an Active Status. 

Roster - Group - Includes all Group records

Roster - Expired - Includes all members with an End Date equal or prior to the current date. 

Roster - Inactive Statuses - Includes all members with an Inactive Status. 

Note: Since the above versions of the roster are not customizable, the address format will always be the
default format specified in Preferences.

21.10.72Sent Mail by Member

This report lists the Subject, Date/Time, and Priority of all email they have been sent, grouped by
receiving member name.

Note that MemberTies has no way of knowing if email has been received or even processed after it has
been handed off to your mail server.  So this report is essentially showing what your mail server was
given to process.

21.10.73Status Change History

Each time the status of a membership record is changed, either manually or automatically by the
system, an entry is recorded in the membership record's status history. This history log can be printed
using this report.

21.10.74Status Codes

This report prints all status codes, and all applicable settings for each code. A similar report, called
"Status Codes - Complete" is available for MemberTies Professional users, and includes all interest and
schedule posting settings defined for the status.

There are user-modifiable settings for this report.
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21.10.75Status Codes (Complete)

Like the Status Codes report, this report prints all statuses; but additionally includes Interest and
Scheduled Posting settings assigned to the status.

There are user-modifiable settings for this report.

21.10.76Stored Comments

This report prints a list of all stored comment texts currently defined in the system.

There are user-modifiable settings for this report.

21.10.77Summary - Group

This report provides a full summary of each group record. 

21.10.78Summary - Individual

This report provides a full summary of each membership record. 

21.10.79ToDo List

This report provides a To Do List based on your specifications. You can restrict it the same way you can
restrict the display of the To Do List itself. Note that this report can also be printed either from the To Do
List window as described below.

Printing the Report from the To Do List Window

1 Open the To Do list and adjust the display until the To Do List contains the items you want to
print. See the To Do List Overview for more information.

2 Click Print.

3 Confirm the printing.

21.11 PSR Format Reports

21.11.1 Saving PSR Reports

You can save a displayed card or label style report as a file that can be reloaded into the Reports
window at a later date. For example, each time you print mailing labels, you may want to save the report
as a file so you can reload it later to verify that a certain person was part of the mailing, or you may
simply want to send the label report to another person who needs to print them.

Reports saved in this format can also be viewed with Myrro International's free Report Viewer. This
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simple viewer enables the user to open any .psr file and view or print it as if they were looking at it within
MemberTies. To download this utility, go to http://www.myrro.com/memberties, go to the Download area,
and choose the Report Viewer.

Saving a Report

1 Choose File > Workspace > Reports.

2 Select the desired report from the report selection dropdown. 

3 When the report is displayed, choose File > Save As > Other Data Formats > Report Format.

Note: You can save reports in other formats, but the results may vary widely.  Reports are
designed for display, not exporting. An exported report may include code values instead of
display values (i.e., "100" instead of a State name).  The only report really designed for
exporting is the Membership Data Export report.

4 When the Save dialog appears, enter a name for the report, then click Save.

Note: The extension must be ".psr" or you will not be able to reload it!

5 A message will appear indicating the success or failure of the operation. Click OK.

For information about viewing the saved report, see Viewing a Saved Report.

21.11.2 Viewing a Saved PSR Report

If you have a report saved as a ".psr" report, you can display it in the Reports window. For information
about saving reports in psr format, see Saving PSR Reports.

Viewing a Saved Report

1 Choose File > Workspace > Reports.

2 Select "(Saved Report)" from the report selection dropdown.

3 When the Select Saved Report dialog appears, select the saved report file, then click Open. The
report will be displayed.

4 If you want to select a different report after the first one is displayed in the Reports window, click
Reselect.



Part

XXII
User-Defined Reports
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22 User-Defined Reports

22.1 Overview

MemberTies ships with an assortment of reports and mailing labels designed to meet the needs of a very
general audience. Some reports, such as the Individual Summary, are very complex and display a large
amount of data; while others are very simple, like the Name and ID List. With MemberTies Professional
you also have the ability to define your own columnar reports, mailing labels, and business cards.

Columnar Reports are reports similar to the Contact List -- several fields, with or without headings,
displayed as columns of data where each "row" normally represents one record.  

Mailing Labels are a set of fields arranged into one or more rows to fit a specific format of mailing
label.  Several standard label formats are supported, in both A4 and standard USA letter/legal
sizes. (If you really need a mailing label format that isn't listed, contact support and let us know.)

Business Cards are a set of fields arranged into one or more rows to fit on a standard business
card. By default, the left half is used for a user-defined logo.  You can turn off the logo if you wish.

Photo ID Cards are a set of fields arranged into one or more rows to fit on a standard business
card, similar to a business card report, but the left half of the card is used for the member photo,
and if a member does not have a photo assigned, the record cannot appear on the report.

Roster & Directory Reports are a kind of combined columnar and label report. Each record is
displayed as multiple rows of data within a 2, 3, or 4 column layout. A directory report is really
just a roster that includes an alphanumeric heading to show where the "A's" start, then "B's",
"C's", etc.

Similar to user-defined views, you are able to choose the fields you want to display. You have the ability
to place them in any order, set the sort order (i.e., by City, then by Last Name), change or hide the text
displayed for the column headings (for reports), modify various font settings, and even append or prepend
text to any field. 

The reports, labels, and cards you define are referred to as "User Reports", "User Labels", and "User
Cards" and appear in the dropdown of available reports on the Reports window as soon as they have
been created. After you choose one of them for display, the report Settings window will open just like a
normal report, enabling you to specify criteria.  

This last point about criteria is important.  A common question sent to Support is about how to create a
specific type of report, i.e.,  "How do I create a report that just shows members who are past due?"  The
answer is, you don't create a report like that.  What you create is a report that includes the fields you
want to show, and then you use report Criteria to determine what the report really means; in this case,
members who are past due.  For example, a simple columnar report that includes just the First and Last
Name and Home Telephone Number can easily be: 

A past-due members contact list -- by using report criteria to only retrieve members with an End
Date in the past.

A "activity attendee" list -- by using report criteria to only retrieve members who attended a
specific activity.

An honorary members list -- by using report criteria to only retrieve members with the Honorary
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status.

The idea is simply that when you define a report, you are defining the presentation of the data, not the
meaning of the report.  It is the report criteria that determines what kinds of records are found, and
therefore what the report really "means."

22.2 Grouping, Hiding, and Controlling Duplicate Data

Often when a user-defined report or view is created, the results end up showing a single "member" for
example, on several rows, with only part of the data changing on each row.

For example, a member record can contain several kinds of "additional" data that isn't part of the primary
record. It can contain dues or donation postings, associated members, friend/family records, assigned
items, etc.  These are things that they can appear multiple times on a member's record, unlike a "First
Name" which is a single field and can only have one value.

Normal Duplicate Data

When you create a report that includes fields from these "additional" record types, you can end up with
duplicate data. For example, if your report includes the member name, and the amount posted, the
report will display a row for every amount posted it finds, and the name will repeat on each row  even
though only the amount posted is changing:

Normal display of duplicate data

Suppress Repeating Values

Using the options for field properties on the report however, you can control how that duplicate data is
treated.  One option is the "Suppress Repeating Values" option.  If this is set for the Name field, the
resulting list will hide the value for the name any time it matches exactly the value in the preceding row
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on the report:

Repeating Values Suppressed

 This option is normally used on Views, or on normal column reports. 

Group Header

Another  field property on columnar reports you can use is Grouping.  All fields added to the Group
Header will display as a heading "above" the rest of the data for that record.  (Include all the group
header fields together at the beginning of the report.)  Once grouped, the data below the group appears
slightly indented from the left margin, below the header:
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Grouping by Name

 You can also turn on the Calculate  field property for the amount field, and it will generate as a subtotal
within the group as well as a total at the end of the report:
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Grouping by Name

Total on Amount

22.3 Working with User Defined Reports

User defined reports are easier to create than cards and labels, because all fields appear on the same
line (with the exception of Roster reports, which are formatted like labels). However, you have some
additional options with reports, because each field has a "header" at the top of the column that normally
contains the field name.

This is a large Help topic. It is divided into three sections: 

Adding a User Defined Report - Explains how to get started.
Using the Define Fields Tab - Explains how to use the first tab page of the main report definition
window to give the report a name, title, and a set of fields to display.
Using the Preview Tab - Explains how to preview the report and adjust column widths

Adding a User-Defined Report

The first thing to do is tell the system what kind of report you want to create. This will determine the
fields that can be added to the report, and how the report will behave.

1 Choose File > Workspace > Reports.

2 Choose Actions > User Reports, or click the User Reports toolbar button to open the Maintain
User Reports window.  This window displays all user-defined reports that are currently available.
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3 Click Add to open the Report Type selection window.

4 The Data Type and Report Type form the basis of the report. Once set, these cannot be
changed.

Data Type - This should be the primary focus of the report. If your main goal is to show
member data, choose Membership Data as the data type. The data type you choose is very
important. If you choose an Activity report, for example, then activities are the primary focus of
the report.  If you add a membership data field to the report, you could see a member displayed
once for every activity her or she attended. Likewise, a Group Data report will mean all address
fields will apply to the group, not members who are part of that group.  Consider the type of data
you are most interested in, and focus the report appropriately.  If the data to be shown is
primarily member data, the report data type should be "Membership Data".

Report Type - This determines the layout the report will follow. Refer to the Overview topic for a
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description of the various types.

Make your selections, then click OK to open the New Report window.

5 The maintenance window for user defined reports is divided into two tabs, "Define Fields" and
"Preview."  As you might expect, you must define the fields on the report before you can preview
what it will look like. Therefore, the Define Fields tab must be completed and changes applied
before the Preview tab is enabled. If you have opened an existing report, the Preview tab is
available immediately, but if you make any changes on the Define Fields tab, they must be
saved before the Preview can be accessed again.:

Define Fields - The Define Fields tab is used for specifying the name of the report as it will
appear in the reports dropdown, the default report title, and fields to be displayed. Once
fields have been selected, you can change the order, and edit certain attributes such as
alignment, sort, etc.

Note: Regarding Custom Fields, the Available Fields list will only show those custom fields
defined as able to be Displayed on User-Defined Reports and Views.

Preview - The Preview tab lets you "run" the report with actual data so you can make final
adjustments to column widths. You can also change the column order on this tab, and
changes will be reflected on the Define Fields tab. 

Note: In Preview mode (with the Preview checkbox selected) a divider line may not be
visible due to scaling issues, but it will print normally.

Using the Define Fields Tab

The process of defining a report varies slightly between standard reports and label/card/roster reports,
because on a standard report all data appears on the same line. With other reports, each "record" has
multiple lines down the face of the label/card/roster area; therefore, you have to tell the system what line
you are working with before you can add more fields.  Differences like this are noted below.

1 If you are creating a new report, enter a name for it in the Report Name field. This is the name
that will appear in the dropdown of available reports on the Reports window.

2 Specify basic settings for the report, as applicable. Some of these settings are not available for
some reports (i.e., mailing labels do not have a Title)

Report Name -- the name of the report to be shown in the report selection dropdown list on the
Reports window.

Default Title -- this title will be displayed on the report, but can be changed any time the report
is run via the Report Settings window.

Default Font -- this font and height will be used for all fields on the report unless a different font
is specified for a specific field. (See Changing Field Properties for details.)

Orientation -- specify portrait (vertical) or landscape (horizontal) by clicking the icon. You can
use any orientation with any page size (if available to change), but Roster reports always use
Portrait orientation. 

Page Size -- the type of paper the report will be printed on.  For reports like Mailing Labels, this
information is set automatically when you choose the label format. 
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3 Enter other special settings that are available to your specific type of report:

Standard Reports

Row Divider -- displays a horizontal line every 1, 2, 3, 4, or 5 records. The line is a visual
helper to separate one record from another, and is especially helpful on wide (landscape)
reports with lots of data.  Note: in Print Preview mode, the dividing line may not be visible
due to scaling issues, but it will display when printed.

Roster/Directory Reports:

Columns  -- sets the number of newspaper-style columns to display on the report. A two-
column report allows for a wider block of data than a three-column report.

Heading -- selecting this option creates an Alpha heading to separate the "A's" from the
"B's", etc., on the report.  The heading can either be the first letter of the first sort field's
data, or the complete text of the field. For best results, use a field like the Last Name for the
first sort. This will cause records to be displayed in last name order, and will create
appropriate headings from A to Z.  Tip: The first sort column does not have to be visible! If
you want the first column of the roster to use the "First Name/Last Name" combined field,
just add the Last Name column as well somewhere and make it the first sort -- just select
the "Hide Data" option so it stays invisible (see below).

Label Reports

Label Format -- select the type of label you'll be using.  The system ships with the most
common formats pre-defined. If you need another format, please contact support.
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Card Reports

Logo File -- select the logo to display on the left side of the card. This defaults to the report
logo specified in preferences if you leave it blank. The logo graphic file is expected to be
144x144 pixels square. Type the full path and file name for the file, or click the browse
button to find it. The file must be one of the allowed types (.bmp, .gif, .jpg, .jpeg, .wmf, .rle).
If your logo is not square, just create a 144x144 pixel square graphic with a white
background, and place your logo in the middle of it, leaving the extra white space
untouched. Note: After saving, the logo file name will display something like, Stored ID: 1
instead of the original filename.

Report Format -- select the card format you'll be using. The system ships with the most
common formats pre-defined. If you need another format, please contact support.

Photo ID Card Reports

Report Format -- select the card format you'll be using. The system ships with the most
common formats pre-defined. If you need another format, please contact support.

Which Photo is Shown?

The system decides whether to show the member photo or the Friends/Family photo by
looking at the fields you select. If you include at  leats one Friends/Family field on the
report, the system will use the Friends/Family photo. If there are no such fields on the
report, it will use the member photo.  There is no way to display both a member and a
family member photo on the same report.

4 Select fields for the report. Note that for a multi-line report, you must choose the line you want
to work with before adding fields.

Standard Reports: Use the left and right arrow buttons to move fields back and forth between
the Available Fields list and the Selected Fields list. All fields that are visible in the Selected
Fields list will be shown on the completed report unless you turn on the "Hidden" option (see
below). On a standard report, the top-to-bottom order of fields in the Selected Fields list
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represents the left-to-right order the columns will take on the report. In other words, the first (top)
field in the Selected Fields list will appear as the left-most column on the report.  For a multi-line
report like a label, the top-to-bottom order is relative to the currently selected line.

Multi-Line Reports: These reports display a block of information for each record. The block can
contain multiple lines, and each line can contain one or more fields. Fields must be selected for
a specific line of the block. Use the "View/Edit Fields on Line ##" dropdown to choose a line to
work with, then use the left and right arrow buttons to move fields back and forth between the
Available Fields list and the Selected Fields list. 

Selecting the line to work w ith on a multi-line report.

When all fields have been added to one line, change the dropdown to the next line and continue
adding fields. To see all the fields that have been added to entire report, choose the (All) option.
The value in the Line Number column indicates which field is on which line.

Smart Fields: Some fields are smarter than others, and will automatically calculate, combine,
or otherwise manipulate multiple fields into one.

 

See Smart Fields for more information.

General things to consider when choosing fields:

When choosing fields, it is very important to consider the primary data type of the report you are
creating.  Even though you can choose almost any activity, group, or membership field, they
can change the behavior of the report based on the primary data type.  For example, if the
primary data type is Membership Data, adding activity fields will convert it into an "activity
attendance" style of report, where member information might be repeated for every attendance
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record found.  Likewise, adding dues posting fields to a membership report will turn it into a
dues postings report, and the member data will be repeated for every posting displayed on the
report.

To hide this duplicate data, you should consider suppressing repeating value fields, or adding
certain common fields to the group header.  See Grouping, Hiding, and Controlling Duplicate
Data for more information and examples.

5 If you want to adjust properties of a field in the Selected Fields list, select the field you want to
change and click Open to open the Field Properties window.

See Changing Field Properties for complete details.

6 Adjust fields up and down in the Selected Fields list to put them in the correct left-to-right order
or top-to-bottom order. The top of the list is the left-most column of the line being edited, and the
bottom of the list is the right-most column. For a Roster style report, this applies only to the
currently selected line.

7 When you are ready to display the report, click Apply to save changes, then click the Preview
tab.

Using the Preview Tab

The Preview tab enables you to see what the new report will look like, and to make changes to the
widths of columns, and even adjust the column order again. (If you're creating a multi-line report, all
column editing (width or position) must be done for a specific line.)

1 The Limit to ## Records field below the list can be used to prevent the preview window from
returning an unnecessarily large number of records for viewing. This setting has no effect on the
way the report will work when opened from the Reports window -- it only applies to the Preview. 

2 Click the Adjust Column Widths button to shift the preview into editing mode. The blue rectangle
displayed on top of the data represents the approximate usable width of the report (don't worry
about the height of the box, only the width matters). Be sure that all fields within the width of the
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blue box.

To work with a line other than Line 1 (for Roster reports), use the "Adjust Fields On" dropdown
to change the displayed line number. Be sure to check the fields on each line.

Drag the border between column headings to resize them. To do this, press and hold the left
mouse button on the borderline between columns (or at the edge of a column, as above) the
icon shown appears. Then while continuing to hold down the left button, drag the column border
to resize it as appropriate. When the size is correct, release the left mouse button.

Drag an entire column by its heading to change its position. To do this, press and hold the left
mouse button on the column heading until the icon shown appears. Then while continuing to
hold down the left button, drag the column left or right as appropriate. When you have it in the
desired position, release the left mouse button. (Note that it is much easier to move columns by
using the arrow buttons to adjust them up and down on the Define Fields tab.)

Tip: To adjust the width of the right-most column of a line, drag the whole column to the left one
column as described above, then adjust the width. When the width is correct, drag the whole
column back to the right where it belongs.

When you're finished editing all lines, click Return to Preview and save the changes.

3 If you want to print a test copy of the report, click Print.

Note: Printing from the Preview tab is not the same as printing from the Reports window. The
printing option on this tab is for testing purposes only -- it will not include settings for margins,
fonts, etc. Printing for distribution should always be done on the Reports window.

4 Once you have the report the way you like it, close the window and then close the Maintain
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User Reports window to return to the Reports window. You can run the report "for real" by
selecting it in the Available Reports dropdown like any other report.

22.4 Changing Field Properties

The Field Properties window is available for any field on a user-defined report, label, or view.  

To change the properties of a field on a user-defined report, select the desired field in the Selected Fields
list, then click Open.

The properties vary by type of report/view, as described below.

The following fields are available:

Name: The name may be changed for your own reference, even if it doesn't appear on the report
(such as for a mailing label).

Hide Data - Select this option to hide the entire field. This is helpful if you only want to use the field
for sorting, but don't want to actually see it. For example, suppose you use the combined First
Name/Last Name smart field on the report, but want to sort on the last name only. Since the
combined field shows the first name first you can't sort on the last name portion; instead, add the
last name field and mark it as the appropriate sort, and then make it hidden to solve the problem.

Hide Heading: If you want to see the field, but want the heading left blank, select this option. This
field is not available to mailing labels or other report that don't have column headings.

Sort: Choose the sort order if this field should be used for sorting. It is important to at least choose
one sort field (1st). If no sort is chosen, the records will be returned in the order they are found in the
database, which may not be the way you want to see them. You do not have to use every available
sort order.

Bold: Select this option to display bold text.
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Italic: Select this option to display italic text.

Underline: Select this option to display underlined text.

Font: Choose a specific font face and height for this field, or select "Use Default" to take the default
font settings  from the Define Fields tab.

Font Color: Defines the color used for the field data.

Back Color: Defines the color used for the field background. This option is not available to Views.

Case: Choose whether data should be forced to appear in uppercase, lowercase, or "any" case (i.e.,
as entered in the database).

Alignment: Choose the alignment setting for data in the field. 

Calculate: For numeric data fields, you can choose to produce a total or average of the column in
the summary area of the report. This option only applies to standard columnar reports, not to labels
or directories.

PreText: Text entered here will be displayed to the left of the data for this field (you can leave
leading or trailing spaces in this field). Tip: If you want to force a blank line to appear above a
particular line (for a Roster style report), enter "~r~n" (without the quotes) in the pretext field. This
code means "carriage return/line feed" and will cause a blank line to be produced before the data of
the field. This field is not available to Views.

PostText: Text entered here will be displayed to the right of the data for this field (you can leave
leading or trailing spaces in this field). This field is not available to Views.

PreText and PostText are designed to be used however you choose. One possibility is to use
PreText in place of the column heading. In other words, if the column's "Hide Heading" checkbox is
checked, no heading will appear. Instead, you could use PreText to show the same "heading" in
front of each field to display. For example, a telephone entry on one line might show, "Tel: 123-456-
7890" by using a pretext value of. "Tel:".

22.5 Smart Fields

Certain fields available for user defined reports, views, labels, etc., do more than just select a specific
piece of data -- they combine multiple pieces of data, or even make a decision about which data to
display based on what is available. These fields are known as "Smart Fields," and are used to provide
additional flexibility when displaying certain kinds of data.

Smart Fields appear in the available fields listings as shown:
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Smart "Name" Fields

For general name formatting, use:

Name (First/Last Name)
This field will display the first and last name, i.e., "John A. Smith"

Name (First/Last/Suf)
This field will display the first and last name, and suffix, i.e., "John A. Smith, Jr."

Name (Last/First Name)
This field will display the name "last name first), i.e., "Smith, John A."

Name (Last/Pre/First/Suf)
This field will display all parts of the name, "last name first", i.e., "Smith, Mr. John A., Jr."

Name (Pre/First/Last/Suf)
This field will display all parts of the name, i.e., "Mr. John A. Smith, Jr."

To use the Company name whenever possible, use:

Name (Company | Full - First/Last) 
This field will automatically display the Company Name if it is available. If no company name is
found, the complete name will be shown using the "Name (Pre/First/Last/Suf)" format described
above.

Name (Company | Full - Last/First)
This field will automatically display the Company Name if it is available. If no company name is
found, the complete name will be shown using the "Name (Last/Pre/First/Suf)" format described
above.

To use the Company Name only when there is no first/last name, use:

Name (Full First/Last | Company)
This field will automatically display the full name using the "Name (Pre/First/Last/Suf)" format
described above unless both the first name and last name fields are blank. If both names are blank,
the company name is used instead.

Name (Full Last/First | Company)
This field will automatically display the full name using the "Name (Last/Pre/First/Suf)" format
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described above unless both the first name and last name fields are blank. If both names are blank,
the company name is used instead.

Note: All membership records have an available "Alt Mailing Name" field. This field is designed to be
shown on mailing labels in place of the normal member name. This field value will automatically be used
instead of the "Name" value on user-defined mailing label or post card reports, just like the standard
system-defined mailing label report.

Other "Smart" Fields

There are also several fields available:

Age
This field displays the calculated Age if all birthdate components exist.

Birthdate 
This field displays the raw birthdate text. If the year was entered as "9999", it displays the same
way.

Birth Year
This field displays the year, or displays blank if the year is 9999.

Birth Month
This field displays the birth month.

Birth Day
This field displays the birth day.

Birth Month/Day
This field displays the birth month and day in MM/DD order.

Birth Day/Month
This field displays the birth day and month in DD/MM order.

Freeform Text
These fields enable you to enter plain text (via field properties, where Pre/Post Text is normally
displayed). No database information is used for these fields.  A common use for a freeform field is a
series of underscores, to form a signature line on a member list.

22.6 Exporting or Importing

Any user defined report, card, label, view, etc., can be exported to a file and then imported by another
user.

Exported reports/views are saved to a special ".mtx" (meaning "MemberTies export") file. These files can
be used to import the report later, as long as no report or view already exists by the same name (unless
you want to overwrite it).
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Note: Do not attempt to modify the exported file using any kind of word processor or text editor.  It
contains some fairly complex data structures, and altering the file may render it unusable.

Exporting a User Defined Report or View to a File

1 For reports, choose File > Workspace > Reports, then choose Actions > User Reports, 

or...

For views, choose File > Workspace > Membership List or Group List, then choose Actions >
Views.

2 When the list of views or reports appears, use the right mouse button to click the one you want
to export, then choose "Export to File..." from the popup menu.

3 Click OK when prompted to confirm the export.

4 When the "Save As" window opens, enter the name of the export file you want to create, then
click Save. (It is a good idea to name the file similar to the report or view, so you can tell what it
is later.)

Importing User Defined Reports or Views

Exported reports and views can only be imported to the same software version that was used to export
it.  That means if you export a file using MemberTies version 6.0, you cannot import it to version 6.1.
This prevents potential conflicts that could arise due to database or programming changes.

1 Choose File > Workspace > Reports, then choose Actions > User Reports, 

or...

Choose File > Workspace > Membership List or Group List, then choose Actions > Views.

2 When the list of views or reports appears, use the right mouse button to click anywhere on the
list, then choose "Import from File..." from the popup menu.

Note: It does not matter whether you click on a row or not, just click anywhere in the list.

3 Click OK when prompted to confirm the import.

4 When the "Select File" window opens, enter the name of the previously exported file you want to
import, then click Open.

5 A message will be displayed for you to confirm the import. If you want to continue, click OK.

6 If the report or view being imported already exists, you will be prompted to overwrite the existing
data.

7 If the import is successful, the new report or view will appear in the list and will be immediately
ready for use.

22.7 Making a Bar-Coded Member ID Card

There are two primary things to know about using barcodes:
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A barcode is just a True Type font like any other Windows font.  You can pick any text in
any report and set the font to your barcode font, and it will print as a barcode.  Barcode
fonts are not free.  Most of the "free" barcode fonts you find are either poor designs that
may not scan well, or are stolen.  Do the right thing and license a font for your use.  There
are excellent, inexpensive font packages available at ID Automation. They deal exclusively
with barcodes and barcode scanners, and we've recommended their products for a long
time.

When you scan a barcode, it simply dumps the contents of the code into whatever field
your cursor is currently in.  If the barcode contains the member ID, then the cursor should
be sitting in a search field labeled, "Member ID".

Install the Font

1 Buy a barcode font if you don't have one.

We recommend the Code 39 (also known as "3 of 9") barcode font.  It is available through ID
Automation (http://www.idautomation.com)  in a package that contains the font in various sizes,
and with or without the text below the code that displays what the barcode means. This font is
recommended for normal alphanumeric data that doesn't need a checksum.  

2 Install the font(s) you want to use.  This is as normally as simple as dropping the font into your
c:\program files\windows\fonts directory, but follow any instructions that come with the font.

Create the Membership Card

1 Create a new user-report.  Note that the plain business card format is available as a "mailing
label" style report. The photo ID and membership card (with logo) are their own report types.

2 Add the fields you want to show on the card normally, and as the last field at the bottom,
choose Member ID.

Note: If you want to show the Member ID as an ID, as well as a barcode, there is a field called
"Member ID (Copy)" just for this purpose. i.e., it lets you put the Member ID on the report twice.

3 Open properties for that field and set the font to be your new barcode font.

4 Preview the report and adjust the column widths appropriately.  You'll probably want to make the
Member ID field the full width of the card, and then center the text so it looks the best.

5 Save the card.

Note: Depending on which font you use, you may need to add a start and stop character to the
barcode.  If so, use the Pretext and Posttext settings for the Member ID field.  i.e., if the start/
stop character is a "!", then when you set the barcode font for the Member ID field, also enter a
"!" for the pre and post text values.

Barcode Scanners

There are lots of scanners available. Once again, we like the ones at ID Automation, because they're
ergonomic, and several models come with a stand that makes it easy to use unattended check-in mode.

http://www.idautomation.com
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23 Search Criteria

23.1 Entering Basic Search Criteria

A basic search means you are going to simply fill in the predefined fields with the values you want to
match in the records you are searching for.  You do not have to use all of the available fields, in fact, if
you don't use any of the fields you will retrieve all records (because you aren't trying to restrict the data
to anything in particular).  

The main thing to remember is that you should not enter any search value unless you really want
EVERY record found to contain that value.  For example, if you want to create a mailing list for all of
your members, you shouldn't put a value in the City Name field, because that will restrict the records
found to only those with the specified city name on their address.

Each search window displays the most commonly used search fields If you need to search using a more
obscure field, or using more specific or complicated criteria, you should perform an advanced search if
one is available on the window you are using.

Note: A common question is, "How do I search for a blank (something). i.e., all members with a blank
email address?"  To do this, you must use the Advanced Search, and leave the value for the email
criteria empty.  The basic search cannot search for a blank, because it only searches for values that
have been entered in the fields, and you can't enter "nothing."

This is an example of the basic search on the Membership List:
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Notice in the above example that a popup menu has been opened to help enter some special search
criteria.  This popup menu is displayed by clicking the right-hand mouse button on the desired field (in
this case, the Company Name field).  After choosing "Contains" from the popup menu, you simply
change the word "text" in the field to be whatever portion of a word you are trying to match. For example,
to find all companies with "widget" in their name, the field would be left as "LIKE %widget%" as shown
above.

Using Barcodes or Magnetic Stripe Readers

If your members carry membership cards that contain a barcoded Member ID, you can scan it into the
Member ID field to quickly search for that member.  If you use the member's US Driver License number
as the Member ID, you can also scan a driver license into the Member ID field, and the system will pull
the driver license number out of the data and search with that.  Note that only cards meeting the
AAMVA specification are supported.  If you scan a driver license and nothing happens, the card is either
too old, or doesn't follow the spec (California cards, for example).

Special Expressions using LIKE and NOT LIKE

% The percent sign is used in conjunction with the word "LIKE" to search for data that begins, ends, or
contains specific text or numbers. For example, you might enter any of the following in the Last Name
field:

"Smith%" to get "Smith", "Smithe", or "Smithington.
"%burg" to get "Sederburg", "Frankenburg", "Hidelburg"
"%der" to get "Sederburg", "Fender", and "Derston"

You can also use the opposite of LIKE, which is NOT LIKE, to reverse the search requirement. 

Note: If you use a "%" symbol in a search field, the system will assume the word LIKE should be
used with it. Therefore, "LIKE smith%" is equivalent to simply "smith%". But if you want to use NOT
LIKE, you must actually specify it, i.e., "NOT LIKE smith%".

> < <> The greater than, less than, and not-equal-to signs are used at the start of data to indicate a
relationship to the data following the sign. These symbols can be used with letters or numbers. For
example:

>300 in the Member ID field would get all records with a Member ID numbered 301 or larger (if the
Require Numeric IDs preference is on).
>a  used in the Last Name field would return all records that have a Last Name beginning with b-z.
<>Smith in the Last Name field would get all records with a Last Name other than "Smith," i.e.,
"not equal to Smith".
<12/31/1999 in the End Date field would get all records with an End Date prior to 12/31/1999.

Complex Expressions Using LIKE and NOT LIKE

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
each expression below would be preceeded with LIKE or NOT LIKE.

Expression Searches for... Sample Return Data

Mc% Names that begin w ith the letters "Mc" McEvoy

%er Names that end w ith "er" Brier, Miller, Weaver, Rayner
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%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]ow ell Names ending w ith "ow ell" that begin 

w ith a single letter in the range M to Z

Pow ell

M[^c]% Names beginning w ith "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas the
_ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

Multiple Criteria

Entering criteria in multiple fields enables you to build more complex searches. 

For example to get all members who live in Dallas, TX, with a phone number beginning with 972 who
joined prior to 01/01/1999, you would enter:

"Dallas" in the City field
"TX" in the State/Prov field
"LIKE 972%" in the Home Phone field
"<01/01/1999" in the Start Date field

The key thing to remember with multiple criteria is that there is an implied "AND" for each value.  So in
the above example, the criteria reads, "city = Dallas AND state = TX AND home phone LIKE 972% AND
start date < 01/01/1999". Every value must match for a record to be returned by the search.

23.2 Entering Advanced Search Criteria

An advanced search can be an extremely powerful way of extracting very specific data from the
database.  An advanced search is available on membership, group, and activity lists, and is the only
search used for reports and documents.

Unlike a basic search that gives you a set of predefined fields to pick from, a search using advanced
criteria is built one field at a time, with each field represented by a new row on the advanced search
criteria list.

Each row represents a specific criteria or "rule" that a record must meet in order to be displayed. If you
create membership criteria that says Last Name = "Smith", then only membership records with "Smith"
in the Last Name field will be found. 

This is an example of the advanced search on the Membership List:
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This search will require four things from every record displayed:

The member must have a positive dues balance (i.e., greater than zero)
The End Date on the record must be prior to today's date
The city (on the current address) must be Chicago.

Building Criteria 

Criteria is created row-by-row, with each row representing another criteria (you can think of it as a
"rule") that must be true for a given record to appear on the report. For example, if you are running a
membership report and use a criteria like, Last Name = Smith, then only membership records with
"Smith" in the Last Name field will be on the report.

1 Start a new criteria line by clicking the Add icon. A new blank row will appear.

2 Click the dropdown arrow in the Field Name column to open the selection window. Then, choose
the field whose data you want to check with this criteria. For example, if this criteria will restrict
the report to members in a certain city, expand the Address section and choose "City."

Note: Custom Fields will only appear in this list if they have been defined as available to be
used as Criteria.

3 Click the dropdown arrow in the Operator column to open the selection window. Then, choose
the method that will be used to compare the data to the selected field.  For example, if you want
the city value to be equal to, "MyTown", you would choose "Equals" ( = ).  

4 Click the dropdown arrow in the Value column to open an appropriate data-entry window. Then
enter the appropriate value to be compared to the selected Field. 

More than One Criteria

When you have several criteria rules you want checked the system needs to know if you mean "this
criteria AND that criteria" or whether you mean, "this criteria OR that criteria" since there is a big
difference. To control this, there is an option to specify AND or OR at the end of each row of criteria,
to tell the system how to link that criteria rule to the next.

Also remember that when using multiple criteria, every piece of the criteria (at least those with
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"and") must be true for each record being shown on the report.  Therefore, if you use criteria like:

City = MyTown AND
City = YourTown

... the report won't show anything. This makes sense if you think about it, because no member has
a city set to MyTown AND YourTown at the same time.  There is only one city on an address.

If the criteria was changed to:

( City = MyTown OR
City = YourTown )

...the report will work, because now it can find members with a city of MyTown OR a city of
YourTown -- it doesn't have to match both at once.

Using Parenthesis 

The advanced criteria list includes options for left and right parenthesis. Parenthesis are very important
if you use an OR to join your criteria rows. Consider this criteria:

State = Texas AND 
(City = Mytown OR
 City = YourTown)

This will require a state of Texas, and either a city of Mytown or a city of YourTown, because the AND
refers to all of the criteria grouped by the parenthesis.  However, if the parenthesis were omitted, the
criteria would look like this:

State = Texas AND 
City = Mytown OR
City = YourTown

This can produce unpredictable behavior, because now it essentially says, "state of Texas and city of
MyTown, or the city of YourTown without regard to the state".  Thus, records could be returned for
YourTown, Washington, and YourTown, Oregon, as well as YourTown, Texas.

Special Expressions using LIKE and NOT LIKE Operators

% The percent sign is used in conjunction with the word "LIKE" to search for data that begins, ends,
or contains specific text or numbers. For example, if you selected Last Name as the field, and LIKE
as the operator, you might enter any of the following in the Value field:

"Smith%" to get "Smith", "Smithe", or "Smithington.
"%burg" to get "Sederburg", "Frankenburg", "Hidelburg"
"%der" to get "Sederburg", "Fender", and "Derston"

You can also use the opposite of LIKE, which is NOT LIKE, to reverse the search requirement.

Complex Expressions Using LIKE and NOT LIKE Operators

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
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each expression below would be preceded with LIKE or NOT LIKE.

Expression Searches for... Sample Return Data

Mc% Names that begin w ith the letters "Mc" McEvoy

%er Names that end w ith "er" Brier, Miller, Weaver, Rayner

%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]ow ell Names ending w ith "ow ell" that begin 

w ith a single letter in the range M to Z

Pow ell

M[^c]% Names beginning w ith "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas
the _ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

Sample Searches - Click to see several examples of search criteria.

Address Criteria

When using MemberTies Professional, if you use address fields as part of your criteria, i.e., "City =
MyTown", and your membership records often include multiple addresses, you may want to use a
special criteria field called "Address to Use".  With this criteria, you can tell the report which address
you want it to look at when matching the City value.

If you don't use this criteria, the system will automatically assume you want to use the Current
Address whenever it needs to look for address data.  That means if a member has a Home Address in
"MyTown" and a Summer Address in "YourTown", the record won't be displayed unless the Home
Address is marked as Current on the membership record.

Include in Mailings, Include on Reports

These two checkboxes are available on membership records in case you want to use them as report
criteria.  You may select either of these fields for criteria if you wish to use them.  If you do not use
them, i.e., if you don't include the "Include on Reports" criteria, it won't matter whether the checkbox is
selected or not on a member record.

To Save and Reload Search Criteria

See Saving Advanced Criteria.
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23.3 Selecting a Criteria Field

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.

The Select Criteria Field window enables you to choose the Field whose data you want to compare.  

The window organizes the available fields into a simple tree display, grouping the fields by general types,
or sections. There will be one or more sections available, each containing a number of fields. The Activity
section contains fields for activities, attendance, and activity locations; the Members section contains
contact fields from the membership record, and so on.

Note: The Address, Custom Field, and Assigned Item fields are specific to the primary data type of the
report. i.e., on a Member data report, the address fields only relate to member data. Even if you select a
Group field as criteria, the fact that the report is primarily a membership report means the address fields
are for member addresses. (Custom Fields will only appear in this list if they have been defined as
available to be used as Criteria.)

Special Criteria Behavior

Some types of criteria can cause more records to be excluded than expected, depending on the type of
report and the criteria used. For example, a membership report is by definition focused primarily on
membership data. However, if you use a Group Name as criteria you're bringing in a whole other area of
the system and tying it to the report. That means that now only members who are part of at least one



MemberTies465

©1998-2014 Myrro International

group can be considered at all. In other words, the system will first determine what members are tied to
ANY group, and then narrow that to those who belong to the group name you specified with your criteria.
 A member who doesn't belong to any group will be excluded before the group name is even considered.

23.4 Selecting an Operator

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.

The Select Operator window enables you to specify the way the criteria value you choose will be
compared to the value of the field in the database.  For example, if the field is "Last Name" and you
choose "Not Equal (<>)" for the operator, then whatever value you enter must NOT be in the last name
field. i.e., Last Name <> Smith means "no members with a last name of smith"

The list will contain options appropriate to the field chosen. For example, if you choose a freeform text
field like "Address Line 1", all options will be available, including the LIKE and NOT LIKE operators for
expressions (see below). However, if you choose a field that uses a dropdown list of values (such as
Country), the only options will be Equal and Not Equal. As soon as you select an operator, the window
will close and the selection will appear on the list.

The following operators may be available:

Equal - indicates that the field data must exactly match the value

Not Equal - indicates that the field data must not match the value

Greater Than - indicates that the field data must be larger than the value.  For numeric values, it
means the data must be numerically larger. For text values, it means the data must sort
alphabetically after the value. i.e., "> b" means the data must start with "c-z".
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Greater Than or Equal - indicates that the field data must be equal to or larger than the value. See
"Greater Than".

Less Than - indicates that the field data must be smaller than the value.  For numeric values, it
means the data must be numerically lower. For text values, it means the data must sort
alphabetically before the value. i.e., "< d" means the data must start with "a, b, or c".

Less Than or Equal - indicates that the field data must be equal to or smaller than the value. See
"Less Than".

LIKE - indicates that an expression will be used to match data to a value using the % "wildcard"
character. i.e.,  "%smith%" will search for the word "smith" within the data, since the leading and
trailing % symbols indicate that any text can come before or after the word.

NOT LIKE -  indicates that an expression will be used to look for non-matching data using the %
"wildcard" character. See "LIKE".

RLIKE - Similar to LIKE, but with regular expressions.

NOT RLIKE - Similar to NOT LIKE, but with regular expressions.

23.5 Selecting a Criteria Value

A criteria entry is composed of a Field, an Operator, and a Value.  For example, "Last Name"
"Equals" "Smith" means the field, "Last Name" must be an exact match (equal) when compared to the
value "Smith".  Therefore, only members with a last name of Smith will pass the criteria to appear on the
report.

The advanced search list has to do a lot of thinking in the background to be sure the right options are
presented to you based on the field you select. For this reason, separate windows must pop up to help
you enter the Operator and the Value. To enter this information, simply click the appropriate field on the
list, and the necessary window will appear.

Note: To search for records with a blank value, leave the value field empty. i.e., criteria like, "Email
Address = (blank)" will find records with nothing in the email address field.

Entering a Text Value

The above example shows the entry field for a plain text value.  The Enter Criteria Value window creates
the appropriate type of entry field for the chosen Field Name. Since most fields in the system (such as
"Last Name") are standard text fields, the input field will normally let you type whatever you wish.
However, some fields have special values that must be selected in a special way. For more information
about these special values, please choose one of the following:
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Entering a Checkbox Value

The available checkbox options for criteria purposes are:

Selected - the checkbox on the record must be selected

Not Selected - the checkbox on the record must be clear

Any - it doesn't matter whether the checkbox is selected or not. This is useful when the criteria
cannot be deleted, but needs to be ignored.

Entering a Date Value

There are a number of ways to specify a date. It can be relative to the current date, a specific day, or a
specific kind of date. Please see Entering Date Criteria for details.

Entering a Status Value
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When the membership status is used for criteria, the Enter Criteria Value window displays a list of all
available statuses.  You may either select the statuses individually, or the Options button will display a
popup menu of quick select choices.

Note: If you choose more than one status the criteria list will display, "Multiple Statuses" rather than
attempt to list them all.

Entering a Dropdown List Value

Fields that display as lists in the application show similarly when used as criteria. 

23.6 Entering Date Criteria

There are several options available for entering a Date criteria value to provide additional flexibility. You
can specify a particular date, a predefined range of dates, or a relative date based on the current day (i.
e., today + 5 days).  

For example, these options enable you to set up a report to always retrieve records where the End Date
is less than 30 days from the day the report is run, i.e. (End Date < Current Date + 30) as shown in the
example below.
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Note: "Current Date" is always the day the report is run.

The following options are available:

Use - This field determines how the date criteria is going to behave. There are several options:

No Date - to find records where the date in question is blank.

Specific Date - to find records matching a specific date

Current Date (Today) - to find records matching the current date

Tomorrow - to find records matching the current date +1 day

Yesterday - to find records matching the current date -1 day

Current Date (Adjusted +/- Days) - to find records with a date relative to the current date. A
negative number such as "-10" means the date must fall within the preceeding 10 days. A positive
number such as "30" means the date must fall within the following 30 days.

The rest of the options are predefined ranges. For example, if the report is run on 5/28/2005, the
"Last Month" option means "4/1/2005 - 4/30/2005", and "Month to Date" means "5/1/2005 -
5/28/2005", and "Last Year" means 01/01/2004 - 12/31/2004.

Date - This field is only enabled when the "Use" field is set to "Specific Date" so you can choose the
date.  

Adjusted - This field only appears when the "Use" field is set to "Current Date (Adjusted +/- Days). Its
usage is described above.

23.7 Saving Criteria

Advanced criteria can be saved and then reopened later when you want to run a particular search again.
This is particularly helpful for complex searches that take a lot of time to set up.  

Note: Only advanced criteria can be saved.

Saving Advanced Criteria

If you have not created criteria yet, see Entering Advanced Search Criteria.

1 After your criteria is working correctly, click the "Save" button (or if there is no Save button,
right-click the criteria list and choose "Save Criteria").
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2 When the "Save As" window opens, enter a name for the search criteria such as, "Expired
Dues" or "Committee Members".

3 Click OK.  The system will verify that the search layout is valid, and then will save it under the
specified name.  

Loading Saved Criteria

To reload the search, click the "Load" button (or if there is no Save button, right-click the criteria list and
choose "Load Criteria") on the Search tab and select the desired search.

23.8 Exporting/Importing Criteria

Any report criteria, as well as criteria created on the activity, group, or membership list search tab using
the Advanced Search option can be exported to a file. This can be helpful if you need to create criteria
for another non-networked user, or if you need to send confusing criteria settings to the Support group for
analysis or help.

Criteria is saved to a special ".mtx" (meaning "MemberTies export") file. These files can be used to
import the criteria later, as long as no criteria already exists by the same name (unless you want to
overwrite it).

Note: Do not attempt to modify the exported file using any kind of word processor or text editor.  It
contains some fairly complex data structures, and altering the file may render it unusable.

Exporting Criteria to a File

Before criteria can be exported, it must first be saved.  If you haven't saved the criteria settings yet, see 
Saving Criteria for details.

1 On the Activity, Group, or Membership List, go to the Search tab, choose Advanced Criteria if
necessary, and click the Load icon,

or...

On the Report Settings window, right-click the criteria list and click the Load icon

2 On the Saved Search Criteria window, use the right mouse button to click the saved criteria you
want to export, then choose "Export to File..." from the popup menu.
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3 Click OK when prompted to confirm the export.

4 When the "Save Criteria As" window opens, enter the name of the export file you want to create,
then click Save.

Importing Criteria

Saved criteria can only be imported to the same software version that was used to export it.  That means
if you export a file using MemberTies version 6.0, you cannot import it to version 6.1. This prevents
potential conflicts that could arise due to database or programming changes.

In addition, you can only import criteria to the same place. In other words, criteria exported from the
Membership List cannot be imported to the Group List, or to Reports.  Criteria is specific to the area of
the program where it was created.

1 On the Activity, Group, or Membership List, go to the Search tab, choose Advanced Criteria if
necessary, and click the Load icon,

or...

On the Report Settings window, right-click the criteria list and click the Load icon

2 On the Saved Search Criteria window, use the right mouse button to click anywhere in the list,
then choose "Import from File..." from the popup menu.

Note: It does not matter whether you click on a row or not, just click anywhere in the list.

3 Click OK when prompted to confirm the import.

4 When the "Select Import File" window opens, enter the name of the previously exported file you
want to import, then click Open.

5 A message will be displayed for you to confirm the criteria being imported. If you want to
continue, click OK.

6 If the criteria being imported already exists, you will be prompted to overwrite the existing data.

7 If the import is successful, the new criteria will appear in the list and will be immediately ready
for use.

23.9 Using the Quick Search Window

There are several places in the system where you are allowed to search for a membership or group
record while you're inside of another record.  For example, if you're using an Activity and want to add
attendees, or if you're using a membership record and want to relate other members or groups to that
record.

This is the window that appears when adding attendees to an Activity. We chose this example because
unlike other quick search versions, this one includes an "Additional Information" tab.
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The fields available in the Criteria section, and the columns displayed in the Results section vary with
each Quick Select window. 

The following options are available:

Criteria - Fields appropriate to the search being performed will be available. In this example they are
appropriate to adding attendees to an activity. Otherwise, the criteria fields work just like all other 
basic search windows.

Search - Starts the search using whatever criteria you have entered.  If you don't enter any criteria,
the search will return all records available.  

Append - Prevents the Search Results list from being cleared prior to a new search.  This enables
you to search for a last name of "Smith", then search again for a last name of "Jones" and add the
new results to the results for "Smith". It just appends more rows to the results, rather than replacing
the results.

Clear - Removes all entries from the Criteria section.

Remove - Removes the selected rows from the Results List.
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Additional Information Tab - This tabpage may or may not be displayed on all quick search
windows. 

In this example, the Additional Information tab enables you to specify attendee information that will
be applied to each record you select to keep. (See "Use Selected Results" below.)

Use Selected Results - The purpose of this button is to return one or more records to some other
window.  Since the search could display hundreds of records, you have to select the row(s) you
want to use, then click this button to go back to the window you were on before.

Cancel - Closes the search without returning any records.

23.10 Advanced Search Examples

This topic provides various examples of more complex Advanced searches, as sell as ways to use
complex expressions in Basic searches.

Here are some common searches:

Desired Result Criteria Example

Field Operat
or

Value

Members with a Chicago address City = Chicago

Members with an End Date in the next 30
days

End Date
End Date

>
<=

Today AND
Today +30

Members with a negative dues balance Dues Balance < 0.00

Everyone except "Alumni" status Status <> Alumni

Members with at least 2 relationships Count of Associations >= 2

Members with no email address Email = [leave blank]
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Members with no email address (another
option)

Email NOT
LIKE

%@%

Members with a phone number starting with
555

Home Phone LIKE 555%

Complex Expressions

If you are comfortable with the concepts of LIKE and NOT LIKE, the following table provides several
advanced examples of ways to use wildcards and expressions for even more precise queries. Note that
each expression below would be preceded with LIKE or NOT LIKE.

These can be used in any Basic search window, or when using LIKE or NOT LIKE in an Advanced
search criteria entry.

Expression Searches for... Sample Return Data

Mc% Names that begin with the letters "Mc" McEvoy

%er Names that end with "er" Brier, Miller, Weaver, Rayner

%en% Names containing the letters "en" Pettengill, Lencki, Cohen

_ish Four-letter names ending in "ish" Fish

Br[iy][ae]r Brier, Bryer, Briar, or Bryar Brier

[M-Z]owell Names ending with "owell" that begin 

with a single letter in the range M to Z

Powell

M[ ĉ]% Names beginning with "M" that do not 

have "c" as the second letter

Moore, Mulley, Miller

As illustrated above, the % (percent) symbol will be replaced by any number of characters, whereas the
_ (underscore) symbol can only be replaced by one character.

Text within brackets ( [ ] ) will be required unless preceded by the carat ( )̂ symbol, in which case the
text is disallowed.

The following examples illustrate various uses of the Advanced search criteria capability:

Finding Expired Members

This search illustrates what it might look like to search for all members whose membership (and
probably their dues) have expired.  Since MemberTies assumes that you will reset the End Date to a
point in the future when someone pays their dues, it can also be assumed that anyone with an End
Date in the past is probably past due.
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The Status on the first row displays "Multiple Statuses," because we have selected each status that
pays dues. The value for End Date displays as "Current Date," meaning that the date in the query
will always be "today." The system takes care of replacing the date for you when the search runs.

With these settings, this search will only find records that pay dues and have an End Date in the
past.

Note: Using MemberTies Professional, you can post dues as debits and credits.  Therefore, it might
be equally logical to assume that any member with a Dues Balance less than 0.00 is past due.  You
could accomplish this using the Dues Balance criteria field name.

Using a Date Range

These examples illustrate two different ways to search for all records with a Start Date that falls
within the month of November.

Example (1) uses the ">="  and "<=" operators to request any date that is greater than, or equal to
November 1, AND less than or equal to November 30. 

Example (2) accomplishes the same thing by using the ">" and "<" operators to request any date
that is greater than October 31, and less than December 1.

Both queries will only return records with a Start Date within the month of November.

Using a Relative Date

This example illustrates how to search for a relative date, i.e., all records with an End Date that
occurs within the next 30 days. 
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Notice that on the Enter Criteria Value window, the Current Date option is selected, and 30 is
entered into the Adjusted field.  This tells the system to find records with an End Date starting
today, and going +30 days into the future. 

Likewise, you could enter -30 to find records with an End Date within the previous 30 days.

Correct vs Incorrect Use of "AND" and "OR"

These examples attempt to retrieve all members of the Johnson family living in Berryville and
Birmingham. 

Example (1) is incorrect, because it is telling the system to retrieve anyone in Berryville, and then
only Johnson family members in Birmingham.

Example (2) solves this problem by simply surrounding the city portion in parenthesis. Now the
query tells the system the records must have city of (Berryville or Birmingham), and a last name of
Johnson. This query will bring back a much smaller set of records.



Part

XXIV
Snapshots



Snapshots 478

©1998-2014 Myrro International

24 Snapshots

24.1 Overview

The Snapshots window, available with MemberTies Professional, enables you to choose one or more
informational snapshots to display on a single window. Each snapshot provides a view of a specific kind
of data, and many shapshots have user-definable settings to control the kind of data that is displayed. 
For example, the "Dues Balance Notification" snapshot lists all membership records with a dues
balance that meets a certain rule, such as "Greater Than 1000.00", or, "Less Than 0.00". 

Snapshots can be arranged on the snapshots window in any order or position you wish, and sized as
you wish, to provide the display that is appropriate to your needs.  For example, if you want to see every
member who is checked in to an Activity, but just want to know about members with a dues balance
less than zero, or upcoming birthdays, you could size one snapshot much larger than the others. 

You work with snapshots via the Snapshots window. To get to the Snapshots window, click the
Snapshots toolbar button.

24.2 Using the Snapshots Window

You can choose to display any number of the available snapshots on the window, and you can arrange
and resize them any way you wish. When you close the window, the system will remember the layout
you created, and will restore it for you when you return.  Snapshot settings and layouts are saved for
each user.

Note: If you would like the snapshots window to be the first window opened when MemberTies starts,
you can set the Opening Window Login Preference.

Choosing Snapshots
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1 Choose File > Workspace > Snapshots.

2 If you have never opened the Snapshots window before, you will be prompted to choose
snapshots to display.  Choose Yes to open the Snapshots List.  You can also open the
Snapshots List by choosing Actions > Choose Snapshots.

The Snapshot List displays all available snapshots, and indicates whether they are currently
open.

3 Place a checkmark next to each snapshot you want to open. If you clear a checkmark, that
snapshot will be closed when you close the list.  

4 The system will open each newly selected snapshot. Depending on how many snapshots are
already open, the new snapshot panels may open on top of existing panels.

5 Use the mouse to drag the panels around and resize them as necessary to create a layout that
is easy for you to use.
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Changing Snapshot Settings

At a minimum, you are allowed to set the title of each snapshot using its settings window. In addition,
many snapshots allow other settings to be made, to control the records that are displayed.

1 Right-click anywhere in the snapshot panel you want to change, then choose Settings from the
popup menu.
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2 When the Settings window opens make any appropriate changes, then click OK to save and
refresh the snapshot panel.

Other Snapshot Options

Always check the right-click menu to see what options are available for the snapshot panel in question.
Some typical options are:

Refresh - Choose this option to force the snapshot to re-retrieve data. This is helpful if you've
changed a record that was displayed in the snapshot list.

Printing - Choose this option to print the contents of the snapshot list.

Opening Records - If the snapshot displays a list of member records, for example, choose this
option to open the selected member's main record.

Snapshot Security

Security Group settings are available to prevent users from either opening the snapshot window, or from
changing snapshot settings. Additionally, certain snapshots are only available to the administrator user,
such as the listing of active users. 
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25 ToDo List

25.1 Overview

The To Do list feature simply enables you to keep track of things that need to be done.  However,
instead of a single general list, you can assign To Do items to individual member or group records, as
well as to yourself.

To Do items can be anything you choose. For example, you might create a To Do for yourself entitled,
"Print Year End Membership Roster" with a due date of December 31st. Then you just forget about it!
When the due date arrives, the To Do will display when you start MemberTies (if you turn on that Login
Preference ). You can even specify how soon before the Due Date the To Do should begin to display. For
example, setting the "prompt" to 10 would cause the To Do to display anytime you start MemberTies
after December 20th.

To Do items can be marked as Completed at any time, and can be reopened if necessary. A To Do List
report is also available to print To Do items.

The "Show To Do List" Login Preference controls whether to display all open To Do items each time you
login to MemberTies. Turning on this feature ensures that you never login without seeing the current list
of outstanding items.  If there are no open To Do items, the window will not appear.

The To Do List window enables you to manage any list, whether it is for a member, group, or yourself.
The following options control what appears in the list:
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List Type - Determines whether the list will include items for members, groups, yourself, or all items
without restriction. If you choose to display the list for Members or Groups, a second dropdown list
will be displayed so you can limit the list to specific record.

To Do Status - Determines whether the list will include only Open items (items with a dues date
that has arrived or past), Completed items, or both open and completed items.

Include Future To Do Items - Items that are scheduled in the future can be displayed on any list
by selecting this option.

25.2 Working with the ToDo List

The To Do List enables you to view or create To Do items for any record in the database, without having
to actually open the record.  Note that if the To Do item is for a Member or Group record (as opposed to
for yourself), you can open the associated Member or Group by choosing the option from the right-click
menu.

Adding a To Do Item

1 Choose Tools > To Do List to open the List. The To Do List window will automatically show all
currently open items in the list.

2 The fields at the top of the window control not only what appears currently in the list, but what
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list new items will be added to.  Therefore, if you want to add a new item for yourself, the List
Type should be set to "Your To Do List". If you want to add a new item for a member or group,
you need to choose the appropriate list type, and then choose a specific record from the
dropdown next to the List Type field.

Choose the appropriate type of list, and specify a member or group record if appropriate.

3 Click Add.

4 When the New To Do window opens, the following fields are available:

Description - A brief description of the item

Due Date - The date the item is to be completed

Prompt - The number of days ahead of the Due Date you want to be reminded of the item. Note
that you will need to turn on the Show To Do's on Startup preference to be reminded.

Complete - Select this option if this item has already been completed.

Tip: Once the To Do Item has been completed, you can change the Completed Date and
Completed By fields by clicking in them and typing new information.  This actually enables you
to set a user name in the Completed By field that isn't in the database.

5 When you're finished, click OK.

Note: The item you added may not be displayed in the currently open To Do list if it doesn't fit
the criteria of the List. For example, if the list is not currently set to display future items, a new
item due tomorrow or after will not be displayed.

Changing a To Do Item

1 Choose Tools > To Do List to open the List. The To Do List window will automatically show all
currently open items in the list.

2 Set the appropriate options to display the item you want to change.

3 Select the item, then click Open.

4 Make your changes, then click OK.

Deleting a To Do Item

1 Choose Tools > To Do List to open the List. The To Do List window will automatically show all
currently open items in the list.

2 Set the appropriate options to display the item you want to delete.

3 Select the item, then click Delete.

4 Confirm the deletion.

Opening the Associated Record

1 Right-click the desired To Do item, and choose Open (member/group) from the popup menu.
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2 The appropriate detail window will open for the member or group record. When you're finished
and close that window, you will return to the To Do list.

 

Printing the To Do List

25.3 Printing the ToDo List

This report provides a To Do List based on your specifications. You can restrict it the same way you can
restrict the display of the To Do List itself. Note that this report can also be printed either from the To Do
List window as described below.

Printing the Report from the To Do List Window

1 Open the To Do list and adjust the display until the To Do List contains the items you want to
print. See the To Do List Overview for more information.

2 Click Print.

3 Confirm the printing.
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26 Users, Passwords, and Security

26.1 Overview

Every database has one or more users that are allowed to login.  The Login window takes the user name
and password provided, and checks it against the selected database to see if that user is allowed to log
in at all. If the database accepts the login, everything from that point forward is controlled by the user's 
Security Group settings.

IMPORTANT: If you lose your password, there is no way to retrieve it.  Passwords are
encrypted, and there is no way for anyone (not even Myrro International) to determine what
password you used. Make the password something you can remember, and keep it somewhere
safe!  In the event that you do lose a password, the mtadmin user can log in and give you a
new password.  If the mtadmin password is also lost, you will need our help to reset it.

See Working with Users for details about creating and managing user accounts.

Users

MemberTies has several types of users: the Administrator, Exempt users, and Normal users; each is
described in more detail below.

Administrator User

The administrator user is a special user known to the system as "mtadmin". This is the most
powerful user, and it is created automatically by the system when you create a new database.  
By default, the password for this user on all new or converted databases is simply,
"password."   You should change the password to something more secure as soon as
possible. This user has rights to do special things to the database, such as check and repair
tables, create or modify other users, display currently active users (and stop their sessions if
desired) and more. 

This is the only user with the authority to add new users to the system. This helps prevent
someone from simply creating a new name and using your database. See Adding Users for
more information.  It is also worth mentioning that you should not leave user names assigned to
a database if they aren't going to be used.  Leaving active user accounts in the system leaves a
security hole in your system, allowing somebody to access data using a name and password
you thought was out of service.  When users leave your organization, you should have the
administrator remove or inactivate the account.

The administrator user is also able to:

Create new databases

Delete entire databases

Update Security Groups and assign them to users

Change passwords for other users

Activate and Deactivate other users

Display all currently active users
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Run commands to check, repair, and optimize database tables

Restore database backups

Reset internal database sequences

Run command files provided by customer support against the database to perform mass
updates

Obviously, this is a powerful user account and should not be used for day to day activities.  You
should keep the password for this user in a secure place, and only use this account when
necessary for administrative duties.

Normal User

A "normal" user is someone who just uses MemberTies to work with the data, who doesn't need
to do any of the things the administrator can do.  You will normally want to log in as a non-
administrative user and reserve the administrator accounts for those times when you actually
need to do something that only the administrator can do.

Passwords

The MemberTies database uses passwords to help ensure that all of the confidential personal
information contained within your database is safe from casual snoopers. It isn't foolproof, but it goes a
long way toward preventing the pool boy from finding out the names and addresses of all your single
female members.  The more secure a password you create, and the better you protect it, the more
secure your data will be.

Note: Passwords are case-sensitive!  The word "password" is not the same as the word
"paSSwoRD" (and of course, neither of these are very secure choices for a password).

26.2 Working with Users

Only the administrator user (mtadmin)  can modify existing users' passwords, active status, or Security
Group settings.

For a general overview of users and passwords, see: Users and Passwords Overview.

For a general overview of the relationship between users, the server, and the database, see: Server and
Database Overview.

Adding a User 

1 Login to MemberTies as the user "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Users. The Maintain Users window will open,
displaying all users that exist on the current database.
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3 Click Add.

4 When the New User window opens, the following fields are available:

User Name - The name the user will enter on the Login window to connect to the database.
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Password - The password for this user. (Note that you are able to leave the password field
blank if you do not want to use a password at all.  This is extremely insecure and you should
only do this if the computer exists in a secure location and is not accessible from the Internet. 
Click the Set button next to the password to actually enter and confirm a password.

Security Group - The security group that will dictate the things this user is allowed to do. Every
user must belong to a specific Security Group. By default, all new users are added an
unrestricted group that allows access to all features. Security Groups must be set up
beforehand to appear in this list. To view the actual settings for a selected security group, click
the View button next to the field. See Security Groups for more information about creating
security groups.

Active - Indicates whether this account can be used to log in to the system.  If the account is
changed to Inactive, even the correct username and password will not grant access to the
system. New users are automatically created as Active. If you do not want the user to be active
at this time, clear the Active checkbox.

The fields in the User Details section are optional and can be used to track additional
information about who the user really is:

Real Name - The name of the user.

Address - The user's address.

Phone - The user's telephone number.

Email - The user's email address.

Comments - Additional comments about the account.

5 When you are finished, click OK to add the new user to the database.

Removing a User 

When a user no longer needs to be able to access a database, you can either inactivate the account, or
remove them from the system entirely. Either option will prevent them from logging into the database.

1 Login to MemberTies as the user "mtadmin". 
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2 Choose Tools > Database Admin Tools > Maintain Users. 

3 Choose what you want to do:

To remove a user from the database completely, select their record in the list, then click
the delete button to remove the entry and confirm the deletion when prompted.

To inactivate the user so the account remains but is unusable, select their record in the
list, then click open. On the Edit User window, clear the Active checkbox.

4 When you are finished, click OK.

Changing Passwords

You can use the Maintain Users window to change the password for any user.

1 Login to MemberTies as the user "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Users. 

3 Select the user whose password you want to change.

4 Click Change Password.

5 Enter the new password, then click OK to return to the Maintain Users window.

6 When you're finished, click OK. The new password will be required the next time the user logs
in.

26.3 Passwords

Anyone logged in to MemberTies can change their own password at will, but only the administrator
(mtadmin can change the password of other users. This procedure covers both of these scenarios.

Note: You should always choose a password that is difficult to guess (i.e., don't use your birthday, your
address, your pet's name, or "password."). As a rule, membership databases contain a lot of confidential
information -- a good password is the first step to preventing a loss of information.

Passwords are CAsE SensiTive! The word "mypassword" is totally different from "mYpassWord" (and
still not a very secure password, by the way).

By default, the password for the most powerful account in the system (mtadmin) is simply,
"password." You should login as this user as soon as possible and change the password to
something more secure.

IMPORTANT: If you lose your password, there is no way to retrieve it.  Passwords are
encrypted, and there is no way for anyone (not even Myrro International) to determine what
password you used. Make the password something you can remember, and keep it somewhere
safe!  In the event that you do lose a password, the mtadmin user can log in and give you a
new password.  If the mtadmin password is also lost, you will need our help to reset it.



MemberTies493

©1998-2014 Myrro International

Changing Your Own Password

1 Log on normally using your valid User Name and Password.

2 Choose Tools > User Tools > Change Password.

3 Complete each field:

 Current Password - Enter your current password.

 New Password - Enter the new password.

 Confirm Password - Enter the new password again to confirm it.

Asterisks ( * ) will appear instead of the letters or numbers as you type passwords, but do not
assume that each asterisk represents one letter. They are just there to hide what you type.

4 Click OK. 

5 If you entered your current password correctly, and the New and Confirm passwords match, a
message will be displayed indicating the success of the change.  If the change is successful,
the system will be restarted so you can login with the correct information.

Changing Another User's Password (administrator only)

1 Login to any MemberTies database as the administrator user "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Users. 

3 Select the user whose password you want to change and click Open.

4 On the Edit User window, click the Change button next to the password field.
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5 Enter the new password, then click OK on all windows to save.  The new password will take
effect as soon as the user logs in again.

 

26.4 Security Groups

MemberTies is designed to enable you to secure various actions that a user could perform in the
system, such as adding members, viewing reports, or opening credit card data. Security settings are
created and applied with Security Groups. You can create any number of security groups, each with
different security options enabled and disabled.

By default, every new user is assigned to an unrestricted security group.  If you don't change this
setting, the user will have access to everything in the system (other than things restricted to the
administrator user, of course).

Security Groups require time to setup correctly, but save you time in the long run.  Since there are
almost 200 different security settings available, setting up a new user with security options like another
user would be very time-consuming.  With Security Groups, you only need to setup a particular set of
rules once, and then you can apply it to any user you wish.  Of course, if you have no need for security,
you can just leave users set to "All Access."

Adding Security Groups

1 Login to MemberTies as the administrator user, "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Security Groups. 
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3 Click Add. 

5 The following options are displayed on the Security Group window:

Group Name - This is the name of the security group that will be displayed in the "Security
Group" list when working with a user account.
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Description - A general description of the group, what it is for, why it should be used, etc.

Allowed - If this checkbox is selected, the action shown can be performed by the any user
in the group. If the user tries to do something they do not have access to do, they will
receive an "access denied" error message. (Hint: The right-click menu enables you to
quickly select all settings and toggle them on and off. If you're creating a new severely-
limited group, it's easiest to select and disable everything first, then enable the things that
apply.)

Remember - changing a setting here affects everyone who has been assigned this
security group!

Application Area - Security settings typically apply to a particular area of the system. It is
important to look at the application area for the setting you are changing, to be sure it will
behave as expected.  For example, the security setting "User is Allowed to Open the
Members Tab" relates to the Members tab on the Group window. It has nothing to do with
the Membership window at all. 

Application Areas include:

Activities
Database
Financials 
Groups
List Contents
Members 
Miscellaneous
Preferences
Reports
Security

Security Status - This indicates the status of the security option. It changes from "is" to "is
not" as the Allowed checkbox is modified.

Filter to Security Area - This enables you to limit the rules displayed in order to help you
find the type of security setting you want to change.  For example, an option is provided to
only show "Add" security rules, such as the ability to Add Activities, Add Members, Add
Dues, etc.  Other options show only Modify and Delete actions, or all actions pertaining to
Membership, or to the opening and access to tab pages and windows.

Print - Prints the current security settings.

6 When you are finished, click OK to return to the Maintain Users window.

Changing a Security Group

1 Login to MemberTies as the administrator user, "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Security Groups.

3 Select the group you want to change, then click Open.

4 Make your changes, the click OK.
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Deleting a Security Group

When a group is deleted, all users that had been assigned that group are updated to point to the default
"All Access" security group instead. This occurs because every user must have a security group
assigned.

1 Login to MemberTies as the administrator user, "mtadmin". 

2 Choose Tools > Database Admin Tools > Maintain Security Groups.

3 Select the group you want to remove, then click Delete.

Usage Notes

Some security rules depend on other rules to be enforceable; for example, consider the following
settings:

Members: User is Allowed to Add Dues Data 

Members: User is Not Allowed to open the Dues Tab

Activities: User is Allowed to open the Activity Front Desk window

These settings prevent the user from adding dues data on the Member window, because they won't be
able to get to the Dues tab in the first place. However, with the professional version, there is a preference
that allows dues to be added from the Front Desk window. If this preference is active, then this user
would be able to add dues via the Activity Front Desk window even though they can't add them via the
Dues tab.

 

26.5 Security Settings (Viewing)

Normal users can view or print their security settings at any time, though they cannot make changes.

Viewing Security Settings

1 Choose Tools > User Tools > View Security Settings.  A view-only window is displayed,
showing the security settings for the security group to which the current user is assigned.
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2 To print these settings, click Print.

3 When you are finished, click Close.

26.6 Showing Active Users

The Active Connections window displays a list of all users currently connected to the active database. 
This list appears automatically if you try to login and the maximum number of connections allowed by
your license has already been reached (if you do not have a license, the maximum number of
connections is one.)
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The administrator user can also display this window at any time.

Showing Active Users

1 Login to MemberTies as the administrator user, "mtadmin". 

2 Choose Tools > Database Admin Tools > Show Active Users to open the Active Connections
window.

The following information is displayed:

User - The user currently logged in. 

Login - The date and time the login occurred.

Elapsed - The number of hours, minutes, and seconds the user has been logged in. (If the
number of hours exceeds 24, the number of days is shown as well)

Connection ID - The server connection ID, for information only.  Database connections are
counted from the last time the server was restarted. The system opens and closes
connections in background frequently, so you shouldn't worry too much about the ID you
are assigned. i.e., if your connection ID is "41", it doesn't mean there are 40 other people
connected.

3 If a user is shown that you know is not actually logged in, you can disconnect them by selecting
the record and choosing, "Disconnect".  This typically happens when a computer crash or power
failure prevents MemberTies from cleanly finishing the normal Log Out process. 
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Note: A disconnect command takes effect immediately. Do not disconnect a user if they really
are logged in! The disconnection process will kill their server connection, and they will get lots of
database errors and will be forced out of MemberTies without a chance to save or exit normally.

4 When you are finished, click OK.

When this window appears at Login

This window will display at login time if there are no more available "seats" on your license to allow
another user (you) to log in.  In this case, the window will show as it does above, but the "Disconnect"
button will not be available unless you are the administrator user or have the appropriate security
setting. 

If you are not allowed to disconnect an entry, you can only click Refresh to see if there is an opening, or
click OK to close and try to log in later.

 

26.7 Record Locking

If the license in use allows more than one user to be logged in at a time, the system will use a record
locking process to try to prevent two users from updating the same record at once.  If your license only
allows a single user, no record locking is used.

For example, suppose user "sally" logs in and opens a membership record.  The system will make an
entry in its records that sally now "owns" that record.  Now if user "joe" logs in and tries to open the
same record, he will receive a message similar to:

This record is locked and unavailable because it is currently in use by "sally" (effective:
11/26/2006 11:57:28)

Viewing Record Locks

Any user can view record locks, and by default, any user can remove locks.  The "Unlock Records" 
security setting can be used to prevent certain users from being able to remove record locks.

1 Choose Tools > User Tools > View Locked Records.
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Any record currently in use will be displayed.

2 If you are certain that the "Locked By" user is not actually using the record, click "Clear Lock"
to free the record.  If you have the appropriate Security Setting to unlock records, the lock will
be removed.

Note: It is important to be certain the record is not in use before removing the lock. If the record
is still being used, removing the lock will allow other users to open and change the record at the
same time. This could cause data to be lost or overwritten when each person saves their
changes.

3 When you are finished, click OK.

 

26.8 Running an SQL File

When logged in as the administrator (mtadmin), you can run an SQL script file (provided by Support)
directly against the database. This is an extremely powerful feature that allows data to be manipulated
without any of the controls imposed by the normal MemberTies interface. It is critical that you
understand what the file you plan to run will do. An SQL file can do anything from changing specific data
to wiping out the entire database. Never run an SQL file if you do not know what it does! 

Note: Most commands of this nature cannot be undone. Depending upon the type of file you are running,
you may want to consider backing up the database first.

SQL Files are normally provided as part of a customization package, or to do a mass change of some
kind at your request. For example, suppose you have a database of 10,000 members and you want to
automatically change the telephone prefix for every address in a particular city. Doing this manually
could take several hours, whereas an SQL  File could accomplish the same task in seconds.

Contact support if you think you have a need for this type of file. There is normally no charge for this,
though complex files or files designed to provide some sort of increased functionality may incur a small
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fee.

Running an SQL File

1 Login to MemberTies as the user "mtadmin". 

2 Choose Tools > Database Tools > Run SQL File. 

Choosing this option will force all open windows to close, and a file browsing window will appear.

3 Use the Select Command File dialog to navigate to the file you want to run, then click Open.

4 Depending on the nature of the file you are running, you may receive prompts, messages, or
other windows or warnings. Follow the instructions that appear.

5 When the script finishes, a results message of some kind will normally be displayed. This may
be a simple, "Success" message, or it may be a window listing changed data.  It is normally a
good idea to destroy a command file after it has served its purpose, so someone won't
accidentally run it in the future.
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27 Registering/Buying a License

27.1 Why Bother to Register?

This information is from the Association of Shareware Professionals with regard to the question, "Why
Should I Register my Copy of a Shareware Program?"

Why? For same reason you should pay for any program -- it is the honest thing to do. Shareware is
commercial software, fully protected by copyright laws. Like other business owners, shareware authors
expect to earn money for making their programs available. Paying for and registering a program also
entitles you to support from the author and other benefits, such as free or less expensive upgrades,
customization, quick bug fixes, etc. Moreover, the more consumers who pay an author to use a
program, the more likely the author will continue to improve it and to offer new programs.

Support

Consumers who purchase shareware programs receive a level of product support that exceeds what
traditional software manufacturers deliver. Shareware users who need support often speak directly to the
actual developer of the program, who is intimately familiar with how it operates and therefore can provide
excellent technical support. Shareware authors often fix bugs in programs and add features quickly,
based on feedback from users. 

The Association of Shareware Professionals (ASP)  (http://www.asp-shareware.org/ ) is an international
trade organization comprised of over 1000 shareware authors, publishers, vendors, and online service
providers. Its members agree to uphold high standards of professionalism and to always deal fairly and
courteously with their customers. The ASP logo on a shareware product means that product has been
produced by an ASP member. In addition, the ASP maintains an Ombudsman service, which can help
customers resolve any problems with ASP members. See Contacting Support for more information about
your rights via the ASP.

Pricing

There is a wide price range for shareware, as there is with software distributed through other channels. In
general, many shareware programs cost less than other kinds of software, while some programs cost
about the same as retail counterparts. MemberTies is offered in standard and professional versions to
help keep prices down. The basic version is priced to be affordable to any organization. The professional
version costs more and includes more powerful features that may not be needed by a small organization.

Viruses

The shareware industry has an excellent track record in providing products that have been checked
thoroughly for viruses. Shareware authors, online service operators, as well as disk vendors, carefully
scan programs for viruses before offering them to consumers. 

In fact, there have been many cases of viruses spread through shrink-wrapped software purchased in
stores. So downloading a shareware program from the internet or an online service is probably safer than
buying a disk in a store.

Why Shareware?

Shareware is an efficient way to run a software business. Authors do not spend nearly as much money
marketing, packaging, and advertising their products as do developers of software sold through traditional
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channels. Lower costs means shareware authors can concentrate on writing great programs, while often
charging users less. 

Shareware authors also retain complete control over their programs -- a powerful incentive to
programmers who have developed products from the beginning, and would rather see their fate
determined by technical, rather than marketing, considerations. Shareware authors recognize that their
programs have to be good. If they're not, consumers simply won't buy them. 

IBM and Microsoft are just two of the software companies that have recognized these benefits of the
shareware channel, as both have distributed "try before you buy" versions of products recently.

How to Register

See Registering for complete information about registering MemberTies.

27.2 How to Purchase

To use all of the functionality of a MemberTies database, you must assign a valid license to the
database. A license is obtained by registering the software. Upon registration, you will receive a license
that includes the Licensee Name (typically the name of your organization), and a License Number.  This
information can then be applied to any database profile to unlock the database and remove the record
limit. If you maintain multiple databases, you may want a separate license for each of them. This is not
a requirement -- you can use the same license for more than one database -- but the organization name
displayed on reports will be taken from whatever license is currently in use.

Without a valid license, you can only use a database in Unregistered mode. In this mode, the number of
membership records that can be created is limited. 

Once you have a license, it is valid for all updates (including patches, minor updates, and major
upgrades) to the software for a period of one year.  Once the one year period expires, your license will
continue to be valid, you just will not be able to use it with any further updates to the software. If the
"License Update Prompt" preference is turned on, a message will be displayed 30 days prior to the end
of the free updates period.

Note: If you had a valid license have lost the information, i.e., it is no longer stored with the database
profile, your system will revert to shareware mode. Records in excess of the maximum will not be lost,
but you will be unable to add more until the license information is replaced. Contact support in this
situation and your current license information will be sent to you. There is no charge for retrieving this
information.

To Check Your License Status

The check the license in use for the current database and determine when the free update period of your
license expires, choose Help > About MemberTies and choose the "License Information" tabpage. The
free update period can be extended at any time for a small fee.
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License information will be displayed, as well as contact information and the version of the software you
are running.

Note: You cannot use a standard MemberTies license to run MemberTies Professional or visa versa.
Each version requires a special type of license.

To Register 

Open the Help menu and choose Register, or go to our website at http://www.myrro.com/memberties.
Payments are accepted via check, postal money order, credit card, or purchase order, and may be
made over the phone or via a secure Internet transaction.

27.3 Using a New License

First of all, THANK YOU for registering! Your support is greatly appreciated.

Your new license will generally be sent to you in an email, which should include instructions on how to
apply the license. Since MemberTies is available for download at any time, most users will already have
seen the "reminder" Registration Notice window that is displayed each time you login.  If you follow the
instructions in the email and copy the specified license text to the clipboard, it will automatically be
entered in the license fields when the window appears.

The text to copy form the email will normally be in a special area of text, like this:

--Start Here---------------------------------

My Organization Name
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x011p54d023a17zs09u90ak47s78

-----------------------------------End Here--

You should copy everything, including the dashed line above and below the text to use the "Paste
License" option. But if you would prefer to copy just the licensee, and then right-click and paste it into
the Licensee field, then copy the license number and right-click and paste it into the Number field, that
is fine too.

If you choose not to enter information at this time, just click "Not Yet" to bypass the window and
continue to log in. You can choose "Registering" under the Help menu and click the "I Have a License"
button to display this window again if needed.  You can also enter the license information on any
existing Database Profile in Preferences.

Note: There is a difference between a license for MemberTies, and a license for MemberTies
Professional -- they are not interchangeable. You can upgrade an existing standard license to the
professional version by paying the difference in cost.

Updating the License on Multiple Databases

If you have multiple databases, you should open each database profile in Database Preferences and add
the information there. See Working with Database Profiles for details.

Updating the License for Multiple Users

The license information is stored within the database itself, so as soon as one person loads a new
license, it will apply to all other users.

Upgrading a License

A license is typically valid for all upgrades, large or small, for a full year.  When the license expires, the
only thing that changes is your ability to download and install new releases. Nothing will change with
respect to using your database(s), logging in, adding records, etc.  You still have an existing license, but
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the maintenance period has expired.

Note: If the "License Update Prompt" preference is turned on, a message will be displayed 30 days prior
to the expiration date.

You can quickly determine when your current license expires by choosing Help > About MemberTies. 
The date of expiration ("Free Updates Until"), as well as the maximum number of users is displayed on
the License Information tab.

27.4 Using Database Profiles

Database profiles tell MemberTies where to find a particular database, what to call it (the name that
appears in the Database dropdown on the Login window), and what license should be used with it, if
any. 

Note: All profiles that are stored on your computer are available for editing. However, the license
information can only be modified if you are connected to the database the license is assigned to.  If you
log into one database and then open the profile for another, license information will not be available
because the system cannot find the information from the other database.
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Profiles can also be exported/imported for easy distribution. See Importing/Exporting Database Profiles
for details.

Adding a Database Profile

1 Open the New Database Profile window. This can happen in several ways:

From the Login Window, choose (Specify New…) from the database dropdown list.

From within MemberTies, choose Tools > Preferences, expand the Database section,
choose Profiles, and click New.

2 A new Database Profile has two major sections: 

Database Name - This is the brief "user friendly" name of the database which will appear in the
Database dropdown on the Login window.  If your database is for your Skiing Club, a logical
profile name would be, "Ski Club". The profile name is simply a convenience. If your database
folder name is actually "mt_skiclub_aspen_division", a simple name like "Ski Club" is much
nicer to see in the Database list.

Database Folder - This section lets you specify the name or location of the database folder,
which is where all the files that make up the database are stored.  Chose one of the following
options:

Choose Existing Database - to identify an existing local or remote database

Create New Database - to create a new database. See Creating a New Database for
details.

3 If you click "Choose Existing Database", the Choose Database window will open:
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To specify a local database, select "Local Database (on this computer)", and then choose a
database from the dropdown list of available databases.  This list contains all database on your
computer to which the server has access.

To specify a remote database, select "Remote Database (on another computer)", and then
complete the fields to identify the database. If you're not sure what these fields are for, please
see, Setting Up a Multi-User System database for details.

4 After choosing or creating a database, you will return to the New Database Profile window, and
the database folder will be displayed. 

If you are connecting to a database hosted by Myrro International, you will have received special
Server Login credentials.  In this case click the Advanced button and enter the login information
on the Advanced Profile Settings window.

Note: Do NOT use these fields if you are running a local database server (i.e., a normal
MemberTies installation with a database on your computer) or you will not be able to connect.
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These settings are only for remote database profiles to servers requiring special connection
parameters (such as our hosted database server).  These fields are not used for the normal user
name and password information you put on the Login window when  MemberTies  starts.

The "Show" button will display the password in plain text so you can see what you're typing. 

After entering advanced options, click OK to return to the Database Profile window.

5 When you are finished, click OK. The database information will be verified, and if applicable the
license name and number will be validated. If everything is correct, the new profile will be added
to the list of databases MemberTies knows about.

Note: If you are adding a new profile from the Login window, clicking OK will return you to the
login window and the database dropdown list will be updated with the new entry.

Changing a Database Profile

A database profile can be modified from within MemberTies, or from the Login window.

From the Login window:

1 Select the database you want in the Database list.

2 Right-click the Database field, and choose "Modify Database Profile" from the popup menu.

or from within MemberTies:

1 Choose Tools > Preferences, expand the Database section, and choose Profiles.

2 Select the database profile you want to change, then click Open.

On the Maintain Database Profile window...
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The following fields are available:

Database Name - This is the name that displays in the Database list on the Login window.  Any
short, simple name is good.

Database Folder - This is the actual location of the database. This field is filled-in for you when you
choose an existing database or create a new one.

License Info for this Database - 

(These fields are only displayed if you are editing the active database profile from within
MemberTies. )

If you do not have a license, leave these fields blank and the database will function in
"shareware mode," allowing a limited number of records but otherwise fully functional. 

You can also leave the license fields blank if you have just upgraded from an older version of
MemberTies and your license is no longer valid.  You may not be allowed to enter new records
until you upgrade your license, but your existing data will not be harmed or lost, and you'll be
able to open records and see everything normally.
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Licensee - If you have an existing license, enter the licensee name exactly as it appears on
your license.

Number - If you have a license number, enter it exactly as it appears on your license.

Easy License Entry: If you have an email containing the license information, it contains specific
instructions about how to copy the license text from the email message so that it can be easily
pasted into these fields all at once using the "Paste License" option. 

Advanced

If you are connecting to a database hosted by Myrro International, you will have received special
Server Login credentials.  In this case click the Advanced button and enter the login information
on the Advanced Profile Settings window.

Note: Do NOT use these fields if you are running a local database server (i.e., a normal
MemberTies installation with a database on your computer) or you will not be able to connect.
These settings are only for remote database profiles to servers requiring special connection
parameters (such as our hosted database server).  These fields are not used for the normal user
name and password information you put on the Login window when  MemberTies  starts.

The "Show" button will display the password in plain text so you can see what you're typing.
For security reasons, if you accessed this window from the login window rather than from within
MemberTies, any existing password will be cleared first before the field is changed to plain text.
Otherwise, anyone could go to the login window, edit your profile, and see your password.

After entering advanced options, click OK to return to the Database Profile window.

Deleting a Database Profile

Deleting a database profile has NO EFFECT on the actual database or its current or backup directory. It
simply removes details in the database profile.  To physically delete the database follow the instructions
under Deleting a Database.  If you do not delete the physical database itself, a new empty profile will be
created for it the next time you log in, because MemberTies will see that a database exists.

1 Choose Tools > Preferences, expand the Database section, and choose Profiles.
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2 Select the database profile you want to delete, then click Delete.

27.5 Contacting Support

You are free to contact the support group at Myrro International for any reason. While this may seem
like a small benefit, remember that you are probably going to be reaching the person or persons who
programmed the software and wrote all the help directly -- not a low-level support person hired last week,
or worse, a marketing representative in a huge corporation. Your concerns or comments are always
important and you will receive a very prompt response.

Some common reasons to contact support are:

To suggest an enhancement or new feature (it's really nice to see your own suggestion appear in
the newest release!)

To request to be included in the next beta-testing program

To report an error in the documentation

To report a bug (a problem) in the software

To discuss the registration process

To discuss a customization for your organization

To discuss funding immediate development of a major new feature

Contacting Support

You may contact the support department at Myrro International at:

Myrro International
PO Box 2154
Frisco, TX 75034
U.S.A.

Email: support@myrro.com
Website: http://www.myrro.com/memberties
Voice: +1 972-816-1190 (Please note the time zone, Central Standard, GMT - 06:00)

Note: If believe you have discovered an error in the software, it is recommended that you send an email
to support@myrro.com  and include a complete explanation of the problem, the operating system you
are using, the version of MemberTies, and steps detailing what you were doing when the error occurred.
In most cases, when an error occurs a window will be displayed with important information that we can
use to diagnose the problem. That window provides an easy way to copy the information and send it to
us.
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28 Moving the Software

28.1 Moving the Software

Perhaps your term as membership director has expired and it's time to move the software to the next
person, or perhaps you've purchased a new PC and need to move MemberTies from the old machine to
the new one. How do you accomplish this?

The process is essentially, 1) Backup the database, 2) Install the Software, 3) Restore the database. 

Moving the Software

1 If you're going to be turning the software over to a new user, the first thing you should do is
create a new Username and Password for the new person to use. Otherwise, you'll have to give
them your username/password so they can login, which makes it harder to tell who made which
changes. To create a new user, login as the mtadmin user and go to Tools > Database Admin
Tools > Maintain Users. Create a new user with a simple password like "password". The next
person can login and change it to something more secure.

2 Backup the database (Tools > Database Tools > Backup Database). Take note of where the
backup file is saved.

3 Copy the backup file you just created and take it to the new machine.

4 Copy any additional files associated with your database and take them to the new machine.
These file may include photos or related files that are been saved on the computer (unless you
have the database "File and Photo Storage" preference set to save these in the database, they
will be moved automatically).

5 Now, on the new machine, install MemberTies either from your original install files, or by
downloading the current version. DO NOT simply copy all the files from one machine to the
other. You won't get all the libraries and registry entries that way, and the program will not run.

6 Start MemberTies and when the Welcome window appears, choose to Restore a database.

7 Restore the backup file you created earlier. 

8 Place any additional files copied earlier in their corresponding locations on the new machine.

Troubleshooting

If you restored the database, but when you log in you only see the "sample" record, you may have
restored the database to a different name.  Database backups can be set to only restore to the
original name. Go back to the Login window and see if there is another database listed in the
Database dropdown list. If the database is there, you can use the Server Utility to delete the
"empty" database that you don't need anymore.

If your license information won't work, make sure you installed the appropriate standard or
professional version. If you were using the pro version, and accidentally installed the standard
version, it won't recognize your license. Download the correct version and reinstall.  The
Professional version will show the word "Professional" on the Login window.
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If the version is right but the license still won't work, you may have installed a version that was
released after the "free update" period of your license expired. In this case, you'll need to renew
your license so it will be valid for new releases again. 

If you get Win32 errors, bad .dll errors, or other operating system messages, it normally means
you've copied program files instead of installing. You have to actually install the software for it to
work.  Either install from a current CD, or download the software from our website and run the
installation program.

If you have other problems, send an email to support@myrro.com and we'll do our best to help.
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29 Troubleshooting

29.1 Contacting Support

You are free to contact the support group at Myrro International for any reason. While this may seem
like a small benefit, remember that you are probably going to be reaching the person or persons who
programmed the software and wrote all the help directly -- not a low-level support person hired last week,
or worse, a marketing representative in a huge corporation. Your concerns or comments are always
important and you will receive a very prompt response.

Some common reasons to contact support are:

To suggest an enhancement or new feature (it's really nice to see your own suggestion appear in
the newest release!)

To request to be included in the next beta-testing program

To report an error in the documentation

To report a bug (a problem) in the software

To discuss the registration process

To discuss a customization for your organization

To discuss funding immediate development of a major new feature

Contacting Support

You may contact the support department at Myrro International at:

Myrro International
PO Box 2154
Frisco, TX 75034
U.S.A.

Email: support@myrro.com
Website: http://www.myrro.com/memberties
Voice: +1 972-816-1190 (Please note the time zone, Central Standard, GMT - 06:00)

Note: If believe you have discovered an error in the software, it is recommended that you send an email
to support@myrro.com  and include a complete explanation of the problem, the operating system you
are using, the version of MemberTies, and steps detailing what you were doing when the error occurred.
In most cases, when an error occurs a window will be displayed with important information that we can
use to diagnose the problem. That window provides an easy way to copy the information and send it to
us.

29.2 The Help/About Window

Almost every software package contains a "Help/About" window, and MemberTies is no exception.  This
is a simple window that displays general program and license information.  Information on this window is
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commonly requested by Support if you have a problem, because it helps in the recreation of the
problem.

Opening the Window

1 Open the Help menu, and choose "About MemberTies". This is normally the last entry on the
menu.

2 The "About MemberTies" window includes two tabpages, each containing different information:

Program Information - includes details about the program version number, when it was
created and released, the database version, and contact information for questions.

License Information - includes your license details, when the maintenance period expires,
how many users the license is valid for, and the name of the current user and database.

3 When you are finished, click OK to close the window.

29.3 The System Error Window

It happened -- you were working normally when suddenly an ugly window with a red box appeared. Now
what?

First, please understand that we do everything possible to try to catch problems (bugs) long before the
software is released.  But with tens of thousands of lines of code, hundreds of windows, and countless
ways of doing things, it's almost impossible to think of everything. Sooner or later somebody will perform
some series of actions we didn't think of, the software will get confused, and boom! There's the window.

Since we really do want to hear about any errors you find, we built a special window to show errors in a
format that makes it easy to send the information to us so we can act on it.

For example, we caused the following error to occur by shutting down the server while someone was still
logged in:
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The window is divided into two sections:

The top half is for you to use to provide details about what you were doing when the error
occurred.  The more information you can provide, the more helpful the error report will be.  At a
minimum, please at least tell us what window you were using, or what you just clicked or typed.

The bottom half includes information for our programmers to use to help diagnose the problem. (In
this example, you can see that the "server version" couldn't be displayed, because we caused the
error by shutting down the server.)

When you're ready to submit the error to us, just click "Copy". Then paste the information into an email
message and send it to support@myrro.com.

Thank you for your help!

29.4 Uninstalling MemberTies

You can uninstall MemberTies via the Control Panel >  Add/Remove Programs. However, before
uninstalling, there are a couple of things you might want to do, especially if you are transferring the
program to a new user.
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Uninstall Checklist

You might want to create a user name and password for the next person who will be using the
database. Remember, only valid users can add new users. See Working with Users for more
information.

You might want to change your personal password if it is something obvious and you won't be
using it anymore. See Changing Your Password for more information.

You might want to print a current roster of your membership for reference while the program is not
available. See Reports Overview for more information.

After you've made the above changes, make a current backup of the database, and just to be
safe, copy it somewhere completely outside the program directory.  The uninstall process
shouldn't delete the active database or any backup files, but you want to be certain your data is
safe. In other words, if you've been backing up data to c:\program
files\MemberTies\database\backup\, copy the database file to a directory like c:\myclub\.  See 
Backing Up the Database for more information.

Shutdown the Server. If the server is running, Windows won't be able to uninstall anything the
server is "touching."  Use the Server Utility to shut the server down and release all files.

 

 

29.5 Common Questions/Issues

29.5.1 Associating Saved Reports with the Report Viewer

If you have ever tried to open a saved report file (i.e., "myreport.psr") with a program other then the
Report Viewer http://www.myrro.com/viewer/ you may have accidentally created a permanent
association between .psr files and a program that can't use them, such as Notepad or Word.

From them on, when you want to view a .psr file, you have to open the Report Viewer first, and then open
the report file, instead of just double clicking the report file itself.

Here's how to reassociate the .psr file type with the Report Viewer for easy opening:

1 Go to Windows Explorer (via start menu, or double-click My Computer and open your c:/ drive)

2 Find a saved report file (something.psr)

3 Click the file ONCE to select it without opening it.

4 Hold down the SHIFT key, then right-click the file.

5 The popup menu will have an option called "Open With..." If you don't see the option, you didn't
have the SHIFT key held down when you right-clicked it.

6 The dialog that opens will list all the programs Windows knows about. Find the Report Viewer. If
the program isn't listed, you may have to click "Other" to browse for it. (This assumes it's
installed, of course. )
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7 After you select the program, be sure the "Always use this program to open this kind of file"
checkbox is selected before you click OK.

The report file should open in the Viewer, and from then on, those .psr files will be associated with the
report viewer.

See Saving PSR Reports for more information.

29.5.2 Can I put the database on a network drive?

Yes and no.  You should not move just the database. Instead, you should install a separate copy of
MemberTies on the networked computer, and place all the databases you use on that computer in the
normal location (see the Server and Database Overview for more information). 

Once installed, you can use the Server Utility to start the database. Then on each networked machine,
create a new database profile that points to the IP Address of the server machine. 

29.5.3 Can I use the same license for more than one database?

Yes. You can use a license for as many databases as you wish. However, if the databases are for
different organizations, you may want to consider separate licenses for each database so the
organization name will be correct for reports.

See Maintaining Database Profiles for instructions about applying a license to a database.

29.5.4 Do you accept credit cards for registration payment?

Yes. You can place a credit card order online via the MemberTies website at http://www.myrro.com/
memberties.

See How to Purchase for more information.

29.5.5 How do I handle dues payments that apply to more than one person?

If you have related members who make a single dues payment, there are several common practices:

Create a dues entry on each record and apply half of the payment to each.

Create a dues entry for the full amount on the "main" record (whichever record you consider to be
the head-of-household, perhaps), and a $0.00 entry on the other record that includes a comment
explaining the entry.

Create a dues entry for the full amount on both records. This is not recommended because it will
throw off the calculations on dues reports.
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29.5.6 How do I hide tabs I don't want to see?

By default, the member and group details windows display many tab pages of data.  The member details
in particular can include 10 different tab pages, including the General, Status, Private, Dues, Donations,
Items, Related, To Do, Custom, and Activities tabs.

Each tab that is loaded must be retrieved and translated, so if you do not need or want to see certain
tabs, turning them off can reduce the time it takes to open a record.

The membership or group tabs to display, and the order in which they appear, is controlled by a 
membership or group preference.

29.5.7 How do I select more than one row in a list?

MemberTies supports standard Windows multi-row selection using the CTRL and/or SHIFT keys and the
mouse.

Please see Selecting Rows in Lists for details.

29.5.8 How do I sort on a combined user report field?

When creating a user defined report, label, view, etc., you typically will want to use one of the combined 
smart fields that automatically display the full name, or "last name, first name", or that combines the
city, state, and ZIP code, etc.

That's great for display, but what if you want to sort on just one of the fields that are "part of" the
combined field you selected? How do you do it?

The answer is simple: use a hidden field!

For example, say you are using the combined field "City/State/Prov" for one line of a mailing label report,
but you want to sort the labels by State. Since the state isn't the first thing displayed in the field, you
can't just sort on this field (because that is effectively sorting by City).

To solve the problem, do the following after adding your normal fields:

1 Add the State/Prov field somewhere on the label.

2 Select that field and click Open.

3 Mark it as the Primary Sort.

4 Select the Hide Data checkbox.

5 Click OK.

The field will now appear in italics in the Selected Fields list, indicating that it is hidden.

Now you have an invisible field that is only used for sorting, leaving your display fields unchanged.

29.5.9 How do I track a Committee?

Group records work quite well for tracking committees and other "sub-groups" of your membership.
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Group records were originally intended for tracking other similar organizations to which your members
might belong. For example, if you run the Texas Widget Chapter, but some of your members also belong
to the Louisiana Widget Chapter, you could create a group record for Louisiana Widget Chapter and
relate the appropriate members to that.

Since you can assign members to group records, you can use them to group any number of members
without the need for custom fields or categories/items. If you need to track a group of some kind where
you just need to know which members are a part of it, you can create a Group record for the group and
relate members to it as necessary. You can even assign members to groups directly from the
Membership List (Actions > Assign Group).

Once assigned, you can easily query for group members of a particular group by using the standard
Search on the Membership List; just select the name of the group in the Group Name dropdown on the
Search tab (basic search).

You can also use the Group Name as criteria on most reports, so it's easy to run a listing of all the
group members, or mailing labels, or any other report.

Of course, if you need to track things like attendance and expenses for the committee, then an Activity
record makes more sense; but, in many cases a group record will do just fine.

29.5.10 Our licensed organization name changed!

If you change your organization name, contact support for a new license file keyed to the new name.
There is not normally a charge for this, but be aware that your current license will cease to function after
the new one is created.

29.5.11 The Member ID Column Sorts Incorrectly

See About Member IDs for additional information.

29.5.12 When should I use a Custom Field vs an Item?

To decide whether to track a piece of information in a custom field (on the Custom tab) or in an Item (on
the Items tab) of the membership record, you have to ask one question:

"Can a member be assigned this more than once?"

If the answer is yes, then you don't want to use a custom field, because a custom field only holds one
entry. Thus, the second time a member is assigned this "thing", you would have to use another field for
it, when it's really just an extension of the first.

For example, say you need to track the member's Driver License number. Typically, a person will only
have one of those, so that's a good candidate for a custom field (or possibly for the Member ID).

But if you want to track something like, "Donated Auction Items", "Offices Held", or "Degrees Earned", a
system of Categories and Items is much better.



Troubleshooting 526

©1998-2014 Myrro International

Take the example of Degrees Earned. If you create a category called "Degrees Earned", you can create
items under it for "PhD", "Doctorate", "Masters", "BS", "BA", "MBA", etc.

Then, if Suzy Smith earns her bachelor's, you can go to the Items tab on her record and create a record
for "BS" and even set the date and a comment (maybe the university name). Then when she gets her
Masters in business administration, you can go back to her record, go to the items tab, and enter
another record for "MBA" with the date and comment.

Since Suzy is going on to Law School, you know you'll be back to add another item. If you had used
Custom fields it would have been much more difficult.

Further, if you want to run a report and show everyone who has earned a masters degree, you can just
use criteria like:

Assigned Item = "MBA" 

29.5.13 Where do I find information about program updates?

Our website shows the current program version on the Download pages. See http://www.myrro.com/
memberties. 

Registered users are also automatically added to a mailing list that provides a notification of major new
updates and releases. 

You can also choose Tools > Check For Program Updates within MemberTies if you are connected to
the Internet.

29.5.14 Why do some members appear twice?

This situation normally only applies to MemberTies Professional. 

The most common reason a membership records appears more than once in the Results tab of the
Membership List is multiple addresses.  When you add more than one address on a membership
record, there is a field on the Search tab of the membership list that becomes important. The field is
called "Addresses," or "Address to Use", and it has options of "All Addresses", "Current Address", and
"Non-Current Addresses". This field determines what addresses will be included when records are
displayed.

Consider a record that has two addresses:

Home Address (marked as the current address)

Work Address

When you retrieve the membership list, the results will vary based on the setting in the Addresses field
on the Search tab as follows:

Addresses field = "Current Address"
One "row" will show in the list. If your list shows address info, the data for the Home address will
appear.

Addresses field = "All Addresses"
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Two rows will show in the list. One is the member record with home address info, the other is the
member record with work address info. There is still only one member, it just appears once for each
address regardless of whether there is address info on the list.

Addresses field = "Non-Current Addresses"
One row will show in the list. If the list shows address info, the data for the Work address will
appear.

So the short answer is simply to always set the Addresses field to "Current Address" when using the
multiple address capabilities, and you'll never see a membership record appear more than once. 

29.5.15 Why is the date format wrong?

The date is displayed according to the format specified in your Windows Control Panel. To check your
setting:

1 Click the Start button and choose Settings > Control Panel.

2 When the Control Panel opens, double-click the icon for Regional Settings.

3 Click the Date tab.

4 The format displayed for Short Date Style is used for date display. To display a four-digit year,
select a style that includes "yyyy" or "YYYY," indicating a four-digit year.

If the above settings appear to be correct, it could be that Windows has not entered the correct settings
in a place where MemberTies can find them. Follow these steps to force Windows to update the
appropriate settings in the Registry:

1 Click the Start button and choose Settings > Control Panel.

2 When the Control Panel opens, double-click the icon for Regional Settings.

3 Click the Date tab.

4 Change the date format to something you do not want.

5 Save

6 Return to the Control Panel, Regional Settings, Date tab, and change the date format to the
setting you want to use.

7 Save

Note: This setting only affects the way dates are displayed in MemberTies. Dates have always been,
and continue to be, stored in the database using a four digit year. The database is fully Y2K compliant.
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Index
- ( -
(delete) status     258, 304, 357

- . -
.psr file     436

- ~ -
~r~n     70, 73, 213, 297, 300, 451

- < -
<     377, 404, 460

<=     377, 404, 460

<>     377, 404, 460

<HTML>     174, 202, 286, 315

- = -
=     377, 404, 460

=CLEAR     52

- > -
>     377, 404, 460

>=     377, 404, 460

- 2 -
24 hr clock     359

- A -
-a command line switch     38

absent from activity reporting     61

action     167, 254

active     272

active connections     35, 498

active membership roster     435

active reports     361

active statuses     258

activities     61, 62, 67, 75, 80, 85, 86, 88, 94, 148,
238, 239, 347

activity expenses     82

activity income     82

expenses     167, 254

income     167, 254

activities by member report     418

activities tab     304

activity     52, 61, 88, 283

activity attendance     283

activity attendance by group report     418

activity attendance status     240

activity attendance totals report     418

activity attendee search     471

activity balance     347

activity balance report     418

activity by attendeereport     419

activity by group report     419

activity by sponsor report     419

activity capacity     75

activity check-in not foundreport     420

activity counts by date report     419

activity counts by date/time report     419

activity detail (w/absentees) report     419

activity detail report     419

activity expenses     75, 80, 86, 148

activity front deak preferences     351

activity guests     80

activity hours by attendeereport     420

activity income     75, 80, 86, 148

activity limit by status     75

activity list     61, 64, 67, 75, 209, 293, 356

activity list report     420

activity overbooking     75

activity postings     354

activity role     80, 88, 238

activity selection message     94

activity sponsorship counts report     420

activity summary report     420

activity totals by type     420

activity type     239

activity type by attendee     420

add current resident     361

add icon     43

add members to a group     282

add members to an activity     283
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add members to multiple activities     283

add multiple members to multiple activities     283

additional address     220, 311

additional addresses     52

additional users     100

address     210, 223, 268, 294, 356, 361

active     220, 311

address line 4     359

address lines     359

address name     220, 223, 311, 324, 359

address name (default)     359

address names (predefined)     239

date range     220, 223, 311

first address name     359

format     361, 394, 403

format (report default)     361

line names     223, 324

non-current     220, 311

address to use     377, 404, 415, 460, 473

addresses     220, 239, 245, 246, 257, 311, 526

adjusted     412, 468

adjusting report margins     394

administrator     37, 41, 489, 492, 501

administrator user     488

advanced database profile settings     127, 508

advanced search     64, 195, 197, 277, 415, 460, 469,
473

advanced searches     415, 473

affiliation     428

age     327

automatic status change     258

Age (smart field)     452

alignment     70, 73, 213, 297, 300, 396, 451

all addresses     220, 311

allow activity selection     94

allow checkin     351

allow dues entries     351

alt mail name     324, 452

alumni status     323

amount     80, 82, 88, 153, 157, 160, 163, 165, 225,
330, 334, 347

analyze table     111, 142

anniversary     327

anniversary list report     421

antivirus software     22, 37, 98, 135

any     377, 404, 460

any posting criteria     429, 430, 431, 432, 433

application     22, 98, 135

application fee     170, 354

application security     494, 497

apply selected view on close     68, 212, 296

apply to     165

arial     361

assigned items     52

assigned items report     421

assigning items     337

assigning members to groups     230, 339

associated    

files     339

groups     339

members     339

associated activities     347

associated members     52, 75

associated to     82

associating members to activities     80

association types     240, 339

asterisks     492

attachment     174, 202, 286, 315

attendance     52, 61, 75, 80, 240, 347

attendance limit (overall)     258

attendance limit (per activity)     77

attendance sponsor     80, 88

attendance status     80, 88, 240

attendee     61

attendee synopsis     351

authentication method     183

auto-login     35, 38, 352

automatic     153, 330

backup prompt     118

delete of (delete) status members     357

dues posting     153, 165, 330

group relationship creation     218

group selection     219, 399

interest posting     153, 258, 330

logoff     357

posting dues     258

posting for new records     258

posting on End Date     258

posting on Start Date     258

report criteria     377, 404

server startup     139

status changes     258

automatic check-in options     77

automatic postings by status     77

automatic reports     77

auto-relate group     218, 224
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available to     167, 254

average of column     73, 300, 451

average row length     111, 142

- B -
background color     70, 73, 213, 297, 300, 451

backup     516

automatica backup prompt     118

backing up the database     118

backup prompt     352

manual     352

restoring a backup     119

timeout     352

balance adj     167, 254

balance forward     424, 425, 432

balancing accounts to zero     163

bank card     169, 247

bank phone     169

barcode     88, 94

bar-coded member id card     455

barcodes     455

basic search     64, 195, 197, 277

billing address     220, 311

Birth Day     452

Birth Day/Month     452

Birth Month     452

Birth Month/Day     452

Birth Year     452

birthdate     327

Birthdate (smart field)     452

birthday list  (+family) report     421

birthday list report     421

blank lines     375

bold     70, 73, 213, 297, 300, 451

bottom margin     396

brief description     85

brother     240

browse for file icon     43

bugs     514, 519

building criteria     377, 404, 460

bullets and numbering     373

business card     439

- C -
calendar     46

calendar icon     43

cancel prompt     359

capacity     75

card format     361

card reports     443

card type     169

cards     439

carriage-return     201, 281, 307

case-sensitivity     27, 492

categories     228, 241, 337, 421, 525

category rank     421

centering     396

change data (bulk)     308

change password     492

change password icon     43

change to (delete) status     304, 357

changing dropdowns     235

check addresses at login     356

check table     111, 142, 488

check time (table)     111, 142

checkbox criteria     410, 466

checked in     67

checked out     67

check-in     77, 88, 94, 347

checking data     114

check-out     77, 88, 94, 347

cheque     80, 82, 88, 153, 157, 160, 163, 225, 330,
334, 347

children     342

choose random members     285

choosing a preview display     198, 278

city     223, 245, 324

clear     408, 458, 465

clear dues entries     357

cleared     377, 404, 460

clearing a database     121

clearing a field globally     308

clearing all flag settings     116

clearing all print receipt settings     116

clearing dues entries     357

clearing record locks     500

codes     241, 253, 257

activity roles     238

activity types     239

address names     239

association types     240

attendance status     240

category     241
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codes     241, 253, 257

city     245

country     246

county     246

credit card names     247

group types     245

item     241

location types     252

locations     251

payment method     253

phone types     253

posting types     167, 254

references     257

relationship types     240

states/provinces     257

status codes     258

colors     359

column    

order     70, 213, 297

spacing     396

width     70, 213, 297, 396

columnar reports     439

combining    

dropdown values     235

list values     235

comma-delimited     52

command files     501

command line     139

command line switches     38

comments     80, 82, 88, 153, 157, 160, 163, 169,
183, 225, 228, 265, 330, 334, 337, 347, 436

committees     524

compact membership list 2 report     422

compact membership list report     422

company name     452

complete     231, 345, 484

completed by     345

completed date     345

completed todo     231, 345

completing todo list items     484

complex search expressions     415, 458, 460, 473

concatenated name fields     452

confidential data     329

confirm password     489, 492

connect remotely     104

contact information     210, 294, 505

contact list (+family) report     422

contact list report     422

contacting support     514, 519

contains     458

control email address     174, 202, 286, 315

controlling actions     494

converting an old database     52

copy icon     43

copying a database     102

counties     246

country     223, 246, 324

country display     361

county     223, 324

couple    

default status     323

relationships     327, 339

status     327

CRAM-MD5 email authentication     183

create time (table)     111, 142

creating    

new database     100

reports     439, 443

users     100, 489

views     67, 211, 295

credit card     153, 157, 160, 169, 225, 247, 330, 334,
422, 523

credit cards on file report     422

number     169

credit card icon     43

criteria     247, 377, 394, 404, 407, 408, 410, 460, 464,
465, 466

crosstab     433

CTRL key     47

current    

address     220, 311, 356, 394, 428

attendance     67

date     412, 468

month     412, 468

password     492

quarter     412, 468

year     412, 468

current resident     361

custom field label     247

custom fields     88, 233, 247, 346, 525

custom prorate amount     170

custom reports     400, 401

custom roster     435

custom tab     217, 233, 304

custom tools menu option     359

customer support     514, 519
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customizing     235

CVC2     169

CVV2     169

- D -
-d command line switch     38

daily dues prorating     258

data free     111, 142

data integrity     114

data length     111, 142

data type     247

database     22, 26, 48, 52, 98, 100, 114, 115, 118,
119, 124, 127, 135, 352, 489, 506, 508

hosting     102

IP address     104

port     104

remote     102, 104

database access     489

database fields     174, 181, 202, 286, 315

database folder     104

database location     127, 508

database name     104

database preferences     352

database profiles     127, 352, 361, 508, 523

advanced     127, 508

exporting     126

importing     126

server login     127, 508

date     80, 228, 337, 347

date conversion - custom fields     247

date criteria     410, 412, 466, 468

date established     224

date format     527

date posted     82, 153, 157, 163, 165, 225, 330

date range     223

date/time     88

dates     527

and new attendance entries     75

dblist.dat file     127, 508

dd/mm/yyyy     527

debit card     169, 247

debit/credit action     354

default    

activity type     239

address format     361

administrator password     488, 492

city     245

country     246

county     246

database     100

end date     357

group for reports     219, 224, 399

item date     359

posting type     167, 254

profile     183

report margins     396

role     238

sex     357

start date     357

state/province     257

statuses     323

values     257

default logo     361

default value     247

define fields     443

delete action     304, 357

delete file icon     43

delete icon     43

delete immediately     304, 357

delete prompt     357

delete report definition     400

deleting    

a database     145

activity postings     165

all data     121

donations postings     165

dues postings     165

files     85

group postings     165

members     304, 357

multiple postings     165

records (reclaiming table space)     111, 142

users     489

delimiter     52, 201, 281, 307

deposit     86, 148

deposit detail     423

deposit detail report     423

description     75, 80, 82, 88, 231, 345, 347, 484

dial phone     223

dial phone icon     43

direct match     52

directory     443

directory listing report     423

directory reports     439

disable preview     209, 293
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disconnect selected user     498

display additional (4th) address line     359

display contact info     210, 294

display now     394

distinguished status     323

dividing the view     64, 198, 278

do not prorate     170

document    

criteria     377, 404

settings     377, 404

documents     368, 369, 371, 373, 375, 380, 383, 384,
387, 388

adding     366

bullets & numbering     366

bullets and numbering     366

copying     366

deleting     366

embedded database fields     366

find/replace     366

font/character formatting     366

font/character styles     366

images     366

multi-column layouts     366

page headers/footers     366

paragraph formatting     366

paragraph styles     366

renaming     366

section formatting     366

tables     366

donation date     160, 334

donation postings     354

donation summary     423

donation summary report     423

donations     52, 86, 148, 167, 253, 254, 268, 423

by date report     423

by member report     423

entering     160, 334

posting types     167, 254

private comments     160, 334

receipt report     423, 425

donations print receipt criteria     423, 425

donations tab     304

draft     398

driver license     304, 314, 357, 458

dropdown     167, 235, 238, 239, 240, 241, 245, 246,
247, 251, 252, 253, 254, 257, 258

dropdown criteria     410, 466

dropped status     323

dropping a database     145

due date     231, 345, 484

dues     52, 86, 148, 169, 170, 253, 258, 268, 357,
424, 425, 523

account statement report     424, 425

balance forward     424, 425

balance report     425

calculator     153, 170, 258, 330

end date change     153, 330

entering     153, 157, 165, 225, 330

group     157, 225

posting (multi)     163, 165

posting types     167, 254

postings - statement     424, 425

postings report     425

private comments     153, 157, 225, 330

prorating     258

receipt report     423, 425

remittance advice     424, 425

schedule report     425

standings report     426

statement text     424, 425

dues calculator icon     43

dues overview     151

dues postings     354

dues print receipt criteria     423, 425

dues tab     304

duplexing     398

duplicate members     526

duplicate results in reports     403

duplicates    

merging list values     235

removing from lists     235

- E -
edit icon     43

effective date     170

effective month     170

email     174, 183, 188, 189, 202, 210, 223, 286, 294,
315, 324, 435

control address     174, 202, 286, 315

custom field     247

database fields     181

display     193

email address     188

email attachments     174, 202, 286, 315

email list     201, 281, 307
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email     174, 183, 188, 189, 202, 210, 223, 286, 294,
315, 324, 435

email log     191

email profile     174, 183, 202, 286, 315

emailing reports     394

formatting     193

global signature     361

gmail profile example     187

hotmail profile example     187

HTML     174, 202, 286, 315

links (inserting)     174, 202, 286, 315

loading HTML file     180

loading messages     174, 180, 202, 286, 315

log     174, 202, 286, 315

max recipients     174, 202, 286, 315

POP3 server     174, 202, 286, 315

priority     174, 202, 286, 315

problems     191, 193

return receipt     174, 202, 286, 315

searching sent mail     174, 202, 286, 315

sending     174, 181, 202, 286, 315

sent mail     174, 202, 286, 315

signature     183

SMTP server     174, 202, 286, 315

strange characters     193

testing connection     183

troubleshooting     191, 193

email formatting issues     193

email icon     43

email log     191, 193

email signature     183

global     361

embedded database fields     375

enable log     174, 202, 286, 315

enable preview     209, 293

end date     61, 75, 80, 153, 230, 268, 327, 330, 347,
357, 361

automatic dues posting     258

automatic status change     258

dues changing     354

validation     351

end time     61, 75

ends with     458

enhancements     514, 519

enter criteria value     377, 404, 460

entry type     163

equal     408, 465

error window     520

ESMTP     174, 202, 286, 315

event log     115

excel (importing from)     52

exempt from attendance max     75, 77, 258

existing database     26

exit prompt     357

expense     88, 347

expiration date     169

expired membership roster     435

export report     427

exporting     74, 115, 216, 302

exporting criteria     413, 470

exporting database profiles     126

exporting user-defined reports and views     303, 454

expressions     415, 458, 460, 473

extra label information     361

- F -
family     240, 339, 342

photo     271, 309

features     14

fee proration     170

field     407, 464

field name     377, 404, 460

field properties     73, 300, 451

field style     247

file locations     22, 98, 135

database files     22, 98, 135

program files     22, 98, 135

saved files     22, 98, 135

Windows Vista     22, 98, 135

Windows XP and earlier     22, 98, 135

file storage     352

find/replace     368

firewall software     37

first name     357

fiscal year     170, 361

flag     116, 324, 357

font color     70, 73, 213, 297, 300, 451

font face     70, 73, 213, 297, 300, 451

font settings     361

font size     70, 73, 213, 297, 300, 451

font/character formatting     371

fonts     361, 394

foreign addresses     361

forum     43

freeform text     452
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friends     342

photo     271, 309

friends and family     52

from address     183

from date     322

front desk     77, 88, 94, 247, 351

full name     452

- G -
general tab     217, 223, 304

generating IDs     272

getting started     12, 41

gmail email profile example     187

greater than     408, 458, 465

greater than or equal to     408, 458, 465

gregorian to hebrew date conversion     46

group     282

group list     67, 163, 165, 195, 197, 198, 201, 209,
211, 217, 218, 219, 281, 293, 295, 307, 356, 399

group list report     421

group members     230

group membership report     422

group name     361, 525

group preferences     355

group roster     435

group summary report     436

group types     245

groups     86, 148, 169, 195, 223, 233, 245, 483, 484,
524

adding     217

addresses     220, 311

auto-relate group     218

changing     217

custom tab     233, 247

default group     219, 399

deleting     217

dues tab     157, 167, 225, 254

email list     201, 281, 307

general tab     223, 239, 245, 246, 257

hiding tab pages     524

items tab     228, 241

members tab     230

name for     361

opening via To Do list     484

status tab     224

todo tab     231

guests     80

- H -
head of household     327

hebrew date     46

help     43

help/about window     519

helvetica     361

hidden sort column     70, 73, 213, 297, 300, 451

hide data     70, 73, 213, 297, 300, 451

hide default country     361

hiding unused tab pages     524

history of status changes     435

honorary status     323

host     104

hosted database    

server login settings     127, 508

hotmail email profile example     187

housekeeping     352

how to register/purchase     504, 505

HTML     174, 202, 286, 315

html email     174, 202, 286, 315

husband     240, 339

- I -
images     383

import map file     52

importing     52, 247

importing criteria     413, 470

importing database profiles     126

importing IDs     272

importing user-defined reports and views     303, 454

inactive items     241

inactive membership roster     435

inactive status     258, 357

inactive statuse     357

include future todo items     483

include in mailings     224, 258, 327, 357, 361, 377,
404

include on reports     258, 327, 361, 377, 404

income     88, 347

income/expense     75, 77, 88, 347

index length     111, 142

individual summary report     436

information icon     43

install     26, 31, 33
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installation files     22, 98, 135

interest     167, 254

interest settings     258, 436

invalid email address removal     188

invoice     424, 425

ip address     104

issuing bank     169

italic     70, 73, 213, 297, 300, 451

item     359

item rank     421

items     228, 241, 268, 337, 421, 525

items tab     217, 228, 304

- J -
joint members     327, 339

- K -
KB size limit for stored files     352

kiosk     357

- L -
label font face & height     361

label reports     443

labels     361, 403, 426, 439

LAN     104, 110, 141

languages     36

last month     412, 468

last quarter     412, 468

last year     412, 468

leap year     357

leave of absence status     323

left margin     396

left to right     396

less than     408, 458, 465

less than or equal to     408, 458, 465

liability waiver report     426

license     48, 124, 361, 498, 505, 506, 523

applying to database     127, 508

code     48, 124, 127, 506, 508

expiration     48, 124, 506

information     505, 519

licensee name     48, 124, 127, 506, 508

life of a license     48, 124, 506

registering     48, 124, 504, 506

status     505

update/renewal prompt     356

using     127, 508

like     377, 404, 408, 458, 460, 465

limit synopsis     351

limit to currently selected records     165

limiting email volume    

max recipients     174, 202, 286, 315

per connection     174, 202, 286, 315

per minute     174, 202, 286, 315

list colors     359

list refresh style     359

list type     483

lists     235

combining     235

merging     235

removing duplicates     235

selecting rows     47

live scrolling     359

llabels     377, 404

loading    

email messages     174, 180, 202, 286, 315

HTML file     180

saved report criteria     413

saved search criteria     469

local database     127, 508

localhost     488

location types     80, 251, 252, 347

locations     61, 75, 251, 252

locked by     500

locked on     500

log     115

logging on     26, 48, 124, 127, 506, 508

login     27, 31, 33, 35, 37, 352, 498

existing database     33

login window     12

new upgrade     31

new user     27

normal     35

problems     37

reinstall     31

restoring a backup     31

LOGIN email authentication     183

login preferences     356

logo     361, 394, 426, 428

logoff     357

logoff preferences     357

lowercase     70, 73, 213, 297, 300, 451
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- M -
magnetic strip     304, 314

magnetic stripe     458

magnetic stripe scan     357

mailing label reports     443

mailing labels     361, 377, 403, 404, 439

mailing labels report     426

mailing list flag     327

maintain tables     111, 137, 142

maintenance prompt     352

manual amount     163

manual backup     352

manual entry     163

many to one     337

map fields     52

map file     52

margin settings     394, 396, 400

mass data change     308, 501

max amount     167, 254

max data length     111, 142

max recipients     174, 202, 286, 315

maximum for posting type     163

MD5 email authentication     183

member ID     88, 94, 269, 272, 324, 357

member ID (column sort order)     357

member ID (prefix)     357

member ID (preloaded)     357

member ID column sort     525

member ID prefix     357

member ID sorting     278

member todo's     345

members     80, 86, 148, 169, 268, 269, 272, 275,
308, 483, 484

activities tab     347

adding     304

adding from driver license     304

addresses     220, 311

associated tab     240, 339

changing     304

children     342

custom tab     247, 346

deleting     304

donations tab     160, 167, 254, 334

dues calculator     170

dues tab     153, 167, 247, 254, 330

email list     201, 281, 307

friends/family tab     342

general tab     239, 245, 246, 253, 257, 324

hiding tab pages     524

items tab     241, 337

opening via To Do list     484

photo     271, 309

private tab     257, 329

spouse     342

status history     327

status tab     252, 257, 258, 327

todo tab     345

members tab     217, 230

membership by country report     426

membership card     88, 439

membership cards report     426, 428

membership data export     427

membership fee     170

membership history report     427

membership list     67, 163, 165, 201, 209, 211, 268,
277, 278, 281, 282, 283, 285, 293, 295, 307, 308, 356

membership preferences     357

membership statistics report     427

membership status report     428

membership statuses     323

MemberTalk Forum     43

merging    

dropdown values     235

list values     235

message limit     174, 202, 286, 315

message of the day     356

microsoft network services     183

middle name     324

min amount     167, 254

minimum for posting type     163

miscellaneous preferences     359

mm/dd/yyyy     527

modem     104, 223, 324

month to date     412, 468

monthly dues prorating     258

MOTD     356

moving a database     102

moving the software     516

MSN email authentication     183

mtadmin     488, 489, 492

mtdfdb     100

mtie.db     52

multiple addresses     64, 197, 220, 277, 311, 394,
526
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multiple check-in warning     351

multiple databases     48, 124, 127, 506, 508

multiple group affiliation report     428

multiple licenses     127, 508, 523

multiple messages     174, 202, 286, 315

multiple row selection     47

multiple users     104

multi-user     104

- N -
name     70, 73, 75, 213, 268, 297, 300, 451

name & ID list report     428

Name (Company | Full - First/Last) smart field     452

Name (Company | Full - Last/First) smart field     452

Name (First/Last Name) smart field     452

Name (First/Last/Suf) smart field     452

Name (Full First/Last | Company) smart field     452

Name (Full Last/First | Company) smart field     452

Name (Last/First Name) smart field     452

Name (Last/Pre/First/Suf) smart field     452

Name (Pre/First/Last/Suf) smart field     452

name fields     452

name on card     169

naming addresses     220, 311

negative numbers in red     354

network     104, 110, 141

network drives     523

new    

database     100

group     356

member     356

password     492

user     26, 27

new record dues posting     258

news     478

newsletter status     323

no date     412, 468

non-current addresses     220, 311

non-members     342

normal users     488

not equal     408, 465

not found log     94

not like     377, 404, 408, 458, 460, 465

not rlike     408, 458, 465

notifications     478

NTLM email authentication     183

number of copies     398

numeric ID preference     357, 428

numeric IDs     278

- O -
occupations     252, 327

old    

database     52

online help     43

open file icon     43

open member icon     43

open todo     231, 345

open url     223

open URL icon     43

opening window     356

operator     377, 404, 408, 460, 465

optimize table     111, 142

organization name     361

font height     361

organization preferences     361

other options     398

other organizations     195

output     201, 281, 307

overbooking     75

overview     22, 98, 135

file locations     22, 98, 135

professional version     18

program     14

saved files     22, 98, 135

server & database     22, 98, 135

system     22, 98, 135

- P -
-p command line switch     38

page settings     369

pages to include     398

paper sizes     361

paper source     398

paragraph formatting     371

paragraph styles     388

parenthesis     377, 404, 460

password     27, 183, 351, 352, 488, 489, 492

payment     167, 254

payment method     253

phone     223, 324

phone dialing     223, 324
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phone list     210, 294

phone list report     428

phone type     253, 324

photo     88, 271, 309, 324

photo directory     423

photo icon     43

photo ID card     439

photo ID card report     271, 309, 426, 428

pick list criteria     410, 466

pick lists     235

ping     104

PLAIN email authentication     183

POP3     174, 202, 286, 315

authentication     183

port address     183

Server     183

SSL     183

testing connection     183

popup calendar     46

port     104, 183

posting     82, 153, 160, 163, 165, 330, 334, 354

activity automatic     77

activity expenses     82

activity income     82

activity income/expense     354

automatic dues     153, 165, 330

deleting multiple     165

donations     160, 334, 354

dues     153, 157, 165, 225, 330, 354

dues (multi)     163

financial preferences     354

group     157, 225

interest     153, 330

types     82, 153, 157, 160, 163, 167, 225, 254,
330, 334, 354

posting (any) criteria     429, 430, 431, 432, 433

posting by date report     429

posting by month report     430

posting by payment method report     429

posting by source report     430

posting by type report     431

postings     253

postings - listing report     431

postings - statement report     432

postings - totals by year     432

postings - totals by year and month     433

postings - type grid     433

posttext     70, 73, 213, 297, 300, 451

pre-defined text     265

preferences     127, 350, 351, 352, 355, 356, 357, 359,
361, 508

prefix     324, 357

preloaded member IDs     269, 357

requiring for new records     272

pretext     70, 73, 213, 297, 300, 451

preview     64, 174, 198, 202, 209, 278, 286, 293, 315,
394, 443

preview mode     394

pricing     504

primary sort     70, 73, 213, 297

print     398

print pattern     396

print quality     398

print range     398

print receipt     82, 116, 153, 157, 160, 163, 225, 330,
334, 423, 425

print setup     398

printer     398

printer settings     394, 396, 400

printing     198, 278, 380, 394, 398, 400, 418, 419,
420, 421, 422, 423, 424, 425, 426, 427, 428, 429, 430,
431, 432, 433, 434, 435, 436, 478, 486, 494

printing order (labels)     396

printing the todo list     436, 486

priority     174, 202, 286, 315

private data     329

private field     329

private field labels     257, 329

private tab     304

problems     514, 519

professional version features     18

profile     127, 174, 202, 286, 315, 508

profile name    

database     127, 508

email     183

profiles    

database     352

email     183

program information     519

program updates     526

prompt    

before deleting     357

on exit     357

todo     231, 345, 484

when cancelling with unsaved changes]     359

prorating dues     170, 258

by day     170
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prorating dues     170, 258

by month     170

prospect status     323

provinces     257

psr files     436

pulldowns     235

- Q -
quarter to date     412, 468

query     377, 403, 404

quick search window     471

- R -
random members     285

read-only files     33

receipt     434

printing     82, 153, 157, 160, 163, 225, 330, 334

receipt book     82, 153, 157, 160, 225, 330, 334

receipt book number     354

receipt listing report     434

receipt number     82, 153, 157, 160, 167, 225, 254,
330, 334

receipt number (generating for old entries)     167, 254

receipt number (resetting)     354

receipt tag line     361

recipient     174, 202, 286, 315

reclaiming empty table space     111, 142

record lock     500

record status     165

recovery     118, 119

recycle preloaded IDs     357

references     257, 327

refresh display     64, 137, 198, 217, 278, 478

refresh style    

complete     359

targeted     359

registering     48, 124, 361, 504, 505, 506

registration    

see license     127, 508

regular status     323

reinstall     26, 31, 33

related    

end date     230

files     75, 85

groups     218, 428

income     347

members     268

members to groups     218, 230

members to members     327, 523

start date     230

related group search     471

related groups     52

related member search     471

related members     52

related members contact report     434

related members report     434

related tab     304

relationship required     258

relative date criteria     412, 468

reloading    

saved report criteria     413

saved search criteria     469

reloading sent mail     189

reminder     484

remittance advice     424, 425

remote database     104, 118, 119, 352

advanced profile settings     127, 508

remote profile     127, 508

remove database     137, 145

removing an email address     188

removing record locks     500

removing users     489

renaming custom fields     233

renaming views     67, 68, 211, 212, 295, 296

repair table     111, 142, 488

reply-to address     183

report     361, 443

address format     394

alt name preference     361

criteria     377, 394, 403, 404

default group     219, 224, 399

duplicate results     403

font face & height preference     361

fonts     394

logo     361, 394

margins     394, 396, 400

preferences     361

printing     394

snapshots     436

troubleshooting     401

viewer     436

report as attendee     240

report criteria     410, 413, 466, 470
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report type selection     443

reporting problems     514, 519

reports     219, 303, 356, 361, 394, 396, 398, 399,
400, 401, 418, 420, 421, 422, 423, 424, 425, 426, 427,
428, 434, 435, 436, 437, 439, 454, 486, 524

activiity hours by attendee     420

activities by member     418

activity attendance by group     418

activity attendance totals     418

activity balance     418

activity by attendee     419

activity by group     419

activity by sponsor     419

activity check-in not found     420

activity counts by date     419

activity counts by date/time     419

activity detail     419

activity detail (w/absentees)     419

activity list     420

activity sponsorship counts     420

activity summary     420

activity totals by type     420

activity type by attendee     420

anniversary list     421

assigned items     421

birthday list     421

birthday list (+family)     421

compact membership list     422

compact membership list  2     422

contact list     422

contact list (+family)     422

credit cards on file     422

custom     401

deleting     400

deposit detail     423

directory listing     423

donation summary     423

donations receipt     423, 425

dues account statement     424, 425

dues balance     425

dues postings     425

dues receipt     423, 425

dues schedule     425

dues standings     426

duplicate data     440

general settings     403

group list     421

group membership     422

group summary     436

individual summary     436

liability waiver     426

Logo     426, 428

mailing labels     426

Membership by Country     426

Membership Card     426, 428

membership data export     427

membership history     427

membership statistics     427

membership status     428

multiple group affiliation     428

name & ID list     428

phone list     428

Photo ID Card (Family)     426, 428

Photo ID Card (Members)     426, 428

postings - listing     431

postings - statement     424, 425, 432

postings - totals by year     432

postings - totals by year and month     433

postings - type grid     433

postings by date     429

postings by month     430

postings by payment method     429

postings by source     430

postings by type     431

receipt listing     434

related members     434

related members (contact)     434

report criteria     377, 404

required criteria     377, 404

retention     434

return address labels     435

rosters     435

saving     401

sent mail by member     435

status change history     435

status codes     435

status codes complete     436

stored comments     436

todo list     436, 486

require numeric member ID     357

effect of changing     278

reset end date on expire     357

resetting a database     121

restore     27, 516

backing up the database     118

restoring a backup     119
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restore     27, 516

timeout     352

results     62

retention report     434

return address     361

return address labels report     435

return receipt (email)     174, 202, 286, 315

reusing IDs     357

right margin     396

rlike     408, 458, 465

role     80, 88, 347

roles     238

root database directory     137

root server directory     137

roster header     443

roster report     435

roster reports     439, 443

router     104

routine maintenance     111, 142

row divider line     443

row selection     47

row spacing     396

- S -
sample advanced searches     415, 460, 473

sample criteria     377, 404, 460

sample statuses     323

save as     74, 216, 302

save icon     43

save report definition     401

saved report     394, 437

saved search criteria     413, 470

saving     436, 437

criteria     413, 470

email messages     174, 202, 286, 315

report criteria     413

search criteria     64, 197, 277, 469

scan     88, 94

scanning     304, 314

scheduled dues postings     258, 436

scrolling     359

search icon     43

searching     62, 64, 197, 198, 277, 278, 415, 458,
460, 469, 473

searching for sent mail     189

searching sent mail     174, 202, 286, 315

seats     498

secondary address     220, 311

secondary sort     70, 73, 213, 297

secure password authentication     183

security     357, 492, 494, 497

selected     377, 404, 460

selecting rows     47

sending email     174, 181, 189, 202, 286, 315

sent mail     223, 324

searching     174, 189, 202, 286, 315

sent mail by member report     435

sent mail list icon     43

seperator     201, 281, 307

sequential IDs     269, 272

server     22, 98, 110, 135, 141, 489

server engine     137

server host     104

server IP address     137

server login    

hosted database     127, 508

password     127, 508

username     127, 508

server port     137

server utility     111, 137, 139, 142, 145

set flag on new     327, 357

set new dates (when posting dues)     163

setup     41

sex (default)     357

shareware     504

SHIFT key     47

shifting report text     396

shortcut     38

show active users     498

show by category     228, 337

show by posting type     153, 157, 160, 225, 330, 334

show tip of the day     356

show todo list     356, 483

show welcome help     12

simplex     398

single message     174, 202, 286, 315

sister     240

smart fields     452

smart mode     94

SMTP     174, 202, 286, 315

authentication     183

port address     183

Server     183

SSL     183

testing connection     183
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snapshot settings     478

snapshots     356, 478

sort     70, 73, 213, 297, 300, 440, 451

sort settings     359, 403

sorting     64, 198, 278, 524, 525

sorting by member ID     278

sorting views     70, 213, 297

special expressions     377, 404, 460

split match     52

sponsor     80, 88

spouse     240, 339, 342

SQL script files     501

SSL    

email     183

POP3     183

port     183

SMTP     183

StartTLS     183

testing connection     183

start date     61, 75, 80, 153, 230, 268, 327, 330, 347,
357

automatic dues posting     258

start server     137

start server automatically     139

start time     61, 75

starting field     357

starting over     100

starts with     458

StartTLS     183

startup window sequence     356

state/province     223, 257, 324

statistics     427

status (activity)     80, 88, 240, 347

status change history     322, 327, 427

status change history report     435

status changes (automatic)     258

status codes     153, 163, 165, 170, 224, 258, 268,
322, 327, 330, 427, 428

status codes report     435, 436

status criteria     410, 466

status history     327

status tab     217, 224, 304, 324

statuses     323, 435, 436

stop server     137

stored comment icon     43

stored comments     265

stored comments report     436

strange characters in email     193

style     70, 73, 213, 297, 300, 451

suffix     324

suggest new end date     354

support     43, 504, 514, 519

synchronize     272

sys info file     137

system preference     350

- T -
tab order     355, 357

tab-delimited     52

table description/comment     111, 142

table maintenance     111, 142, 352

table name     111, 142

table optimization     111, 142

tables     384

tabpages, hiding     524

tag line    

receipts     361

reports     361

telephone     223

terminator key     94

testing data     114

text frame     387

time format     359

timeout     352, 357

timeout period     357

times new roman     361

tip of the day     47, 356

title     327

to date     322

todo list     231, 345, 356, 483, 484

todo list report     436, 486

todo status     483

todo tab     217, 231, 304

too many connections     35, 498

toolbar buttons     44

tools menu options     359

top margin     396

top to bottom     396

total of column     73, 300, 451

total records line (reports)     361

translation     36

troubleshooting     401

types     239
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- U -
-u command line switch     38

unattended check-in     88, 94

unattended check-in not found log     94

unattended check-out     94

unattended mode password     351

underlined     70, 73, 213, 297, 300, 451

uninstalling     521

unlisted flag     327

unprintable area     396

update end date to     153, 330

update record     153, 330

update start date to     153, 330

update time (table)     111, 142

updates     526

upgrading     26, 31, 33, 48, 124, 506

uppercase     70, 73, 213, 297, 300, 451

use alt name     361

use status on the membership record     163

used     272

user accounts     489

user actions     494

user locations     488

user name     27, 352, 489

user preference     350

user reports     247, 443, 524

grouping     440

hiding duplicate data     440

sorting     440

suppressing repeating values     440

user security     494

user-defined cards     247, 303, 439, 454

user-defined labels     247, 303, 439, 454

user-defined reports     247, 303, 439, 443, 454

user-defined rosters     247

user-defined views     67, 68, 70, 74, 211, 212, 213,
216, 247, 295, 296, 297, 302, 303, 454

username     183

users     488, 492, 494, 498

- V -
valid     169

validate address lists before sending     174, 202, 286,
315

value     377, 404, 460

verification value     169

version     519

viewing photos     271, 309

viewing saved reports     437

viewing security settings     494

views     67, 68, 70, 74, 211, 212, 213, 216, 295, 296,
297, 302, 303, 454

viruses     504

- W -
waiting for scan text     94

web browser icon     43

website     210, 223, 294, 324

members     324

welcome     12

welcome text     94

widening a column     64, 198, 278

wife     339

windows service     110, 141

- Y -
Y2K     527

year begin date     170

year display     527

year to date     412, 468

yearly dues amount     170, 258

yearly dues for record status     163

yearly dues for selected status     163

your organization     195

- Z -
zero-balance     163
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